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GETTING STARTED
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Welcome to DEVONthink, a powerful

assistant in your quest to organize many

kinds of information. From recipes to

your dissertation, hobbies to health, for

work or home, DEVONthink can help you

gather, organize, and connect your data.

This manual will help get you familiarized

with DEVONthink's concepts, interface, and

options. We begin with simple overviews,

move into descriptions of the essential

controls, then conclude with the deepest

details in the appendix.

Note this manual is meant as a handy

reference, not as a series of mandates on how

you must use it. DEVONthink can be used

very simply or in very complex ways and each

person brings their own personal approach

to using it. To that end, this document can't

be an exhaustive guide to everything you

could ever do with it. With the flexibility

and capabilities built-in, that would be an

impossible task. We hope you find this guide

helpful.

Note: Text in blue color (besides hyperlinks

that might get colored in blue by your

ebook reader) refers to functionality only

available in higher editions. You can find

a list of the editions and their features

online.

Warmest Regards, The DEVONtechnologies

Team

Now let's get into it…

INSTALLING, UPDATING,
UNINSTALLING

INSTALLING

If you haven't already installed DEVONthink,

here are the easy steps to accomplish that:

Download an installer from the Download

page.

If your browser isn't set to open safe

downloaded files, double-click the ZIP file

to decompress it. You will see a disk image

file.

Double-click the disk image to open it.

Drag and drop the application from the

disk image to the Applications folder

shortcut.

After the application has copied, press ⌘E

to eject the disk image.

Note: Please note that macOS Services

and the connection to DEVONagent

work only for applications installed into

the Applications folder, and that logout

and login or a restart is suggested after
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installation to make all parts of macOS

aware of the additional services that come

with DEVONthink.

UPDATING

Updates to DEVONthink are done per the

schedule set in Settings > General > General >

Check for Updates.

If you need to manually update the software,

follow the previous installation instructions,

but allow the Finder to overwrite the

old version. Your database(s) will not be

affected. To avoid any potential problems, do

not use a third-party uninstaller utility. Just

replace the current version, as directed.

UNINSTALLING

If for some reason you need to fully uninstall

DEVONthink from your Mac, trash the

following files and folders (~ stands for your

account's home folder):

DEVONthink

~/Library/Application Support/

DEVONthink 3

~/Library/Application Scripts/

com.devon-technologies.think3

~/Library/Preferences/com.devon-

technologies.think3.*

All DEVONthink-specific scripts in ~/

Library/Scripts

All DEVONthink-specific workflows in ~/

Library/Workflows/

All DEVONthink-specific scripts in ~/

Library/PDF Services/

Uninstall the DEVONthink browser

extension, following the uninstallation

process for the particular browser.

Bookmarklets from your web browser

The reference to the global inbox folder in

your Finder's sidebar

Keychain entries containing devoncloudy

in the name

The DEVONthink .mailbundle in the ~/

Library/Mail/Bundles directory.

Note: In troubleshooting situations, please

do not uninstall the software without

talking to our support team beforehand.

Most issues can be resolved without

uninstalling the software.
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DEVONTHINK SIMPLIFIED

DEVONthink is a very flexible application,

appealing to a broad range of people and

accommodating many different working

styles. Since people use it in such diverse

ways, it often leads people to believe there

is a "steep learning curve" associated with

it. The truth of the matter is DEVONthink is

a powerful application built on simple, and

often familiar components and concepts.

Here we'll cover the basics.

INTERFACE

At its core, DEVONthink is a multi-window,

document-based application. Multi-window

merely means you can have more than one

window open. Document-based means it

supports viewing, and in some cases editing,

documents. Apple Notes is an example of a

document-based application without multi-

window support.

DEVONthink has two main window types: a

main window (seen immediately when the

software opens), and document windows.

These windows are used in already familiar

ways, supporting drag and drop, sorting on

different attributes, full screen views, etc.

Whether you are working (or playing) in

DEVONthink, you will be using one or both

window types.

DEVONthink supports different ways of

viewing your items, e.g., in lists or as icons.

You can show or hide many details in the

window, allowing you to work in very simple

or complex views of your data. Specifics

about windows and their component panes

and bars are discussed in more detail in the

Windows and Inspectors chapters.
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DEVONthink also has a powerful array of

tools found in its menus. Many of these

are also found in the context menus when

Control-clicking items in the software. And

to fine-tune some of the options, it also has

extensive preferences.

DATABASES

Beyond the interface, DEVONthink has only a

few core working components: databases and

items. Items are comprised of two essential

components: groups and documents.

Note: Throughout the documentation, we

use item to represent both groups and

documents. Things that only apply to one

or the other will use the appropriate term.

Displayed as  and shown only in the

Navigate sidebar, databases are the

fundamental unit in DEVONthink, filled with

items. No matter if your content is grouped,

ungrouped, or a mix, it is all housed in a

database. You add, remove, organize, and

search for files within DEVONthink, just as

you've done in the Finder forever. Simple.

When you create a database, it is made

as a self-contained package in the Finder.

Packages are technically folders that are

handled like single files by the Finder.

DEVONthink databases are not merely a

series of files and folders in the Finder, but

are isolated from each other and function

a bit more like disks. When you plug in an

external drive, it appears in the Finder's

sidebar isolated from other disks, but still

capable of moving and organizing data on it.

In a similar fashion, open databases appear

in DEVONthink's sidebar and behave in much

the same way.

Global Inbox: Displayed as , when you

launch DEVONthink, you will immediately

see a database called Inbox. This is a special

database and a core component of the

software. As a core database, you can't

delete or close it, as it provides an always

open database for quickly storing unfiled or

transient data.

Imagine you are reading about fission

reactions and someone sends a link about

a vacation place in Bali. You jump to the

website and quickly clip a webarchive of

the page. But instead of putting it in your

research database, you add it to the Global

Inbox and get back to work. You can go

back later and read or sort things to other

databases. If you are familiar with Getting

Things Done you'll recognize the concept.

The Global Inbox is also special as it is the

only database you can add a shortcut to

in the Finder's sidebar. This allows you to

save a file into the Global Inbox from other

applications.

All databases also have an Inbox group with

the same purpose as the Global Inbox. It just

allows you to save unfiled data to a more

specific database, as needed.

GROUPS

One of the two basic items are groups. No

different than the folders and groups found

in many other applications, they merely

serve as ways to keep certain bits of data

together. But within the DEVONthink groups
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are a few variations. They are all simple to

recognize and understand, but they bear

being introduced.

Ordinary Groups: Displayed as  , these are

analogous to folders in the Finder. Except for

underlying technology, groups operate in the

same fashion. Creating, adding and removing

contents, and deleting are all essentially the

same. Just as in the Finder, you can create

subgroups to suit your needs.

Looking and behaving like folders you've used

in the Finder, groups are the simplest way to

segregate data. DEVONthink allows you to

create deeply nested hierarchies or simple

top level groups, whatever you need to keep

things organized in a way that makes sense to

you.

New empty groups can be made with the

Data > New > Group command. Groups

of selected items can be easily made and

unmade via the Group Items and Ungroup

Items commands in the Data menu. These

commands are also in the context menu.

Groups are also the target of DEVONthink's

classify function. The AI compares

document contents and locations and offers

suggestions for where items may best be

filed. As documents are filed, manually or

taking the AI's suggestions, it becomes more

and more adept at helping you file more

efficiently.

Group Tags: Displayed as  , these are

created and operate like ordinary groups, with

one extra function: the name of a group tag is

applied as a tag to its contents (sometimes

referred to as "children"). By unchecking

Exclude Groups from Tagging in a database's

properties, any group you create will function

this way. For individual groups, you have the

option of choosing Exclude from Tagging from

the context menu or Info inspector.

As you add items to a group tag, they are

automatically tagged with the parent folders'

name. Similarly, removing items from a group

tag will remove the parent tags. Also, if you

create sub-groups, these will also be created

as group tags. This can be useful if you're

using a group for staging purposes, e.g., a

groups for unassigned, in progress, and done

items. Moving files between these groups

would change the tag to its current parent

group.

Smart Groups: Displayed as , smart groups

should be familiar to anyone using saved

searches in the Finder. Similar to them, smart

groups don't actually contain anything. They

merely show you items matching the criteria

you specify. Sometimes broadly used in

situations where deeply nested groups are

not used, you can create as many as you'd like

no matter your approach.

These special groups allow you to create

virtual groups based on any number of

matching criteria. These can be simple, e.g.,

"all PDF files in a database", or complex, like

"all unread documents with a specific color

label added in the last week but excluding

HTML files". If you like to use a looser filing

method, using smart groups allows you

to file your items with less concern about

where they're located in the database.

With smart groups you can also have items

appear in more than one smart group without

replicating or duplicating files explicitly. For

example, a smart group could show items
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tagged with "taxes". You could then create

another smart group with items tagged with

"taxes","business", and "2018".

Local smart groups, i.e., ones applied to

a specific database, can be created and

edited via the Data > New > Smart Group

command. You can also find this command

in the context menu when Control-clicking

in the item list. Smart groups can also be

created when doing an Advanced search.

When you create a new database,

DEVONthink automatically adds a few

of predefined smart groups for your

convenience:

All Images: Shows all images.

All PDF Documents: Shows all PDF

documents.

Duplicates: Lists all duplicates.

Note: Smart groups filtering on dates or

unread status are shown with special icons.

Smart Rules: Displayed as  and found only

in the Navigate sidebar, smart rules are a

type of smart group with an extra function:

they not only match items by the criteria you

specify, they can also act on them. These

actions can even trigger when certain events

happen. For example, you could have a smart

rule matching PDFs in the Global Inbox and

have newly added PDFs be added to the

Reading List.

DOCUMENTS

The second basic item in DEVONthink are

documents. No different than the Finder,

documents are any files you add or create in

your databases. Perhaps you are importing

spreadsheets for work, or PDFs for your

thesis. Maybe some photos from your

vacation you want to link to in a Markdown

document you're working on. They're all just

documents.

DEVONthink supports adding many kinds

of files to your databases, but note the

type of file determines its usefulness in the

database. For example, images can easily

be added but searching for them is limited

to searching by attributes like file type or

filename. Remember DEVONthink excels at

text-based operations, so files like rich text

or PDFs are very well supported.

Note: More information on the types of

files you can create or import can be found

in the Documents chapter.

While not types of document per se, there

are two variations on documents available to

you: duplicates and replicants.

Duplicates: Displayed with  to the right of

a document's name or the name optionally

shown in blue type, there are two ways to

get a duplicate in your database. Firstly, just

as you'd expect in the Finder, select a file

and press ⌘D: a duplicate is made. Secondly,

if DEVONthink examines the contents and

determines it has another file with the same

content, it will mark them as duplicates.

Duplicates are separate files, and changes

to the content of one should remove its

duplicate status.

Replicants: Displayed with  to the right of

a document's name or the name optionally

shown in red type, replicants are conceptually

similar to aliases in the Finder or a second

phone book entry for the very same person.

Replicants are one file showing up in more

DEVONthink 3.9.17 Documentation, page 10



than one location. However, they consume

no more space than a single file. Since they

are clones, changes made to any instance

of a document apply to all instances. This

makes them useful when you want to file a

document in more than one location, but

don't want to have to update each document

individually. It can also be useful if you have

larger files you want filed in more than

one group. A 10 MB PDF, replicated in ten

different groups, would only use 10 MB of

space in the database.

There is also the possibility of having a

document that is both replicated and a

duplicate. This will display this icon to the

right of the name: 

It's important that you understand how

replicants work before you begin making

changes to documents. Any changes to a

replicant are carried over to all replicants; as

you might imagine, this means that you can

to do some very powerful (and potentially

negative) things with your database's

contents via replicants. Duplicates, on the

other hand, allow you to change the files

without modifying the original document

or group. Duplicates are less powerful than

replicants, but no less important in the grand

scheme of database organization.

Note: Replicants cannot be created in the

same location as the originating file, nor

can they be made across databases.

THE DETAILS

We hope this has given you some insight

into the basics of DEVONthink. DEVONthink

is deep and powerful, but understanding

these basic concepts and seeing parts you

are already familiar with will hopefully dispel

some of the "fear" that it's complicated and

hard to learn.

That being said, we also have more in-depth

information for you. From simple overviews

of menu commands to details in the appendix

can be found in the remainder of this guide.

BUILDING YOUR DATABASE

The first step in starting your own custom

database is to create a new database with

File > New Database. Give your database

an easily recognizable name, and choose

where you want to save your database. We

advocate putting them in a folder in your

home directory, like ~/Databases. With your

new database created, you are ready to add

information.

Encrypted Databases: If you have databases

containing sensitive or private information,

you can create an encrypted database. This

is specialized AES-256 encrypted disk image

that will not appear in the Finder or your

desktop when it's open. In the Navigate

sidebar, you will see a key icon to the right

of the database's name, denoting it is an

encrypted database. Quitting DEVONthink

or closing the database unmounts the disk,

so you are always required to enter the

password to access it.

Choose File > New Encrypted Database and

enter a password that will be used to unlock

it. Enter a reasonable anticipated size for

the database, in megabytes or gigabytes.

This is how large you think the database will

get. Since the encrypted database functions

like a connected drive, you define how large
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it is and "fill it up". You can choose to let

Spotlight index the contents, but bear in

mind the Spotlight index is stored locally and

isn't encrypted. This means someone could

find a document in the database exists via

a Spotlight search. However, they wouldn't

be able to open and access the database

without the proper password.

Note: You cannot create or store a

database in a cloud-synced folder, e.g.,

iCloud Drive or Dropbox. This is not data-

safe so the behavior is explicitly disallowed.

The advocated location is a folder in your

home directory, like ~/Databases. If you

try to open a database in one of these

locations, you will be prompted to let

DEVONthink move the database, or reveal

it so you can manually relocate it.

ADDING YOUR FILES

After you've created your database, you'll

add your files to it. Often it's a simple

matter of dragging and dropping files into

your database, but we've covered several

additional methods in the In and Out chapter.

Also, please take a moment to review the

Importing & Indexing section to familiarize

yourself with these two options.

While you may be tempted to dump every

file on your hard drive into DEVONthink

and sort it out later, you're best off being

more selective in what you add (especially

in the beginning). Having a large, "dump it all

in" database can contain a lot of files that

will do you no practical good (for example,

DEVONthink can't read your Microsoft Office

user profile files), and weeding these files out

after-the-fact can be both time-consuming

and frustrating. Also remember, DEVONthink

has to index metadata and contents of any

compatible files. This will be less productive

if you add files you'd never want to use or

search for.

Here's a practical example: Your iTunes

database runs over 22 gigabytes. There's

nothing to be gained by simply copying

that into a DEVONthink database. Copying

the iTunes database into DEVONthink

would result in a large, inefficient, and slow

DEVONthink database, and would cripple

DEVONthink's ability to manage and use

content in a well-designed manner (much

less perform simple search and organizational

tasks).

As your growing databases use RAM,

processor time, etc., smaller, more focused

databases are often a more effective

approach than using singular, monolithic

databases. Separate databases generally

perform better, sync faster, and in the rare

case of a catastrophe, can help avoid data

loss since you're not keeping "all your eggs in

one basket". Another benefit of this approach

is the ability to conserve some machine

resources. With a single, large database all

the information is always using resources,

even files unrelated to what you're working

on at the moment. With separate databases,

you can close and open specific databases as

the need dictates.

One way to effectively create separate

databases is to use a topical database

approach. Create multiple databases, with

each holding only related information: a bird

watching database full of birding articles and

newsletters; a quantum physics research
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database with research briefs and email.

This method can improve the effectiveness

of DEVONthink's artificial intelligence (AI)

features with each database. The AI work

best within a database that contains context

relationships among many documents;

clogging your new database with everything

from A (apple pie recipes) to Z (Zengobi user

documents) will only hamper the AI's ability

to work effectively.

Having topical databases can help down the

road as well. You may be collaborating on a

database, syncing between machines in a

group. Imagine having just one database: You

decide to share your painstakingly researched

academic articles with colleagues, only to

find that you've mistakenly also shared

personal financial records and chats. Not

hard to imagine how that has the potential to

be both dangerous and embarrassing. Having

multiple, topical databases will allow you to

keep your data separate and private.

ORGANIZING

Database organization depends on the

parties involved. For collaborative work,

you'll want to organize it in a manner that's

understandable to all parties using it. This is

especially important as our sync technology

is a mirroring sync, meaning changes to one

copy of the database gets synced to the

other copies. For personal work, just set

up your database in a manner that makes

sense to you. There is no right or wrong way

to organize it. This is something you've likely

already been doing in the Finder, making

folders and filing things in them. Apply the

same personal choices to DEVONthink. You

can also use smart groups to create virtual

groups.

Remember that creating databases isn't an

inviolable commitment. Create and destroy

them as you see fit. Start with one way of

organization and decide later to re-organize

your databases. With DEVONthink you can

keep multiple databases open simultaneously,

easily moving documents from one database

to the other at any time. As you work with

your databases, new ideas may spark new

approaches which can easily be tried and

adopted or discarded.

CASE STUDY: BILL'S DATABASE FARM

Bill DeVille, formerly DEVONtechnologies'

Evangelist, worked in a number of scientific

areas. Bill's main database covered

environmental science and technology

topics, with related interests in science

and technology exchanges with developing

nations. The database even contained some

projects dealing with graduate education

in environmental sciences and engineering.

There's a broad topical relationship among

these subjects and the database covers

disciplines ranging from chemistry, toxicology,

statistics, risk assessment, and engineering

to economics, legal, regulatory, and policy

issues. These disciplines fit together and

combinations of these topics are necessary in

many real-world cases.

As you can imagine from the above

description, Bill's main database was quite

large, containing about 20,000 documents

and over 20,000,000 total words. Because

of the relationships knitting together all
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these scientific, technical, legal, and policy

issues, the artificial intelligence features

of DEVONthink worked very well for Bill in

researching the database and contextualizing

the information.

In addition to his main database, Bill had

seven additional databases (so, eight total).

For example, he had one database for Apple

Newton literature he has accumulated over

the years. It's almost as big as his main

database, but the topical coverage has no

practical relationship to the main database,

so Bill kept the Apple Newton literature in its

own domain. If he were to keep this unrelated

information in his main research database,

the result would be a larger, slower database,

with poorer performance by the artificial

intelligence.

Occasionally, Bill added topical materials to

it that are not related to its main purpose.

However, when those "unrelated" topics grew

large enough in volume, he spun them off into

to a new database in order to preserve AI

accuracy and relevance.

If you'd like to follow Bill's method, start by

creating a database with some collections

of files that interest you, but don't be afraid

to create other databases that contain

"different" material as your interests, and

main your database, grow. And if you need

to search across databases, simply open

all of them at the same time. DEVONthink

searches all of them almost simultaneously.

TAGGING

Tagging is a common method of creating

context relationships between documents.

For example, you can apply a "hobby" tag

to a woodworking article and a sewing

machine PDF manual. You would then

find both documents when searching for

the "hobby" tag. Used in the Finder and

many other applications, DEVONthink also

supports tagging in your databases (including

preserving Finder tags on imported and

indexed items). Tags are either ordinary tags

or group tags, each discussed below.

ORDINARY TAGS

Similar to tagging methods used in other

applications, ordinary tags are added to

items by you. Each database has its own Tags

group and is accessed in the item list or the

Tags section of the Navigate sidebar. The

item count of a tag shows how many items

it has been applied to. If there are unread

items in a tag, the tag's name will appear in

bold type. If there is a mixture of read and

unread items, the count in the item list will be

displayed as "unread items/total items".
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Creating tags: When you add a new tag to

an item, a tag group is automatically created

in the Tags group for the database you're

working in. However, you can also create

tags to be used later. Create them in the

database's Tags using the Data > New > Tag

command or the New > Tag command in the

context menu or New toolbar button.

Applying tags: When you apply a tag to an

item, a reference to that item is created in

the appropriate tag group. You will have an

item reference in each tag you apply to it. So

if you add three tags to a document, you will

see a reference to the document in each of

the three tags.

Ordinary tags are most commonly applied by

these methods:

Type tags into the Tag bar under a

document's view/edit pane.

Type tags into the Tags section of the

Info inspector or the Info popover for a

document.

Drag items in your database to the desired

tag in the Tags section. Be aware dragging

an item to a tag in another database will

move it to the receiving database.

Note: While importing directly into a tag,

e.g., via drag and drop, is supported, it is

not generally recommended. If you do this,

an item reference is made in the tag but

the original item will be located in the Inbox

of the receiving database. Importing then

tagging is suggested.

In the case of multiple selected items, tags

will only be shown in the Info inspector and

Info popup if the items all have the same

tags. However, you are able to tag all the

selected items via the inspector, popover, or

Tag bar.

Modifying and Merging Tags: You can rename

an existing tag in the Tags of a database

as simply as renaming any other item. The

change will instantly apply to all the items

using that tag. If you have similar tags but

would like to consolidate them into one, e.g.,

having tags of apple and Apple, select them

in the Tags group, then choose Tools > Merge

n Tags. The tags and their item references

will be merged into one tag, preserving the

topmost tag's name. Again this change is

applied immediately.

A tag can be dragged and dropped into

another tag to create parent/child tags. But

please read and understand the Nested Tags

subsection below before proceeding.

Deleting Tags and Tag Groups: Deleting

individual tags from items is done via the

same methods you apply them, e.g., in the

Generic Info inspector. Deleting tag groups

is done in the Tags group of the database.

Simply select the unwanted tag and choose

Data > Move to Trash. This immediately

removes the tag from all them items it was

applied to. And only the item references are

moved to the Trash, not the original items in

the database.

Applying, modifying, or removing tags can

also be done by more automated means, e.g.,

scripting, smart rules, and batch processing.

see the Automation chapter for more

information.
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FINDER TAGS

Finder Tags: DEVONthink supports reading

and writing macOS' Finder tags. If tags are

present on an imported or indexed files, they

will be preserved in the database. When

tagging imported files, tags are not written to

the filesystem. Instead the tags are recorded

in the Spotlight metadata when the Create

Spotlight Index option is enabled in Database

Properties popover. This allows searching

for tags in Spotlight using the tags:myTag

syntax. If you export or drag and drop files

to the Finder, macOS tags will be written

to the exported file. When tagging indexed

files, the tags are immediately written in the

filesystem and searchable, just as they would

be if you tagged them directly in the Finder.

Note: If you would like to disable the

tag exchange between DEVONthink

and the Finder, click the On link under

DisableFinderTags in the Hidden

Preferences. Bear in mind this option

inhibits importing and exporting Finder

tags globally.

TAGGING SOURCES

Beyond the tag exchange with macOS, the

following options in DEVONthink's Import

Preferences or RSS preferences control other

tagging mechanisms. The options in the

Import preferences can also be manually

applied via the commands in the Data > Tags

submenu and the context menu in the item

list.

RSS: In the RSS preferences, the Convert

categories and hashtags to tags option

converts categories detected in the feed

articles or hashtags in the contents into tags.

In conjunction with the previously mentioned

Finder tags or Spotlight data, this can lead to

a large number of macOS tags being added

automatically in the Finder.

Hashtags: Popularized in social media,

hashtags are a type of tag prefixed by a

#. If enabled in Settings > Files > Import,

DEVONthink can detect hashtags in the

contents of text-based files and convert

them to tags for the file automatically.

Removing the hashtags from the content

will remove the tags from the file. Hashtags

do not support spaces in them and they

should be listed on a separate line. They will

not be detected within existing paragraphs.

Of special note, hashtags supports creating

nested tags as noted here. The first tag

just needs to be prefixed with the # to be

detected as a hashtag..

Keywords: When enabled in the Import

preferences, DEVONthink will convert the

keywords of PDFs and rich text documents

into tags.

Properties: Also found in the Import

preferences, DEVONthink will attempt to

convert certain properties to tags, e.g., the

names and email addresses of the sender and

recipients of emails.

Geolocation: Enable Convert location to

tags in the Import preferences to convert

the applied geolocation of a file into tags.

The Geolocation can be viewed in the Info

inspector.
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Image Tags: The Add tags to images option

in the Import preferences, will use machine

learning to attempt to add subject matter

tags to selected images. There are no user-

definable controls for this option.

NESTED TAGS

Sometimes referred to as "hierarchical tags",

nested tags are a series of related ordinary

tags, combined under a parent tag. When

you add a child tag, the item automatically

inherits the parent tags. In the example

shown below, adding a tag of "Casper" to an

item would automatically add the "Wyoming"

and "US" tags.

A special mechanism in DEVONthink allows

you to create nested tags automatically:

enter the tags separated by a forward

slash. For example, type a tag of software/

productivity to create a parent tag of

software with a child tag of productivity.

Use this option in the places where tags are

entered, e.g., the Tags bar, Tags field of the

Info inspector and Info popover, and the Tags

column in the item list.

Note: If you are having trouble deleting a

tag from an item, check to see if you are

adding a nested tag.

Caution: Tags for a database can have the

same name. This may seem illogical, but it's

something more commonly seen that you

may expect. For example, say you have a

travel database with points of interest like

restaurants tagged in different locations. You

may find yourself with a tag structure like

this…

Example:

US

  Wyoming

    Casper

      Restaurant

  Minnesota

    St. Paul

      Restaurant

If you added a tag Restaurant to an item,

what tag would it go to? It actually would go

to the most recently entered instance of the

Restaurant tag.

So how is this resolved? Tags are meant to

be unique, so eliminating redundant tags is

first priority. Restaurants aren't specific to a

geographic location. Create the Restaurant

tag as a top level tag. If you had a need

for hierarchy with the tag, perhaps for tax

purposes, you could move it into a parent

Tag of Entertainment. Then you would get

both tags when you added Restaurant. But

again, if you anticipate wanting to use the tag

without the parent tag, you should make it a

top level tag.

Also, you shouldn't view the tags as a group

structure in and of itself. Nested tags are just

meant to group tags specifically related to

each other, so they can be applied en masse.

Note: Tagging methods and philosophy is

full of strong opinions. Many people feel

tagging should always be flat; only top

level tags and no hierarchies. DEVONthink

accommodates both approaches. However,

if you want to used nested tags, we hope

you carefully consider the caution we've

presented and use a hybrid method to

avoid unexpected behavior.
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GROUP TAGS

Previously discussed in the Groups section

earlier in this chapter, group tags allow

you to dynamically assign tags based on

their location. As you add files to a group,

they have tags of the parent groups' name

assigned to them. Similarly, if you move

the items to a new group, the tags are

removed and new ones applied relative to

the new location. Whether used statically

or dynamically, group tags can be used

creatively. They also work in conjunction

with ordinary tags, so you can employ both

methods in one database.

Example:

Imagine you have a work database with

groups for different stages of a project:

Unreviewed, Assigned, In Progress, On

Hold, and Done. At the beginning of

the process, you'd put the item in the

Unreviewed group and it would be tagged

as such. After reviewing, you could move

the file into the Assigned group and

the previous tag would be removed and

replaced with Assigned. As the project

moves through the staging groups, the tag

would change.

And of course you can use ordinary

tags, e.g., Reviewed or a client identifier,

on these items. Those tags would be

preserved no matter where you move them

in the databases.

Groups tags are applied by DEVONthink

automatically. But you can also do some

automatic filing by entering existing group

tags manually. If you enter the name of an

existing group that is not excluded from

tagging into the Tag bar or an Info panel or

popover, the item will be replicated to the

appropriate group. You can also drag an item

to a group tag in the Tag Cloud at the bottom

of the Navigate sidebar.

Considerations: When you enable using group

tags for a database, it starts as an all-or-

nothing situation. All groups in the database

function as group tags.

If you want to use group tags for most groups

in a database, you can Control-click specific

groups and choose Exclude from Tagging. You

can also choose this option in the Exclude

from… section of the Info inspector or Info

popup for a specific group. However, note

you must change this setting on all individual

groups you'd like to exclude.

If you only want a limited number of tags, it

would be advisable to exclude groups from

tagging for the database and use ordinary

tags instead.

AUTOCOMPLETION

When you are typing tags, an autocompletion

list will appear. In the Global Inbox, tags

from any open databases are shown as

potential tags. In other databases, the items

displayed are only from the tags of the

current database.

While group tags aren't added to the Tags

group for a database, they are displayed in

autocompletion suggestions.

Tags and Aliases: DEVONthink also honors

aliases added to groups. You can add

"alternative names" to a group using Info

popup or inspector and later use these

alternative names as a tag. Continuing the

previous example, you could add an alias of
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IP to the In Progress group. Now, type

IP as a tag and it will be replicated to the

In Progress group. When you view the

file, you will see the proper group tag was

automatically added.

SEARCH AND GATHER

Finally, tags have two main functions:

segregating data and searching for data. You

use tags to gather items together in certain

contexts. You also use tags to search for

those items.

Searching for items by their tags is easily

done in a few ways:

Tag cloud: The Tags Cloud allows you to

filter the current list of files by clicking on

available tags. As you click, only related

tags are shown so you can fine-tune the

items displayed in the item list.

Search field: The search field at the top of

every main window allows you to search for

tags by using the advanced options for a

search. You can also search for tags using

a simple tags: prefix. Multiple tags can be

specified, separated by commas. You can

also use tags!:, to exclude tags.

Gathering similarly tagged items is powerfully

achieved with Smart Groups. Smart groups

allow you to use the smart group editor

controls to set criteria to be matched.

Included and excluded tags can be added as

criteria. Files matching the parameters of the

smart group are shown, regardless of their

location in the database. This way you can

leave your files where they are and create

virtual folders for specific purposes.

A WORD ABOUT BACKUPS

For many users, the value of the data is much

greater than the value of the computer that

hosts it. There are many things that could

go wrong. Your notebook computer could be

dropped, lost, or stolen. Your hard drive will

fail (it's not a matter if, but when). A power

outage could corrupt the files on your hard

drive. For the truly paranoid (remember,

paranoia is sometimes justified), how

significant would the loss of your database

be if your house or office were to burn down?

Avoid insomnia and back up your database(s)

frequently. Your data stored in DEVONthink is

valuable, so back it up.

INTERNAL BACKUPS

DEVONthink backs up its database index

every week, either immediately after opening

the database (if the backup is overdue) or

during the day when appropriate.

Note: The internal backups are mainly a

troubleshooting mechanism for use in the

application. Backing up your files, including

your DEVONthink databases, is up to you.

FULL BACKUPS

We strongly recommend you get in the

habit of triggering backups whenever you

have invested substantial time and effort

into modifying the database. Apple's Time

Machine and an external drive is an easy

way to do this. Simply connect the drive and

let Time Machine do its thing. With the low

cost of portable external drives, it's even

feasible to take a 1 TB drive that can fit in a

shirt pocket for backups when you're out and
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about. Online backups such as Arq Backup

are an alternative if you don't want to own

another piece of hardware to care about.

As a secondary backup option, you can create

an optimized and compressed copy of the

whole database that you can then save on

a server or other media. Use File > Export >

Database Archive or Scripts > Export > Daily

Backup Archive to create a ZIP file of the

database. The former option allows you to

choose specific place; the latter creates it in

a Backup folder in your home folder.

Lastly, as events such as house fires and

natural disaster frequently prove, valuable

data should probably be kept at more than

one location. Consider saving a copy of your

backed up information at a secure, off-site

location such as a bank safe, or put the

exported ZIP files of your database in your

cloud account.

Note: As noted in our FAQ, sync is not a

backup, neither advertised nor advocated

as such. While database restoration may

be possible with sync data, it is not meant

to be relied upon or used in lieu of proper

primary backups.

TUTORIALS, SCREEN CASTS,
AND MORE

In addition to this help resource, explore

tutorials and install pre-made scripts and

templates that extend DEVONthink's

functionality in the Support Assistant. Also

new tutorials are shown in the Extras sidebar.

For a great resource of tips, promotions,

and release announcements, check out our

company blog.

And if you feel like talking to other people

using our applications, you'll find discussion,

camaraderie, and well over a decade's worth

of information at our Forums.

Take time to learn how to work with the

software — and to decide how you want the

software to work. You'll be rewarded with a

powerful assistant for all your information

organization needs.
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Analyze Text Documents 21
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Archive Printed Documents 23

Browse the Internet 23
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Index Files on Your Hard Drive 27

Manage Your Bookmarks 27

Share Project Data 28

Read News Feeds 29

Take notes 29

Write Texts and Outline Projects 30

The number of possible uses for DEVONthink

is nearly endless. In this chapter we've tried

to outline a few typical use cases that show

how you can use DEVONthink in your daily life

and work.

ANALYZE TEXT DOCUMENTS

With its built-in artificial intelligence (AI)

functions, DEVONthink can be used to

analyze the documents in your databases.

The Concordance function allows you to

view a list of all the words contained in a

document or database. Selecting a word

highlights the word in the current document.

Additionally, a graph of related words is

shown at the bottom of the Concordance.

Right-click a word in the list or graph to

exclude them. And if you're wondering about

other documents containing a word, double-

click one to start a search for that term.

Other functions of the AI's analyses include

the Classify function. This examines the text

content and locations of other documents

in your database and makes suggestions for

filing the current document. Additionally, See

Also lists documents with a similar content to

help find connections you may not have found

otherwise.
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Possible uses:

Analyze the complexity and focus of a

specific document collection

Find relationships between documents or

snippets quickly

Clean up large collections of documents

Continue to read here:

Import documents from the file system

Use the See Also & Classify Inspector

Use the Concordance Inspector

ARCHIVE YOUR MESSAGES

DEVONthink is the repository for emails you

want to save.

Its hierarchical groups structure, automatic

classification function, and powerful

search engine are perfectly suited to

adding, sorting, and finding emails in

your databases. DEVONthink comes with

advanced email archiving functions that

transfer selected messages or mailboxes

from Apple Mail, Microsoft Outlook, and

any email applications using standard

Unix mailboxes, e.g., Thunderbird, to

a DEVONthink database. The original

structure of the message, as well as all

attachments, are preserved when possible.

You even can reply to messages directly from

DEVONthink's context menu commands!

Possible uses:

Archive important correspondence

Archive invoices, offers, purchases, or

software licenses

Store interesting news bits from

newsletters

Keep project-related emails and other

documents together
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Continue to read here:

Archive email messages

Reply to archived emails

Organize data using Classify and See Also

ARCHIVE PRINTED
DOCUMENTS

DEVONthink is the "paperless office" solution

for the Mac, a central hub for all your paper

and electronic documents.

Using the integrated scanner support you

can directly scan documents, make them

searchable through OCR (optical character

recognition),and file them in a database. Of

course, you can also make existing scanned

documents searchable. If you own a Fujitsu

ScanSnap or other compatible document

scanner, you can use the fast auto-feeder to

scan batches of sheets in one go.

When you are working in a team, use the

embedded web server to give your colleagues

access to your data using an interactive web

interface. Even friends using Windows are

invited.

Possible uses:

Archive your important correspondence

Archive invoices, offers, purchases, or

software licenses

Store printed documents together with

electronic documents

Keep project-related emails and other

documents together

Keep a central repository for all team

members

Continue to read here:

Scan paper documents

Scan with the Fujitsu ScanSnap

Import existing files with OCR

Organize data using Classify and See Also

Share data with your team

BROWSE THE INTERNET

Besides being a knowledge and information

database, DEVONthink has built-in web

browsing capabilities. This allows you to

browse and capture online information

directly in a database.
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DEVONthink enables you to treat web pages

the same way as you treat documents.

Whenever you select a bookmark,

DEVONthink immediately loads and displays

its content live from the internet in the

View/Edit pane. You can also open a page in

a separate document window. Archive the

complete page for offline viewing, add a new

bookmark, or drag elements from the page

into your database.

DEVONthink also handles RSS, RDF, Atom,

and JSON news feeds, either through feed

documents or by simply displaying them

via the built-in web browser. Stay up-to-

date with your subject and clip important

information right away.

Possible uses:

Visit frequently used web sites in a

convenient interface

Integrate "live" content from the web with

your other documents

Grab data from web sites and store it in

DEVONthink

Capture and archive complete web pages

Continue to read here:

Capture data from the Web

Create new bookmarks or HTML

documents

View "live" and local HTML pages

Integrate news feeds with your data
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CAPTURE DATA FROM THE
WEB

Increasingly, information is provided not

on paper but directly through web sites,

blogs, online news sites, social media, and

user forums. DEVONthink offers a variety of

options for conveniently capturing data from

the web:

Bookmark: Captures only the address (URL,

uniform resource locator) of the page.

HTML page: Saves the source code of

the page to the database, but images are

downloaded from the web each time the

page is displayed in the database.

Web archive: Saves both the HTML code

and all resources, like images, necessary to

display the page.

Rich/Plain text: Grabs selected text/

images and hyperlinks, but avoids saving

unwanted areas of the page to the

database. A plain text capture will not

include formatting, images or links.

PDF: "Freezes" the web page, just like

printing to paper. PDFs from web pages can

be paginated or non-paginated.

All of these options, except the bookmark,

capture the text content of the page (or a

selected area of it) and hyperlinks if present,

and preserve the text information for

searches in DEVONthink.

Note: There are a number of web sites

that prohibit use of some of the capture

options described above. A secure banking

site or a university portal to journals may

direct a bookmarklet or script capture

option to the login page, which will be

captured instead of the desired content. A

capture option that requires re-download

of the page on such sites will capture only

the login page. The page always can be

selected and captured as rich or plain

text. The viewed page can be captured by

"printing" it as PDF to the database.

Possible uses:

Capture important news in an easily

searchable database

Collect all relevant data for your project in

one place

Collect links to web pages and captured

data about the same subject in one group

Save data from the web in future-proof

formats such as PDF

Continue to read here:

Capture data using Services

Capture data using scripts

Capture data with bookmarklets or

browser extensions

Add the global inbox to the Finder's sidebar

"Print" any web page or document as PDF

to your database
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CATALOG YOUR SD CARDS OR
DVDS

By using the Index function, you can use

DEVONthink to set up a catalog for your data

DVDs, SD cards, or other removable volumes.

Create a group for each disk by using the

index function, and organize your disks/

groups in any way you like. When you need

a specific file, search for it in DEVONthink,

insert the volume, Control-click the file in

DEVONthink, and select Open With to open

the original file on the removable volume.

Note you will only see a thumbnail if the

disk or volume is not available. A message

to Mount Volume will be shown if a server

volume is unavailable. Clicking this button

should remount the volume, if possible. For

removable disks, DVDs, etc., you will have to

reinsert the media.

Possible uses:

Find files even when they're on a removable

volume that is not currently mounted

Create a virtual library of SD cards and

other media

Integrate static documents with other

project-related data

Continue to read here:

Import or index files

Search your database

Launch the original file of an index item

CATALOG YOUR PHOTOS AND
MEDIA FILES

Besides storing text documents and

PDF files, DEVONthink can also contain

multimedia data such as photos, illustrations,

music, or movies in your databases.

While not designed to replace Photos

or Music, DEVONthink can be used as a

repository for images you frequently use or

as an interface to your music library (if you

don't like other music software). If you do not

want to import these files, leave them where

they are in the file system. You can index the

files instead and access them from within

DEVONthink See also p. 140ff

Possible uses:

Create a dedicated database for photos

only

View your images in full screen mode

Include project-related images, audio, and

video in your databases

Play your music from within your work

environment

Continue to read here:

Import or index files

View files as thumbnails

View images and movies

Search your database

COLLECT TEXT SNIPPETS AND
OTHER VALUABLE DATA

Use macOS's handy Services menu for

collecting and organizing information bits and

snippets to DEVONthink.
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Select any piece of data and capture it to

the currently open database with a keystroke

or a quick visit to the Services menu. Most

true macOS applications such as TextEdit,

Safari, or DEVONthink itself support this

mechanism.

DEVONthink automatically sets the title of

the newly created snippet to the first line of

text, so there's a good chance that you won't

even need to rename it. New snippets are

created in the global inbox or the location you

choose. Also, DEVONthink can help classify

and file the items using its built-in artificial

intelligence.

Possible uses:

Collect recent news from your favorite web

sites

Keep important information from any

source and your other project-related

documents together

Create an info collection for a specific topic

Continue to read here:

Capture a note quickly using the Services

menu

Use the Sorter

Drag text clippings to the Groups panel

INDEX FILES ON YOUR HARD
DRIVE

Besides importing documents, DEVONthink

can also index files. When indexing files,

DEVONthink reads the contents of the file

and stores it for internal reference, but leaves

the files in place in the Finder. Use indexing

for easily accessing information stored on

removable volumes, creating a library of all

important documents regardless where they

are physically stored, or integrating files

stored elsewhere with your documents in

DEVONthink. See also p. 53ff

Possible uses:

Keep the folder structures you've created

in the Finder, while allowing access to

DEVONthink

Create a front-end for your document

collection

Integrate indexed items with imported and

items you've created in DEVONthink

Continue to read here:

Import or index files

Search your database

Launch the original file of an indexed item

MANAGE YOUR BOOKMARKS

With its integrated, document-based

web browser, DEVONthink can be used

as a bookmark manager. Organize all your
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bookmarks as bookmark documents and visit

the web sites by simply selecting them with

a preview visible. DEVONthink loads the page

and displays it in the View/Edit pane.

If you want to open the web page in your

default browser, simply Control-click the

bookmark and choose Launch URL from the

context menu.

Possible uses:

Manage your bookmarks

Keep project-related web pages and other

documents together

Visit frequently used web sites in a

convenient interface

Integrate "live" content from the web with

your other documents

Grab data from web sites and store it in

DEVONthink

Continue to read here:

Create a new bookmark

View "live" and local HTML pages

Drag URLs to the Sorter

SHARE PROJECT DATA

With its built-in synchronization, DEVONthink

allows you to have your databases on

multiple Apple devices. Changes made on one

machine propagate to the others, keeping

them in sync. It can also be used to manage a

shared project workspace.

Keep all your project-related data in an easy

to structure database and share it with

your team members. Use a shared WebDAV

volume, a shared cloud account, a local file

server, or direct connections to propagate

new data to the team automatically.

And if your coworkers don't use a Mac give

them access via DEVONthink's built-in web

server. You can set up web users and fine-
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tune the access permissions so that visitors

only gets access to what they should see.

SSL/TLS encrypts all data in transit.

Possible uses:

Organize project files, use advanced

feature such as tags and smart groups

Add new data from any team member's

computer or even iOS device running

DEVONthink To Go

Integrate "live" data, e.g., web pages or

newsfeeds, with your other documents

Give your colleagues using Windows or

Linux access to your knowledge with web

sharing

Continue to read here:

Set up sync to share data with your team

members

Set up the local web server

Add smart groups to organize data

automatically

Add newsfeeds

READ NEWS FEEDS

DEVONthink comes with built-in support

for RSS, RDF, Atom, and JSON news feeds,

which makes it a reliable basic news reader.

In addition, its integrated web browser

supports news feeds and displays them

like any other web page. Use its document-

oriented structure to organize bookmarks and

store news feeds like internet-updated smart

groups.

Mix live news feeds with static documents,

e.g., in your project materials.

Possible uses:

Read your daily news in a convenient

interface

Integrate "live" newsfeeds with your other

documents

Grab interesting information easily and

store it in DEVONthink

Continue to read here:

Create a new bookmark or HTML

document

View "live" web pages and news feeds

Create a news feed document

TAKE NOTES

DEVONthink is perfectly suited for taking

notes and organizing them.
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Quickly create new notes and file them in

your database using DEVONthink's Tools >

Take Note command to open the Sorter (or

an independent Take Note panel, if the Sorter

is hidden). Alternatively, use the Take Note

command in the Dock menu. Notes can be

created in plain or rich text, Markdown, or

formatted note formats.

Possible uses:

Write down ideas before they vanish

Take quick phone messages

Keep project notes and your other project-

related documents together

Continue to read here:

Create new documents

Create a new note using the Dock menu

Revise notes and documents using the

built-in rich text editor

WRITE TEXTS AND OUTLINE
PROJECTS

With its hierarchical group structure,

organization, and navigation functions, as well

as its advanced text editing capabilities and

full screen mode, DEVONthink is perfectly

suited for writing many kinds of documents,

from notes to whole books.

Create new documents with just one click,

find related documents in your database,

and connect them with Wiki-style or static

cross-links. Working these documents in

your databases, you can switch from one

document to another with just one click, and

manage even large projects with ease.

Utilize markers, like flags or color labels to

help visually distinguish items, by importance

or other criteria using label names. And

similar to the Finder, you can create groups,

as deeply (or shallowly) nested as you'd like.

Possible uses:

Write notes, white papers, and letters

Write and organize book chapters

Organize your ideas or projects in outlines

Create a network of information for your

projects or interests
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Continue to read here:

Create new documents

Use the built-in rich text editor

Use the See Also & Classify Inspector

Use the Concordance Inspector
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As DEVONthink is an information and

document management application, it

supports importing many different file

types. While not all formats are editable, if a

QuickLook plugin is installed on the machine,

the files should be viewable. Also, if a

Spotlight importer for these files is installed,

the files should be indexed by DEVONthink

and searchable. In addition, DEVONthink

supports creating some common types

directly in the application.

In the General section of this chapter, we will

discuss the essential window components

you'll use when viewing or editing these

documents. Following that are chapters for

the types of files DEVONthink supports.

GENERAL

When working with files in DEVONthink,

they can be viewed in the view/edit pane of

a main window or in a separate document

window. When viewing a document, there

are two essential components visible: the

view/edit area and the navigation bar. These

will always be available when working with

a selected file. Additionally, there are a few

optional components available: the editing

bar (for compatible formats), the tag bar,

and the context menu.

VIEW/EDIT PANE

The view/edit pane is where you can see or

edit the current document (with compatible

files). Each file type you view has its own

tools, context menu commands, and

keyboard shortcuts.

NAVIGATION BAR

At the top of the view/edit pane,

DEVONthink shows a navigation bar that

gives you access to some additional tools

that deal directly with the contents of

the document. Which tools are available

depends on the type of the document you are

viewing. The options below are shown in the

navigation bar for most file types. Specific

options are shown in the separate sections:

Navigates back to the last visited

document after following a link.

Navigates back to the next visited

document after going back.

Reloads the displayed page in a web view.

Only visible for, e.g., bookmarks.

Shows an action menu with options for

opening the shown page in Safari, copy its

address, or capture the page in a variety of

formats.
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Shows if the document is locked or

editable.

Scrolls to the previous highlight, e.g., a

search term occurrence.

Scrolls to the next highlight, e.g., a search

term occurrence.

Scrolls to the next page of the displayed

document.

Scrolls to the previous page of the

displayed document.

Switches to Text Alternative mode. Useful

for selecting text in uneditable formats,

e.g., Word documents.

Switches to Best Alternative mode. For

Markdown documents, this is the rendered

HTML view.

Word Count: Shows the number of

paragraphs, words, and characters of the

displayed text.

URL: Shows the URL associated with the

displayed item, if one is present. If a PDF

annotation is selected the URL field shows

the associated URL if available. Click to

launch the URL in its default application.

Hold the ⌥ Option or the ⌘ Command

key to open the URL in a new tab. Holding

⇧⌥ or ⇧⌘ opens the URL in a new tab and

selects it.

Page Count: Shows the number of pages

as well as the page number of the currently

displayed page. Click the page number in

PDF or PostScript documents and enter a

page number to jump directly to that page.

EDITING BAR

For some formats, e.g., rich text or sheets,

there is another bar available: the Editing

bar. If you click this icon , the editing bar

will appear in place of the Navigation bar.

This offers quick access to some editing tools

related to the file type you're working on. See

the appropriate file type section for more

info.

TAG BAR

The tag bar, which can be shown or hidden,

shows all tags associated with the document.

Click the tag bar and type to add tags; select

a tag and press the ⌫ Backspace or ⌦ Delete

key to remove it. See also p. 14ff

When you type the name of a tag,

DEVONthink offers automatic completion.

Choose the right option with the mouse

or the arrow keys and press ↩ Return or

 Enter to accept it. Press ⎋ Escape to use

whatever you entered. Auto-completion

prefers ordinary tags (tags represented in

the Tags group) over groups used as tags,

and also matches sub-strings. Press ⇥ Tab to

enter another tag.

Note: The tag bar is also visible for

multiple selected documents when all the

documents have the same tags attached.

Use it to change the tags on multiple

documents.

CONTEXT MENU ITEMS

If you Control-click in many types of

documents in DEVONthink, you are presented

with a context menu showing many options.

The options displayed depend on what you're

clicking; e.g., selected text, and in whether

you're in an editing or preview mode. As

many of these commands are the same for

most formats, we have provided a list in
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the appendix. Items specific to a format

are listed in their respective sections in this

chapter.

TOOLBAR & SHORTCUTS

DEVONthink can display documents in

separate windows when you double-click the

documents in a main window. Depending

on the type of document, the tools in the

toolbar can change. Even though not all tools

are always present in the default toolbar for

a particular type, you can easily add some by

choosing View > Customize Toolbar. Changes

made to the toolbar will be persistent for

that file type, but are independent of the

toolbars of other types.

Please find a list of toolbar items and 

shortcuts  in the appendix.

Note: Documents are automatically

saved every five minutes after the last

modification, when deactivating the

window, or when quitting DEVONthink.

DOCUMENT LINKING

Documents in DEVONthink are independent

items but often have context relationships

with other documents in your databases.

Efficiently creating and using these links is

key in many peoples' use cases. DEVONthink

supports three types of links.

LINK TYPES

WikiLinks: WikiLinks are specialized links

found in plain text, rich text, and Markdown

documents. Use them to link to existing

items or create documents on-the-fly. For

existing items, these links are automatically

detected depending on the method chosen

in the WikiLinks preferences. Note these are

not item links, which are discussed below.

Relative and Absolute Links: Most often used

in Markdown documents and also supported

in HTML-based formats, these are links

similar to what is seen in the source code of

web pages; e.g., /stylesheets/styles.css.

Note, these are not item links. See the

subsection on linking in the Markdown

section of this chapter for more information.

Item Links: Many applications today have a

URL scheme — a special URL that provides

some extra functionality for that application.

In DEVONthink, every item has a unique

URL, pointing only to that item. When used

with in-application documents or in external

applications that support URL schemes, the

item link will open the linked document in our

software. In some cases, the link may even

contain certain parameters to do things like

open a video to a specific time.

Item links are either incoming and outgoing

links. The two types of links function as sides

of one operation. If you create an item link

to an image, the file will have an outgoing

link detected. The image you have linked to

will have an incoming link detected since the

file has a link pointing to it. Documents with

these links will have a special property icon

displayed to the right of the filename in the

item list. You can display a sortable Incoming

Item Links and Outgoing Item Links column

in the headers of the item list in List view.

There also are incoming and outgoing item

link criteria usable in toolbar searches, smart

groups, smart rules, and AppleScript.
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One of the advantages of using item links

is the link title of item links can be updated

when you rename a linked document. To do

this, enable the Update name of item links

automatically options WikiLinks preferences.

You can also leave this disabled and use

the Tools > Item Links > Update Name of

Item Links command to manually update a

document. To switch from WikiLinks to item

links in a document, use the Tools > Item Links

> Convert WikiLinks to Item Links command.

Note: Item links are also discussed in the

Automation > Item Links section of this

help.

CREATING LINKS

Making links to other documents should

be easy to do. However, working within the

constraints of certain file formats sometimes

requires different methods to create them.

Listed below are the most common ways to

add links between documents.

Make Link: In rich text files, you can select

words and choose Format > Make Link to

create an active hyperlink of the selected

words. Clicking on the hyperlink will

generate a new WikiLinked document.

Copy and Paste: Select an item in the

item list and choose Copy Item Link. This

captures the item's unique link to the

clipboard so you can paste it into another

document or even another application.

Some other types of links can be captured,

e.g., page links. Item linking methods

specific to certain file formats are covered

in their respective sections of this chapter.

Add Link: For text in rich text and

formatted notes, you can select words and

choose Format > Add Link. You can then

add a URL, including an item link, to create

an active hyperlink of the selected words.

Drag and Drop: You can Option-Command-

drag and drop a file into a compatible

document to insert an item link. This is an

efficient way to insert links into rich text or

Markdown documents.

Insert Link: Edit > Insert > Item Link opens

the Insert Item Link popover, allowing you

to add an item link to a document.

VIEWING LINKS

View incoming and outgoing links in the

Document > Links inspector. You'll also see

web links in a document are listed as outgoing

links.

PLAIN AND RICH TEXTS

PLAIN TEXT

Plain text files may seem too simple to be

truly useful. No styling. No images. Nothing

but text. But the reality is these simple files
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are underlying a lot of your daily experience.

From the HTML code instructing your

browser how to display a web site, to the

code DEVONthink is written in, plain text is

very powerful. DEVONthink supports plain

text files as a native, editable format.

Plain text files can be created via Data > New

> Plain Text.

RICH TEXT

Word processing applications brought

us text with flair. Need some bold and

italic text? How about adding a photo to

the page? And color? These applications

were providing it all. But their formats are

proprietary so if you don't have the creator

application, you can't open the file or you'll

have to convert it first. The rich text format

provides a useful text format that supports

formatted text. These files are generally

cross-platform compatible and editable in

many applications. DEVONthink uses the

same text engine found in Apple TextEdit, so

it's an easy transition if you're already familiar

with it.

You can attach other documents to rich text

documents simply by dragging them into

the text. Technically the rich text document

becomes an .rtfd package and the dragged

file is saved as part of the package. Using the

context menu, you can show an attachment's

content in a Quick Look preview. Also, if you

double-click an attachment, it will open in the

system default application.

Rich text files can be created via Data > New >

Rich Text.

EDITING BAR

The navigation bar for rich text files includes

the Editing Bar. Click this  icon and

the editing bar will appear in place of the

navigation bar. The tools available here

consist of:

Edit the formatting of a list.

Edit parameters of a table.

 Increase the size of the font.

 Decrease the size of the font.

 Set characters to be subscript.

 Set characters to be superscript.

Adjust the line spacing of selected text.

 Set bold on the text.

 Set italic on the text.

 Set underlines on the text.

 Set strikethrough on the text.

Highlight selected text. This uses the

currently selected highlight color.

Add or edit a link applied to the selected

text.

Convert selected text into an active link.

This can be used to dynamically create Wiki

documents.

Show or hide the ruler. Place tab stops with

the mouse, then remove them by dragging

them off the ruler. Drag new tab stops (left

aligned, centered, right aligned, or decimal

aligned) from the repository at the right

side to their desired positions on the ruler.

Use the mouse to adjust the left and right

margins and indent.

Show the Fonts panel.

Show the Color Picker.
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THE FORMAT BAR

In addition to formatting options in the

Format menu and the simple controls in the

editing bar, DEVONthink provides another

toolbar just for rich text editing. Select

Format > Show Format Bar to display a set of

rich text controls under the toolbar in main

or document windows. Similar to TextEdit, it

provides the following options:

Styles: Select a predefined text style from

the pop-up menu. To define your own

styles, choose Other to open the standard

macOS style editor. In the style editor,

navigate back and forth through the styles

of your document or the stored favorite

styles. (Use the radio buttons to switch

between document and favorite styles.)

Click Select to select all occurrences

of text with the displayed style in the

document, click Apply to apply the style

to selected text, or click Done to leave

the style editor. To add a style from your

document to the favorites, click Add

To Favorites; to remove a favorite, click

Remove From Favorites.

Font Controls: Displaying three dropdown

menus for, choosing the font face, font

weight, and font size.

Colors: Two buttons are available for

setting the text and background color.

Basic Styling: Allows you to choose bold,

italic, or underlines.

Alignment: Align the current paragraph

(the one with the insertion caret inside)

left, centered, justified, or right by clicking

the according alignment buttons in the

ruler.

Spacing: Choose the desired spacing for

the current paragraph from the Spacing

pop-up menu. Choose Other to enter

values other than the ones shown.

Lists: Make the current paragraph a list

(indented and with a bullet or numbered)

by choosing the desired list style from the

Lists pop-up menu. Choose Other to define

your own list style.

Note: The built-in "mini outliner" is a nice

feature of the macOS rich text editor. On

any blank line in a rich text document,

type ⌥⇥ Option-Tab to create a bullet

point (macOS shows dashes instead of

bullets). Press ↩ Return for the next item,

and so on. Additional ⌥⇥ will increase the

indentation; a ↩ on a blank list line will

decrease it. The mini outliner uses hyphens

to indicate list items by default.

CONTEXT MENU

In addition to the context menu items

available with text selections, rich text files

also feature these specific commands:

Copy Paragraph Link: Copies a link to the

current document, but appends a pointer

to the selected paragraph.

Insert > ...: Inserts special characters or

items into the document.

Quick Look Attachment: Opens a Quick

Look panel for the selected attachment in

a rich text file.

Split Document: Splits the document

at the current insertion position. A new

document is created for the text after

the cursor position and removed from the

current document. This can be used in rich

text and plain text, including Markdown

content in edit mode.
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ITEM LINKING

In addition to the document's standard item

link, plain and rich text files support this

alternative item link:

Paragraph Link: Link to the paragraph of

the selected text.

Alternate item links are available in the

context menu in the view/edit pane or when

holding the Shift key while viewing the Edit

menu.

PDFS

PDFs are a very common format, from

academia and online bill payments to

equipment manuals. Fortunately, they

are first-class citizens can be viewed

and annotated within DEVONthink. The

annotation tools should be familiar and

include options like arrows, text, and link

annotations. While DEVONthink may not

have some options found in specialized PDF

applications, it is still a very capable PDF tool.

PDF files can be imported or indexed.

They can also be created by capturing web

content, directly in DEVONthink or via our

browser extension, Clip to DEVONthink. You

can also use the PDF Service Save PDF to

DEVONthink 3 in the PDF dropdown of the

print dialogs of most macOS applications.

This will print a paginated PDF to your

database. PDFs often come directly from

text sources, like word processing or page

layout applications. The content of these

files should be indexed and searchable when

added to your database.

You can also acquire PDFs from scanned

documents. These files will only have a text

layer if OCR is done on them. For scanned

PDFs without a text layer, you can do OCR

directly in DEVONthink when needed.

Viewing PDFs: When you view a PDF it will

display as single or two side-by-side pages.

Choose the desired option in the View >

PDF Display options. When the document

opens, the pages are viewed as the entire

page or magnified to the width of the view/

edit pane. You can choose how the document

is displayed in the View > Zoom submenu. If

you'd like to always view PDFs with a specific

Zoom option, you can set a default in the

Files > Multimedia > PDF Display preferences.

Enable Automatically resize then choose

a single or double page option. The Zoom

option used is controlled as shown below:

Continuous: Zoom to Width

Non-Continuous: Zoom to Fit
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NAVIGATION BAR

In the navigation bar for PDFs, the number of

pages in the document is displayed. Clicking

on this navigation bar item opens a Go to

page function so you can quickly jump to a

specific page. In addition, there are options

to move to the first, previous, next, or last

page.

EDITING BAR AND ANNOTATIONS

The navigation bar for PDF files includes the

Editing Bar, providing access to editing and

annotation tools. Click this  and the editing

bar will replace the navigation bar. The tools

available here consist of:

Select text for copy or highlighting.

Select annotations on the page. Double-

click an annotation to edit its properties.

Press the ⌦ Delete key to remove the

annotation.

Move or scroll the current page.

Underline selected text in the document.

Strike through selected text in the

document.

Apply or remove highlighting on selected

text. The highlight color will be the color

selected in Format > Highlight Color.

Alternately, click and hold to select another

color.

Add a link to a selected area. Click and

drag over an area to establish a hotspot

for the link to be active. For the Link

Type, choose Link within PDF, navigate

to another page and click Set to create a

link between pages within the same PDF.

Alternatively, choose URL and enter a URL

to an external item. This can be a web site

address, or drag files from the Finder or

your DEVONthink databases into this field.

Add a rectangle annotation.

Add an oval annotation.

Add a line annotation.

Add a note annotation.

Add a text annotation. Drag to create

a text box. To change the font, choose 

Format > Font > Show Fonts.. Note only one

font can apply to each text annotation.

Rotate the current page left (counter-

clockwise).

Rotate the current page right (clockwise).

Add a new blank page before the current

page.

Delete the current page.

Reverse the page order of the document.

The annotation tools in the editing bar are

also available in the Tools > Annotate menu.

CONTEXT MENU

In addition to many common context menu

items there are also a few PDF-specific

options:

Automatically Resize: When checked, the

zoom factor adjusts to the width of the

view/edit pane or document window.

Delete Annotation: Deletes the selected

annotations.

Single Page/Two Page (Continuous):

Displays the PDF as single or double

pages. Use the Continuous option to allow

quick scrolling through the pages as one

continuous document.

Previous/Next Page: Jumps to the previous

or next page.

Rotate Left/Right: Rotates the current

page 90 degrees in the selected direction.
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Insert Blank Page: Insert a new blank page

before the current page.

Delete Page: Delete the current page.

Reverse Page Order: Reverses the order of

the pages in the entire document.

INSPECTORS

There are a few inspector panes with

information specifically pertaining to PDF

documents: Info > Properties, Content

inspectors, and Document > Annotations.

Properties: The Properties inspector displays

PDF metadata from some third-party

applications, e.g., Adobe Acrobat. This will

display things like a title, copyright, author,

and keywords, if available.

Content: The Table of Contents inspector

displays a PDF's table of contents, if one

exists. You can navigate through the

document with the section markers in it.

The Thumbnails inspector displays page

thumbnails of the PDF currently displayed

in the view/edit pane. You can navigate

via the thumbnails. You can also, drag to

rearrange the pages, or even drag them out

of the inspector to export them. Alternately,

drag other PDFs into the inspector to merge

one document into another. Commands for

deleting or inserting blank pages are found

in the Tools > PDF submenu. And the Split

Document command becomes available in

the Tools and context menus when you've

selected a page thumbnail.

Document: If you are annotating your PDFs,

the Document > Annotations inspector

is where you can see and manage the

document's annotations. Edits made with

the annotation tools mentioned above will

appear here. You can also selectively delete

annotations in this inspector.

ITEM LINKING

In addition to the document's standard

item link, PDF documents support these

alternative item links:

Page Link: Links to the current page.

Selection Link: Links to selected text.

Annotation Link: Links to a selected

annotation.

Alternate item links are available in the

context menu in the view/edit pane or the

Thumbnails inspector. The alternate links are

also accessible when holding the Shift key

while viewing the Edit menu.

MARKDOWN DOCUMENTS

Markdown is a simple formatting language

invented by John Gruber that has gained in

popularity over the past few years. It allows

you to write in plain text, using some easily

learned control characters, to produce nicely

DEVONthink 3.9.17 Documentation, page 40

https://en.wikipedia.org/wiki/Markdown


rendered HTML output. With some styling

and ingenuity, you can create a wide variety

of documents.

Markdown files can be imported or created

via Data > New > Markdown text.

Editing: Writing Markdown is essentially the

same as writing plain text documents. As

you're writing you can switch easily between

a plain text editor and the rendered view or

even view both simultaneously using the side-

by-side view via the View > Document Display

commands.

When editing the source of the Markdown,

DEVONthink's hybrid source rendering

will display many types of formatting or

elements as you type. For example, typing

**important** will display the plain text in

bold; `{"name":"Audrey Hepburn"}` will

display as a code block, etc. If you'd prefer to

see no formatting in the source code, you can

disable WYSIWYG editing in Settings > Files >

Markdown.

The currently supported WYSIWYG types,

including CriticMarkup syntax, are:

Formatting:

Bold: **bold**.

Italic: *italic* or _italic_.

Bold-Italic: ***bold-italic***.

Highlight: {==highlight==}.

Underscore: {++underscore++}.

Strikethrough: {--strikethrough--}.

Subscript: ~subscript~.

Superscript: ^superscript^.

Elements:

Header: # Header. Prefix each header with

the appropriate number of pound signs.

Supports header levels 1 through 6.

Link: [Link Text](URL) or <URL>.

Blockquote: > preceding each line in the

quote.

Code block: `code terms`. Note: Those

are backticks, found on the tilde (~) key.

Fenced code block: ``` - triple backticks

on a line above and below the code. To

show syntax coloring in the rendered

view, see the Markdown Extensions: Prism

subsection below.

Metadata headers: attribute: . As noted

below, these must be the first lines in the

document.

File Transclusion: A special feature of

DEVONthink's Markdown handling is support

for file transclusion. This provides the

capability of displaying the contents of one

file inside the contents of a Markdown file.

This supports displaying the contents of:

plain text, rich text, HTML, formatted notes,

sheet, or more commonly, other Markdown

files. For example, you may have several

chapters of a book written in individual

DEVONthink 3.9.17 Documentation, page 41



Markdown files. Use transclusion to view

them all as one document with out the need

to merge or copy and paste the content

between files, similar to some popular writing

applications.

To use transclusion, just enter the desired

document's name or item link between

double braces, e.g., {{Chapter 1}}.

Transclusion supports filenames with and

without extensions, relative and absolute

links, as well as item links. It also supports the

Obsidian syntax, e.g., ![[Chapter 2.md]].

Styling: Styling your Markdown documents

can be done with internal styling or externally

referenced stylesheets. If you have a specific

stylesheet you'd like to use globally, you can

specify one in Settings > Files > Style Sheet..

Here are the options:

Internal styling: <style type="text/

css"> … </style>

HTML Link: <link rel="stylesheet"

type="text/css" href="css/

styles.css" />

XHTML Link: CSS: css/styles.css.

XHTML headers must be placed at the very

top of the document.

Note: If no specific styling is applied, the

font choice in Settings > Editing > Rich Text

& Note Font will be used when previewing

Markdown documents.

Linking: You can reference local images,

scripts, and other resources using item links,

downward-relative (traveling subgroups;

it's not possible to travel up with '..' as

documents can have multiple parents) or

absolute (start with a forward slash) paths.

Here are examples of linking an image:

![link](item.png): Use this when

linking to an item in the same group as the

Markdown document.

![link](group/item.png): Use this when

linking to an item in a sub-group of the

group containing the Markdown document.

![link](/group/item): Use this when you

are linking to an item in a group outside the

group containing the Markdown document.

For example, if you have common resources

in a specific group, you can link to them

using this format.

Linking Images: Regarding keeping track

of your linked images, if you drag or paste

images into a Markdown document, they will

be imported into a group in the document's

location if Preference > Files > Markdown >

Import images to group is enabled. The group

name is also assigned in the preferences, with

the default name being Assets. This group

will also contain images from web content

clipped as Markdown documents if the above

option is enabled.

If you enter a name in the preferences

mentioned above, this will create a subgroup

in the location of the Markdown document

and a relative link will be created in the

Markdown document. If you add a name

preceded by a forward slash, e.g., /Markdown,

this will create a group in the root of the

database and an item link placed into the

Markdown text. You can even set a more

precise location, e.g., /Inbox/Markdown/

Images.

Linking Other File Types: If you have enabled

automatic WikiLinks > Names & Aliases,

documents can be detected as you write your

Markdown. These WikiLinks are active when
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previewing the file and are also preserved

in a website export or conversion to other

formats.

Drag and drop items into a Markdown

document to add the appropriate links. Drag

and drop documents while holding ⌘-⌥ will

create a URL with an item link. Dropping

an image will create a properly formatted

Markdown image link. Drop .mp3 or .mp4 files

to insert a playable multimedia link.

Another option for inserting links into

Markdown documents, Control-click while

editing and choose Insert Link To from the

context menu. A Markdown formatted

link will be automatically inserted for you.

For images, just add an exclamation point

before the link if you want it to display in the

rendered document.

You can learn more about Markdown and its

syntax on Gruber's Markdown pages or the

MultiMarkdown syntax guide.

Metadata: One of the features of

MultiMarkdown is metadata headers. These

allow you to add non-displaying information

about the document, like authors, dates, and

even linked stylesheets. To use the feature,

format the first line of the document with a

colon, e.g., Author: DEVONtechnologies. This

must be the first line of the document. Other

metadata fields you wish to add must follow

immediately after this first line.

However, if you would like the first line of your

document to contain a colon, perhaps adding

notes like Developer: A. Edwards and Re:

OCR, just add a single blank line at the top of

the document and the subsequent lines will

be treated as normal paragraphs.

Emoji: For a little extra personalization, you

can type Slack-style emoji, like :grinning:,

directly in the Markdown document.

MARKDOWN EXTENSIONS

To support some features in Markdown

that aren't built in, DEVONthink supports a

handful of known and widely used extensions.

The first option below requires no user

interaction. The following three can be

enabled in Settings > Files > Markdown, if

desired.

Highlighting, strikethrough, …: Text notations,

e.g., for noting changes are sometimes

necessary in documents. DEVONthink

supports the features of the CriticMarkup

extension of Markdown. It also supports

a few alternate highlighting syntaxes, like

==text== and ^^text^^, found in some other

Markdown-enabled applications.

MathJax: Markdown is often used

in academic situations, many using

mathematical equations in their writing.

DEVONthink supports the Mathjax extension

that will beautifully render LaTeX coded

equations in your Markdown documents.

For more information on how MultiMarkdown

handles equations, please see: Math support

in MultiMarkdown.

Mermaid: Diagrams can be created in

Markdown documents using the Mermaid

extension. Add a line of three backticks as

shown```mermaid. Add the diagram code as

needed and close the diagram with another

line of three backticks. There are several

diagram types available and discussed on the

Mermaid.js website.
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Prism: For those writing code in their

Markdown, DEVONthink supports Lea

Verou's Prism extension. Just add a line

of three backticks ```language- and the

language you're writing about. For example,

```language-applescript. Remember to

add a line of three backticks under the code

to close it. This displays syntax highlighting

of code blocks in the rendered output. Note

it does not affect the Markdown source as

you're writing, only the rendered output.

Note: Not all languages supported by Prism

are available. Additional languages may

be added in the future if there's sufficient

interest in them.

NAVIGATION BAR

When working with Markdown documents,

you can switch between Preview and Source

modes. There also is a special icon  present

in the navigation bar. This switches to Side-

by-Side mode, allowing you to edit and

preview the current document in two side-by-

side panes.

CONTEXT MENU

Markdown documents support the same

context menu items available with text

selections in the document source.

ITEM LINKING

In addition to the document's standard item

link, Markdown documents support this

alternative item link:

Section Link: Links to the section, e.g., an

h1 header, of the selected text.

Alternate item links are available in the

context menu in the view/edit pane or when

holding the Shift key while viewing the Edit

menu.

HTML-BASED FORMATS

HTML-based files in DEVONthink include

bookmarks, web archives, formatted notes,

and RSS articles. These are formats that

are viewable in web browsers and are also

mobile-native.

BOOKMARKS

Bookmarks are exactly the same as the

ones found in your web browser. With

DEVONthink's ability to act as a browser,

bookmarks can be a valuable part of your
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experience. When using File > Import >

Bookmarks,  you can bring your bookmarks

into DEVONthink easily. Though this depends

on the capability of the individual browser,

you may be able to drag links directly into

your database. You can also capture them

with DEVONthink's browser extension, Clip to

DEVONthink.

Note: If you import your bookmarks from

a browser, this is a copy operation not

a sync, i.e., if you modify bookmarks in

your browser, this will have no effect on

DEVONthink's contents. However, you

can do another import to add the new

bookmarks to your database without

duplicating the previous ones.

In addition to importing bookmark files, they

can be created via Data > New > Bookmark.

Just provide a URL and title. If you don't enter

a title, DEVONthink will attempt to detect

and use the page title.

FORMATTED NOTES AND HTML

Formatted Notes:  allow to write simple

formatted text including embedded images

that can be viewed on any system with

just a web browser. While the range of

formatting options is smaller that that of

rich text they are much more compatible to

today's standards. You can find all available

formatting commands in the Edit and Format

menus. When creating new formatted notes,

DEVONthink will use the font set in Settings

> Editing > Rich Text & Note Font. Captured

or imported formatted notes, e.g., from

Evernote, use the font set in Settings > Web >

Standard Font

Technically formatted notes are based on

HTML, the language of the world-wide web.

Images are embedded directly into the

HTML code so that formatted notes are

completely self-contained. The HTML code

is also cleaned from unnecessary tags and

an identifying meta tag is inserted that lets

DEVONthink distinguish formatted notes

from normal HTML pages. Form tags, e.g., for

checkboxes and input fields are not removed

and the status of checkboxes and form fields

is retained.

Bear in mind, the underlying markup

in formatted notes can't be edited in

DEVONthink. However, you can open the files

in a compatible external editor, if you'd like.

Note: Since images are completely

embedded in the documents, the resulting

file size can grow large very quickly. Resizing

images before adding them is encouraged.

HTML Files:  are similar to formatted notes,

but they do not preserve the state of

checkboxes and form fields. You also cannot

add images by dragging them into the live

editing view. However, you can edit the

underlying HTML code using the Source and

Side-by-Side modes found in the navigation

bar.

Formatted notes can be imported or created

via Data > New > Formatted note. When

using the Notes from Evernote or Folders

& Attachments from Notes options in the

File > Import menu, the imported notes are

formatted notes. HTML files can be imported

or created via Data > New > HTML page.
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WEB ARCHIVES

Web archives are a special HTML file format

intended to create offline archives of

individual web pages. The downloaded data

preserves the look and feel of the page very

closely. It is often a more useful capture

option when a PDF would generate a very

long page since web archives always view at

the size determined by the browsing area.

They function in a similar fashion as

formatted notes, so you can actually edit the

captured contents and save your changes.

This can be very handy for highlighting

passages or removing unwanted elements,

e.g., ads, in a captured web page. Also, since

they are HTML files the underlying markup

can be edited using the Source and Side-by-

Side modes found in the navigation bar.

Note: Web archives can be very useful with

web pages using statically linked content.

However, some popular and monetized

sites get their contents dynamically from

other sources, so the actual data is not

in the underlying HTML. These pages may

have missing content due to this, require

an internet connection to display content,

and run JavaScript. If you encounter this, a

PDF may be a better archiving option.

Web archives files can't be directly made.

They are the result of capturing web content,

either in DEVONthink or using our browser

extension.

Note: Web archives made on macOS

Mojave aren't necessarily compatible with

earlier versions of macOS.

RSS

RSS feeds are special "web pages" that don't

show as pages but as a stream of news

articles. DEVONthink allows you to keep that

news flowing directly into your databases.

Supporting RSS, RDF, Atom, and JSON feeds,

DEVONthink functions as a basic newsreader.

RSS feeds are treated as a special type of

file that functions as a group. Feed articles

are downloaded to the feed and saved

in a format you specify in DEVONthink's

Settings > RSS > Feed Format. The default is

Automatic and saves summary files as HTML.

The styling of the HTML articles is controlled

by an internal CSS stylesheet specified in

Settings > RSS > Feed Style Sheet. Other

formats will get their styling from the source

they're downloaded from.

Note: When using an option other

than Automatic as the feed format,

DEVONthink must download the linked

content and convert it to the appropriate

format.

RSS feeds can be created via Data > New >

Feed. Provide a URL and title. If you don't

enter a title, DEVONthink will attempt to

detect and use the feed's title.

EDITING BAR

Like rich text files, editing HTML-based files

(excluding bookmarks) includes the Editing

Bar. Click this  icon and the editing bar will

appear in place of the navigation bar. The

tools available here consist of:

 Increase the size of the font.

 Decrease the size of the font.

 Set characters to be subscript.
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 Set characters to be superscript.

 Set bold on the text.

 Set italic on the text.

 Set underlines on the text.

 Set strikethrough on the text.

Highlight selected text. This uses the

currently selected highlight color.

Add or edit a link applied to the selected

text.

Show or hide the ruler. Place tab stops with

the mouse, then remove them by dragging

them off the ruler. Drag new tab stops (left

aligned, centered, right aligned, or decimal

aligned) from the repository at the right

side to their desired positions on the ruler.

Use the mouse to adjust the left and right

margins and indent.

Show the Fonts panel.

Show the Color Picker.

CONTEXT MENU

In addition to the context menu commands

available with text selections in a document,

HTML based files often include these items:

Add Page to Reading List: Adds the current

page the Reading List as a bookmark.

Capture …: Captures the Control-clicked

frame, image, link to the inbox of the

current database.

Capture Page: Captures the current page

in the selected format to the inbox of the

current database.

Copy … Address: Copies the frame URL of

a Control-clicked frame, image, page, or

video to the clipboard.

Insert > ...: Inserts checkboxes into the

document.

Open … in New Tab: Opens a Control-

clicked image, page, or video in a new

DEVONthink tab.

Open Image in PhotoStickies: Opens the

image in PhotoStickies.

Open Page in Browser: Opens the current

page in your default web browser.

Open Page in DEVONagent: Opens the

current page in DEVONagent Pro.

Reload: Reloads the page from the Internet.

Update Bookmark: Updates the URL of this

document to the current one, e.g., after

navigating to a sub-page.

Update Captured Archive: Updates the

contents of a web archive file with the live

version on the Internet.

Add Page to Downloads: Adds the page

address to the Download Manager.

Download Video: Downloads the video

using the Download Manager.

ITEM LINKING

Web-based formats currently support no

alternate item links.
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SHEETS

Sheets contain text in a table and can be

used to store any kind of tabular data from an

address book to recording health statistics to

employee timesheets. They are made up of

records, defined by parameters displayed as a

form or columns. For example, a simple sheet

could contain a table of peoples' name, title,

and department.

When you create a sheet or make changes

to the sheet columns via the Column Editor,

you will specify the column names and their

types. An explanation of the data types can

be found in the Data section of the appendix.

Sheets can be displayed as a table or a form

via the View > Document Display menu or

using the  and  buttons in the navigation

bar. The table view is similar to standard

spreadsheet views. Form view is similar to

the record view e.g., in FileMaker.

Use sheets like any other document. Add

new rows using Tools > Sheets > Add Record,

delete rows by selecting them and using

Edit > Delete. Alternatively, use the context

menu. Click a cell to edit its content, press

the ⎋ Escape key to stop editing, and use the

Tab or Return keys to navigate from cell to

cell. Hold the ⌘ Command key to activate a

link in a cell.

If you import tab or comma-delimited files,

e.g., CSV or TSV files, they will be imported

and displayed as sheets. Sheets can also be

created via Data > New > Sheet. You will just

need to provide starting column headings,

which you can certainly add or take away

from later.

NAVIGATION BAR

The Navigation bar displays the current

record and the total number of records in the

sheet. Clicking on this information opens a

Go to record function so you can quickly jump

to a specific record in the sheet. In addition,

there are options to go to the first, previous,

next, or last records.

EDITING BAR

To make working with sheets even more

efficient, DEVONthink includes the editing

bar with some basic tools:
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Add a new record to the sheet.

Duplicate the current or selected records.

Delete a new record from the sheet.

Add a new column to the sheet.

Displays the Column Editor to allow editing

and managing the columns.

Delete a column from the sheet.

In Text Alternative, there is one more option

in the editing bar: Delete Selected Column

allows you to delete a column. Just click on

the column header you want to delete, then

this option is enabled.

CONTEXT MENU

There are a few sheet-specific context menu

items available when you're Control-clicking in

a sheet.

Cut/Copy/Paste: Cuts, copies, or pastes

whole records in a sheet. Use them, for

example, to duplicate records. Pasting

always pastes as the last record in the

sheet.

Delete Records/Columns: Deletes the

selected record(s) or column(s).

Edit Columns: Displays the Column Editor

to allow editing and managing the columns.

New Column: Creates a new column in the

sheet.

New Record: Creates a new record in the

sheet.

Duplicate Record: Duplicates a selected

record in the sheet.

Note: Despite any visual or behavior

similarities with Microsoft Excel, sheets

are not spreadsheets and therefore do not

provide functions and formulae.

ITEM LINKING

Sheets currently support no alternate item

links.

IMAGES, AUDIO, AND VIDEO

DEVONthink uses macOS core technologies

to display images and videos, and also play

audio. Interacting with images uses the same

controls you are used to, like pinch to zoom

in and out, two-finger tap to zoom to width,

and even two-finger rotation in 90 degree

increments. Audio and video files display the

familiar macOS controls.

Images, audio, and video files can be

imported. Also in DEVONthink's Sorter you

can capture the screen to an image, as well as

record audio and video notes.

EDIT PANEL

When working with images, double-clicking

opens an edit panel with three tabs. The

Adjust tab allows you to do some basic image

editing, like adjust exposure, saturation,
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adding a sepia tone, etc. The Effects tab

provides some simple pre-defined image

effects. The Details tab displays metadata

about the image, including EXIF metadata

and a map of the geolocated origin of the file.

NAVIGATION BAR

For audio and video files, there is a special

option available in the navigation bar: the

playback time. This displays the current time

of playback (audio and video only). Also,

if you click the time it shows a Go to time

function so you can quickly jump to another

time in the playback.

CONTEXT MENU

There are a few media-specific context

menu items available, excluding common

ones related to magnifying the image. In

addition to the standard controls, e.g.,

volume, playback position, etc., some of the

same context menu options are found in the

action menu for these files.

Rotate Left/Right: Rotate the image

left and right. The image is saved in an

uncompressed TIFF format.

Flip Horizontal/Vertical: Flip the image on

the chosen axis. The image is saved in the

lossless TIFF format.

Edit: Opens the Edit panel.

Copy Image: Copies the image or current

video frame to the clipboard. When used

with an image, an uncompressed TIFF file

will be captured.

Set As Thumbnail: Makes the current frame

the thumbnail of the video (only available

when the video is not playing).

Note: Edits to or copying an image

via context menu items produces an

uncompressed TIFF file. These files can

be quite sizable, but are also saved in a

lossless format.

ITEM LINKING

In addition to the document's standard

item link, audio and video files support this

alternative item link:

Frame Link: Link to the current time of

paused media.

Alternate item links may be available in the

context menu in the view/edit pane or via

the Action menu (gear icon) while the media

is paused. The alternative command is also

accessible while holding the Shift key while

viewing the Edit menu.

Note: We sometimes get inquiries

about including entire photo libraries in

DEVONthink, e.g., from Photos, Lightroom,

etc. While it's certainly possible to

include images in your databases, please

understand DEVONthink is not a digital

asset management application. If you

want to include some images on a per

project basis, perhaps for journaling or

genealogy, etc., that works fine. If you are

trying to have an image archive, searchable

by media-specific metadata, you'll be

better off using an application built for this

specific purpose.
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OFFICE DOCUMENTS, EMAIL,
AND OTHERS

DEVONthink is the central hub for many

environments, from home to office, and you

are likely using several other applications

along side it. As often mentioned,

DEVONthink supports importing many file

types; some editable, some not. If a format

is text-based, like XML files, they may be

directly editable. But even if a file is not

editable, it may be searchable. This section

is obviously not exhaustive in what kind of

files can be added to DEVONthink, but if

you have a format we haven't discussed, the

easiest thing to do is just try importing it.

Any failures will be reported in Window > Log.

EPUB

EPUB files (.epub) are a popular format,

commonly used for digital books (including

our manual). While they can't be edited

in DEVONthink, their contents are fully

indexed and searchable, making them a viable

resource in your databases.

Navigate an EPUB file in the Content > Table

of Contents inspector or choose the View >

Document Display > Text Alternative view.

When searching an EPUB file, the view/edit

pane will switch automatically to the Text

Alternative view to display the search hits.

OFFICE DOCUMENTS

Word processing, spreadsheet, and

presentation applications are common in

many situations. When using the proprietary

formats from these applications, like

Microsoft Word documents (.doc, .docx)

instead of rich text files, these formats aren't

directly editable in DEVONthink. However, it

does support importing and indexing these

particular document types:

Apple Pages, Numbers, and Keynote from

Apple's iWork suite

Word, Excel, and PowerPoint from

Microsoft's Microsoft Office suite.

Files from supporting applications, like the

OpenOffice or  LibreOffice suites.

Files from the popular macOS Mellel word

processor.

These formats can only be imported, however

it is possible to add template files of these

formats. For example, you may have a

boilerplate Pages document you often use.

This could be added as a template to quickly

add to your database, then opened and

edited in Pages. See the appendix for a bit

more information.

EMAIL

Imported email messages have their

contents indexed (excluding the contents of

attachments). This makes them searchable

and a valuable asset, whether you're archiving

email for personal or professional reasons.

TEXT AND BEST ALTERNATIVE

For some document formats, e.g., email

messages or Word documents, DEVONthink

only allows you to select and copy text in

the Text Alternative view. If DEVONthink is

able to interpret and convert the document

format, you can use the  and  buttons

in the navigation bar to switch between a

view that allows you to select, copy, and drag

text or the Quick Look view showing a more

"accurate" view of a file.
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Also note you will have text-related context

menu items available when you can make text

selections in the Text Alternative view of a

file.

Note: For uneditable formats, DEVONthink

uses Quick Look to display the file,

provided an appropriate Quick Look plugin

or application providing one is installed. If a

document you want to view in DEVONthink

does not show a Quick Look preview, you

may need to contact the maker of the

source application and ask them to add

Quick Look support.

CONTEXT MENU ITEMS

Context menu items aren't available in

Quick Look views, e.g., Control-clicking

in a PowerPoint file. Also, when using the

Text Alternative mode for these files, some

but not all context items related to text

selections are available. See also p. 230ff

ITEM LINKING

No alternate item links are available for non-

native formats.

LINKED FILES

On occasion we get an inquiry about

importing files with linked assets, like Adobe

Illustrator or InDesign files. While it's certainly

possible to import these, the links will be

broken if you try to import a folder structure

containing the links. Groups in DEVONthink

do not exist in the file system, so the groups

that are created when you import a folder

structure from the Finder don't exist as

real folders in the database. The files inside

the folders are imported into the internal

structure of the database, so their paths are

not pointing to the groups in the database.

If you want to include these kinds of files in

your databases, you could keep the linked

files external and only import the documents.

You could also index the complete folder

structure containing your files into the

database, leaving them where they are in the

Finder. Since the paths aren't changing, the

links would be preserved when you open the

documents.
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DEVONthink is not an island. It integrates

with the rest of your Mac and iOS devices

in a variety of ways to make it easy for you

to add data to DEVONthink. There are even

some options that allow you to share your

data with friends and colleagues.

IMPORTING & INDEXING

When it comes to getting data into your

databases, there are two fundamental

methods to consider: importing and indexing.

IMPORT

Importing copies files into the internal

structure of the database. This creates a

portable, self-contained database that can

be moved as a single file. This is the default

behavior of DEVONthink.

When you drag-and-drop files or choose File

> Import > Files and Folders, files are copied.

This does leave the originals in the Finder,

which you can choose to keep or delete. But

note there is no connection between the

files any longer. Editing the file in the Finder

after importing has no effect on the file in

the database, as the database has a copy of

it. If you want to access and edit the files, do

so from inside DEVONthink.

If you hold the ⌘ Command key when you

drag into DEVONthink, the file will be moved,

not copied, into the database. If you are using

File > Import > Files and Folders, you can

click the Options button and enable Move

Originals to Trash.

INDEX

Creates links to files outside the database.

This allows more direct access to the files in

the Finder by other applications or people.

A common example is people using a cloud

service like Dropbox and indexing folders

in the local Dropbox folders. DEVONthink

indexes the content and metadata for use

with classification and other content-related

functions, just as it does with imported

items. Do note while indexing doesn't copy

the contents of the files, the full text of text-

based documents is stored. This can still take

up a considerable amount of space.

Finder files and folders can be indexed using

File > Index. You can also hold ⌥⌘ while

dragging and dropping into your database.
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When you do, you will see a curved arrow

on the cursor while dragging, indicating the

items will be indexed. Indexed items will have

a small square Finder icon to the right of the

item's name.

INDEXING AND THE FILESYSTEM

Indexing is not the default option for getting

files into your databases. This is not only

because importing creates a singular,

portable database, but also due to some

technical things that must be considered

when indexing. Here are a few behaviors you

should know and understand before indexing.

With indexing, the integration with the

filesystem is very tight. When you rename a

file in DEVONthink, the file's name changes

in the Finder. If you rename in the Finder, the

change should be automatically reflected in

the database. DEVONthink tries to keep the

group in the database and the folder in the

Finder in the same state. Also, if you move

a non-indexed file into an indexed group or

create a new file in an indexed group, the file

will be moved to the external indexed folder, a

process we call "deconsolidation".

When indexing items into DEVONthink, you

can index a file, a folder, or a parent folder

containing subfolders. In the image shown,

the "DEVONtech" folder is the parent folder

and could be indexed with all its contents

included. You could also index an individual

folder, e.g., the "Data" folder, which would be

treated as a parent folder for its contents. Or

you could index individual files. Each of these

options has specific behaviors you should be

aware of, covered below.

Updating indexed files: In general use,

DEVONthink can usually detect filesystem

changes of indexed folders and will update

the indexed group in the database. However,

there are two things to be aware of regarding

automatic updating of indexed files.

Files synced by other applications: If

you are indexing files in a folder synced

by another application, e.g., iCloud or

Dropbox, you may need to use the File

> Update Indexed Items command to

manually update the indexed group.

DEVONthink does this to avoid causing

a discrepancy in the data for the other

application. Also, a particular process

may not generate a filesystem event
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for DEVONthink to detect a change has

occurred.

Individually indexed files: While it's

certainly feasible to index individual files,

be aware these files won't be updated

automatically. This is due to the potential

overhead of watching many individual files

versus watching one folder. In this case,

you can also use the File > Update Indexed

Items command or the file will be updated

when you select it again.

Note: If you'd like to control whether

DEVONthink updates existing or

deconsolidates new files, there

are two hidden preferences

regarding the behavior of indexing:

DisableAutomaticUpdatingOfIndexedItems

and DisableAutomaticDeconsolidation.

Moving Indexed Items: DEVONthink stores

individually indexed items by its absolute

path in the filesystem. If you move an

individually indexed file or folder, it will

disappear when the database updates or be

reported as missing. This is because the item

no longer exists in the indexed location, so

the absolute path points to nothing. If you

move a file or subfolder inside an indexed

parent group, the change should be reflected

in the database or the Finder. The parent

folder still exists in the same location and

DEVONthink can adjust for the changed

relative paths within it.

While it's generally best to index fairly

static locations, i.e., ones that you won't

be relocating or renaming, sometimes

it becomes necessary to do some

housekeeping. Perhaps you are running low on

space on the internal drive and need to move

an indexed folder to a connected external

drive. Open the Tools > Inspectors > Generic

Info inspector, you can click the down arrow

next to the Path title, choose Select, and

select the parent folder in its new location.

DEVONthink should update the stored paths

to point to the Finder folder and its contents

in the new location.

Deleting Indexed Items: When deleting

indexed items, you will see one of two

warnings when you empty the database's

trash, depending on how you've indexed

the item. With individually indexed files or

an indexed parent folder, you will see the

warning above prompting you to choose

whether to delete the item from the file

system or just the reference in the database.

In this instance, DEVONthink is prompting

you to make sure you aware of the potential

removal of a top level indexed item.

DEVONthink 3.9.17 Documentation, page 55



If you delete a subgroup or file in an indexed

group and empty the database's trash, you

will be shown the a warning there are indexed

items detected in the trash. You can choose

to Remove Imported Items which will not

delete indexed files. Choose Remove All

Items to remove both indexed and imported

files when emptying the trash. Indexed files

will be moved to the system trash from

their location in the Finder. In this situation,

DEVONthink is modifying the content of the

indexed parent to ensure both the Finder and

database's contents match.

Duplicating Indexed Items: When you

duplicate an indexed item, the behavior

depends on if you're duplicating with

a database or across databases. if you

duplicate the item in the same database,

a copy will be created in the Finder in

anticipation of potential changes. If you

duplicate the item into another database, no

copy will be created in the Finder. However,

changes made to the item - in either

database - will affect both databases as the

indexed item is pointing at the same item in

the Finder.

Note: While you cannot replicate files

across database, the duplication of an

indexed file across databases can provide

you with a similar behavior. However,

the files will not be marked as duplicates

since duplicates are not detected across

databases.

Replicating Indexed Files: Replicating indexed

files within a database, individually or within

parent folders, has no effect on the files in

the Finder. Replicating only adds a record

of another instance of the file. However, if

you delete a replicant of an indexed file and

empty the database's trash, this will have

no effect on the files in the Finder. They will

remain intact.

Indexing Cloud-synced Folders: One of

the common uses of indexing is to keep

a local folder in a cloud-synced location,

e.g., Dropbox, and have access to the files

within DEVONthink. While this is certainly

supported, be aware that changes made to

the local folder, especially when the cloud

service syncs changes to the local folder,

the changes may not always be detected

by DEVONthink. In that instance, you can

manually update the indexed group by

selecting and hoisting it via the disclosure

triangle or choosing the File > Update Indexed

Items command. Also, you should only index

local data, e.g., on the local hard drive or

connected drives. DEVONthink doesn't

support indexing data that resides only in the

cloud.
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Lastly, if you are indexing content and want

to sync the databases between devices,

please review the Indexing and Sync section.

Due to the flexibility of DEVONthink, it's

possible to have a database containing both

imported and indexed files.

Note: While DEVONthink can handle large

amounts of data, it is inadvisable to import

or index uncurated data, like entire hard

drives or your Home directory. You should

be judicious in what you put into your

databases.

DRAG & DROP

The Mac has always been an an environment

with rich drag-and-drop support.

DEVONthink is a well-behaved citizen in this

regard. Here are some ideas:

IN

The easiest way to add data to DEVONthink,

other than creating the documents directly

inside the application, is to drag files or

selected data, e.g., text, images, etc., into a

DEVONthink window.

Drag files from the Finder into a database.

Holding certain command keys will allow

you to copy, move, or index them. See also

p. 53ff

Drag files from the Finder to DEVONthink's

dock icon. Files will be sent to the default

destination.

With applications supporting drag-and-

drop, you can drag data between them

and DEVONthink. For example, you can

drag messages from Apple Mail into your

database or DEVONthink's dock icon.

Inside DEVONthink, you may be able to

drag content from a file into the database.

If you have an email message with an

attachment imported into your database,

you can drag the attachment out as a

separate file.

With some file types it's possible to select

text and drag it out to create a new file.

DEVONthink will attempt to create the

most appropriate file type.

Note: With the last two options, you may

be able to drag-and-drop content between

files.

OUT

DEVONthink isn't just a receiver; it also allows

drag-and-drop of its files too.

For email applications lacking good

automation support, drag a document onto

its dock icon or into a draft email to attach

it.

Drag documents or groups to the Finder as

a quick export option. When you do this,

DEVONthink will apply tags you've added to

the documents also to the exported files as

Finder tags.

If you need to upload a document to

a website, drag the document in the

database to the page or the upload sheet,

if the site requires it. Note that groups

can't be added this way. You'd need to drag

the group to the Finder first, then to the

site.

INSIDE

And obviously DEVONthink allows

dragging database items inside itself for

reorganization.
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Dragging: Moves items, by default.

Option-Dragging: Duplicates items to the

dropped location.

Option-Command-Dragging: Replicates

items to the dropped location. Note you

cannot replicate a file to the same location

as the dragged file.

SORTER

The Sorter is a multi-purpose utility built into

DEVONthink providing options for adding

files and creating various types of notes.

When enabled in Settings > Sorter, it is found

in the menubar at the top of your screen —

displayed as DEVONthink or the  nautilus

icon — or docked to the side of your window.

Details about the views and controls of the

Sorter are covered in the Sorter section of

the Windows chapter.

The first view of the Sorter is the Navigation 

view. Access your favorites, or browse and

search for groups in the open databases.

Double-clicking a found group will open it in

a new DEVONthink window. Drag and drop

files on the Sorter to quickly file them in a

favorited group, an inbox, or a location you've

found in a search. When docked, the Sorter

will lock open during a search so you can

easily drop files into the desired location.

The Sorter's other views allow for quick and

easy note creation. It supports these note

types:

Take Note: Create text notes in plain or

rich text, Markdown, or formatted note

formats.

Voice Note: Record an audio note.

Video Note: Record a video note with the

built-in camera.

Screen Capture: Snap screen captures with

the option of adding metadata, e.g., tags,

rating, etc. directly into DEVONthink.

The Sorter allows you to clip web content as

well. It also functions as the interface to the

Clip to DEVONthink browser extension.

Clip content from the current page in your

default web browser.

Clip content from a URL detected on your

clipboard.

Clip content via Clip to DEVONthink or

enter information and a URL manually, if

desired.

All these methods give you the option of

capturing the content in a variety of formats,

with or without extra metadata, directly into

your DEVONthink databases.

ARCHIVING EMAIL

Email is an important item in many

situations, both professional and personal.

DEVONthink allows you to import email

messages directly from supported email
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applications. It also allows you to import

UNIX mailboxes (.mbox files) that can be

exported from some other email clients.

The imported email messages are saved

in their original file format (.eml) and

are displayed using QuickLook or as an

alternative text view. See also p. 157ff 

Additionally, metadata, e.g., from MailTags

may also be preserved. In addition, the "read"

and "flagged" status of email messages are

transferred from Microsoft Entourage and

Microsoft Outlook independently from your

settings in Settings > Files > Emails.

The Import sidebar: One method for

importing your emails into DEVONthink is to

use its View > Import sidebar. In the Emails

mailboxes from these email applications

can be accessed: Apple Mail, Microsoft

Entourage, or Microsoft Outlook. You can

read more about the controls and functions

of this view in the Sidebar: Email section of

this document.

Apple Mail plugin: If you are using macOS

11 Big Sur through 13 Ventura, there is a

plugin for Apple Mail that creates a direct

link between Mail and DEVONthink. It adds

an Add to DEVONthink 3 command to the

Mailbox and Message menus of Apple Mail.

If the plugin is not automatically installed

select DEVONthink > Install Add-Ons to install

it. The go into Mail's Settings > General >

Manage Plug-Ins and enable it. Unfortunately,

Apple deprecated Apple Mail plugins in

macOS 14 Sonoma and later.

Importing UNIX Mailboxes: UNIX mailboxes

(.mbox files) exported from some email

applications, e.g., Thunderbird or Postbox,

can be imported into your database. There is

no mailbox structure in these exported files

so multiple mailboxes have to be exported

and imported separately. They can be

imported into DEVONthink in one of two

ways:

File > Import: Use File > Import > UNIX

Mailboxes, then select the .mbox file in

the Open dialog and press Open. This will

import the messages into a group in the

current location.

Drag and Drop: Drag and drop the .mbox

file onto DEVONthink's dock icon to import

the messages into your database.

Other options: If you're running a more

modern version of macOS or not using Apple

Mail, there are some other ways for you to get

emails into DEVONthink. Bear in mind, the

possibilities depend on the what your email

application supports, e.g., scripting. Here are

some potential options:

Drag and drop: Drag to the Finder then

into DEVONthink, into the Sorter, into the

Global Inbox, or directly into a database.

Mail Scripts: Run AppleScripts from the

global Scripts menu in the menubar when
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in scriptable email clients, e.g., Apple Mail.

See also p. 214ff

Mail Rule Scripts: Apple Mail rules support

running AppleScripts in their mail rules.

We have provided a few for you to use or

modify. See also p. 213ff

IMPORT OR ARCHIVE

When it comes to archiving email, the

question arises: "Do I use import or archive?"

Here's the simple way to understand it:

Import Email: While Import can be used on

a mailbox, it is generally used on selected,

individual emails. This is especially useful

when using a filtered view, e.g., filtering

by a date range or recipient. You'd select

those files and use the Import option.

Archive Mailbox: As the name implies, this

command can only be used on selected

mailboxes. The mailbox will be imported

into a special Emails group. DEVONthink

will attempt to preserve the mailbox

structure shown in the email application.

This is very useful for archiving a mailbox

and keeping it up to date. Since previously

imported emails are excluded from the

mailbox view, subsequent visits to the

Import sidebar will only show newly

received emails. Using the Archive Mailbox

option will import only those new emails

into the existing Emails group in the

database.

Depending on the settings in Settings > Files

> Emails > Conversations, DEVONthink can

attempt to import complete conversations

and optionally group them.

Note: Email threading is not an exact

process. There has also been no standard

defining relationships between messages

for a very long time. DEVONthink will

attempt to thread the conversations, but

cannot guarantee all related emails will be

detected.

PROBLEMS IMPORTING OR MOVING EMAILS

Briefly discussed in the Appendix, the UUID

is a value given to each item in DEVONthink.

It is unique to each item and more than one

item can't have the same UUID. When email

messages are imported, they are given such

an identifier based on metadata from the

actual email. This means you can't import the

same message into a database more than

once, as that would result in more than one

file having the same UUID. This will be shown

in DEVONthink's Window > Log. It can also

cause issues when moving messages between

databases. If you already imported messages

into a database and forgot you did, trying to

move the same email into it will fail.

In Settings > Email you can enable Previously

imported will become replicants to import

the messages into the same database as

replicants. However, this still will not allow

moving messages into databases already

containing those emails.

REPLYING AND SENDING

To reply to an archived email message,

Control-click it in the item list and choose

Send Reply. A draft message will be

composed in your default email application.

Choose Send by Email to email a selected

document from the item list.
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Note: The inter-application communication

capabilities of the email client you are using

determine how well these two commands

work. If the commands aren't producing

the expected results, check with the

developer about what kind of interactions

they allow between applications.
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SYNC

Before we discuss particular details of sync

methods, take a moment to check out the

Settings > Sync section. This gives you an

overview of the preference pane where syncs

are set up. Additionally, you will find a short

glossary of sync-related terminology in the

Appendix.

SYNC SIMPLIFIED

Sync is an incredibly simple concept. You

have a database on one machine. You want

that database on another machine. From

the machine with the database, you upload

the database to a sync location accessible

from both machines. On the machine without

the database, you'd access the same sync

location and import the database. This way,

every device, Mac or mobile, has a local copy

of a database. Changes are made locally

then synced through the sync location to the

connected devices.

The only variations are:

If the second machine already has a

opened copy of the database, you will have

the option to merge with the sync data in

the sync location.

Using a Bonjour sync, in which you'd import

and sync directly between devices.

That's it. Every sync is conceptually the same.

The differences you find are the requirements

of the particular sync method, e.g., Dropbox,

and are covered below. Bonjour and local sync

stores show a few more specific (but simple)

steps, but they all follow the same essential

pattern shown here:

DEVONthink 3.9.17 Documentation, page 62



Enable a location (with or without an

encryption key).

Upload a database to the sync location.

Enable the same location in DEVONthink

on another Mac or DEVONthink To Go in

iOS (using the same encryption key, only if

specified).

Import from or merge a database to the

sync location.

Repeat as needed.

BASICS AND HOW TO

This sync section isn't long because it's

complicated; it's long because of the variety

of options available. While the basics of sync

are very simple, questions will arise and there

are details to be covered. Below we answer

some common questions, then describe

specifics per sync method.

What is a sync store?: A sync store is a folder

on a server or service (the 'sync location')

that DEVONthink uses to store sync data

for your syncing databases. Give it a name

made only of alphanumeric characters. A

concatenated name, e.g., Research_01 can

be used. Note this folder is only for use by our

sync engine.

What is a 'copy of the database'?: One

detail to understand about syncing: Only

true copies of a database will sync together.

Two databases having the same name but

created independently are not the same

database. These databases will never sync

together. This is also why you shouldn't

create a database on the receiving machine,

hoping to "fill it up" with data from the source

database.

If you copy the database (.dtBase2 file)

between machines, that is clearly a true copy

of the database. Also, importing a database

via sync logically yields a true copy of the

database. True copies are databases that

have the same internal identifier (UUID).

What is an encryption key?: Regarding

the privacy of your synced data, all sync

methods allow you to specify an optional

(but recommended) encryption key for a

sync location. The key is an alphanumeric

string of your choice and length. This key

is used to "scramble" or "descramble" the

sync data using AES-256 encryption and

the data is stored in an encrypted state.

All databases synced to a location using an

encryption key will sync encrypted data. If

you specify a key when syncing, you must use

the same encryption key when setting up the

same sync location on other devices running

DEVONthink or DEVONthink To Go.

Note: Bonjour syncs don't allow you to

explicitly specify a key, but the sync data is

encrypted by default.

Can I encrypt after I've already synced?: It

is not possible to simply add an encryption

key after syncing as DEVONthink cannot

encrypt already synced data. Indeed, if you

add, remove, or modify an encryption key

post-sync, you will see Invalid encryption

key warnings in the Log window. In order to

switch to an encrypted sync, you'll need to

clean the sync location first. Control-click

the sync location and choose Clean Location.

After the clean has been successfully

reported in the Log window, Control-click the

sync location again, modify the encryption

key as desired, then enable databases to sync
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again. However, remember that changing or

removing the key will require making that

change in DEVONthink or DEVONthink To

Go if they are syncing with the same sync

location.

What are the Local and Remote sections

for?: As noted above, a database must

be local to the machine so it must either

be open in DEVONthink or imported from

the sync location. For a non-Bonjour sync

location, Local section of the Databases

list displays all local open databases. For a

Bonjour location, the Local section displays

databases that are open both on the local

machine and the Bonjour server machine.

The Remote section displays any databases

that aren't open locally or those that have

never been imported to the local machine.

You cannot sync to a remote database. It

must be imported locally, then you sync the

local copy.

How quickly will it sync?: DEVONthink's

sync does not run constantly. To balance

performance and reduce unnecessary

network noise, it syncs on an interval. While

the interval can vary by sync method, a good

standard to consider is: sync will initiate

up to 45 seconds after a change is saved

in a database and every 4.5 minutes of idle

time when set to Automatic. You can set a

different interval, noting a longer interval,

e.g., Hourly, can help lessen the resource load.

Another consideration with a remote sync

is the quality of the network and server

responses. If your network is slow or poor

quality or the remote servers are slow, not

responding quickly, or bandwidth is being

throttled, the speed of the sync will be

affected. Syncs on your local network, e.g.,

Bonjour, are much less likely to be affected.

INDEXING AND SYNC

Often people index content from the local

repository of a cloud service like Dropbox.

The question then arises: "If I have my data

on Dropbox' servers and I sync to Dropbox

via DEVONthink, aren't I just using twice the

space?" The answer is practically, yes. In the

Show Info for a sync location in Settings >

Sync there is an option Synchronize contents

of indexed items. Unchecking this will sync

only the metadata for the files, not the

contents. However, you should only disable

this option if:

You are syncing another Mac, linked to

your Dropbox account, and having the

local Dropbox folder in the same relative

location. The default location is ~/Dropbox.

If the locations are different, the files will

appear as missing on the second Mac.

You are not syncing with our mobile

application, DEVONthink To Go.

DEVONthink To Go does not support

indexed items. Also, if you are using

the Download Files: On demand option

in DEVONthink To Go, you could never

download the contents since the contents

are not present in the sync location.

For the most flexibility, it is advisable to

ensure you have enough storage space for

syncing.
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BONJOUR

Bonjour (also called a direct connection) is

technology you are almost certainly already

acquainted with. If you have a wireless printer

or scanner and notice how your Macs and

mobile devices can see those devices by

name with no setup by you, they are using

Bonjour. Bonjour is a way for devices, or

services like DEVONthink's sync, to broadcast

its presence on a network without requiring

technical know-how by the user.

When it comes to syncing, a Bonjour sync

deals directly between devices. One device

acts as a server, the other a client to that

server. The participating devices must be

on, running DEVONthink or DEVONthink

To Go, and on the same network. There

is no intermediary location where data is

stored. This is much faster than uploading

all data to some server on the internet and

downloading it again on another device. But,

when you leave your office and you haven't

synchronized your databases, you'll need to

wait until you come back another day.

Note: Bonjour does not function over

VPNs. This is a technical limitation of the

technology, not DEVONthink.

Bonjour Setup:

Step 1: On the machine acting as the

server, open Settings > Sync and press the

Bonjour Options button.

Step 2: Click Enable Incoming Connections

to use this Mac as a Bonjour server of

its databases. Optionally, have closed

databases open when a client initiates a

sync.

Step 3: Enter a mandatory password. This

password is required for other devices to

act as a client of DEVONthink's. If you are

working with an IT department who has

assigned a port for you, or you have a port

you'd specifically like to use, enter it in the

Port field. Otherwise, leave this blank and

DEVONthink will assign one for you.

The Mac with Bonjour enabled should now

be visible as a sync location to other devices

on your local network. On the other devices,

enable it, enter the password, and you can

import databases or sync existing databases

directly with it.

Note: You should never use more than

one device as a Bonjour server for a given

database.

LOCAL SYNC STORE

A local sync store is a specialized folder

containing sync data on your local machine or

connected drives and servers. This is a very

fast and reliable sync method for Mac-to-Mac
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syncing. You can use one sync store to sync

multiple databases or create more than one,

e.g., one for a particular group of databases.

Setup a new local Sync store:

Step 1: Open Settings > Sync and enable

the Local Sync Store option. If you already

have one created, click the + button and

choose Add Local Sync Store.

Step 2: In the sheet that appears, navigate

to the location you want to save the

sync store. Enter a name and an optional

encryption key, if desired. Then press Add.

Step 3: When the location is created,

select it and enable the databases you

want to sync in the Databases list on the

right.

Setup an existing local sync store:

Step 1: Locate the local sync store

(.dtCloud) file in the Finder.

Step 2: Double-click the sync store or drag

and drop it into the Locations pane in the

Sync preferences.

Step 3: If you used an encryption key when

you first synced to the existing location

from another machine, select the sync

location and press the Info button to open

the Info popup. Enter the appropriate

encryption key.

Step 4: When the location is created,

select it and you should see any importable

databases listed in the Remote section of

the databases list.

Step 5: Double-click a database you want

to import, saving it to a safe location,

e.g., the Databases folder in your Home

directory.

Note: Due to technical limitations, a local

sync store currently cannot be used for

Mac-to-mobile syncing. iOS doesn't have

the ability to mount file servers.

ICLOUD (LEGACY)

As most Apple devices are logged into your

Apple ID, iCloud is the simplest method to

set up and sync with. Since it's logged into

your personal account, it can only be used

for syncing with your own devices. If you

want to keep your databases in sync but

not share them with others this is a great

choice. We strongly recommend an iCloud

plan with enough storage. Here are the simple

instructions to set it up.

iCloud Setup:

Step 1: Open Settings > Sync and enable

the iCloud (Legacy) option.

Step 2: Enter an optional encryption key, if

desired. If you are already syncing to this

location from another machine, you must

enter the same key you used. Leave it blank

if you didn't use an encryption key.

Step 3: Select the sync location and enable

the databases you want to sync in the
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Databases list on the right. If you already

synced from another machine, double-click

a database in the Remote section, saving it

to a safe location, e.g., ~/Databases.

One thing to realize with iCloud syncing, the

sync is done locally. After sync is finished,

iCloud uploads to Apple's servers, then to

devices using your Apple ID. This means

databases may not be immediately available

to sync on the other devices. The initial

sync requires patience, as DEVONthink has

no control over the speed and reliability

of iCloud's process. It syncs to the iCloud

folder, iCloud does the rest. See the CloudKit

section below for an alternative option.

CLOUDKIT (ICLOUD)

Utilizing the same active iCloud account, the

CloudKit option offers a single-stage sync

with the same simple setup as the iCloud

(Legacy) method. However, with this option,

the sync is directly to Apple's servers. This

can appear to be a bit slower than the legacy

option, but once the sync is finished the

files are already uploaded without having

to wait for iCloud to sync on its own. This

also conserves space as no sync data is

temporarily stored on the local machine's

hard drive. The instructions are essentially

the same as setting up iCloud (Legacy).

You're just choosing the CloudKit (iCloud)

option instead.

CloudKit Setup:

Step 1: Open Settings > Sync and enable

the CloudKit (iCloud) option.

Step 2: Enter an optional encryption key, if

desired. If you are already syncing to this

location from another machine, you must

enter the same key you used. Leave it blank

if you didn't use an encryption key.

Step 3: Select the sync location and enable

the databases you want to sync in the

Databases list on the right. If you already

synced from another machine, double-click

a database in the Remote section, saving it

to a safe location, e.g., ~/Databases.
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DROPBOX

If you have a Dropbox account you can use

it just like you'd use WebDAV. DEVONthink

creates a private folder for its sync stores

and so keeps its data separate from your

photos and other documents. Of course it

does not get access to anything except its

own files. Dropbox and DEVONtechnologies

respect your privacy.

The setup for a Dropbox sync location is

essentially the same as for iCloud. However,

there are two differences of which to take

note:

Sync Store Name: You will have to enter a

Sync Store Name. This is where the sync

data will be stored in the Apps folder of

your Dropbox account. You can add more

than one sync location, if desired.

Authentication: Since the Dropbox sync

connects and syncs directly with the

Dropbox servers, you are required to

authenticate the connection. When you

first enable a Dropbox sync location in

DEVONthink your default web browser

will open and ask you to allow access

to our sync engine. This will need to be

done on other devices you are setting

up this same Dropbox sync location.

Once the authentication is allowed, you

subsequently can add and remove other

Dropbox sync locations in DEVONthink.

If you are using a Dropbox sync and also the

Dropbox application, it is advisable to exclude

the DEVONthink Packet Sync folder inside

the Apps folder from being synchronized with

your Mac. This keeps the Dropbox app from

wasting valuable disk space and bandwidth

by re-downloading all changes you've made to

your databases, and from spamming you with

notifications.

Step 1: Click the Dropbox icon in the

menubar at the top of your screen,

then click the account icon and choose

Preferences.

Step 2: Select the Sync tab and click the

Choose folders to sync button.

Step 3: Select the Apps folder, and uncheck

the DEVONthink Packet Sync folder.

Step 4: Click the Update button and okay

the removal of the local data.

Note: Due to Dropbox' API restrictions,

you cannot sync between Dropbox

accounts, .e.g., between yours and a

colleague's account. Also it is not possible

to connect DEVONthink to more than one

Dropbox account at a time.
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WEBDAV

If you run your own WebDAV server, your ISP

offers it as a service, or you have subscribed

to an online service such as CloudMe, this

might be for you. Generally, if you can access

the WebDAV server with Go > Connect to

Server in the Finder, you should be able to

connect DEVONthink to it.

Your data is stored in encrypted sync stores

on the server. You can keep all your devices in

sync at any time as long as you have internet

access.

Setting up a WebDAV connection follows

the same simple pattern and allows you to

specify a sync store name. But there are a

few parameters that must be entered to

make the connection:

URL: This is the address of the WebDAV

server to which you are connecting. Make

sure you use the proper protocol of http

or https. Also make sure the URL is a

complete path, as required by the server or

service you're using.

Username/Password: Enter the defined or

provided username and password to allow

DEVONthink to connect to the WebDAV

server.

Note: A typical complete path would

be similar to: https://myWebDAV.com/

WebDAVvolume/WebDAVFolder. The volume

and folder are generally case-sensitive.

Specifying a WebDAV folder may be

required if the server doesn't allow you to

write to the root of the volume. Check with

the manufacturer or provider.

CloudMe: A European cloud service offering

WebDAV services, there is a built-in template

for syncing with it. Just enter the username

and password you use to log into the service,

enter a store name, and DEVONthink with

connect with a proper WebDAV URL for you.

Other cloud services: If you are interested in

other cloud services to sync with, services

offering WebDAV connections should be

supported. Check the FAQ or Support pages

to see if it's supported.

Rolling your own: It is possible to run

a WebDAV server on your own. Some

NAS drives, e.g., Synology, have WebDAV

capabilities and you can run a WebDAV server

by repurposing an older Mac. Even some
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more full-featured packages like OwnCloud

or NextCloud can be set up for WebDAV

services. However, these options can provide

more technical challenges in setup and

administration beyond the scope of our

support.

Note: With Dropbox and WebDAV

connections, if you are connecting to a

location you've already synced to, a list of

existing sync stores is displayed in the Sync

Store Name dropdown. This way you can

quickly add the proper sync store instead

of trying to remember the exact name you

gave it.

Q & A

I'll just put my databases in (name your cloud

service): This is not data-safe and never

has been. The mechanisms used by cloud

services are not compatible with package

files, like our databases. Due to the number

of broken databases we've seen over the

years, DEVONthink will neither sync nor open

databases stored in these locations. We

suggest keeping them in a folder in your home

folder, like ~/Databases.

I want to access my databases from one

location: Along with the previous note, this is

not possible. Databases are stored locally and

must be imported to the current machine.

I want to find my files in the sync location:

Your databases do not "live in the cloud". Sync

does not copy your databases and files into

any sync location. It transmits raw, chunked,

and optionally encrypted DEVONthink-

specific data, only useful to DEVONthink

and DEVONthink To Go. You cannot go into a

sync location and retrieve a specific file, and

neither could anyone else, friend or foe.

Should I use one sync store per database:

This is either a personal choice or a

requirement of your specific situation. A sync

location can be used with one, several, or

all databases. Multiple sync stores can be

employed for different sync situations and/or

different devices, e.g., to synchronize specific

databases via one sync store for personal use

and sync others via a second sync store for

business purposes. In situations where you

need to sync certain databases to certain

individuals, you can use one sync store for

each subset of databases.

And while this shouldn't be the first

consideration, if you'd like to use one sync

store per database or for a subset of them, it

may lessen the time troubleshooting a sync

issue with a particular database.

Can I use more than one sync method at

the same time?: Indeed this is supported

behavior. For example, you may want to set

up a Bonjour or a local sync store for syncing

on your local network and a remote sync

option for syncing when you're out and about.

However, if you want to sync via two cloud-

synced services, e.g., Dropbox and iCloud,

you should not sync the same databases

via two different methods. Doing so could

cause conditions where one cloud-service's

sync data would be out of date, causing

conflicts with syncing. Each sync location is

updated independently so changes may not

be received in one location before it syncs.

Additionally, unnecessary duplicates might

be caused, especially if the Conflicts setting
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in Sync preferences is set to Duplicate

documents. Lastly, syncing a database to

multiple remote locations may waste space

and bandwidth in some cases.

TROUBLESHOOTING

Generally, syncing is a transparent and

reliable process. However, poor network

conditions, unreliable servers, etc. may cause

unexpected issues. Please refer to the Sync

section of the Troubleshooting chapter for

some possible fixes.

CAPTURING PAPER (IMAGE
CAPTURE)

DEVONthink comes with built-in support for

Image Capture compliant scanners, as well as

for the Fujitsu ScanSnap.

OCR: DEVONthink optionally makes scanned

documents searchable by using optical

character recognition (OCR). OCR adds an

invisible text layer to the scanned file that is

computer-readable and searchable; a layer

that is recognized by DEVONthink's AI engine.

OCR on scans is generally enabled by default.

For best results we recommend scanning at

200 dpi in color and with 100 percent quality.

Note: If you are using a Fujitsu ScanSnap,

see the next section.

To capture paper using an Image Capture

compliant scanner open the Import sidebar

using View > Import or selecting the icon over

the sidebar. It is divided into a sidebar and

a main pane, which changes depending on

your selection in the sidebar. The options

in the sidebar are arranged from top to

bottom according to a typical scan workflow:

Scan, check the scanned pages, arrange the

pages in a document, and save them to the

database.

If you are using a scanner with an automatic

document feeder (ADF), you can also use a

Queue to prepare a pile of sheets for batch

processing and scan them in one go.

DEVICES

Select your connected scanner or camera in

the Devices section of the sidebar to run a

scan or download images from a connected

iOS device or camera. The main pane shows

an interface similar to what Apple Image

Capture uses.

Choose the scan destination in the To pop-

up menu. Either send the scan directly to any

of your databases, add them as single files

to the Imports section, or choose any binder

that you have created there.

Scanners: DEVONthink generates an overview

scan of the current page in the scanner,

and allows you to select which parts of the

page you want to capture and set the scan

options. Click Scan to capture the page.
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Cameras: DEVONthink shows the available

images. Select the images you want to

import, rotate them if necessary, and click

Download or Download All to download the

images to your computer. You can also delete

images from your camera with the Delete

button.

IMPORTS

The Imports section contains scanned pages

or binders of collected scans. Create empty

binders here to which you add your scanned

pages. Alternatively, use the Create new

Binder button at the bottom of the sidebar.

Add pages by dragging them from to the

desired binder, in the current view or the

sidebar. Rearrange added pages if desired

and set the document properties by clicking

the Properties button. Use the Sort button

to reverse the sort order or shuffle pages,

e.g., when scanning all front pages first, then

the back pages. Choose Sort and Merge

Documents to merge two documents where

one contains all the odd pages and the other

all even pages.

Note: You cannot save multi-page

documents as images; therefore, PDF is the

only option for the file type here.

TRASH

This is where you find images that you have

deleted from Scans & Images or Imports.

Empty the trash using the Empty button

at the bottom of the window or right-click

or Control-click images to add them to an

existing or new document using the context

menu.

QUEUE

If you are using a document scanner with

automatic document feeder, you can use the

queue to add multiple pages or even multi-

page documents to the feeder and scan them

in one go.

Choose your scanner in the pop-up menu

above the list. Then use the Add and Delete

buttons to add or delete steps and rearrange

them by dragging. Edit the fields to set a title

or tags, or to change the document type or

destination. Check OCR to convert a scan to

a searchable PDF after import.

To scan a batch of paper, set the Separator

either to Page Count and the number of

pages in the document or to Blank Page to

begin a new document every time a blank

page is encountered.
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Before starting the batch run, adjust your

scan settings by clicking the Configure

button. If you want to convert the scans

to searchable PDFs, you should choose a

resolution of minimum 300 dpi. Then click the

Start button to start scanning. Finished steps

are marked as "Sent". To remove finished

items from the list, select the ones to remove

and press the minus button at the bottom of

the window. Alternatively, click the dropdown

button and choose Remove Sent or Remove

All.

CAPTURING PAPER (OTHER
OPTIONS)

DEVONthink works with the Fujitsu

ScanSnap, ExactCode ExactScan, and other

scanners that are not directly supported.

In addition, you can add already scanned

pages to your DEVONthink database and

manually convert them to searchable PDFs.

USING A SCANSNAP SCANNER

DEVONthink recognizes scans sent to it from

the Fujitsu ScanSnap Home application or

the older ScanSnap Manager software. To

send scans automatically to your databases,

simply add DEVONthink to ScanSnap Home

or ScanSnap Manager as the application

to use for opening completed scans. The

scanner app will send the created PDFs to

DEVONthink which in turn will import the

document. The files will be imported into

the Global Inbox or a selected location,

depending on the option set in Settings >

Import > Destination.

ScanSnap's scanning software can provide

already OCR'd PDFs. However, if you don't

enable this option, DEVONthink can perform

the OCR on the incoming scans if you've

enabled Settings > OCR > Convert Incoming

Scans.

USING AN UNSUPPORTED SCANNER

You can also capture paper using an

unsupported scanner and import the finished

scans into DEVONthink. To do this, use the

scan application that came with your scanner

or a third-party scan application. Check

the scan application's preferences and look

out for an option that allows you to open

the finished scan with another application,

e.g., an image editor. Change the default

application for the scan to DEVONthink.

DEVONthink knows the identifiers of many

scan applications and will convert the

incoming scan to a searchable PDF if possible.

If DEVONthink does not recognize your scan

application, please create a Zip archive of

the application and send it to us so that we

can add its identifier to a future release of

DEVONthink.

Note: In the settings for the scanning

application you're using, it is best to leave

the default location for the output path,

often ~/Pictures. Do not set the path to

DEVONthink's Global Inbox, as this can lead

to errors when DEVONthink tries to import

a scan that is not completed yet.

DEVONthink 3.9.17 Documentation, page 73

https://www.fujitsu.com/us/products/computing/peripheral/scanners/scansnap/
https://www.fujitsu.com/us/products/computing/peripheral/scanners/scansnap/
https://www.exactscan.com
https://www.scansnapworld.com/scansnapworld/software/scansnap-home/
https://www.devontechnologies.com/redirect/contact


IMPORTING EXISTING FILES WITH OCR

If you already have an archive of documents

that have been scanned without OCR, or

if you cannot use the capture function for

whatever reason, you can import image files

while applying OCR.

To import an image file while applying OCR,

choose File > Import > Image with OCR. Click

the Options button to choose the output

format and whether to send the original to

the system trash after importing. The image

will be processed with DEVONthink's OCR

engine and be imported to the database

in the format chosen. If you have enabled

Searchable PDF: Set metadata after

text recognition in the OCR preferences,

DEVONthink will show the metadata entry

window when the OCR process is completed

(before the file is actually imported to the

database).

The date of the created document is set to

the date of the original file. Thus, for archival

purposes, the searchable document is

identical to the original one. The modification

date is set to the current date and time to

reflect the addition of the searchable text

layer. If you're importing a PDF, any keywords

in the original file are retained and used as

tags.

EXTENSIONS AND
BOOKMARKLETS

DEVONthink provides a sharing extension

(requires OS X Yosemite or later), a web

browser extension, as well as bookmarklets,

for conveniently clipping information from

other applications into your DEVONthink

database.

SHARING EXTENSIONS

Sharing extensions let you "share" data with

other applications, Airdrop, etc. Extensions

are mainly intended for the sandboxed App

Store environment where applications can

no longer easily communicate with each

other. When you access the Share menu in

a compatible application, you should see

an option, Add to DEVONthink that allows

you to send data from the application to

DEVONthink.

Installation: Just as other sharing extensions

are installed, open System Settings >

Extensions > Share Menu and enable the

option for DEVONthink. It should now be

available in any sharing-enabled application's

Share menu.

Note: The data being sent is controlled by

the sending application, not DEVONthink.

If there are issues with the data received

in your database, please contact the

developer of the application to report your

findings.

BROWSER EXTENSIONS

Browser extensions add functionality to your

favorite web browser. DEVONthink's Clip to

DEVONthink extension usually appears as a

 nautilus icon in the web browser's toolbar.

When clicked, the Clip to DEVONthink will

identify data about the current page in the

browser and open the Web Clip section of

the Sorter. Here you can simply select the

location to clip the content or add optional

metadata, like tags, label color, etc.
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Installing: The Clip to DEVONthink for Safari

extension is installed by DEVONthink by

default. The extensions for Firefox and

Chrome can be installed from our Extras

download page. You can also access these

pages via the DEVONthink > Install Add-Ons

panel.

Note: While there is no direct support for

other browsers, some allow you to install

Chrome extensions. This may allow you

to install our browser extension in those

browsers as well.

BOOKMARKLETS

Similar in function to a browser extension,

but much simpler, bookmarklets are special

bookmarks that execute some JavaScript

to capture the current page or selection in

the browser. To use one of the bookmarklets,

load the page you wish to archive or clip

text from in your web browser. When the

page is fully shown, select the bookmarklet

in your bookmarks bar. Instead of loading

another page as normal bookmarks do, the

bookmarklet adds the selected text or the

whole page as text, bookmark, HTML code,

web archive, or PDF to DEVONthink's default

destination.

Installing: Bookmarklets can be installed

from our Extras download page. Typically,

the bookmarklet can just be dragged and

dropped to the browser's bookmarks toolbar.

However, you may need to Control-click

the bookmarklet and copy the code to

add it manually, if the browser requires it.

We have provided separate bookmarklets,

one for each type, currently supporting

capturing: bookmark, web archive, HTML,

PDF (paginated or single page), plain text, or

the selection as plain text.

Note: Due to increased security in macOS,

Apple Safari will prompt you to allow

launching DEVONthink when using the

browser extension or bookmarklets. Other

browsers allow you to make a persistent

choice about this behavior.

WEB SHARING

DEVONthink allows you to give others on the

local network access to your databases using

a standard web browser on any operating

system (including Windows and Linux). The

embedded web server provides an interactive

web interface that allows defined users to

interact with the shared databases. Here are

the first steps to getting started using this

powerful feature.

SECURING YOUR SHARED DATABASES

Before you start sharing your data it's a good

idea to check the security settings.

To enhance the security for the databases

you broadcast, you define users and give

them per-database permissions. You will

also set a certificate for the server, so the
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connecting users can validate they are

connecting to a safe server. These items

are set in Settings > Server. Users will only

be able to interact with the databases

based on the permissions you give them,

including disallowing them even to see certain

databases.

Note: Depending on the certificate settings

specified in the preferences, a warning

about an invalid certificate may be shown

when users access the web sharing. This

is especially true when using a self-signed

certificate. While this warning is something

to be suspicious of when browsing in

general, you and your users can accept it in

this case.

SHARING A DATABASE

Start and stop the server: Once the

certificate and users have been set up to

your liking, press the Start button to start

the server. You can also select the Tools >

Start Server command or choose the Start

Server option in DEVONthink's dock icon. If

the server is running, these will display Stop

instead.

Share your server's address: Once the web

server is started, you will see links at the

bottom of the preference pane. These are

the active links you will share to individuals

you have defined as users. One option is

to Control-click the link, select Share from

the context menu, and share it via your

preferred method. You can also use Copy Link

and paste it where you need to. Lastly, you

can click and drag the link directly to many

applications, like Apple Messages.

The person who receives your link will open

the page, login with the username and

mandatory password you've defined for

them, and have access to the databases you

want them to see. If you have specified a port

in the preferences, your users may be able to

add a bookmark to their browser for quick

access.

Note: We believe in data privacy and

hope you do too. Browsers may present

options to save login credentials. Some

may even save the credentials by default.

We are cautious of the first and not a fan

of the second. If the user is on a shared

computer, consider what access other

users could have if using these options to

save credentials.

USING THE WEB INTERFACE

The interactive web interface imitates the

look-and-feel of DEVONthink in many ways,

but in a condensed form. Contrary to a static

web site, it only loads once; clicking buttons

or links does not reload the whole page but

dynamically updates it. This also means you

should use the Back and Forward controls in

the user interface instead of the ones in your

browser's toolbar.

Similar to the DEVONthink, the web interface

is divided into panes: toolbar, sidebar, item

list, and view/edit pane. But note some

operations, e.g., deleting or organizing items,

are dependent on the permissions you've

been given for the specific databases.

Sidebar: The sidebar is where you can

navigate the databases' inboxes, groups, tags,

and trashes in the sidebar. You can even drag

items from the item list to reorganize things.
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Item List: Selecting items in the sidebar will

display the contents in the item list. When

using the standard preview position, the

list can be sorted by clicking the column

headers. There are options to enable or

disable them in the context menu. Items can

be dragged, handily for filing loose documents

into groups. Double-click groups to display

their contents in the item list. For quick

navigation, press the < and > arrows to go

back and forward to visited locations in the

databases. You can also click the locations in

the path bar above the item list to jump to a

parent location.

View/Edit pane: Displayed below the item

list or to the right, depending on the preview

choice made in the toolbar, this pane will

attempt to display the contents of the

selected file. Clicking and dragging the divider

bar allows you to resize the pane, relative

to the item list. A select number of file

types, e.g., plain text, formatted notes, and

Markdown files can be viewed and edited in

this pane. When the Info inspector is shown it

will display as a pane on the right side of the

view/edit pane.

Note: Due to the limitations of browser

technologies, some file types cannot be

displayed.

Toolbar: Some handy options are available

in the toolbar, including switching the

position of the view/edit pane, adding

some metadata, e.g label or rating, to a

selected item, and creating groups and a

few document types. It also has controls for

uploading new documents and downloading

currently selected ones. A user menu allows

you to switch between English and German

language and also provides a Log Out option

for more security when allowing others

access to the computer. Lastly, it gives you

access to two powerful options: the See Also

pane and the search field.

See Also: When you show the inspector

pane, the second view is a See Also view. This

displays potentially related files in the current

database you are viewing.

Search: Searching the viewable databases

can be done in the search field. Enter search

terms, including using search prefixes to

focus the searches. For example, you can do a

search for text:housing tags:government.

If you want to restrict where you're searching,

select All Databases or a specific database to

search in.

Descriptions of the controls in the user

interface can be found in the Web Sharing

section of the Windows chapter.

ACCESSING YOUR DATA OVER THE

INTERNET

Web sharing is best used on a local area

network (LAN). But there may be situations

where you want to share the database to

users that aren't on your network. While we

can't provide specific support due to the

differences in equipment and environments,

we have provided a simple guide you can try.

To access your database from outside your

network, you need to make your Mac "visible"

to the outside world. In general, when you

a using a DSL or cable modem, you are also

using a router. Routers create an intranet that

your Mac is connected to and "route" traffic

between the internet and your personal
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intranet. Now, you need to create a route

from the outside leading to the Mac sharing

your database. This offers a port on the

outside that is directly connected to the port

on which DEVONthink is publishing.

If everything goes well, you will be able to

access your database using an address like:

http://xxx.xxx.xxx.xxx:port, where

xxx.xxx.xxx.xxx is your current public IP

address. (Note: This is your router's address

on the internet, not your Mac's.) Next, port

is the outside port number leading to your

published database.

Port forwarding done manually: The following

is only a rough outline of the steps needed

to configure port forwarding manually. The

precise way to do it varies from router to

router. You will need to consult the manual for

your router in order to determine exactly how

to set things up. To configure port forwarding,

follow these steps:

Step 1: Begin by determining your Mac's

public IP address. This can be done

by visiting a web site like https://

www.whatismyip.com from your machine.

Step 2: Determine the port on which

DEVONthink published on your Mac. You

set the port in Settings > Server. To publish

on the internet, enter a port number

here and do not let DEVONthink set it

automatically as the port number may

then change every time you open the

application.

Step 3: Determine your Mac's private

IP address. The IP address is usually of

the form 10.x.y.z, 192.168.y.z or

172.16.y.z. You can find your Mac's

private IP address by going to the Network

preferences panel in System Preferences

and looking it up under TCP/IP for the

interface you are using (usually Built-In

Ethernet or Wi-Fi).

Step 4: Decide on a public port for

DEVONthink. The port should be in the

range 1025-65500. We suggest that you

use port 8080, which is traditionally a

default port for private web servers.

Step 5: Configure port forwarding on

your router. The steps to do this vary

from router to router, but all of them

require you to provide these details: Public

port, private destination IP, and private

destination port. You found the private

destination port in step 2, and the private

destination IP in step 3, and you selected

the public port in step 4. If you are in doubt

about how you configure your router to

do port forwarding, you need to consult

the manual that came with your router.

It is usually done through a web-based

interface or custom-built administration

application. For instance, AirPort routers

can be configured using the AirPort Admin

Utility.

Step 6: Save the configuration changes

on your router, and restart the router if

required. At this point, you are ready to

connect to your DEVONthink from the

outside.

Step 7: From the remote computer, open

a web browser and enter the address as

follows: http://xxx.xxx.xxx.xxx:port,

where xxx.xxx.xxx.xxx is the public IP

address you found in step 1, and port the

public port you selected in step 4. Press

↩ Return and you should get presented

with your database's web interface.
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Setting up port forwarding can be tricky, but

the difficult part is mainly in determining

how to configure your particular router. If you

are in doubt, search online for your router's

name and combine it with a search for "port

forwarding" or "port mapping."

SERVICES

The DEVONthink > Services menu gives

you access to special commands provided

either by other applications, such as TextEdit

or Safari, or by services extensions such

as DEVONtechnologies' WordService or

CalcService. Also, DEVONthink publishes its

own services in the Services menu.

DEVONTHINK SERVICES

DEVONthink installs several services for

copying or summarizing selected text,

capturing a web page, or searching for

documents in your databases.

Add to DEVONthink 3: Adds selected files,

bookmarks, or images to your database.

This service is also available in the Finder's

context menu.

Capture Bookmark: Adds a bookmark to a

URL selected in text.

Add to Reading List: Adds a bookmark to a

URL selected in text to the Reading List.

Take Plain/Rich Note: Adds selected text

to the global inbox as a plain or rich text

note from any application that support

services. Taking a rich text note also copies

images and clickable links. If the source

document is a web page or a news feed,

DEVONthink tries to capture the address

of the page or feed as well. This only works

with applications that support this feature,

such as Safari, DEVONagent Pro, and other

web browsers.

Append Plain/Rich Note: Adds selected

text as plain or rich text to the last note

taken using the DEVONthink Services

menu items.

Lookup: Opens the search pane in

DEVONthink with the selected text copied

as search term.

Summarize: Creates a new note in

DEVONthink's inbox with a summary

of the selected text. DEVONthink uses

all documents in the open database

for determining what's important and

what's not. The summarization settings

in Settings > Editing, define whether the

summary are be based on sentences or

paragraphs.

If you want to assign hotkeys to services,

go to System Settings > Keyboard >

Keyboard Shortcuts > Services. Do note that

application hotkeys can override hotkeys set

here. Try to make sure to specify unused key

combinations in your shortcuts. Also, due to
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the way macOS loads menus, you may need

to show the DEVONthink > Services menu

once before the hotkey will become active.

PDF SERVICES

Another way to get files into DEVONthink is

using PDF services. Installing DEVONthink's

service adds a Save PDF to DEVONthink

option to the PDF button of the print dialog

in any Mac application. This allows you

to print a paginated PDF directly to your

database.

To install the PDF service, select DEVONthink

> Install Add-ons and check PDF Services in

the dialog window. Then click Install and the

option should now be available.

Printing to your database: To "print" (save) a

document to DEVONthink as a PDF, open it

in its creator application (this could even be

DEVONthink itself). Then, do the following:

Select File > Print.

In the appearing print dialog window, click

the PDF button at the lower left corner

and select Save PDF to DEVONthink from

the menu. A PDF will be printed and sent

to DEVONthink. Depending on your choice

in Settings > Import > Destination, the file

import into the Global Inbox or let you

choose the destination group.

Note: This requires an installed printer to

work properly.

THIRD-PARTY APPLICATIONS

DEVONthink offers many standard ways to

integrate with third-party apps including

drag-and-drop of common data formats,

copy-and-paste, and AppleScript. In

addition DEVONthink comes with special

arrangements for applications often used

together with it.

Bookends: Choose File > Import >

References from Bookends to import

Bookends references as rich text

documents with a back link to the original

item in Bookends.

Evernote: Choose File > Import > Notes

from Evernote to import selected Evernote

notebooks.

Tinderbox: Copy notes in Tinderbox and

choose Data > New > With Clipboard to

create plain or rich text copies of the notes

in DEVONthink including backlinks and

tags.

Yojimbo: Choose File > Import > Items from

Yojimbo to import all items from Yojimbo.

Items without URLs are backlinked.

Apple Mail: DEVONthink adds its own menu

commands into Apple Mail to facilitate

importing selected message or mailboxes

into your databases. See also p. 58ff
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WINDOWS

IN THIS CHAPTER
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DEVONthink uses a number of windows to

present information. These windows are

used for displaying and manipulating groups

and documents, finding information, editing

metadata, analyzing text, and changing the

properties of your database.
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MAIN WINDOW

The main window is split into simple sections,

some of which will be familiar from other

applications. In fact, as we introduce the

components of the window you'll see

DEVONthink has many familiar elements in

it. We start off with the fundamental panes

you'll use.

VIEW/EDIT PANE

When You launch DEVONthink you will see

an empty pane at the bottom of the window

reading Nothing Selected. This is the View/

Edit pane, a preview pane displaying the

currently selected document. This pane gives

you a view of the content of compatible

documents. It also allows you to work on

compatible files directly in the main window

when the pane is shown. Or you can hide the

preview, perhaps if you want to concentrate

on information about a group of documents.

You can can toggle the pane's visibility in the

View > Preview menu or via a toolbar button.

Layouts:

Widescreen: The View/Edit pane is

displayed to the right of the item list, an

option common in many Mac applications.

Standard: The View/Edit pane is displayed

under the item list. This is a bit more

traditional but very useful on smaller

screens, e.g., MacBooks.

None: Hides the View/Edit pane. Note you

can still select any file and press the space

bar to preview it in a Quick Look pane, as

needed.

As noted above, DEVONthink allows

displaying and editing, and even creating,

some file types. Please refer to the
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Documents chapter for more information on

this and other components related to the

View/Edit pane.

ITEM LIST

When you open a Finder window, you are

presented with a list of files in a certain

location. The view may be icons or a list, etc.

but you are still just viewing the contents of a

folder, hard drive, etc.

DEVONthink is no different in this respect.

When you open a main window, you will see a

list of groups and documents in the current

location. Clicking on or opening other groups

shows their contents. Smart groups, just like

the Finder's smart folders, also display their

contents in an item list. The item list also

supports familiar operations like drag-and-

drop between groups, copy and paste, group

and ungroup, context menu items when you

Control-click, etc., just as you've done in the

Finder.

Views: Again, taking a cue from the Finder,

the item list allows you to display your

documents in some familiar views:

Icon: For the more visual folks, we have the

 Icon view. This displays the thumbnails

of the documents with just their name. You

can choose Show Details to display some

additional metadata in a widescreen view.

Change the size of the thumbnails with

the slider in the information bar, noting

this will affect the amount of metadata

shown as well when details are shown.

Double-clicking groups behaves just as

double-clicking a Finder folder, displaying

the contents in the current or a new

window, depending on the Double-click

opens groups in a new window checkbox

in Settings > General. Note this view is

best used without a preview or in standard

layout.

List: Behaving much like Finder's List

view, the  List view shows a list view

of the items with metadata columns.

Drag the columns left and right to reorder

them to your liking. Sort them by clicking

the column headers, switching between

ascending and descending each time you

click. Control-click the headers to add or

remove columns. Or make these choices

from the Tools menu.

Columns: The Mac OS X Finder received

the Columns view from its NextStep

counterpart, then iTunes adopted it for

browsing music. DEVONthink's  Column

view functions in the same way. This option

works best with a preview in standard

layout, for quickly viewing selected files,

but you can also use Show Details to

display metadata and the file's thumbnail.

Expanding the width of the column by

dragging the separator will scale the

thumbnail, if desired.

Cover Flow: An iTunes feature that found

its way to the Finder and DEVONthink is

 Cover Flow. Similar to the Icon view but

with dynamically created thumbnails, i.e.,

the displayed image is generated from

the contents of the file. This side-scrolling

item list can be useful when making visual

assessments of documents. It is best

used with a standard layout or without a

preview displayed.
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All these views can be easily changed in the

View > View options, as well as the quartet of

icons  on the right-hand side of the

Information bar.

Sort: In addition to sorting the item list by

clicking column headers or using the View

> Sort menu, you can also choose a sort

method in the Sort dropdown menu in the

information bar. By default it reads by Name.

Also, notice there is a Customize Metadata

command in the Tools > Columns menu, the

context menu, and this menu. Select it to fine

tune what columns are available to display,

including any custom sets you've created

yourself.

Visual Cues: DEVONthink provides some

visual cues applied to items in the item list.

These are also described in the Iconology

section of the Appendix.

Duplicates and Replicants:

Duplicates: Display their name emboldened

in blue or with the  icon, depending on

your setting in Settings > General > Mark

duplicates and replicants in color.

Replicants: Display their name in red italics

or the  icon, again depending on the

preference setting.

Files with Attributes:

Finder Comment: Displays a small speech

bubble property icon.

Reminder: Displays a small bell property

icon.

Attachment: Displays a paperclip property

icon. Generally seen on email and RTFD

files.

Indexed: Displays a small Finder property

icon.

Labeled: Displays a chosen color on or

near the filename depending on the Label

option chosen in Settings > General >

Appearance.

Files with Links:

Annotation File: Displays an asterisk

property icon as well as an outgoing link

icon.

Incoming Link: Displays a property icon of a

lined square with an arrow pointing inward

from the right.

Outgoing Link: Displays a property icon

of a lined square with an arrow pointing

outward to the right.

Incoming and Outgoing Links: Displays both

the incoming and outgoing link property

icons.

Marked files are ones with item attributes

found in the Data > Mark menu. In List and

Columns views, the property icons will not be

shown unless the Flag option in View > List

Columns is enabled.
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Marked Files:

Flagged: Displays a flag property icon.

Locked: Displays a lock property icon.

Unread: Displays a dot property icon and

the name in bold. Groups containing unread

items will also display their names in bold.

The Flag column shows the state,  flagged

or unflagged, or the  unread status of

items. Clicking in the flag column toggles the

flagged state. If an item is unread, a circle

will appear in this column. If you have a group

containing a mix of flagged and unflagged

items, a dash will appear in this column,

showing an indeterminate state.

Additionally, DEVONthink displays special

property icons to the right of item names

for attributes like Spotlight comments,

reminders, etc. A key of the item icons can

be found in the Iconology section of the

appendix

Context menu items: When you Control-

click in a Finder window, a context menu

appears with a host of commands for you

to choose from. DEVONthink's item list also

has a context menu available. The commands

shown depend on what is selected and

in what pane you're using. A list of the

commands can be found in the Context Menu

Items section of the appendix.

Note: To keep visual consistency and

make some functions more broadly

accessible, item lists are used throughout

DEVONthink's interface, so you'll see

them in some other panes. But note some

functions, like specific context menu items,

may change, depending on the specific

pane you're using.

TOOLBAR

At the top of most Mac applications you

encounter, including the Finder, you will see

the toolbar. For people who prefer working

with tracking devices, e.g., mice, trackpads,

etc., the toolbar allows you to have quick

access to some functions without having

to go through the menus. DEVONthink also

provides a toolbar in main and document

windows.

The toolbar comes pre-installed with a handy

default set of buttons, including the search

field (see below). It can be customized via

the Tools > Customize Toolbar command. You

can also Control-click the toolbar and choose

this command from the context menu. Add,

remove, and reorder these items to suit your

particular needs. On a side note, if you want

to quickly reorganize items on the toolbar,

hold the ⌘ Command key and drag the item

to its desired location, or off the toolbar to

remove it.

If you're looking for a little more space for

your toolbar, or even a little less, you can

choose to display the toolbar as Icon and

Text, Icons Only, or Text Only. Do bear in

mind, the Icon Only view will not show the

current document's title or icon.

A list of the available toolbar items is

available in the Toolbar section of the

appendix.

SIDEBARS

Seen in scores of applications for many

years, a sidebar is a top level organizational

structure, typically found on the left side

of an application window. The Finder or
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Apple Mail sidebars are perfect examples

of this. Looking at them, you should

see the immediate similarities with

DEVONthink. However, unlike most other

apps, DEVONthink has multiple sidebars,

each with their own special functions covered

a bit later in this chapter.

INSPECTORS

In some applications, extra information about

files is shown in a pane on the right side of

a window. DEVONthink also provides such a

pane in its main windows with individual sub-

panes called Inspectors. For example, data

about the name, tags, type, etc. of a selected

file are available in the Info Inspector. Unlike

other applications, it gives you multiple

inspectors presenting more information

and functions, all docked in the inspectors

panes. This gives you quick access to all the

inspectors in one unified window, especially

helpful on smaller screens.

The inspectors are individually discussed in

the Inspectors chapter.
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SEARCH PANE

Storing information is a useful thing, but

it's more useful when you can find things

too. DEVONthink offers a strong search

function for finding items in your databases,

all integrated into a main window.

In the toolbar is a search field for entering

your search terms. Type in a word and the

search pane appears showing any matched

items — and yes, it's another item list

supporting the different views and sort

methods discussed above. Additionally, the

View/Edit pane can be shown to display

selected results. For contents-based

searches, the search terms will be highlighted

in the preview, whenever possible.

Search options: In the search field, you will

notice a  magnifying glass icon. Click this

icon to see where to search, list the ten most

recent search queries, one choose among the

following options:

Live while typing: Enable this option to

search while typing or disable it to search

only when you press ↩ Return.

Partial matches while typing: This option

assumes an asterisk wildcard at the end

of the last search term. That term is only

matched as the beginning of a word. For

example, typing "sync" is used as sync*,

matching "synchronize" or "syncing" but not

"resync". Enabling this option also activates

Live while typing so the results dynamically

change as you type. Press the ↩ Return key

to treat the last term as a complete word.

Ignore Diacritics: This allows you to ignore

special marks on letters, like umlauts or

accents.

Fuzzy: This uses fuzzy-logic to expand the

possible matches DEVONthink makes.

For example, hello and hullo would be

matched.
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There is also a hidden preference,

EnableSearchFieldAutocompletion, to allow

DEVONthink to try to automatically complete

words you're typing. However, this option only

works when the search options Live while

typing and Partial matches while typing are

disabled.

Search prefixes: Anything you type into

the search field will be treated as searching

in all possible attributes. However, if you

want to focus on specific attributes, e.g.,

file types or tags, the search field supports

prefix operator searches, similar to Spotlight.

Common examples are searches like

name:DEVON or tags:tech;sync, separating

multi-valued attributes like tags with a

semicolon. There are a wide variety of

prefixes available, as well as different prefix

operators. A complete list of these items is

included in the Search Prefixes section of the

appendix.

In addition to search prefixes, DEVONthink

supports Boolean operators, parenthesis for

grouping terms, and quotes to match specific

terms. Read more about operators and how

to use them in the Search Operators section

of the appendix.

Search scopes: After you've done a search,

you will also see a bar above the search

results allowing you to choose the scope of

the search. The scope is the "where" you're

searching. You will be shown All Databases,

Inboxes, the name of the current database,

and the name of the current group, if you're

currently viewing one. Choose one to expand

or limit where DEVONthink is searching. If

you are searching in a particular location

and want to ignore possible matches in the

subgroups, enable the Exclude Subgroups

checkbox, as needed.

Advanced and save: To the right of the search

scopes, you will see two buttons. Clicking the

Advanced button displays the criteria of the

current search. You can modify the search

with the same kind of controls used in the

Finder's smart folders, as well as some other

applications with advanced search methods.

Note these controls are also used in creating

smart groups and smart rules.

If you have done a search you'd like to use

again, press the Save button. Enter a name

and DEVONthink will create a smart group

for you. If your search scope is in a group,

the smart group will be created there. If you

are searching a specific database, the smart

group is created in the root of the database.

Searching inboxes or all databases creates

a global smart group, shown in the Smart

Groups section of theNavigate sidebar.

Note: The search index contains

alphanumeric characters as well as the

following symbols: $€£¥%§

PATH BAR

On the left side of the main window, just

below the toolbar, is the Path Bar. This is

a specialized bar displaying a crumb trail

of your current location in a database. For

example, if you are in a nested group, it will

show something like Coding > AppleScript

> WWDC > 416, beginning with the current

database.
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Each item in the crumb trail is a live link, so

you can click it to jump to any parent folder

or back to the top level of the database. ⌃-

click an item in the crumb trail to open the

location in a new main window or reveal it in

the current window.

This bar also has < and > buttons so you can

navigate back and forth between locations

you've visited in this window. Bear in mind,

these buttons only relate to the history of the

specific window. If you open a new window,

it will have no history so the buttons will

not function until you've navigated to some

locations. As an added feature, click and hold

one of these buttons to be shown a list of

previous locations you've visited, just like in a

web browser.

INFORMATION BAR

Another specialized bar, the Information

Bar displays the number of items selected

and the total number of items in the current

location. As mentioned previously, this

bar also hosts the Sort dropdown and the

 view icons.

SIDEBAR: NAVIGATE

The Navigate pane is the default sidebar

where you will access to your databases, tags,

items located in Favorites, etc. Additionally,

you have access to some specialized items:

global smart groups and smart rules.

Each section in the Navigate sidebar has its

own specific purpose: giving you access to

frequently used files, navigating database

groups, or viewing a list of similar files. The

sidebar will only show databases and groups.

Selecting one of these items will display

its groups and files in the item list. This

allows a clear view of the group structure

in the sidebar, while still allowing you to

interact with the contents in the item

list. Alternatively, you can view the group

hierarchies directly in the sidebar. Excluding

smart groups and smart rules, selecting

multiple items will show a union of their

contents in the item list.

The sections in the Navigate sidebar can

be dragged to reorganize them as desired.

Sections you don't need to use as often

can be collapsed to reclaim the space or to

provide a bit of privacy.

UNIFIED ELEMENTS

By default, specific parts of databases are

shown gathered in specific sections, similar

to how Apple Mail displays the inboxes of all

accounts in the same section.
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Globals: The Globals section provides quick

access to three locations common to all

databases: the Inbox, Tags, and the Trash.

If you click a top level section, e.g., Inboxes,

you will see a combined view of items in the

inboxes of all open databases. This can be

especially handy if you want a view of all the

tags you're using in your databases. Click the

disclosure triangle next to each section to

show the locations for each open database,

allowing you to access the locations on an

individual database level.

Inboxes: The inbox of a database, like the

real-world counterpart on an office desk,

is where incoming, unfiled items are kept.

Every database has one by default and you

can see the name of the database each inbox

belongs to. The Global Inbox, shown just as

Inbox, is a special, always-open database

present in every installation of DEVONthink.

This is highly useful when quickly capturing

data, e.g., web clipping, screen captures, etc.,

without stopping to file things. You can then

go back later and file these items at your

leisure.

Tags: The Tags section provides quick access

to all the tags you are using or tags within

individual databases. If you click the top level

tags, the item list will display all the tags

you've created. Open this group and click on

a database's name to show its tags. If you like

to create nested or hierarchical tags, you can

drag and drop existing tags in the sidebar or

the item list.

Typically you will use the Tags bar in the

View/Edit pane or the Info Inspector or

Info popup to apply or create tags. You can

also drag items in your database to the

individual tags. When you create a tag it will

automatically appear in the Tags group of the

database you're in. If you want to create new

tags to be used later, select the Tags group

for the database and choose Data > New >

Tag. Or from the context menu, Control-click

the database's top level Tags group or an

existing tag and select New Tag.

If you find yourself in a situation with multiple

tags you'd like to merge, select the Tags group

for the current database to view the tags in

the item list. You can then select the tags

there and choose Tools > Merge Items.

Removing entire tag groups can be done by

dragging and dropping to the sidebar's trash.

From the context menu, you can choose

Move to Trash. You can delete tags in the
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item list as well. One thing to note: When you

delete a tag, the original file in the database

is preserved. What you see in the database's

trash is the replicant that was created in the

tag group when you added the tag.

Trash: Every database has its own individual

trash. This allows you to see, and potentially

retrieve, items you've deleted from your

individual databases. Just as with the real-

world trash bin, we do suggest you empty

your databases' trash regularly. It is not

meant as another filing location, and items

marked as missing will still register as a

problem for a database. Select the trash,

the top level or individual database's trash,

and choose DEVONthink > Empty Trash. The

command is also available in the context

menu, when Control-clicking a trash. Trashed

files are not deleted completely from the

machine but are put into the system trash.

Open Databases: This section is where you

see and access any databases you have

currently open. Click the database's name

to display items in the root of the database.

Clicking the disclosure triangle allows you to

show groups, and subsequently sub-groups in

the database. As mentioned above, selecting

a database or group will display its subgroups

and files in the item list.

NON-UNIFIED ELEMENTS

As the unified views may be less comfortable

for some people, DEVONthink allows you to

decide what database elements you want

to unify. Controlled by options in Settings >

General > Sidebar, you can enable or disable

unifying: Inboxes, Tags, or Databases.

Inboxes: If you disable unifying the inboxes,

only the Global Inbox will be shown in the

Globals section. The inboxes of individual

databases will be shown in the item list when

the database is selected.

Tags: Similar to the inboxes, disabling this

option will display the Tags group with other

elements in the selected database.
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Note: With Unify Inboxes and Tags both

disabled, the database's contents will

appear similar to how DEVONthink 2

displayed databases.

Databases: When disabled, DEVONthink

displays a database's name in the Open

Databases section of the sidebar but the

contents will be shown in a separate section.

The current database will be marked on the

left by an asterisk (*) and its groups will be

shown in a separate active database section

in the sidebar. This creates an isolated view

of that database regardless of the number

of databases that are open. Interacting with

elements in the active database section

displays contents in the item list, similar to

the Three Pane view from DEVONthink 2.

For switching between active databases,

select another database and the active

database section will display only the groups

and smart groups of that database. Also,

there are Previous Database and Next

Database commands in the Go menu.

When using the keyboard, hold the Command

key and press the up and down arrows to

view the contents of another open database

in the item list while showing the contents of

the previously active database in the active

database section. Press ⇧-↩ to change the

active databases section to the currently

selected database.

CONTEXT MENU

There are a few specific context menu items

found in these sections of the Navigate

sidebar. These commands are also found in

the File or Data menus:

Copy Database/Item Link: Copies a link to

the selected item.

Database Properties: Displays information

about the chosen database.

Close Database: Closes the chosen

database. In the case of encrypted

databases, the encrypted volume will be

ejected as well.

Delete Database: Deletes the chosen

database to the system trash. This includes

its cache and Spotlight index as well.

New Window: Opens a new main window

for the chosen database. When used

on closed databases in the Favorites or

Recent Databases sections, hold the ⌥

key for the alternate command, Open

Database in New Window.

Rename: Change the name of the chosen

database. This can also be done in the

Database Properties.

Reveal: Display the location of the item and

select it in the item list.

Show in Finder: Reveals the database file in

the Finder.

Any section-specific context menu items that

may require explanation are discussed in their

respective sections below.
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FAVORITES

There are many times we have specific

databases, groups, or documents we return

to, again and again. Shown at the top of the

sidebar by default, the Favorites section

allows you to create shortcuts to quickly

access any of these kind of items. Drag a

group or a document to this section's header

and you'll see a curved arrow on the cursor.

Drop the file and you have a new favorite.

An option to Add to Favorites is available in

the context menu commands of most items

in DEVONthink. Use Remove from Favorites

when Control-clicking on already favorited

items to remove them.

Select an item in Favorites to quickly access

it. If an item was last viewed without a

preview, it will be displayed in its own

window. If you see a favorite is greyed out,

it means the containing database isn't

open. Double-clicking the item will open the

database, if possible, and display the item.

Drag items in the section to reorder them.

Groups in Favorites behave as normal groups,

so you can drag items into a favorited group

for quick filing. This includes using ⌥ and ⌘⌥

to duplicate or replicate items while dragging

and dropping to them.

Note: Favorites only support one level of

content, so you can't group or nest items

here.

RECENT DATABASES

The Recent Databases section provides quick

access to reopen closed databases. This will

list the last ten recently closed databases.

Double-click any databases you'd like to open.

SMART GROUPS

The global smart groups function the same

as local smart groups, i.e., the ones in your

individual databases, but generally their

scope is all open databases. This allows

you to have reusable searches targeting all

your open databases, e.g., all Markdown

documents in all databases created in the

last month. These global smart groups can be

modified to target more specific locations,

but such a smart group would be better

suited as a local smart group, i.e., in the

particular database. DEVONthink comes with

some pre-installed global smart groups:

Today: Shows all documents added or

modified today.

Recently Added: Shows all documents

added in the last week.

Due This Week: Shows all documents with

a due date set for this week.

Top Hits: Shows documents opened more

than five times in the last 30 days.

Unread: Shows all documents marked as

unread.

You can create a smart group from the

context menu or the + button at the bottom

of the sidebar. By default all open databases

will be targeted. However, if you have an item

selected in the Globals or Open Databases

sections, the smart rule will use that location

for the matching.

Control-click a smart group to Edit, Rename,

Duplicate, or Remove it. You can also copy a

link to a smart group, export it to the Finder,

or import previously exported ones. If you'd

like to convert an existing smart group into
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a smart rule, ⌃-click the desired smart group,

hold the ⌥ key, and choose Duplicate as

smart rule.

If you have exported smart groups in the

Finder, double-clicking them will import them.

You can also drag them to the smart rules

section of the sidebar.

For more information on editing smart group

properties, global or local, see the Smart

Group Editor section of this chapter.

SMART RULES

Similar to smart groups, smart rules are

created, edited, and behave in a similar

fashion. However, they have one distinct

difference: they can act on the items

matched. The smart rule matches items just

as a smart group does but they perform

actions when certain events take place. This

makes them a very powerful way to add

automation to your DEVONthink life.

DEVONthink provides a few useful example

smart rules to get you started:

Automatic Locking: Locks unlocked

documents (excluding RSS articles), that

haven't been modified in the last 30 days.

This requires user intervention.

Bates Number: A specialized rule that adds

the current database's name and a Bates

number to a filename. The original name is

preserved as a document alias.

Filter Duplicates: Automatically puts

duplicated items in a database's trash

when you import them.

Reminders: Displays the name of a

document and plays the system "glass"

sound when a reminder on a matched item

triggers.

Create Version: Create a new versioned file.

Remove Obsolete Versions: The companion

to the Create Version smart rule, use this

to purge old versions.

Unify Names in Dates: Detects dates in a

filename, retrieves the filename without

the date, the renames the file prefixing the

filename with the detected date as YYYY-

MM-DD.

If you Control-click a smart rule and choose

Edit, you will see the criteria, event trigger,

and actions for that rule. Like smart groups,

you can create a smart rule from the context

menu or the + button at the bottom of the

sidebar. The target of the smart rule also

follows the same behavior as a smart group:

all databases are targeted unless you have

an item selected in the Globals or the Open

Databases section of this sidebar.

Control-click a smart rule to Edit, Rename,

Duplicate, or Remove it. You can also copy

a link to a smart rule, export a smart rule to

the Finder for archiving or sharing, or import

previously exported rules. Double-clicking

exported smart rules imports them, and so

does dragging them to the sidebar.

In the context menu for a smart rule, notice

there is also a smart rule-specific command:

Apply Rule. This runs the clicked command

on any matching files. This means it will

performs its actions, even if the event trigger

is not set to On Demand. Be cautious about

using this command unless you are certain

you want to affect all matched items. There

is also an option to copy the item link for a

smart rule by choosing Copy Rule Link.
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Also when you Control-click a selected smart

rule, you will see a Disable Actions or Enable

Actions option, depending on the state of the

selected rules. Use this to toggle the active

state of any selected rules. This can be useful

in debugging situations.

There are two commands in the Tools menu

related to smart rules:

Tools > Apply Rules: This runs the actions

of a chosen rule on selected items, but only

ones matched by the smart rule.

Tools > Perform Rules: This performs the

chosen rule as defined, not acting on the

selection.

Drag and Drop: Lastly, you can drag and drop

items onto smart rules to apply their actions

to them. Dropped items will be acted on,

ignoring the location and criteria specified in

the smart rule. For example, you may have a

smart rule to add the date to the beginning

of the name of images imported into your

Global Inbox. However, you could drag and

drop a rich text file from a separate database

on to the smart rule and the date would

be prefixed to the name, even though the

location and file type do not match the rule.

For more information on editing smart

rules, see the Smart Rules section of the

Automation chapter.

SIDEBAR: FILTERS

Providing yet another way to isolate files

in the item list, the Filters pane allows

you to only show files that share common

attributes. This pane, displayed at the

bottom of the Navigate sidebar an be shown

or hidden via the Tools > Filter menu or the

trio of icons at the bottom of the Navigate

sidebar. The pane can be resized by moving

the divider at the top of the pane.

INFO

Displayed by selecting Tools > Filter > Info, the

Info filters pane let you shows only files that

share common dates, ratings, color labels,

etc.

Dates: Click the Date dropdown to choose

the type of date you want to filter on: Added,

Created, Modified, Opened, or Due. Click on

a date in the calendar display to only show

files related to the day and type of date

you selected. Use the small arrows to move

backward and forward through time, and click

the circle between them to quickly return to

the last selected date.
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Marks: Choose the type of mark, or a

combination of them, on which you want to

filter. For example, you can click the flag and

a rating of 3 to show only those files. You can

filter on these attributes:

Flagged or unflagged

Read or unread

Locked or unlocked

Rating

Label

File Location: Click the dropdown to choose

whether to display Imported, Indexed, or

both with Any.

TAGS

Choosing the Tags filter via Tools > Filter >

Tags displays a tag cloud derived from the

tags on the current list of files. The cloud

shows the tags in varying sizes depending on

the number of occurrences of each tag on

these documents. The more files with a given

tag, the larger it displays. This makes it easy

to identify commonly used tags. If there are

no tags on the files in the current item list, No

Tags will be displayed. Additionally, Control-

click in this pane to sort the tags by Name or

by Count.

To filter the files, click any tag. You will

immediately see the tag cloud reduce in

number and only related tags are shown. This

allows you to drill down into files that share

common tags, but also exposes tags that

have been used with the previously selected

tags.

Note: The tags you choose will also be

shown in the Information bar above the

item list. Hovering over one of these tags

displays a  close button at the right side

of the tag. Click it to stop filtering on that

tag. You can also press the Reset button to

clear all filtered tags.

Control-clicking a tag in the tag cloud shows

these options:

Reveal Tag: Displays the Tag group in the

list of tags from all open databases.

Remove Tag: Removes the tag from the

Tags groups and also from any document it

was applied to.
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Related Tags: Displays the top two tags

most commonly used with this tag.

Selecting a tag from this list filters the files

on that tag.

View>: Allows you to switch between cloud

and list view.

Sort: Allows you to sort the tags by name

or count.

MULTIMEDIA

Open the Multimedia filter via Tools > Filter

> Multimedia to present options for filtering

out multimedia files, e.g., images, audio, and

video in the current location.

To assist in filtering, there are a few controls

available:

Kind: Select the kind: Any, Image, Video, or

Audio.

Width & Height (pixels): Set a minumum

and / or a maximum pixel dimension for

the width or height of images. Selecting

and pressing the Delete key in a field will

reset it to zero or infinity (no maximum

specified).

Duration (seconds): Set a minimum or

maximum length of a video or audio file,

defined in seconds, e.g., 900 for 15 minutes

(15 minutes x 60 seconds).

Note: The Multimedia filter pane is only

available in macOS 11 or later.

MAP

Utilizing geolocation data from your files,

the Maps filter shows documents related by

location. Show this filter pane by selecting

Tools > Filter > Maps. By default, the pins on

the map show the place a document was

created. However, the geolocation data can

be manually changed to a relative location,

like the site of a historic event. (See the Info

Inspector for more information on this.)
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The map functions similar to Apple or Google

Maps, allowing you to use familiar pinch

gestures or double-click or Option-double-

click to zoom in and out, panning, etc. The

map shows pins for all documents with

geolocation data in the selected location in

the Navigate sidebar. Selecting a pin in the

map displays the files with that geolocation

data in the item list.

SIDEBAR: SMART GROUP AND
RULE EDITOR

When you create or edit a smart group or

smart rule, a sheet appears with options for

specifying options, like the criteria to match

or from where to match items.

OPTIONS

The top section of the sheet contains a

mandatory name and search location, as well

as a few optional items.

Name: Enter a name for the smart item.

Search in: Select where you want this

smart item to search.

Exclude Subgroups: Enable this to ignore

items in subgroups of the location selected

in the Search in dropdown.

In the Comparison section, you will see these

options:

Ignore Diacritics: Check this to treat

letters with diacritics, e.g., umlauts or

accented characters, the same as their

regular counterparts.

Fuzzy: Check this to apply fuzzy logic to

contents-based criteria, ignoring simple

typos so that instances of "hello" and

"hallo" are both found.

Highlight Occurrences: When used with

contents-based matching, this will highlight
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the terms in the text of selected search

results, if possible.

PREDICATES

The second section of the editor shows the

search predicates. These define criteria you

want to match. Criteria may be content- or

attribute-related, e.g., documents containing

a specific word or groups added this week.

Note: The predicate editor is also shown

when using the Advanced options when

searching your databases. It is also shown

in a similar sheet when you run the Tools >

Batch Process command.

The list of predicates consists of a list of

blocks, each beginning with All or Any,

defining whether all (Boolean AND) or any

(Boolean OR) of the contained predicates

need to be true for the document to be

returned as a result. Predicates themselves

consist of the field to search (like "Content"

or "Tag"), and the condition and the data that

needs to be matched.

Add as many criteria as you need. Use the +

and - buttons to add more predicates to your

smart group or to delete them. Predicates

can be rearranged with drag-and-drop. Hold

the ⌥ Option key and click a ... button to

create a "compound predicate" also called

"branch". Each branch also has its own All or

Any option as well. This allows you to create

very targeted searches.

Example: To find all Microsoft Excel files

use the condition Filename ... ends in ...

xslx. To find items created in the last 7 days

use the condition Date created ... is ... Last

Week.

Note: In some predicates you can use

wildcards, Boolean operators, phrases, and

parenthesis, too. See also p. 233ff

SIDEBAR: READING LIST

Similar to the section found in Safari (and

now many other browsers), the Reading

List provides a place to access documents

and groups you've "set aside" for later

consideration. The items are listed in All

and Unread views. Newly added items are

displayed at the top of the list.

Add files from the item list via drag and drop

when this pane is visible. Alternately, choose

the Data > Add to > Reading List menu item.

This command may also be available when

Control-clicking in an item list or in images

and PDFs.

Items added to this pane will automatically

appear in the Unread view. Selecting an item

with the View/Edit pane visible will treat the

item as read and the item will only be shown

in the All view.
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Items in the Reading List can be moved to

other locations by dragging them to any item

list in a main window. The drag operations

also allow you to duplicate or replicate the

files, holding ⌥ or ⌥⌘, respectively.

CONTEXT MENU

The context menu (which appears when

you Control-click an item) offers these

commands:

Open in New Tab: Opens the clicked item in

a new tab.

Open in New Window: Opens the clicked

item in a new document window.

Mark as Read/Unread: Changes the read

state of the clicked item.

Reveal Item: Reveals the item in its current

location.

Move to Trash: Moves the item to the

database's Trash. Emptying the Trash

removes the file and its reference from the

Reading List.

Copy: Copies the selected item(s).

Select/Deselect All: Selects all or none of

the items, respectively.

Remove Item: Removes the clicked item

from the Reading List.

Clear All Items: Removes all Reading List

items.

Note: The last two options cannot be

undone.

For those interested in automation, you can

use the special item links x-devonthink://

readinglist or x-devonthink-item://

readinglist to open the Reading List.

SIDEBAR: IMAGE CAPTURE

The Import sidebar pane gives you access

to two common sources of external data:

scanning and email. Each section in this

sidebar provides controls to import from any

supported scanner or a compatible email

client, e.g., Apple Mail or Outlook. This makes

DEVONthink a reliable companion at home,

in an office, in the hands of an archivist,

and many other scenarios. We will cover the

scanning controls in this section. We have

also provided a more practical overview in

Capturing Paper section of the In & Out

chapter.

Archiving documents is an important

function in many situations. The Image

Capture section of this sidebar allows you

to control compatible scanners or import

images from connected cameras or iOS

devices.

DEVICES

The Devices section allows you to choose

an input device. Choosing a scanner offers

different controls and options than selecting

a connected iOS device or camera.
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Selected Scanner: If you select a scanner you

will be presented with controls and settings

to scan your documents. This allows you to

use your scanner directly in DEVONthink very

efficiently. This interface should be familiar

to anyone using Apple's Image Capture

application or scanning in Preview.

Overview: The overview of what's being

scanned. When using a Custom Size you

will define the scan area in this pane.

From: Choose where you'll be inserting the

paper into the scanner.

Mode: Choose the color type: Black &

White, Grayscale, or Color.

Duplex: Enable double-sided scanning, if

available.

Resolution: Set the desired resolution

of the scan. 300 dpi is the suggested

resolution for most cases.

Size: Choose a pre-defined page size or

check Custom Size and manually change

the scan area in the overview. Resize the

scan area or even drag multiple scan areas

on the same scan. You can also enter

specific measurements. Switching to a

pre-defined size will clear any custom scan

areas.

Orientation: Change the orientation of the

final document.

Name: Enter a name for the final

document. If left empty, a date stamp will

be used as an automatic name.

To: Choose where to send the document:

Imports, create a new binder or use an

existing one, or choose a destination in a

database.

Destination: The chosen location in a

database will be shown here. You can also

choose a location to send binders to when

saving.

Kind: Choose the format for the final

document.

Tags: Enter optional tags to be applied to

the document.

OCR: Enable OCR for the scan, if desired.

Camera or Mobile Device: Clicking on a

connected camera or mobile device displays

an item list of photos to import. These

items can be imported for a variety of

uses. Additionally, for documents you've

photographed, the images can be added

to a scanning document (described below)

and OCR can be done to create searchable

PDFs. This can be very useful for everyday

things like receipts to archiving historical

documents.

To: Choose to import items to Imports, into

a new or existing binder.

Thumbnails/Details: Switch between a

thumbnail or a detailed list of photos.

The size of thumbnails is controlled by

the slider at the lower right corner of the

window.

Delete: Shown as a stop symbol, use this to

delete selected images from the connected

device. A warning will be displayed this

action cannot be undone.

Download: Download selected items to the

location set in the To dropdown. Optionally,

you can double-click items to import them.

All: Download all the items on the

connected device.
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QUEUE

Select the Queue option to display the

scanning queue where you can pre-define

documents to scan. Define parameters for

each document, including: Title, Destination,

Type (PDF or Image), Separator, whether

OCR is enabled, and optional Tags for the

finished document. This section can be very

useful when batch scanning. The following

controls are shown in this view:

Scanner: Choose an available scanner.

Flatbed/Document Feeder: Choose where

you'll be inserting the paper into the

scanner.

Document List: Defined documents and

their parameters are listed here.

Add/Delete: Add or delete new document

definitions.

Remove Sent/All: Contained in a popup

menu, remove already processed or all

documents from the list.

Configure: Global scanner settings for

color type, resolution, page size, and duplex

scanning (double-sided, if available).

IMPORTS

Containing individual scans or Binders,

collections of scanned pages. Create or

access existing binders and scanned pages in

this section.

Document List: A list of thumbnails of

scanned images.

Create new Binder: Create a new empty

binder.

Properties: Change properties of a

selected scan or binder, e.g., where the

scan will be sent, the title, type, tags, and

optionally enabling OCR. You can also add a

Author or Subject for PDF output.

Edit: Change the orientation or make

image modifications of a selected scan.

Double-click a scanned page to display the

image modification pane.

Play: Play video imported from an iOS

device.

Delete: Delete the selected scan(s).

Save: Sends the selected scans or binders

to the To set in the Properties for each.

Select a specific binder in the sidebar to

show a thumbnail view of the pages it

contains. Rearrange the pages by drag-and-

drop or drag pages from one document to

another. Press the Sort button to use these

options:

Reverse Order: Reorder all pages from last

to first.

Shuffle Odd/Even Pages: Automatically

switch odd and even pages

Sort and Merge Documents: Choose two

documents to merge their contents. One

document is chosen as the starting odd

page, the other as the starting even page.

The pages are then interleaved into the

current document.

TRASH

Any scans or documents you've deleted from

the scanning interface will appear here. When

you have this selected, empty the trash with

the button at the lower right corner of the

window.

DEVONthink 3.9.17 Documentation, page 102



SIDEBAR: EMAIL

In addition to scanning, the Import pane also

provides the controls to archive emails from

Apple Mail and Microsoft Outlook. While you

can drag email messages individually from

your email client, the Email section of this

sidebar also allows you to import individual

messages or archive mailboxes directly into

your DEVONthink database.

Open the pane pane by choosing View >

Import. Here we discuss the controls used in

this section. For a more practical overview

of the email archiving process, check out

the Archiving Email section of the In & Out

chapter.

ACCOUNTS AND MAILBOXES

The lefthand section of the Email section

displays the active accounts and mailboxes of

Apple Mail or Microsoft Outlook. Select your

email client, then click the disclosure triangle

to show the accounts then its mailboxes.

Mailbox View: When you select a mailbox in

a specific account, the window will display

more controls for filtering and importing

messages from that mailbox. The central view

shows the contents of a chosen mailbox. This

is where you can select individual messages

to import, if desired.

This view is separated into columns that can

be sorted by clicking the column headers.

The columns include From, Subject, To, the

Flagged state. If you are choosing to show

already imported messages, there is a special

column showing those items. For emails

marked as high priority, the flagged column

will also show two exclamation points and the

subject, etc. will show in red. Control-click in

the Mailbox view to refresh its contents.

FILTER AND IMPORT

When a mailbox is selected, the righthand

side of the window shows options for filtering

the messages displayed. It also lets you

choose the location where the messages will

be imported.

Destination: Choose the destination

database for the imported messages or

mailboxes. Note: You can choose a specific

group in a database when using the Import

function. However, you can only choose a

specific database, and not a group, when

using the Archive Mailbox function. Emails are

archived into a special Emails group at the

root of the specified database.

Search: Use this search field to search for

messages by the sender or recipient's Name,

email address, or the subject line. Note this

only allows for a single term to be used.

However, the search is matching substrings,

so a search for jun would match "junk",

"jungle", and "jejune".
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Show: Select options in this section to

further fine-tune the list of importable

messages, if desired. You can use:

Read: Show emails messages have been

read, unread, or either.

Flagged: Show messages that have been

flagged in the email application.

Priority: Show messages that have an

assigned priority

Date Range: Choose a range of dates to

display messages received between them.

Hide: Use these controls to hide certain items

from the mailbox view. All these options are

enabled by default, but can be selectively

disabled, if needed. However, when these

options are enabled it makes it easy to see

only new messages, ready for import.

Imported: Enabled by default, this hides

messages you've already imported into the

current database. As you can't import the

same message into a database multiple

times, changing the Destination changes

what messages are displayed when this

option is enabled. If you disable it, already

imported messages will show a checkmark

next to their name

Deleted: Hide messages you've put in the

account's trash.

Junk: Hide messages moved to the

account's junk mailbox.

The last two items are buttons for importing

selected emails in the Mailbox view or

archiving the currently selected mailbox. See

also p. 58ff

SIDEBAR: EXTRAS

The Extras sidebar gives you a place to check

for current information from us. It's an easy

way to stay up to date with some of the

goings on at DEVONtechnologies.

Support: Here you will find our recently

published tips, scripts, smart rules, and

templates.

Tips & Tricks: This shows recent blog posts

of handy tips about all things DEVONthink,

presented in a RSS feed style. To read the

full article, click the article's title.

Scripts and Smart Rules: From time to

time, we publish publicly available scripts

and smart rules. You will see a brief

description and a link that allows you to

install the script directly from this section.

Templates: We also offer templates for a

broad audience. This section lists recently

published ones. As with the scripts and

smart rules, a description and installation

link is provided.

If you'd like to quickly mark all items as Read,

⌃-click and select the Mark All as Read from

the context menu.
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For a view of all available scripts and

templates, as well as easy installation and

uninstallation, see the Support Assistant.

DEVONtechnologies: This section provides

a list of blog posts regarding updates and

promotions.

Note: For the sake of transparency,

DEVONthink does connect to our web

server to bring you this information.

DOCUMENT WINDOW

You can isolate a document in its own

window, known as a document window. These

windows are convenient for split screen work.

For any editable file formats, you can open

a document window by double-clicking a

document in any view of a main window.

Alternately, you can choose Data > Open

or Open from the context menu to open

any document in a document window. For

most file types that can't be edited directly

in DEVONthink, double-clicking the file will

open it in the system default application. For

example, double-clicking a Word file will open

it in the same application that opens if you

had opened the file in the Finder.

See the Documents chapter for a detailed

description of the various document types

DEVONthink supports.

Note: Command-clicking the window title

shows the document's location including

the database it's stored in.

TOOLBAR ITEMS

Similar to the main window, a document

window has a toolbar at its top. The default

toolbar buttons may vary, depending on

the type of file being viewed in the window.

You can customize the toolbar via View >

Customize Toolbar, but note there are fewer

options than you have with a main window.

A list of available toolbar items is available in

the Toolbar section of the appendix.

DOWNLOAD MANAGER

Window > Download Manager opens

DEVONthink's Download Manager panel.

Using the Download Manager, you can

download files or complete web sites from

the internet, and either store the information

in your database or as files on your hard

drive. Offline archives stored in DEVONthink

are also used when you visit bookmarks or

open a link in a new tab and your computer is

currently offline.
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PANEL ELEMENTS

The Download Manager panel consists of:

A list of a items to be downloaded

A status bar at the bottom

A  button for adding items to and a 

button for deleting selected items from the

list

A  reload button

A Start/Stop button to enable or disable

downloads.

An  Action menu

ADDING FILES

To download a web site or any other file,

simply add it to the Download Manager by

dragging its URL to the Download Manager

panel. Alternatively, you can click the  in

the panel and add the URL manually, as well

as a referrer, user name, and password. If

Automatic is checked, DEVONthink creates

a referrer automatically when downloading

whole web sites.

You can also paste one or more URLs (copied

Safari bookmarks, DEVONthink links,

or copied links from DEVONagent Pro's

Download Manager), or add files to the

Download Manager by using the context

menu in web and HTML views in DEVONthink.

Note: You can also copy URLs in the

Download Manager to the clipboard or

drag them to other applications (like the

Finder or Safari's bookmark manager).

The Download Manager also supports

URLs for local files (POSIX path, a file://

localhost/ URL, or a file:/// URL).

ACTION MENU

Most actions are available through the Action

menu or the context menu. Click the 

gear button or Control-click an item in the

Download Manager panel to display more

commands:

Add: Manually add a URL to the list.

Edit: Edit the parameters of a selected

item in the list.

Retry: Attempts to reload an item that

failed to download.

Remove: Removes the selected items from

the list. Alternatively, you can press the

⌫ Backspace or ⌦ Delete key.

Enable/Disable: Checks or unchecks the

selected items. Only checked items will be

downloaded.

Start/Stop Queue: Starts or stops the

download queue. Same as the play/pause

buttons at the bottom of the panel. Note

this will only pause queued items. Any in

progress downloads will continue.

Purge Queue: Removes all items from the

list that have been completely downloaded.
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Only Added Files to Thumbnail Gallery:

Offers various predefined option sets (see

below).

Import Files to Database: Selects which

database the downloaded files shall be

stored in. Select Folder to save them

directly to the file system.

Options: Opens the options dialog sheet,

which allows you to specify in detail what

to download, which links to follow, and

where to store the downloaded files (see

below).

For your convenience, DEVONthink comes

with predefined option sets that you can

directly select from the action menu.

Only Added Files: Downloads only the files

you have manually added to the Download

Manager.

Offline Archive: Downloads the files you

have added to the Download Manager

including embedded images, style sheets,

and scripts. Use this option set to archive/

download web pages with everything

necessary to display them properly.

Alternative: Create a web archive.

Subdirectory (Complete): Downloads the

files you have added to the Download

Manager including all embedded or linked

files. This option set follows all links leading

to (items in) sub-directories. For example,

use this option set to download a complete

web site for offline archiving.

Subdirectory (Images & Multimedia):

Same as above, but downloads only

linked images, linked multimedia files

including Flash and QuickTime movies,

and embedded images in the item's

directory and all sub-directories. Use this

set to download a complete web site for

offline archiving (without all linked Office

documents, PDFs, etc.)

Thumbnail Gallery: Downloads the files

you have added to the Download Manager

including linked images, embedded images,

style sheets, and scripts. Use this option

set to download a thumbnail gallery

including all full-size images linked to each

thumbnail for offline archiving.

Note: Downloaded items are by default

excluded from classification and tagging.

OPTIONS

The options dialog defines which file types

the Download Manager downloads, which

links it follows, and where it stores the files.

Files: Check all file types you want the

Download Manager to download (plain

texts, rich texts, Office documents and

PDF files, style sheets and scripts, images,

embedded images, multimedia files, mark-

up language files, etc.) Use the Follow

Links pop-up menu to define how far

DEVONthink should follow links on the

downloaded HTML pages (see below).

Check Overwrite existing to update an

existing archive.

Folder: When you choose Download to >

Folder in the action menu of the Download

Manager panel, DEVONthink stores

all downloaded items in the directory

you specify. Click Set to choose your

preferred location. Use this option to

use the integrated Download Manager

for downloading software archives or

other files you don't want to store in your
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database. Double-click any part of the

location to reveal it in the Finder.

Download: Define how many connections

the Download Manager opens at the same

time. (Choose fewer connections for

slower Internet connection, more for DSL

or broadband.) Also, check Automatically

purge queue to have previously downloaded

items automatically removed from the

queue.

The Follow Links options defines how far

DEVONthink follows links on the downloaded

HTML pages. This feature allows you to

control what gets downloaded--only the

actual pages or a complete web site.

DEVONthink supports the following options:

Off: Does not follow any links.

On Same Host: Follows links, but only as

long as they refer to the same web server/

web site. Files on other web servers will not

be downloaded.

In Same Directory: Follows links, but only

as long as they refer to items in the same

directory as the downloaded HTML page.

In Subdirectories: Follows links, but only

as long as they refer to items in the same

directory as the downloaded HTML page or

its sub-directories.

One Level: Follows all links regardless of

where they point, but only one level deep.

Links on pages linked to from the original

page are not downloaded.

Two Levels: Follows all links regardless of

where they point to, but only two levels

deep.

Note: Following links two levels deep can

result in very large downloads.

THE SORTER

The Sorter is a multi-purpose popup that

allows you to quickly add content to your

databases, even when DEVONthink isn't the

active application. Depending on the option

you choose in Settings > Sorter, it will appear

in the menubar at the top of your screen or

docked to the left or right side of your screen.

When shown as a menu bar icon, you can

choose to display it as the word DEVONthink

or a space-saving nautilus icon.

It supports several views, each providing

handy shortcuts to getting data into your

databases. Switch between these views by

clicking the icons at the top of the pane.

Below we cover the different views the

Sorter provides for quickly capturing data.

NAVIGATION

The Navigation view provides a convenient

list of the databases and groups in

DEVONthink.

To add files in the Sorter, drag over the

docked tab or menu bar item. The Sorter will

spring open. then drop items into specific

groups to quickly import them. Also equipped
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with a handy search field, you can search

for and isolate groups for more targeted

importing. This view is composed of three

sections:

Search Field: Use the search field to help

quickly locate specific groups. This uses

substring matching, so you can enter

parts of words to find matches. The

view updates while you type for efficient

searching.

Favorites: Provides a convenient list of

the groups you've added to the Favorites

section of the global sidebar. Drag items

onto your favorites to import them.

Control-clicking a group or database gives

you the option to Reveal or Open the item.

You can also double-click an item to open it

in a new window.

Databases: Provides a list of open

databases and access to their groups.

Behaves in the same way items in your

Favorites do.

Hotkeys: The Navigation view supports these

hotkeys:

Tab: Switch the cursor focus between the

search field and databases list.

Command-Option: Hold these keys when

dragging Finder files or folders to index

them.

Command: Hold this key when dropping an

item to move it into the database, putting

the original in the system trash.

Up/Down Arrows: Navigate up and down

through the database listing.

Left/Right Arrows: Open and close groups

containing subgroups. Hold the ⌥ Option

key while pressing the right or left arrow to

fully expand or collapse all the subgroups,

respectively.

Note: The ⎋ Escape key can be used in all

views to quickly close the Sorter.

CREATING FILES

The remaining views are focused on creating

files, whether that's a simple plain text file,

a screen capture of an application's window,

or some recorded video. Each of the following

views support the following options:

Add: Saves the file in the specified format

in the chosen location. You can also press

⌘S to save the current content.

Reset: Displayed as a  backward pointing

circular arrow, click it to clear the view to

its default settings.

Control-Tab/Shift-Control-Tab: Move

the cursor between fields, e.g., between

the body and URL. Hold Shift to cycle

backwards through the fields.

TAKE NOTE

The Take Note view is for those times when

you just need to quickly write a note but don't

want to go back into your databases to create

a new file.
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Allowing you to write notes in several

formats, the text will be displayed in the font

defined in Settings > Editing. Make your note

taking a little faster by defining a hotkey with

the Settings > Sorter > Take Note Hotkey. This

view supports these attributes:

Name: The title of your file. If left as

Automatic DEVONthink will attempt to

create a title from the first sentence of the

body.

Body: Enter your note text here.

URL: If there is a URL you'd like to associate

with the file, perhaps a link back to a

source, enter it here.

Info: Add metadata about the file here,

including: read status, locked state, flagged

state, rating, or color labels.

Tags: Enter tags for the file. Tag

suggestions will be made from the tags of

all open databases.

Format: Choose the format of the saved

note. Choose from: plain text, rich text,

formatted note, and Markdown.

Location: Choose the location to save your

file from the dropdown list. The location of

the last saved file will be preserved for the

next note you create.

Add: Saves the file in the specified format

in the chosen location.

Take Note Panel: The Take Note panel is

displayed when the Sorter is set to None in

Settings > Sorter. It has the same functions

as the view in the Sorter and also will be

pinned over any open windows.

VOICE NOTE

Use this view to record a voice note directly

into your database. This creates an AIFF-C

file in the location you choose. With simple

controls, it's easy to record impromptu audio.

This view has a few simple sections:

Audio Levels and Timer: At the top is a

sound meter to help visualize your audio

level as you record. The elapsed time

is shown as it records, convenient for

projects like rehearsing a presentation.

Begin/Stop Recording: Press the red

circular button to begin recording. Press

the black square button to end recording.

When you've stopped recording, you will be

shown:
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Playback and Volume: Playback your audio

to ensure it's good before you save it. Press

the Reset button to clear the audio and

record again.

Name: Enter a name for the audio file. If no

name is provided, a date and timestamped

name will be automatically given.

Info: Add metadata about the file here,

including: read status, locked state, flagged

state, rating, or color labels.

Tags: Enter tags for the file. Tag

suggestions will be made from the tags of

all open databases.

Location: Choose the location to save your

file from the dropdown list.

VIDEO NOTE

Use this view to capture a video from your

Mac's built-in camera. Videos are saved as

MP4 files for convenient compatibility across

platforms and devices.

Like the audio note, this is presented in very

simple controls:

Begin/Stop Recording: Press the red

circular button to begin recording. Press

the black square button to end recording.

Source: Choose the video and audio

source in the small downward facing caret

next to the record button. Any attached

compatible audio-visual devices should be

available here.

When you've stopped recording, you will be

shown:

Name: Enter a name for the video file. If no

name is provided, a date and timestamped

name will be automatically given.

Playback and Volume: Playback your video

before you save it. Or press the Reset

button to clear the video and record again.

Trim: Shown as scissors, click this to access

simple editing tools. You can drag the ends

of the yellow frame to change the start

and end of the video. Click and drag inside

the frame and a red line will appear. This

displays the time above the line.

Info: Add metadata about the file here,

including: read status, locked state, flagged

state, rating, or color labels.

Tags: Enter tags for the file. Tag

suggestions will be made from the tags of

all open databases.

Location: Choose the location to save your

file from the dropdown list.

SCREEN CAPTURE

Screen captures are a common way to

quickly gather information about things on

our computers. While the Apple provided

mechanisms still work, the Screen Capture

view allows you to quickly snap a screen

shot, add some metadata, e.g., tags or labels,
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then direct it to a specific location in your

databases. The captures will be saved as

JPEG files.

This view has one simple section with three

options, also accessible via shortcuts:

Screen: Capture your entire screen (⌘-1).

Window: Capture a specific window

(⌘-2). Hover over a window and it will be

highlighted in blue. Click once to capture it.

Selection: Capture a specified area by

dragging a bounding box around the

desired area (⌘-3). To reposition the area,

hold the space bar. To stop the capture

action, press the ⎋ Escape key.

As with other views, name and information

options will appear after the screen is

captured.

Name: Enter a name for the screen

capture. If no name is provided, a date and

timestamped name will be automatically

given.

Info: Add metadata about the file here,

including: read status, locked state, flagged

state, rating, or color labels.

Tags: Enter tags for the file. Tag

suggestions will be made from the tags of

all open databases.

Location: Choose the location to save your

file from the dropdown list.

WEB CLIP

Use the Web Clip view to quickly clip the

current web page, a URL from your clipboard,

or enter a URL manually. Each option is also

accessible via shortcuts.

Default Browser: Displaying the icon of

your default browser, click this to capture

the current page (⌘-1). This shows the

same options as the Clip to DEVONthink

browser extension.

Clipboard URL: If you have copied a URL,

click this option to detect and capture it

(⌘-2).

Manual: Click this to manually enter a URL

to capture (⌘-3).

Before clipping, you can add other

information to the item:

Name: Enter a name for the screen

capture. If no name is provided, a date and
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timestamped name will be automatically

given.

Info: Add metadata about the file here,

including: read status, locked state, flagged

state, rating, or color labels.

Tags: Enter tags for the file. Tag

suggestions will be made from the tags of

all open databases.

Location: Choose the location to save your

file from the dropdown list.

When using the default browser option or

the Clip to DEVONthink extension, click the

Preview button and DEVONthink will attempt

to display a preview of the intended capture.

This can be helpful in predetermining if the

capture of sites with logins will be successful.

SETTINGS

The Settings window, opened using

DEVONthink > Settings, contains all available

options, which you can modify to adapt

DEVONthink to your personal needs.

Because the application settings are so

important, we have created a separate

chapter for them.

DATABASE PROPERTIES

The Database Properties popup displays

preferences for a specific database. Select

a database and open the properties popup

using File > Database Properties

GENERAL

Location: Shows the location of the database

in your filesystem. Note you can double-click

any part of the database location to reveal it

in the Finder.

Create Spotlight Index: Checking this

option allows Spotlight to be able to locate

documents stored in your databases. Double-

click a result in the Spotlight search results

to open it in DEVONthink. If you are having

issues finding DEVONthink documents in a

Spotlight search, you can click the Rebuild

button to recreate this folder from scratch.

OPTIONS

Name: Enter a name for your database here.

It will appear in the title bar of every main

window of this database.

A database has two names: the displayed

name, set here in the properties, and the

filename, the name of the database file in
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the Finder. When you create a database, the

names will be the same. If you change the

displayed name in the database's properties,

the name of the database file will also

change. However, you can close the database

and change the filename in the Finder,

should you choose to. This can be used in

any situation, including office, health care,

and litigation environments where clients

or cases have a unique number associated

with them. A database could have a filename

of 10459.dtBase2 but the displayed name

of Company A in DEVONthink. When you

close the database, the filename will be

shown in the Recent Databases section of

the Navigate sidebar.

Comments: Add comments about this

database. These comments are only used in

DEVONthink, i.e., not exported to the Finder.

Exclude Groups from Tagging: Excludes all

groups in this database from being used as

tags. Ordinary tags can always be added to

items using the Tag bar.

Inherit Tags of Groups: Applies tags added to

a group also to the group's children.

Case Insensitive Tagging: Check this option

to disallow tags with different capitalization.

Protection: To add a layer of protection

when syncing your databases, you can add

a username and password to the database.

Anyone trying to import the database from

a sync location will need to provide these

credentials. Click on the padlock button to

unlock the entry fields, enter a user name

and password, and then click on the padlock

button again to lock your changes and hide

the password.

Note: For a locally secured database, create

an encrypted database via File > New

Encrypted Database.

STATISTICS

This section displays some basic statistics

about the contents of the database, e.g.,

counts of some different file types, total size

of the contents, and number of words in the

index of the database.

POPOVERS

Popovers are a specialized panel that

appears on command and disappears

after interacting with it. These are usually

used for quickly viewing information about

a selected item but can also be used in

some other ways. For example, Database

Properties is an information popover you may

already be familiar with. Here are a few more

DEVONthink offers, starting with information

popovers and followed by utility popovers.
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INFORMATION POPOVERS

Info: The Info popover shows information

about the currently selected item. It displays

the contents of the Info, Annotations &

Reminders, and Properties inspectors. Open

this popover via Tools > Get Info, ⇧⌘I, or

pressing the  toolbar button.

Log: The Log popover displays any

information available in the Log window. This

allows you to quickly glance at any messages

without having to open a separate window.

Open this popover via the  toolbar button.

Note this button will only be enabled if there

are messages available to be viewed. You can

clear the log or press the Save button to save

the log, usually to send to our support team.

UTILITY POPOVERS

The utility popvers provide extra functions

for moving files, navigating databases, or

linking documents. Each popover has a search

field at the top for helping to narrow the

results. You can use an abbreviated search

syntax matching the beginning of words to

help speed the process. For example, if you

are looking for a group named "Household

Expenses" you could type hou exp to find

matches. After tsearching, double-clicking

a result will move the file to the selected

location. For keyboard navigation, you can

press ⇥ Tab to put the focus in the results list

then navigate with the arrow keys. Pressing ↩

will accept the choice and close the popover

automatically. There is also a plus (+) button

for creating a new group in the current

location when needed.

Move to: This popover allows you to organize

selected files quickly. Open this popover via

Data > Move To or pressing ⌃⌘M.

The default behavior of this popover is

moving files. However, the behavior can be

changed using command keys. Hold the ⌥

key to duplicate files to a selected location.

Hold ⌘-⌥ to replicate the files to a selected
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location within the same database. Note the

text in the popver will change to reflect the

kind of operation will take place.

Go to Group: This popover allows you to

quickly jump to another location. Open this

popover via Go > To Group or ⌃⌘G. One

special property of this popover is the ability

to act as a floating pane. Open the popover

then click and drag it away from the toolbar.

It will remain open as a searchable floating

pane you can use for quick navigation. You

can also drag and drop files to it, similar to

the Navigation view of the Sorter.

Go to Document: This popover allows you to

quickly navigate to a specific file. Open this

popover via Go > To Document or ⌃⌘O. Note

this popover does not support abbreviated

syntax, i.e., matching substrings or non-

contiguous words, as the fuzzy matching

would lead to far too many results. Given

a filename of DEVONthink sync timing

tests.md, timing tests would match;

DEVONthink timing would not.

Insert Link: Used when editing text-based

documents, e.g., rich text, this popover allows

you to search for and quickly insert a link to

that file in the current document. The type

of link inserted will be appropriate to the

current document type, e.g., a Markdown

document will have a properly formatted

Markdown link. Open this popover via Edit

> Insert > Item Link, the Insert > Item Link

command, or ⌃⌘E in the context menu while

editing a compatible document.

WEB SHARING

DEVONthink comes with a built-in server

for broadcasting your databases on a

network. While the operation is covered

in the In & Out chapter, here we cover the

interface shown when accessing shared

databases in a browser window. Also note the

preferences for setting up shared databases,

including setting up users and per-database

permissions are covered in the Settings >

Server section of the Preferences chapter.
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The layout of the web sharing should

immediately be familiar to users of

DEVONthink. While not as full featured as

the native application, it behaves in ways

similar to DEVONthink's main window. Here

we will give you an overview of the parts of

this interface.

Note: The permissions given by the

administrator of the shared databases

determine database visibility as well as

what actions you can take. Due to this,

some actions, e.g., creating new documents

or downloading documents, may not be

available. If you do not have permissions

to modify the database you're browsing,

the cursor will change to show the option is

disallowed.

SIDEBAR

A condensed version of the Navigate  sidebar

found in DEVONthink's main windows, this

provides access to the contents of any

shared databases. Some basic context

menu items, e.g., New Group, New Feed,

Rename, and Move to Trash, are available

when Control-clicking in the sidebar.

Move files by dragging from the item list over

a group in the sidebar to file them in a new

location. Holding the ⌘ Command key allows

you to copy the file instead of move it.

If you hover over a section in the sidebar, you

can hide the Globals or Shared Databases

section. Also, you'll notice this interface

has been built in a responsive manner. This

causes the sidebar to disappear when the

browser window becomes to narrow for it be

effective. You can still use toolbar buttons to

toggle the visibility, as needed.

ITEM LIST

The item list, like its DEVONthink counterpart

(See also p. 83ff ), shows items in the

current location. Items can be selected and

reorganized by drag-and-drop, to the sidebar

or groups in the same location. Above the

item list is the path bath with active links

to parent locations. Click on them to quickly

jump back to a parent location. To navigate

back and forth through locations you've

visited, use the  and  buttons in the path

bar.

Again, taking its example from DEVONthink's

main window, Control-click items in the item

list to show these commands in the context

menu:

New: The submenu allows you to create

new items: plain text, formatted note,

Markdown, Bookmark, RSS feed, and

groups.

Get Info: Shows the Inspector pane for the

selected file.

Label: Apply or remove a color label to a

selected file.
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Mark: Toggle the Flagged, Unread, or

Locked state of a selected file.

Rating: Adjust the rating for a selected file.

Upload Document: Use this to upload a new

document to the database.

Download Document: Download the

currently selected file(s).

Move to Trash: Move the selected file(s) to

the database's Trash.

While you can't reorder the items manually,

the item list can be sorted by clicking on the

column headers. Click the header again to

toggle between an ascending or descending

sort. Control-click the headers to enable and

disable individual headers.

VIEW/EDIT PANE

When an item is selected in the item list, a

preview of any compatible file will be shown

here. Many non-proprietary text-based

formats commonly can be displayed. Plain

and rich text, Markdown, JPEG or PNG files,

PDF, etc. are easily searchable and viewable.

There is also support for editing plain and

rich text, formatted notes, and Markdown

documents directly in this pane. Just click in

the preview and begin editing.

Navigation bar: The navigation bar above the

pane varies what it displays, based on the

type of file it's displaying. If an item has a

URL, it will be active and displayed here. The

bar also allows you to move back and forth

through previously viewed files via the  and

 buttons.

Of special note are the behavior of formatted

notes. They are displayed with a handy

toolbar providing some editing options, like

adding bold or italic type. You can also select

text and create a hyperlink with it. Lastly,

you can choose an image to insert into the

document.

For the Markdown fans, you will see the

same navigation bar options, showing Edit,

Preview, and Side-by-Side modes.

Note: While it is a force of habit — and in

general, a good one to be in — you do not

need to press ⌘S after editing a file. The

changes are saved automatically.

INSPECTORS

Info: A simplified view of the Info Inspector

pane found in a main window. Shown by

clicking the right-most toolbar button or

choosing the Get Info command from the

Action button, this shows basic metadata

about the item selected in the item listing.

If you have permissions to make changes to

the current database, it is possible to change

some of the metadata, like ratings or labels.

See Also: The second view of the inspector

shows the See Also pane. This gives you some

suggestions about other documents that may

be related to to the currently selected item.

Clicking on an item in the results will display

that document in the view/edit pane.

TOOLBAR

There are a handful of toolbar tools in the

web sharing interface. Note a few items will

be discussed separately.

Show/Hide Sidebar: Toggles the visibility of

the Globals sidebar.

Preview: Toggle between standard and

widescreen view, with the preview on the

bottom or right, respectively.
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Action: Displayed with a gear icon, this

shows the same options as the context

menu in the item list.

Add: The submenu allows you to create

new items: plain text, formatted note,

Markdown, Bookmark, RSS feed, and

groups.

Move to Trash: Put the selected item in the

database's trash.

Refresh: Manually refreshes the current

item list.

Download Document: Downloads the

selected items in the item list and

downloads them to the downloads location

for the browser you're using. For some

formats, a ZIP file may be created and

downloaded.

Language: Switch the interface language

between English, French, and German.

Search: Search for files in the open

databases by entering search terms.

Search prefixes can be used and are

covered in more detail here: See also p. 87ff

Show/Hide Inspectors: Toggle the

Inspectors panes.

SUPPORT ASSISTANT

The integrated Support Assistant combines a

welcome screen with a first launch assistant,

tips, installable extras, and a support page

that guides you through the available support

options.

WELCOME

This screen welcomes you when you start

DEVONthink for the very first time. It offers:

The option to subscribe the free

DEVONtechnologies newsletter, as well as a

number of welcome tips

The tip of the day

The extra of the day
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Click the links at the bottom of the window

to access the other Support Assistant

sections. You can also check or uncheck the

Show this window when DEVONthink opens

checkbox at the bottom of the window to set

whether to show the Support Assistant each

time DEVONthink is launched.

FIRST LAUNCH ASSISTANT

The first launch assistant opens

automatically the very first time you open

DEVONthink, and guides you through the

first steps of using the application: creating

a new database, installing the add-ons, and

adjusting the preferences.

GET SUPPORT

The Support screen guides you through the

three common steps for troubleshooting

DEVONthink. In addition, you can update

your details in DEVONtechnologies' customer

database, or buy an upgrade or a second

license.

INSTALL EXTRAS

On the Extras screen, DEVONthink lists all

available extras that you can download and

install from DEVONtechnologies' server:

Scripts

Templates

Smart Rules

Browse the list of extras and install them

with the Install button. The last line of the

description shows where in the Scripts or

Templates menu the extra will show up after

installation. Remove installed extras with the

Remove button.
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The extras are updated live from

DEVONtechnologies' server so it's a good

idea to check back from time to time. The

latest extra is also always mentioned on the

welcome screen. If you check the Install &

update extras automatically checkbox at the

bottom of the window, any updates to scripts

or templates you've downloaded here will be

updated as needed.

Note: If one of these categories does not

show up in your copy of DEVONthink, there

might be no extras of this type currently

available.

TIPS AND TUTORIALS

Here you can find the latest tips and

tutorials to help you squeeze the best out

of DEVONthink. Tutorials can be slideshows

describing basic tasks in DEVONthink or

screencasts.

Both tips and tutorials are updated live from

DEVONtechnologies' server so it's a good idea

to check back on a regular basis. The latest

tip or tutorial is also always mentioned on the

welcome screen.

LOG

The Log panel displays messages and

warnings when importing files and folders,

results of performing maintenance routines,

and AppleScript errors from script actions

in smart rules or reminders. The panel shows

the date of the message, any affected

files, and a little information about what

happened. If you feel you are having sync

issues, this panel is the first place to look.

Also, when doing any database or sync

location maintenance, this is where the

results are shown.

You can save the list to a text file with the

Save button, and clear the log with the

Clear button. To sort the log, click a column

title to sort on that column, changing from

ascending to descending each time you click

it. If you Control-click individual log entries

you will be shown options to reveal the

item in its location or move it to the trash.

Alternatively, double-click the entry to reveal

the file.

Uncheck Show log automatically to prevent

the log popping up automatically. You can

open the Log panel at any time using Window

> Log. For important notifications, the log

is always shown automatically, ignoring this

setting.

ACTIVITY

The Activity panel shows a list of currently

running background processes, e.g.,

converting scans to searchable PDFs,

refreshing news feeds, downloading PDF

documents and web archives via our browser

extension, or sync activity. You can manually

open this pane via Window > Activity. You

can manually stop them to free computer

resources or for other reasons.
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There is also an Activity pane at the bottom

of the Navigate sidebar. Providing a less

intrusive experience, this pane will appear

and disappear quietly on its own.

Note: The Activity window is only used if

it was opened by the user or if there is no

main window to show an Activity pane.
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INSPECTORS

IN THIS CHAPTER

Info pane 123

Annotations & Reminders 126

Content 129

Document 131

Concordance 133

See Also & Classify 135

Search 136

The Inspector panes displayed on the right

side of a main window provide an incredible

amount of information and functionality

when working with files in DEVONthink.

Covering a range of options, from basic

metadata to setting reminders to in-

document search and replace functions. Each

of the Inspectors is individually covered in

this chapter.

INFO PANE

The Info pane, just like its counterpart in the

Finder, displays additional information about

a selected document or group, from icon and

name to comments and other metadata.

Open the Info pane by selecting Tools >

Inspector > Info > ….

Note: When you have multiple items

selected, some editable attributes can be

modified. For example, tags can be applied

to multiple files at once. However, if you

add tags to the same files separately, only

tags common to them will be shown if you

select them together again.

GENERIC

The Generic view shows additional basic

information about a selected document or

group, similar to what is shown in the Get

Info window in the Finder. Additionally, it

shows some other attributes like ratings,

color labels, and geolocation data. Here are

the attributes shown:

Icon and Name: Displays the name of the

selected item. To change the icon of the

item, select it and paste any image you

want over it. To change the name of the

item, use the Name field below.

Name: Displays the name of the selected

item. This is an editable attribute.

Aliases: Displays any aliases for the

selected item. Enter one or more words

here, separated by semicolons, as

alternative targets for Wiki links. Generally,

Wiki links refer to the name of contents,

and aliases make this system even more

flexible.
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URL: Displays a URL associated with the

selected item. This is an editable attribute.

While it is typically used for web addresses,

it also may contain other types; e.g., file

URLs, URL with custom schemes, etc. Click

the down arrow and choose: Launch to

open the URL, Copy to copy the URL to the

clipboard, or Remove to clear the URL.

Path: Displays the item's file's path in the

Finder. This is not an editable attribute.

Click the down arrow and choose: Launch

to open the file in the system default

application; Show in Finder to open a

Finder window with the file selected, and

Copy to copy the file path to the clipboard.

If you are indexing files, there is a Path

option that allows you to select a folder

or volume. If you have moved indexed files

to a new location, this option can be used

to select the new location, provided you

have not renamed any of the files before

updating the path.

Attached Script: Displays the name of an

AppleScript script attached to the object.

This is a script that is triggered when you

select the item in the database. Click the

down arrow and choose: Select to choose

a triggered script to attach, or Remove to

remove the script from the item. See also

p. 205ff

Added: Displays the date an item was

added to the database. This is not an

editable attribute.

Created/Modified: Displays the date an

item was created or modified. These are

editable attributes. Click the calendar icon

to choose a date and time. You can also

select individual parts of the date or time

and type or modify them with the up and

down arrows. When typing, press the ⇥Tab

key to commit the change.

Size: Displays the size of the item. For

groups and news feeds, this field shows the

size of all contained items.

Kind: Displays the kind of the selected

item. For documents, the file type will be

shown, e.g., Markdown.

Location: Displays the location of the item

in the database. This is an active item;

hovering over items will display their full

names and clicking them will navigate to

the clicked group.

Instances: Displays how many duplicates

or replicants of the selected item are in

the database. Click to show a pop-up menu

listing all instances and duplicates and their

enclosing groups. Select any item to reveal

it.

Format: For news feeds you can set the

default format in which new articles are

saved.

Color: Allows you to set a color for a tag.

Only available when a tag is selected. Click

the title Color for options to clear or copy

the color.

Geolocation: Displays geolocation data

based on the creation origin of the file;

i.e., the geographic location when the file

was originally created. This is an editable

attribute and can be changed if you'd like

the location to be relative to something

else, e.g., the site of a historic event.

Marks: Displays these attributes for the

selected item: Flagged, Read, Locked,

Rating, and Label.

Tags: Displays the tags applied to the

current item. Click the + button to add a

new tag. Tags will be suggested from the

existing tags in the current database. If the
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item is selected from the Inboxes in the

sidebar, suggestions will come from the

tags of all open databases. Click an added

tag to reveal the Tag group, or remove it

from the selected item.

Exclude From…: These checkboxes allow

you to exclude an item from being used in

various ways. For example, you can exclude

temporary groups from classification to

increase the accuracy of the built-in artificial

intelligence. You can exclude an item from

these operations:

Classification: When enabled on a group,

this will keep DEVONthink from suggesting

or using the group as a possible filing

location.

See Also: When enabled on any file,

DEVONthink will not include it as an item

potentially related to the current file.

Search: When enabled on any item, it will

no longer appear in toolbar search results,

smart groups, or smart rules.

Tagging: Used with group tags and  Tag

groups, this inhibits the Tag from being

applied to any item.

Wiki Linking: When enabled on any item,

it will not be detected by automatic

WikiLinking, neither by name or alias.

CUSTOM

The Custom view displays custom metadata

fields and their values. These custom fields

are defined by you in Settings > Data. All

available fields you have defined are shown in

this pane. Note some fields may be specified

as data types that include some extra actions

in this view. For example, if you create a

custom parameter with an Item Link data

type, you will have an option to reveal the file.

Note: Like many types of metadata

applied to files by various applications,

custom metadata is not cross-platform.

On macOS, it is stored in the extended

attributes upon exporting the file.

Item Link: Click the down arrow and

choose: Reveal to reveal the item in the

database.

Single-line Text: Type in a value or click the

dropdown menu to choose from a list you

defined in the preferences .

URL: Click the down arrow and choose:

Launch to open the URL or Copy to copy

the URL to the clipboard.
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PROPERTIES

The Document Properties section gives you

access to certain format-specific metadata.

Supported formats are: RTF, PDF, audio

or video with metadata, or images. This

metadata can include some of the following:

Author

Company

Copyright

Title

Subject

Keywords

Comments

Organization

Depending on the document type, you may

be able to edit or view these properties. More

fields may be available depending on the

document type.

There are two parameters supporting extra

actions:

Click the Title button and select Copy, or

select Set Name As to quickly change the

document's name.

Click Keywords and choose Convert to Tags

to apply the keywords as DEVONthink tags.

ANNOTATIONS & REMINDERS

This pane contains Reminders, Finder

Comments and information about

Annotations. It can be shown Tools >

Inspectors > Annotations & Reminders.

REMINDERS

While there are many reminder applications,

including Apple's own Reminders, sometimes

you just want to set a quick reminder for an

item, or multiple items, in DEVONthink. The

Reminders section allows you set a reminder,

even a recurring one, as well as an optional

alarm.

After choosing a schedule, set a date and

time for the reminder or to begin a recurring

reminder. For recurring alarms, the data or

time you set will be the beginning of the

alarms. Reminders can be set to:

Once: Only trigger an alarm once.

Hourly: Set an hourly reminder, triggering

at the minutes of time you set, e.g, 10:15,

11:15, etc. Set an interval for how many

hours should elapse before the next

reminder, e.g., 4 for every four hours.

Daily: Set a daily reminder, triggering at

the hour and minutes you set, e.g., daily at
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9:35 AM. Set an interval for how many days

should elapse before the next reminder,

e.g., 2 for every other day.

Weekly: Set a weekly reminder, triggering

at the hour and minutes you set. Choose

a day of the week the reminder should

trigger on. Set an interval for how many

weeks should elapse before the next

reminder, e.g., 3 for every third week.

Monthly: Set a monthly reminder,

triggering at the hour and minutes you set,

e.g., daily at 9:35 AM. Set an interval for

how many months should elapse before

the next reminder, e.g., 1 for every month.

Choose Each and set which days of the

month you want a reminder, e.g., the 1st

and 15th of the month. Alternately, choose 

On the … to choose a regular interval like

the second Thursday of the month.

Yearly: Set a yearly reminder, triggering

at the hour and minutes you set, e.g.,

daily at 9:35 AM. Set an interval for how

many years should elapse before the next

reminder, e.g., 1 for every year. Choose

which months you want a reminder. Also,

choose On the … to choose a regular

interval like the last day of those chosen

month(s).

Alarm: Reminders are most useful when

you have an alarm to, well, remind you of

something. There are several alarms available

for a reminder:

No Alarm: —

Bounce Dock Icon: Bounce the icon in the

dock. This will only occur if DEVONthink is

not the active application.

Display Notification: Displays a notification

using the Notification Center, appearing

at the upper right of your screen. The

message shown can be a combination of

static text and placeholder text. It defaults

to the Name placeholder. Control-click

and choose Insert Placeholder to add

additional placeholders. Note System

Settings > Notifications > DEVONthink

>  must be enabled for this alarm to

display. Notification are also only shown

when DEVONthink is not the frontmost

application.

Display Alert: Displays an alert dialog when

DEVONthink is or becomes the active

application. If it's not frontmost, the dock

icon will bounce until you switch to it.

Like Display Notification, this contains

static and placeholder text, and defaults to

Name.

Speak Text: Using the Mac's speech

synthesis, this alarm will speak the

specified static and placeholder text.

Play Sound: Choose one of the system alert

sounds found in System Settings > Sound >

Sound Effects.

Send Mail: Enter email addresses to which

to send the matching items. This can be

a comma-delimited list of addresses,

names, or enter the name of a group you've

defined in your contacts.

Add to Reading List: Add the file to

DEVONthink's Reading List.

Open: Open the document in an a

DEVONthink document window.

Open Externally: Open the document in the

system default application.

Launch URL: Opens the URL associated

with the document, if present.

Execute External Script: Run a selected

script. External scripts are stored in

~/Library/Application Scripts/

com.devon-technologies.think3/
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Reminders. Add your own scripts to this

location to make them available for use

with reminders.

Execute Embedded Script: Run an ad-hoc

script written for the current reminder.

Press the … button to display a popup

prepopulated with a core script. Edit this

and press the compile button at the lower

left. Embedded scripts are only available

to the reminder they are created in. If you

want to use the same script with other

reminders, use an external script instead.

As a bonus, reminder alarms will open

databases containing the item when an alarm

triggers.

Note: When setting a reminder on multiple

items, alarms are delivered individually. For

example, an alert notification will show for

each file, even if they were set for the same

time.

If you are interested in the use of scripts in

alarms, please refer to the Reminder Script

chapter of the Automation chapter.

FINDER COMMENTS

Similar to the Comments in the Get Info pane

in the Finder, the Finder Comments field

can be used to store miscellaneous bits of

information about the selected objects.

Note: These comments will not appear in

the files in the Finder unless the files are

indexed or exported from the database.

ANNOTATIONS

This pane displays or allow you to create

annotation files for a selected document.

Annotation files are separate files where you

can store notes about a specific document.

These files can link back to the original file for

quick access. Commonly used with PDF files,

they can actually be used for making notes

with any document in your database.

Note: Annotation files are created in an

Annotations group at the root of the

database. However, you can move the file

to another location, if desired.

If an annotation file doesn't exist, you can

make one with commands from the down

arrow in this section.

New from Template: Opens a submenu

containing three options: Create an

Annotation file from the default template,

choose a custom template added to

DEVONthink's internal Annotations folder,

or open the Annotations folder to access

any custom templates you've added.

New from Clipboard: Choose this option

to create an annotation with content from

the clipboard.

Insert Back Link: This inserts a back link

to the original file into a new annotation

file. If no annotation file exists, one will be

created with this command.

Insert Quote: This inserts both the

selected text and a backlink to the page

or paragraph in the original file. If no

annotation file exists, one will be created

with this command. This option is only

supported by PDF, plain text, and rich text

documents.

If an annotation file is detected by

DEVONthink or you've just created one,

an editable preview of the file will appear

here. Clicking the down arrow reveals these

options:
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Open: Open the annotation file.

Reveal: Reveal the annotation file in its

current location.

Insert Back Link: Insert a link back to

the original document in the current

annotation file. With audio and video

files, the back link will include the current

playback time. With multi-page PDFs, the

back link will include the current page .

Insert Quote: Inserts selected text an a link

to the current page.

Insert Summarized Annotations: Inserts a

summary of the document's annotations,

similar to what is produced via the Tools >

Summarize Annotations commands. The

format of the summary is dependent on

the format of the annotation file.

Export: Exports the current annotation

file to the Finder in one of these formats:

PDF, rich text, plain text, or Word (.doc)

formats.

Remove: Moves the annotation file to

the database's Trash and removes the

reference from the original document.

Creating an Annotation File: DEVONthink has

a built-in default annotation file in rich text

format, suitable for general use. However, you

can create your own custom template in plain

text, rich text, or Markdown formats. These

files can be created externally and added

to ~/Library/Application Support/

DEVONthink 3/Annotations.noindex

or created in DEVONthink and exported

via File > Export > as Template to the

Annotations.noindex folder.

To create backlinks to the original file, there

are two placeholders for use in the body of

your template:

%documentName%: Resolves to the name

of the original document.

%documentLink%: Resolves to the item

link of the original document.

Rich Text: To create the backlink in a rich

text template, use the %documentLink%

placeholder and the document name will be

added as the link's text.

Markdown: To create the backlink in

a Markdown template, use the form:

[%documentName%](%documentLink%).

Plain Text: Since plain text files don't support

live links, you can use WikiLinks to create a

backlink. For example, if you are using the

Square Brackets WikiLink syntax, you could

use [[%documentName%]] in the body of the

plain text.

CONTENT

Navigating PDF documents can sometimes

be difficult when you are just scrolling

through endless pages of documents.

The Content Inspector shows two views,

similar to what you see in Apple's Preview

application:  Table of Contents and

Thumbnails.
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TABLE OF CONTENTS

The Table of Contents displays the structure

of certain document types. View the outline

of a PDF document, provided that PDF

contains one, section headings of Markdown

documents, or emboldened or underlined

lines in rich text files. Click on the disclosure

triangle to show or hide sections within

chapters. Click on any section heading to

jump directly to the beginning of it.

For even quicker navigation, the table of

contents can be navigated via keyboard, using

the arrow keys to move around.

There are two context menu items in the

Table of Contents view: Copy Page Link for

use with PDF documents, and Copy Section

Link for use with Markdown documents.

THUMBNAILS

The Thumbnails view shows a list of

thumbnails, one for each page in the

document. This allows for a more visual

approach to moving through your document.

By default, the thumbnails are shown in a

single column but they can be displayed in

multiple rows if the sidebar is expanded. This

view allows for actions like these:

Jump to or select any page by clicking on it.

Extend a range of selected pages by holding

the ⇧Shift key to select consecutive pages.

Hold the ⌃ Control key to select non-

consecutive pages.

To quickly remove unwanted pages, press

the ⌫ Backspace key.

If you want to reorder some pages, select

the page(s) to move and drag and drop

them within the thumbnails. A blue line

will appear at the place the pages will be

inserted. This will also work if you drag

thumbnails from one PDF to another.

Drag selected pages to another location in

your database and DEVONthink will create

a new PDF containing only those pages.

You also have several options available in the

context menu when you Control-click in the

Thumbnails view:

Cut/Copy: Cut or copy the selected

page(s) to be pasted into another PDF.

Copy Page Link: Copies a URL to the

clipboard pointing directly to the current

page of the document.

Reverse Page Order: Reverse the page

order of the document.

Split Document: Splits the document

at the current page. A new document is

created from the preceding pages and

removed from the current document. This

item is unavailable when the first page of

the document is selected. Also, note this

action cannot be undone.

Insert Blank Page: Insert a new blank page.

Delete Selected Page(s): Delete the

selected page(s).

Rotate Left/Right: Rotate the selected

pages left or right.

Select/Deselect All: Select or deselect all

pages in the document.
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DOCUMENT

The Document inspector provides specific

information about the current document.

This information is presented in four

specialized views: annotations, e.g., highlights

in a PDF, attachments like images in .rtfd

files, detected links in the document, and

other documents mentioning the name or an

alias of the current one.

ANNOTATIONS

As PDF files are often used in DEVONthink,

annotating these documents is

commonplace. The Annotations view displays

a listing of the annotations in the current

document. Each annotation is listed with

the following metadata: page number,

type, content or author, and the date

the annotation was made. In the case of

highlights, text, or note annotations, the

content will be displayed. With graphic

annotations, e.g., rectangle or ovals, the

author will be displayed. The list can be

sorted by clicking the appropriate header.

Select an item in the list to switch to the

proper page. The annotation on the page will

be selected. This makes it easy to navigate

via the document's annotations.

At the bottom of the view is a Details

section. For Note annotations, this will show

the text of the annotation. Details can be

added to other annotation types as well, but

only supports plain text entries.

Opening the context menu in the

Annotations list offers the following options:

Copy: Copies the metadata and any text in

the Details to the clipboard as plain text.

Copy Page Link: Copies a URL to the

clipboard pointing directly to the current

page of the document.

Delete: Delete the current annotation.

Select/Deselect All: Quickly select or

deselect the items in the list.
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ATTACHMENTS

This inspector displays any attachments or

linked images of the current document. For

example, in a rich text with attachments,

.rtfd file, you can see and access the

attachments individually. Selecting the

attachment will select it in the document.

Drag and drop an attachment to export it to

another location. This inspector also works

with Markdown, bookmarks, and HTML-based

files, e.g., formatted notes.

Opening the context menu in the

Attachments list offers the following options:

Open: Provides options to open the

attachment in DEVONthink, tabs, or even

the system default browser, depending on

the current document and its underlying

link.

Copy / Copy Name: Copy the attachment

as a file or just its name.

Add to Downloads: Add the attachment

to the Download Manager. Available when

viewing linked images in web content.

Select/Deselect All: Quickly select or

deselect the items in the list.

LINKS

For the selected document, DEVONthink will

attempt to determine if it contains links.

These may be web URLs, file URLs, item links,

and even DEVONthink's WikiLinks. (You may

be surprised by the number of links in many

documents.) The top section of the Links

view displays a list of any outgoing links, i.e.,

links to other files, websites, etc. The bottom

Incoming Links view shows incoming links, i.e.,

links in other files to the current document.

Select a link in the list to show it in the view/

edit pane. Double-click a link to open it in a

document window or an external application.

Option-click or Shift-Option-click a link to

open it in a new tab. Opening the context

menu in the Link list offers the following

options:

Open: Opens the link in an external

application.

Open in Tabs: Opens the link in a new tab,

when possible.

Copy: Copies the URL to the clipboard

Delete: Deletes the link and the text.

Select/Deselect All: Quickly select or

deselect the items in the list.
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In the Incoming Links section, the context

menu has an extra command: Copy Name.

Use this to copy the name of a linked file and

paste it into another document as a WikiLink.

MENTIONS

This inspector is similar to the Incoming Links

pane of the Links inspector, however it lists

all mentions - linked or not- in a selected

document. Mentions are content matches

in other documents, based name or alias

of of the selected item. This inspector can

be useful both for writing and researching

to view mentions, especially for those not

using automatic Wiki linking. Finally, unlike

the incoming links inspector, this inspector

supports mentions in any document type,

e.g., PDFs.

Selecting a mention shows a summary of the

occurrences in the lower pane. Documents

with mentions can be opened via a double-

click or the context menu or revealed.

Also there are some copy functions in the

context menu: Copy copies the item link,

Copy Name copies the file's name, and

Copy Summary copies the summary for the

selected document..

CONCORDANCE

The Concordance pane, opened in the Tools

> Inspectors menu, gives you a tool for

analyzing the textual contents of documents.

When the inspector is open, selecting

different items will show varying results.

If one or more documents is selected, the

results will be inclusive of the text in all of

them. If there is no selection, the results

will be based on the text of documents in

the current location, whether a group or a

database. This also applies to selecting items

matched in smart groups, both local and

global.

These results are presented in three distinct

views: List, Cloud, and Graph.

LIST

The List view displays the concordance

results in a list, separated by these

parameters:

Word frequency

Number of groups with items containing a

specific word

Word length
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Word weight (relevance, depends on the

contents of the database)

Alphabetical listing

Click the column headers to sort on a

given parameter. Select a word in the list

to highlight all occurrences in the current

document. Double-click a word to open a

database-wide search for the term.

CLOUD

The Cloud view present the concordance as

a word cloud. The size of the terms is relative

to the frequency in the selection or database.

Selecting terms highlights the occurrences in

the current document. The context menu

RELATED WORDS

Of special note is the Related Words graph

shown under the List and Cloud views. Select

a word in the list or cloud and it becomes

the central term in a graph of related words.

These are words found throughout your

database. Double-clicking a node initiates

a database-wide search. The context menu

provides options for copying the word's

information, as well as excluding the word.

Additionally, use the Export command to

create a PDF of the graph.

CONTEXT MENU

Opening the context menu in the List or

Cloud sections offers these options:

Copy: Copies the values for the selected

word to the clipboard.

Add to Tags: Adds the selected word(s) as

a tag to the selected items.

Select/Deselect All: Quickly select or

deselect the items in the list.

Exclude/Include Word: Use this to define

stop-words or to include them again.

Show/Hide Excluded Words: Select this to

show or hide any excluded terms. Excluded

terms will shown with a strikethrough.
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Cloud Inspector Only:

Export: When used with the word list in

the Cloud inspector, exports a PDF of the

word list.

Sort: Sort the word cloud by Name or by

Count.

GRAPH

The frequency graph shows a graph of the

word frequency over the rank number of the

word (see above).

Note: There are no context menu options in

this view.

SEE ALSO & CLASSIFY

The See Also & Classify inspector is the

main interface to DEVONthink's brain, our

built-in AI engine. This engine is analyzing

the contents and locations of all documents

in your database and making connections

between them. These connections can be

seen in this inspector pane.

This inspector will be shown when a

document is selected and you choose Tools

> Inspectors > See Also & Classify. When the

inspector opens, you will be presented with

two sections: Classify and See Also.

GROUPS

Based on analyzing the contents of the

current document, the AI cross-references

the contents and locations of other files

in the database. The results are shown in

the Groups section. This list offers a range

of suggested locations, displaying a heat-

mapped score of its relevance and the

location of the group. The highest ranked

suggestion is presented first. Obviously,

you can choose any other them. If there's a

group you'd like to use, double-clicking the

suggested group will file the document for

you. You can also click the Move to button,

press ⌃C, or drag and drop to file it in any of

the suggested groups. Lastly, if a suggested

group is in the same database as the selected

file, you can hold the ⌥ key and the Move to

button changes to a Replicate button.

Directly above the classify results is a

search field. If there is another group you're

thinking of that hasn't been suggested, type

part of the group name to filter the list of

suggestions. Then file into the location of

your choice.

Below the search field are two options to

help focus the results presented in the

two panes: Based on content, enabled

by default, makes its suggestions based

on content comparisons, while Based on

tags uses only the documents tags for

matching. Since results can be shown for all

databases, Current database only restricts

the suggestions to the active database.

On a related note, in the Data menu, you will

find two menu items: Move to … again and

Classify to…. The first provides you the option

to classify the current document in the group
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into which you classified. If you filed into

a particular group via the Groups section,

this menu item would remember it and offer

that group as a place to classify the current

document. The second menu item offers

its top ranked suggestion for classifying the

current document, if you'd like to just follow

the AI's suggestions.

DOCUMENTS

Another benefit of the AI's content analysis is

the ability to offer suggestions of documents

that may be related to the current document.

These files are listed in the Documents

section of the inspector. Like the Groups

section, this list shows the location of the

document and heat mapped score of the

potential relevance. Hovering over a result

shows a tooltip displaying its full title and

location.

Select a document in the results to display it

in the view/edit pane. For your convenience,

DEVONthink always lists the original

document near the top of the list. This way

you can select it to go quickly back to the

original document. Double-click a document

to open it in a document window. Drag a

document from the list to move it to another

location. When dragging, you can create

duplicates by holding the ⌥ Option key.

You can also create replicants by holding

⌘ Command and ⌥ Option and dragging to

another location in the database.

CONTEXT MENU

The See Also and the Classify sections host

many of the same context menu items as

the item list. A list of these commands is

included in the context menu section of the

appendix. Also an alternative command is

available when holding the ⌥ key: Reveal in

New Window.

SEARCH

The Search inspector provides in-document

searching. Using the same familiar ⌘F hotkey

you use in most macOS application, you can

not only search, but replace found words.

Additionally, DEVONthink provides a list

of the found words to help navigate the

results. The results also show the search hits

in context, either in a sentence or paragraph,

depending on the setting in See also p.

168ff .

Searches match substrings by default. This

means a search for "some" would also match

"something" or "worrisome".

Something you may find useful is the live

updating when you select other files. If you

search for a word in the current document

and leave the Search inspector open,

DEVONthink will automatically search newly

selected files.
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SEARCH AND REPLACE

The Search and Replace section offers these

simple intuitive controls:

Find: Enter the word(s) you'd like to search

for. Note this matches substrings be

default, so entering "word" would match

"words" and "wording" as well. Use spaces

before or after the word to treat it as a full

word.

Ignore Case: Ignores case-sensitivity when

searching.

Enable Wildcards and Operators: Allows

using wildcards and operators, e.g.,

DEVONthink NEAR sync. If this option

is enabled, the Edit > Find > Find Next/

Previous commands and next/previous

buttons in the inspector are available.

Previous/Next Arrows: Use these arrows

to cycle backward and forward through the

highlighted results.

Replacement Text: Enter replacement text,

as desired. Note this field is only enabled

when you have editable text in the current

document; e.g., rich text or a Markdown

document in editing mode.

Replace: Replace the currently highlighted

word and move to the next search hit in

the document.

All: Replace all occurrences of the found

word.

In Selection: If you make a selection in the

text, you can replace all occurrences of the

found word in that selection.

SEARCH RESULTS

The results provide a convenient list of the

found words. This includes the line number

of each hit and the number of occurrences

found. It also includes part of the surrounding

text to help give some context to the found

words. Additionally, there a some context

menu options available when you Control-

click in the results:

Copy: Copies the paragraph fragment

selected. You can optionally drag and drop

this fragment into the database or another

compatible document.

Copy Paragraph/Page Link: Copies a link

to the current document, but appends

a parameter pointing to the selected

paragraph for rich text files or the page for

PDF documents.

Add to Favorites: Adds the current

document to the Favorites.

Add to Reading List: Adds the current

document to the Reading List.

Select/Deselect All: Selects all or none of

the items, respectively.
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MENUS

IN THIS CHAPTER

The Application Menu 138

The File Menu 140

The Edit Menu 144

The Data Menu 146

The Format menu 150

The Tools menu 152

The View menu 155

The Go menu 158

The Window menu 159

The Scripts menu 160

The Help menu 160

The Dock menu 161

A complete listing of all the commands

available in the menu bar of DEVONthink, the

Services menu, and the context menu of the

DEVONthink's Dock icon.

THE APPLICATION MENU

The DEVONthink menu is a utility menu,

similar to those found in other Mac

applications. It has commands that allow you

check the version via the splash screen or

check for application updates. You can install

our add-ons, access the preferences, access

the Services menu, empty your databases'

Trash, and quit the application.

ABOUT & CHECK FOR UPDATES

About DEVONthink: Shows information

about DEVONthink including the version

number to whom the software is registered.

Check for Updates: Checks if updates

for DEVONthink are available. By

default, DEVONthink checks for updates

automatically, however you can change the

update settings in the Settings > General. If

an automatic update is pending choosing this

command shows a window with additional

information about the update.

Note: When checking for updates no

information is uploaded from your

computer to the DEVONtechnologies

server. DEVONthink only downloads a file

listing the most current versions to your

Mac. This option is not available if you have

purchased DEVONthink from the Mac App

Store. In this case, all updates are handled

by the App Store.
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ADD-ONS

This command allows you to install, or

reinstall, some of our extra support files and

scripts.

The following options are available.

Google Chrome Extension: Opens the

Chrome Web/Store  page in Google

Chrome where you can install the browser

extension. You have to do this manually and

follow Google's rules.

Firefox Extension: Opens the Mozilla Add-

Ons page in Firefox where you can install

the Firefox add-on (similar to the Safari

extension). You have to do this manually

and follow Mozilla's rules.

PDF Services: Adds Save PDF to

DEVONthink to the PDF menu of print

dialogs. This allows you to print a PDF

directly to DEVONthink.

Additional Scripts: Installs the mail rule

scripts for Apple Mail, Folder Action scripts

, and Menu extra scripts.

Global Inbox in Save Dialogs: Inserts

DEVONthink's Global Inbox into the

Finder's sidebar and all "Save As" dialog

windows. Use it to save directly to the

inbox from any application. Note: The name

of the inbox is "Inbox" regardless of your

computer's language preferences.

ABBYY FineReader OCR: Installs the

ABBYY Finereader OCR resources for use

with images and PDFs with no text layer.

Apple Mail Plugin: A plugin for Apple Mail

that allows you to archive messages or

whole mailboxes directly from within

Mail. On Mac OS Mojave you'll have

to manually activate the plugin after

installation. In Apple Mail visit Settings >

General > Manage Plug-ins and activate

DEVONthink's plugin.

Note: The Safari browser extension is

now installed by default, but you'll need

to go into Safari's Settings > Extensions

and enable it. Also while extensions for

browsers like Opera, Vivaldi, and Brave

are not explicitly available, it is possible to

install them from the Chrome Web Store,

while in those browsers.

SETTINGS, TRASH, CACHE

Settings: Opens the application Settings.

Empty Trash: Moves the contents of all open

databases' trash to your computer's file

system trash.

Empty Cache: Empties the web browser

cache. This frees up space and makes sure

that all, when displaying a web page, all data

is freshly loaded instead of using a cached

copy.
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PURCHASE & LICENSES

Purchase: Opens the DEVONthink product

page from where you can put the app

into your shopping cart. If this copy of

DEVONthink is already licensed, you will be

presented with upgrade choices.

Enter License: Enter your purchased license

code here. It is best to use copy-and-paste

for transferring the license code from the

email message to the appropriate field.

Note: Enter License changes into License

and Purchase License into Purchase

License or Upgrade  as soon as you have

entered a valid license code (and a paid

upgrade exists). Available options depend

on whether you have purchased your copy

from DEVONtechnologies or from the Mac

App Store.

SERVICES

The Services submenu gives your access

to special commands published by other

Mac applications such as TextEdit or

Safari, or by services extensions such as

our own WordService or CalcService. Also,

DEVONthink publishes its own services. See

also p. 140ff

THE FILE MENU

The File menu contains commands creating

and deleting databases. There are options

for adding or exporting files, as well

synchronizing them. Additionally, if you need

to do database maintenance, you will find

those commands here.

NEW & OPEN

New Database: Creates a new database in

the selected location.

New Encrypted Database: Creates an

AES-256 encrypted database file at a user-

specified size. Technically this database

uses an encrypted disk image but will not

be visibly mounted in the Finder. Obviously,

when you enable Spotlight for the database

the data that Spotlight needs to store will

not be encrypted. The anticipated size of the

database can be specified in megabytes (MB)

or gigabytes (GB).

Open Database: Opens previously created

databases. You can select multiple

databases.

Open Recent: Presents a list of recently used

databases, which gives you quick access to

your frequently used databases. Choose

Clear Menu to remove all items from the

menu.

New Window: Opens a new main window for

the selected database.

IMPORT & EXPORT

Import: The Import submenu contains various

options for importing data, e.g.,selected files,

bookmark, contacts, and some data from

compatible applications. Some options will

import files into their own special groups at

the root of the database.

Files and Folders: Imports selected files

or folders. Files will be imported to the
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current location. Finder tags and Spotlight

comments will be imported.

Bookmarks: Imports bookmarks from

DEVONagent Pro, Firefox, Google Chrome,

or Safari as bookmarks. Bookmarks are

imported into a newly created group

bearing the name of the chosen browser.

Only new bookmarks are imported if you

use this command again.

Bookmarks from HTML file: Imports

bookmarks from an HTML file, e.g., one

exported from some web browsers'

bookmarks.

Contacts: Imports Apple Contacts

addresses selected in the import dialog

into a newly created group named

"Addresses". Contacts can be imported as

a sheet, as vcards (.vcf), or as bookmarks.

Previously created groups are reused.

Tip: To import all addresses, select all

addresses in the group "All" and import

them. Address card bookmarks link to the

original card in the Contacts application.

Folders & Attachments from Notes:

Imports your notes from Apple Notes.

Items from Yojimbo: Imports all items from

Yojimbo into a newly created group named

"Yojimbo". Imported items retain their

name, label, flag, URL, comments, tags

and creation/modification dates. Items

without a URL link back to the original item

in Yojimbo.

Notes from Evernote: Imports selected

notebooks from an import dialog into a

newly created group named "Evernote".

Tags, dates, and URLs should be preserved.

OCR text is also imported if present in

the data. Notes are stored as formatted

notes. This option requires the Evernote

application to be installed.

Note: The import from Evernote command

only works with Evernote's "legacy

version" as Evernote 10 no longer supports

AppleScript. However, you can export

notebooks to importable .enex files from

within Evernote. Exporting individual

notebooks is suggested.

Images (with OCR): Imports images and

applies optical character recognition (OCR)

to create a searchable PDF. This makes all

written text searchable and available to

DEVONthink's AI functions. You can change

the setting in Settings > OCR. See also p.

74ff

References from Bookends: Imports

selected collections from the presented

dialog into a newly created group named

"Bookends". Already imported references

are updated. The keywords assigned to

a Bookends reference are added to the

Document Properties of the created rich

text document. Use the optional script

Scripts > Tags > Convert keywords to tags 

to convert the keywords to tags if needed.

Unix Mailbox: Imports Unix mailboxes, like

those exported from Thunderbird. See also

p. 58ff

Website: Opens the Download Manager

and downloads a complete web page/site

for archiving and offline viewing. Make sure

the download options are set correctly,

especially the options that define which

links DEVONthink should follow (if any).

All links within the site are modified so

that they point to the downloaded images

or other embedded objects. This ensures

that the page/site can be displayed at

any time. By default, groups created by
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the Download Manager are excluded from

tagging.

Scan from ScanSnap: Scans a paper

document using an attached Fujitsu

ScanSnap scanner.

Note: Groups created when importing

bookmarks, contacts, email messages, and

items from Evernote or Yojimbo are not

automatically excluded from classification

and tagging. This makes it easier to classify

them later.

Export: The Export submenu presents

options for exporting selected documents

or groups to the file system. In addition,

the Export menu provides export methods

based on plugins. DEVONthink comes with

a number of standard plugins for exporting

documents in different formats. For these

formats, the export creates a single merged

document when multiple files are selected.

Document: Exports the currently viewed

document in its native format. For images

exported from a separately opened

document window, DEVONthink lets you

choose the desired file format or image

quality; e.g.,you can export a PNG files as a

JPEG file.

Files and Folders: Exports the selected

documents in their native format. Groups

are exported as Finder folders, preserving

the group structure you have built in

DEVONthink. DEVONthink tags are

applied as Finder tags to the exported

files. Internal metadata for the items is

preserved in .DEVONtech_storage files

in the exported folders. These files are

used for reimporting into DEVONthink. If

you will not be reimporting the exported

files, you can safely delete those files. Be

aware the addition date of reimported

items will change, if that is a critical piece

of metadata for your database.

OPML: Exports the selected items as one

OPML file.

PDF Document: Exports the selected items

as a paginated PDF. Hold the ⌥ Option

key to change allow the command to PDF

Document without Annotations.

RTF/RTFD Document: Exports the selected

items as one merged rich text file without

embedded items (RTF) or with them

(RTFD).

Text: Exports the selected items as one

merged plain text file.

Word 2007/97 Document: Exports the

selected items as one merged Microsoft

Word .docx (Word 2007) or .doc (Word

97) document.

Website: Exports the selected items as

standalone web site that you can upload to

your web server and share with colleagues.

In the presented dialog window, choose

the desired template, text encoding, and

whether DEVONthink should convert

diacritics and accented characters to

HTML entities or not. Check Create Index

Pages to create index.html pages with

cross-links to all included documents.

Markdown and formatted notes are

rendered to HTML, other file types that

cannot be displayed in a web browser,

e.g., Pages files, are converted to PDF

if possible. Cross-links are converted

correctly. For the export templates are

used that you can modify yourself.

HTML Bookmarks: Export the URLs of all

selected items and their children as an

HTML bookmarks file.
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Template: Saves the selected documents

as a template, which can then be used

to quickly create new documents using

Data > New from Template. Export multiple

documents and/or groups at once to

create e.g.,a project template. Data & New

from Template & Open Template Folder; 

can be used to organize templates.

Database Archive: Creates an optimized

ZIP file of the current database in the

selected location. This can be useful

as a secondary backup strategy. Note:

When used with an encrypted database,

the database will be compressed in an

unencrypted state.

Metadata (JSON): Export the metadata of

the selected items as JSON data.

Unix Mailbox: Exports all selected email

messages and saves them as Unix mailbox

file that can be imported into other email

applications. Note this only applies to

exporting native email (.eml) files, not

files that have been converted to other

formats, like plain or rich text.

Share: This shows the standard Mac share

menu.

INDEX AND UPDATE

Index Files and Folders: Link to files in

the Finder, leaving them in the current

location. See the In & Out > Importing &

Indexing section for important information

on indexing.

Update or Refresh: This command

dynamically changes, relative to what is

currently selected.

Update Indexed Items: Force DEVONthink

to check for filesystem events and newer

file dates on indexed items, and update

them as needed. This is often used when

indexing cloud-synced locations, e.g.,

folders in Dropbox, or when indexing items

on networked volumes, as some volumes

don't reliably support filesystem events.

Update Items: Similar to Update Indexed

Items but works with imported items.

Sometimes used after editing documents

in external applications when the

application or the database is closed. It

may also be needed when accessing a

database stored on a networked volume.

Refresh Feed: Manually refresh selected

RSS feeds.

SYNCHRONIZE

Synchronize: Synchronizes the selected

database with all its locations. Note, this

command will be disabled if the current

database has no active synchronization.

Holding the ⇧Shift key shows the Synchronize

All option to synchronize all actively syncing

databases.

Download Pending Files: Downloads the files

of selected documents if they are available

through one of the database's locations. Only

necessary if none of the database's locations

is set to synchronize indexed files.

DATABASE PROPERTIES & CLOSE

Database Properties: Opens the Database

Properties popup for the current database.

This panel presents a few options, statistics

DEVONthink 3.9.17 Documentation, page 143

https://www.json.org


about the database, and allows you to change

the displayed name, add comments, and add

a username and password.

Close Database: Closes a selected database.

If multiple databases are open, use Close

All to close them all at once. If you'd like to

keep the current database open but close the

others, use Close All Except. Note that closed

databases will not reopen on launch. Only

databases that were open when DEVONthink

quits will reopen on the next launch.

DATABASE MAINTENANCE

Like any database, DEVONthink databases

need a bit of maintenance from time to time.

All the commands you'll need for this can be

found here.

Verify & Repair: Verifies all database

structures and repairs them if possible. By

default, DEVONthink automatically verifies

the database structure every time you open

a database. If it finds significant errors,

DEVONthink will advise you to run this

command.

Use this command whenever you feel

it is necessary. If you're a heavy user of

DEVONthink, running a Verify & Repair once a

week or more often is a good idea.

Check File Integrity: Verifies the stored

checksum for each file in the database. The

results are reported in the Log window or

popover. Note: If you are indexing files and

they have not been updated, they will report

a checksum error. See also p. 54ff

Optimize Database: Creates an internal

backup of the database and then optimizes

the database structure. Optimizing removes

unnecessary internal elements from the

database and rebuilds the internal structure

to optimize performance. DEVONthink

also creates internal backups on a regular

basis. Hold the ⌥ Option key to display the

Restore Backup option. This allows you to roll

back the metadata to a previous date. This

option would only be used in troubleshooting

situations.

Rebuild Database: Completely rebuilds

the database by exporting all items to a

temporary folder in the file system, creating

an empty database, and reimporting all

items. This removes any structural problems.

Depending on the size of your database,

this can take from a few seconds to several

hours. This option is typically only used in a

troubleshooting situation.

Delete Database: Closes a selected database

and moves it to the Finder trash.

Note: For more information on database

issues, including reports in the Log window

or popover, see the Repairing a defective

database section.

PRINT

Page Setup: Sets your preferred page size and

printer settings.

Print: Prints the current document or view.

THE EDIT MENU

The Edit menu contains all commands and

options relating to editing. You'll find the

classic Mac cut/copy/paste and find/replace

commands here, as well as many more.
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UNDO, CUT/COPY/PASTE, …

Undo/Redo: Use these commands to undo or

redo the last action, e.g.,to undo deleting a

file. Undo and Redo work for most actions.

Cut/Copy/Paste: Cut, copy, or paste as

standard behavior.

Copy with Source Link: Copies selected

text and a link to the current document.

This text and link can be pasted into other

applications.

Copy URL: Copies the URL of the selected or

frontmost document to the clipboard.

Copy Item Link: Copies a URL to the clipboard

that links to the selected document or group.

These links can be used to create a back link

to the document in applications that support

live hyperlinks. For PDFs, hold the Shift key

to reveal alternate item links. If a thumbnail

is selected, Copy Page Link is available. If text

is selected, Copy Selection Link will appear. If

an annotation is selected, Copy Annotation

Link will be shown. With selected content

in text documents, Copy Paragraph Link will

appear as the alternate command.

Paste with Source Link: When copying text

from files in DEVONthink, use this command

to paste the text in rich text and Markdown

documents with a link back to the source

document.

Paste and Match Style: Pastes text from the

clipboard, matching the styles in the current

document.

Delete: Deletes the selected piece of text.

Complete: Tries to auto-complete the

partial word before the insertion caret. This

standard Mac function uses the currently

active dictionary, chosen in the language

dropdown of the Spelling and Grammar >

Show Spelling and Grammar panel.

Select All/Deselect All: Selects or deselects

the complete content of the frontmost

document. Hold the ⇧Shift key to reveal the

Deselect All option.

SUMMARIZE, TAGS, SET NAME

Summarize: Summarizes the selected piece

of text. Unlike the Mac's Summarize service,

this command takes advantage of the built-

in AI of DEVONthink, and uses the complete

"knowledge" contained in the open databases

for improving the results. The better your

databases, the better the results.

Tags: Use this command to quickly enter tags

for the current document. This displays the

Tag bar, if necessary.

Set Name As: Applies the selected text as

the document's name.

FIND, SPELLING, INSERT

Find: This submenu contains standard

Mac find commands, like those available in

TextEdit. Searches on the current document

are displayed in the Search Inspector. Two

commands of note are:

In Database: Brings the search field of the

frontmost window into focus.

Scroll To Selection: In long documents, this

command scrolls the current document to

selected text.
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Spelling and Grammar: Provides the standard

macOS functionality for checking text for

spelling or grammar errors. To choose the

language used for spell checking, or for

auto-completion (see above), open the

spell checker panel with Edit > Spelling and

Grammar > Show Spelling and Grammar and

choose your language of choice from the pop-

up menu.

Substitutions: Shows the standard

Substitutions preference panel and switch

the available options manually on and off:

Smart Copy/Paste, Smart Quotes, Smart

Dashes, Smart Links, Data Detectors, and

Text Replacements. Data Detectors analyze

shown text and make context-sensitive

actions available, e.g., when you hover

the cursor over a phone number or postal

address.

Note: The Spelling and Grammar

and Substitutions commands can be

temporarily applied to the current

document. If you'd like these to be

persistent choices, you can make global

changes in Settings > Editing.

Transformations: Use this submenu to change

selected text to all lowercase or uppercase, or

to capitalize every word.

Speech: Starts or stops speaking the

selected piece of text.

Insert: Inserts items, like pictures,

checkboxes, bulleted lists, etc. The options

available are dependent on the current file

type.

DICTATION & EMOJIS

Start Dictation: Starts the Mac's dictation

function.

Emoji & Symbols: Shows the standard Special

Characters panel for inserting characters and

emoji that you cannot enter directly with

your keyboard.

THE DATA MENU

The Data menu contains all commands that

deal directly with documents or groups. Here

you'll find commands for creating, labeling,

classifying or group new documents, and

more.

NEW DOCUMENTS & TEMPLATES

New: This submenu provides access to the

built-in items DEVONthink allows you to

create.

With Clipboard: Creates a new document

based on the contents of the clipboard.

Note: Some applications such as Microsoft

Word put data in multiple formats into

the Clipboard. DEVONthink tries to use

the most logical data when creating a new

document.

Plain Text: Creates a new plain text

document.

Rich Text: Creates a new rich text

document.

Formatted Note: Creates a new formatted

note.

Markdown Text: Creates a new Markdown

text document.

HTML Page: Creates a new HTML page.

You can use the built-in macOS WYSIWYG

editor to edit the HTML page or switch to
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its source code (from the navigation bar)

and edit it directly.

Sheet: Creates a new sheet. Add columns

to the new sheet by using the + button or

by pressing the ↩ Return key. Name the

columns and sort the sheets by dragging

them with the mouse. Click OK to create

the new sheet.

Bookmark: Creates a new bookmark. Type

the URL and optionally name it to create a

bookmark, just as any browser does. If you

don't type in a name, DEVONthink will set

one automatically.

Feed: Creates a new  RSS feed document.

The feed behaves like a special type of

group that contains RSS entries published

by the feed's author. Type the URL and

optionally enter a name. If you don't type

in a name, DEVONthink will attempt to set

one automatically. You can change the URL

later by selecting the feed document and

changing the URL field in the Info inspector.

Group: Create an empty group. This option

appears as Tag if you are currently in the

Tags group of a database.

Smart Group: Creates a new smart group.

This is a special group that shows items

matching your specified criteria, similar to

the Finder's "Saved Search". DEVONthink

opens the Smart Group Editor, which

lets you define your search criteria.

When saved, the contents are updated

every time you display the smart group's

contents.

New from Template: This submenu allows you

to access any installed templates and add

them to the current group in your database.

There are two other commands to note:

Open Templates Folder: Select this to

open ~/Library/Application Support/

DEVONthink 3/Templates.noindex in the

Finder. You can add your own documents to

be used as templates here.

More Templates: Opens the Extras section

of the Support Assistant to install any

available DEVONthink templates.

Note: For more information on the

pre-installed templates, check out the

Templates section of the appendix.

OPEN, LAUNCH, REVEAL, SEND

Open: Opens the selected document or

group in a separate document window. This

command opens a second main window

for the selected group. If you have selected

multiple documents, hold the ⌥ Option key

to display the Open in Tabs command. If

the View/Edit pane is visible, this opens the

selected items in new tabs. If the View/Edit

pane isn't visible, a new document window

will open with each selected document in its

own tab in the window.

Open with: Displays a list of applications

compatible with the current file type. Opens

the selected documents in the chosen

application. If your desired application is

not listed in the submenu, choose Other to

browse for it.

Launch URL: Opens the file, folder, or internet

location indicated by the URL field in the Info

inspector.

Reveal: Reveals the location of the frontmost

document in either the same main window, if

possible, or by opening a new one.
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Show in Finder: Opens a new Finder window

with the item selected. Note this only works

for documents and indexed groups.

Send by Email: Creates a new message in

the default email application and adds the

selected items as attachments. Supported

email applications are Apple Mail, Airmail

2, Microsoft Outlook, and Postbox, as well

as some legacy email application . If the

selected item is an email message, the sender

is automatically inserted as the recipient and

the text of the original message is inserted

instead of an attachment. Notes: Postbox is

currently only able to send one selected file.

Unsupported email clients (e.g.,Thunderbird)

can only send the plain text of one selected

file.

SAVE, REVERT, DUPLICATE

Save/Save All/Revert To Saved: Saves the

frontmost document or all documents

to disk. Hold the ⇧Shift key to show the

alternate menu item, Save All.

Revert To Saved: Restores the frontmost

document to the last saved version.

Duplicate: Creates a duplicate of the selected

items. The name of the new item ends in

"copy", and because their contents are

identical both items are marked with the

icon for duplicates (or, depending on your

preferences, show their name in bold and

blue).

MOVE INDEXED ITEMS IN AND OUT

Note: The following two commands are only

for use with indexed  files.

Move Into Database: Use this command to

move an indexed file into the database. Use

this command with caution as it moves the

file from its current location into the internals

of your database. It does not copy the file.

Move To External Folder: Use this command

to move a non-indexed item, e.g.,imported

or created in DEVONthink, out to an indexed

folder in the Finder.

FAVORITES, READING LIST, METADATA

Add To: Commands in this submenu add

the currently selected documents to your

Favorites or the Reading List.

Mark: Allows you to mark the item as

flagged/unflagged, locked/unlocked, and

read/unread.

Rating: Allows you to set a rating, from no

stars to five stars.

Label: Allows you to mark the selected groups

or documents with one of seven labels, just

as in the Finder. You can define the color and

the text of the labels in Settings > Colors.

Tags: This submenu offers special commands

for tagging items.

Convert HashTags to Tags: Converts

hashtags into DEVONthink tags. The

hashtag must be prefixed with the  symbol

and entered as a single word without

spaces, e.g., #software-rules.

Convert Keywords to Tags: Converts

keywords, found in the Document >

Properties inspector for PDF or rich text

files, into DEVONthink tags.

Convert Properties to Tags: Converts the

Author property, found in the Document
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> Properties inspector for PDF or rich text

files, into a DEVONthink tag.

Convert Geolocation to Tags: Converts

geolocation data, if present on the

document, into DEVONthink tags.

Add Vision Suggestions to Images: Adds

tags to selected images using Apple's

machine learning technologies.

Scan Barcodes: This option will attempt

to detect a barcode in a selected image.

A successfully detected barcode will be

added to the custom metadata for the

document. A list of barcodes detected with

Apple's Vision framework can be found

here..

Note: The Add Tags to Images and Scan

Barcodes options require macOS 10.13 or

later.

CONVERT, OCR, THUMBNAILS

Convert: This submenu contains commands

for converting between some file formats,

e.g.,between rich and plain text. Note the

options presented are dependent on the

type of the selected document. Also, due to

differences in the formats, any formatting

in the source document may not be able to

be perfectly preserved in the destination

document.

OCR: This menu contains options for

choosing an output format when doing

OCR on a selected compatible document

(JPEG, PNG, TIFF, PDFs with no text layer).

The currently supported output formats

are: Searchable PDF, RTF, Word , and Web

Archive. Additionally, there are two special

commands: to Comment and to Annotation,

which sets the Finder comment or creates

an Annotation file with the text. Neither

command alters the original file.

Thumbnails: Use these commands to add,

remove, or update a thumbnail for the

selected files.

GROUP & UNGROUP

Group Items: Creates a new group containing

all the selected items. This is similar to

creating a new group and moving the selected

items into it. The alternate command Group

Similar Items, shown when the ⇧ key is held,

will attempt to file selected items with

similar content in groups.

Ungroup Items: The exact opposite of Group

Items. Moves all items in the groups one level

up and deletes the now-deserted groups.

SEE ALSO & CLASSIFY

The following commands use DEVONthink's

built-in AI to suggest good locations for the

selected documents:

Move (to): This command allows you to

quickly move other selected files to the last

destination chosen in the See Also & Classify

inspector.

Classify: Using DEVONthink's AI, this

command will move selected files to the AI

suggested location. This command is disabled

if DEVONthink is not sure enough about

possible destinations.
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MOVE TO TRASH

Move to Trash/Move All Instances to Trash:

Moves the selected items to the trash. If

you have selected a replicated item, hold the

⌥ Option key and choose Move All Replicants

to Trash to move the selected item and all its

replicants to the database's trash.

THE FORMAT MENU

The Format menu contains the commands

and options dealing with all aspects of text

formatting. Here you'll find the standard font,

alignment, and ruler commands, as well as

very special DEVONthink commands.

Note: Many commands in this menu

only work with rich text, Markdown, or

formatted notes. Plain text documents do

not allow formatting. (That's why they're

called "plain" text.) Some formatting

options are also available for editable PDFs

and web archives.

FONTS, STYLES, ALIGNMENT, RULERS

Font: This submenu is responsible for

controlling the font and the document

background color (rich text documents only).

Open the fonts panel with Show Fonts, then

increase or decrease the font size of selected

text with Bigger and Smaller, adjust the

text styles and the document background

color. Of special note are these two submenu

commands:

Copy Font: Copies the font formatting of a

selected piece of rich text.

Paste Font: After using the previous

command, applies the copied font to

another selection of rich text.

Style: Commands in this submenu apply

a certain style, such as italics, bold, or

underlined, to selected text. Also, the

commands give you access to some high-

end font control like kerning, baseline

shift, ligatures, and character shape

(only applicable to Asian languages). One

command to take special note of:

Styles: The Styles command opens the

macOS styles editor. With it, you can step

through all the styles used in the current

document. If there's one you'd like to reuse,

add them to your favorites. Use the pop-

up menu to select a saved style and, if you

don't need it any more, delete it. You can

use saved styles from the ruler (see below).

Alignment: Align paragraphs left, right,

centered, or justified. Here, Asian or Arabic

users can also change the direction of writing,

if required.

Ruler: This submenu allows you to display

the ruler above the preview of rich text

documents. There are also two special

commands:

Copy Ruler: Copies the current ruler

attributes (tabs stops, indents, etc.) of a

selected piece of rich text.

Paste Ruler: After using the previous

command, applies the copied ruler

attributes to another selection of rich text.

HIGHLIGHTS

Highlight, Highlight Color: In rich text

documents, editable PDFs, and web archives

use Highlight to highlight a selected piece

of text just as you would using with a

colored pen on a piece of paper. To remove
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highlighting, select the highlighted piece of

text and choose Highlight again. Use the

Highlight Color submenu to choose your

favorite highlight color.

LINKS, SPACING, LISTS, TABLES

Make/Remove Link: Converts the selected

text into an active link, or disables the

link. This command can be used to create

WikiLinks quickly.

Add/Edit Link: Use this command if you want

to add a specific link to some text. If the text

is already linked, the menu will display Edit

Link, allowing you to change or remove the

URL. The behavior you'll see when clicking

linked text depends on the target of the link:

If the text was a valid URL, the URL will be

the target of the link. Editing the link text

later does not change the target. Use the

Edit Link command of the context menu to

edit the link target.

Otherwise, DEVONthink treats the link as

a Wiki-style link. Clicking the Wiki-style

link jumps to a document with exactly

the same name as the linked text (or any

document with a Wiki alias of that name).

If there is no document of that name,

clicking the link creates a new rich text

document named after the linked text and

pre-filled by the template you set in the

Settings > Editing.

Spacing: This command allows you to adjust

the line spacing of selected text in rich text

documents. You can adjust the line height

to an exact value or define a minimum and

maximum height, adjust inter-line spacing,

and define the space before and after a

paragraph.

List: Creates a bulleted list. Select your

prefix, bullet style, and suffix in the dialog

sheet and click OK to insert a new list. In the

list, press ↩ Return to insert new items, and

press ⇥ Tab and ⇧⇥ Shift-Tab to indent/de-

indent items, just as you would in any word

processor.

Table: Inserts a new table into a rich text

document and opens the table inspector

panel. Use the table inspector to adjust the

number of rows and columns, cell alignments,

cell colors, border widths, and colors. Also,

you can merge and split cells and create

tables within a cell.

PLAIN & RICH TEXT, HYPHENATION,

LAYOUT

Make Plain/Rich Text: Converts a rich text

document to plain text and vice versa.

Converting a rich text to plain text removes

all formatting, while converting a plain text

document to rich text applies default rich

text font settings to the document.

Allow Hyphenation: Enables or disables

hyphenation for the current rich text

document.

Make Layout Vertical/Horizontal: Enables

orienting and editing the document text

vertically or horizontally.

Wiki Linking: Toggles whether to display

WikiLinks in the current document.

Wrap Lines: Toggle whether to wrap a

document's content to the width of the

view/edit pane or document window, or let it

exceed the width for sideways scrolling.
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BARS, COLORS, INVISIBLE CHARACTERS

Show Formatting Bar: Displays a toolbar of

formatting tools under the toolbar, providing

access to styles, font and paragraph

attributes, and lists. These tools are only

used with RTF files.

Show Editing Bar: Displays tools above the

current preview pane for some file types.

For example, rich text formats display

several common tools including increasing/

decreasing font size, highlighting, toggling

the ruler, and displaying the color picker are

shown. For sheets, tools to add/remove/

duplicate records, as well as editing columns

are shown.

Show Colors: Shows the color panel, e.g., for

changing the foreground color of selected

text in rich text documents.

Show Invisible Characters: Toggles display of

invisible characters such as spaces, tabs, and

line feeds. Shown invisible characters appear

in light gray.

THE TOOLS MENU

The Tools menu provides tools to get more

detailed information about your documents,

as well as some specialized commands.

INFO & FILTERS

Get Info: Opens an popup containing more

detailed information about the currently

selected file or group. It combines frequently

used elements of the Info inspector and

contains three panes:

Info: The Generic panel shows basic

information including name, aliases, URLs,

file dates, and kind. The Custom pane

shows metadata specified in Settings >

Data that has been applied to the file.

Annotations & Reminders: Shows a

summary of reminders set for this

document, Finder (Spotlight) comments,

and Annotations.

Properties: Shows metadata specific to

PDF and rich text files. This includes things

like keywords, author, and subject that are

sometimes included with these types of

files.

Inspectors: This submenu provides access to

the inspectors panes.

Show/Hide: Shows or hides the inspector

pane.

Info: The Generic view shows basic

information including name, aliases, URLs,

file dates, and kind. The Custom view

shows metadata specified in Settings >

Data that has been applied.

Annotations & Reminders: This inspector

shows a summary of reminders set for

this file, Finder (Spotlight) comments, and

annotations.

Content: When viewing PDF files, this

inspector provides a Thumbnails and a

Table of Contents pane. Note that the

Table of Contents panel is only displayed if

the current PDF contains one. DEVONthink

does not generate the table on its own.

Document: Useful when viewing PDF

and RTF files, this inspector displays

Properties, Annotations, and Links.

See Also & Classify: This inspector is

the main interface to DEVONthink's

brain, our built-in AI engine. This engine

is analyzing the contents and locations

of all documents in your database and
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making connections between them. These

connections can be seen in this inspector

pane.

Search: This pane allows you to search

the current document, displaying the

found words in context and on what lines

they occur. Additionally, you can use the

Replace field to quickly replace selected or

all occurrences of the found words.

Concordance: The Concordance is a

specialized view showing data about the

words in a document. This can be sorted

by frequency, groups, length, or weight.

The data can be viewed in a List, Cloud,

or Graph. Additionally, selected words are

highlighted in the current text and a data

graph showing related words will appear in

the List and Cloud views.

Filter: The commands in this submenu

filter the list of files in the location you are

currently viewing. As you select options

in these panes, the list of files will change

accordingly. The filters are also covered in the

windows chapter.

Info: Shows a pane with options for

filtering on dates, flagged state, unread

status, rating, or color label. When using

the calendar, you can click Any Date to set

which date you want to filter on: added,

created, modified, opened, or due.

Tags: Shows a tag cloud, with frequency-

based sizing, i.e., more frequently used

tags will be larger. Clicking on tags removes

unrelated tags from the cloud, only showing

tags that have been applied with the

current tag.

Multimedia: Displays options for filtering

multimedia files - images, audio, and

video - in the current location. Options for

minimum and maximum pixel dimensions

or durations are available.

Maps: Shows a small map showing pins

from geolocation data will be shown.

Clicking on a pin will show you files created

in that location. The behavior of this pane

is similar to Apple Maps, e.g., pinch to zoom

in and out, etc.

Note: When Info or Maps is selected, the

options will appear at the bottom of the

sidebar. When Tags is selected, they will

also appear there, but will also show in the

information bar above the item list if the

sidebar is hidden.

DOCUMENT COMMANDS

Annotate: This submenu provides access

to the PDF and image annotation tools.

Applicable to PDF documents you have:

Hightlight Text, Underline Text, and Strike

Through Text.

Next, the basic annotation types are

available: Oval, Rectangle, Line, Note, Text,

and Link. Note and link annotations aren't

available with images.

These tools are persistent, so you can select

one and use it in that mode until you change

to another tool.

Capture: This submenu provides options for

capturing the current document to a new

file in a few different formats: Bookmark,

Plain/Rich Text, Formatted Note, HTML, Web

Archive, and PDF (One Page/Paginated).

Captures are made to the current group.

Set as Thumbnail will set a thumbnail for a

currently viewed web page, useful to create
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a clean thumbnail after dismissing cookie

banners. There is also an option to use the

Clip to DEVONthink command, just like in

your browser. This allows you to clip to a

chosen location.

Note: The available options in the Capture

menu are dependent on the type of the

current document.

Mode: Lastly, the commands in this submenu

switch between three modes of interaction

in PDF documents: Move, Text Selection,

and Annotation Selection. When viewing an

image, Move and Image Selection are the

available commands.

Rotate & Flip: This submenu provides a

Rotate command for rotating an image or

PDF page right or left, or by 180 degrees. You

can also mirror images on their horizontal or

vertical axes via the Flip commands.

PDF: This submenu provides options for

editing the current PDF document: Insert

Blank Page, Delete Selected Page, and

Reverse Page Order. See the Documents

chapter for more information on PDF

documents.

Sheets: This submenu provides access to

the following tools for editing a sheet: New

Record, Duplicate Records, Delete Records,

New Column, Edit Columns, and Delete

Columns. See the Documents chapter for

more information on sheets.

IMPRINT, ITEM LINKS, IMPORT MARKDOWN

IMAGES

Imprinter: Choose an imprint you have

defined in Settings > Imprinter to apply it to

the current image or PDF.

Item Links: For documents supporting

item links and WikiLinks (See also p. 34ff ),

there are three commands in this submenu.

Convert WikiLinks to Item Links replaces

detected WikiLinks with their item links.

Update Name of Item Links will scan the

current document for item links and update

the link text for any files whose names have

been changed. Note: This will not update a

name for change WikiLinks, only item links.

Verify Item Links checks all item links in the

document and logs those no longer pointing

to a valid target, e.g., because the referenced

item is no longer available in any database.

Import Online Markdown Images: Download

and link to local copies of images from web

content clipped as Markdown documents.

CREATE, SUMMARIZE, MERGE, SPLIT

Create Expense Report: Creates a sheet

summarizing custom metadata dates and

currencies of selected files. Totals for the

amounts will also be included.

Create Metadata Overview: Creates a sheet

with records for each selected file. The

columns contain data from the generic and

custom metadata of each file.

Create Table of Contents: Opens a submenu

to create a rich text or Markdown document

with links to the currently selected

documents.

Summarize Annotations: Creates a document

with all annotated text passages of the

currently selected documents. In case of

items located in multiple databases the

summary is created in the global inbox.

DEVONthink 3.9.17 Documentation, page 154



From the submenu, choose to create the

summary in a rich text document, Markdown

document, or a sheet.

Summarize Mentions: Creates a new

document containing a list of the documents

mentioning the name or alias of the selected

document. From the submenu, choose to

create the summary in a rich text document

or a Markdown document.

Merge Items: Merge the selected documents

into one. This creates a new file, preserving

the originals. Hold the ⌥ key to choose Merge

& Delete n Documents, removing the original

files after the merged document is created.

When merging documents, the order of the

merge will be the order shown in the item

list. The topmost selected document will

be the first page with the pages beneath it

following. The order of the documents can be

controlled by the current sort method in the

item list. See also p. 156ff

Note: The resulting file type of a Merge

operation depends on the types of the

selected files. Selecting mixed formats,

e.g., a web archive and an image, usually

results in an RTFD file being created.

Split PDF: Use commands in this submenu to

split a PDF document into separate files. Use

into Chapters on a PDF containing a table

of contents to create separate per-chapter

files. Use into Pages to 'explode' the PDF into

individual single page files.

Split Document: Splits the current document

(PDF, plain or rich text) at the insertion mark

position in the document.

RULES

These commands allow you to set or run

smart rule commands

Apply Rules: Apply the selected rule on

selected items that match the rule's

criteria, including the location defined in

the smart rule.

Perform Rules: Run the selected rule at any

time or in any location. This is not isolated

to the documents in the current location.

Batch Process: Use this command to

quickly define and run commands without

specifically defining a rule. This can be

useful to modify multiple selected files.

START SERVER, TAKE NOTES

Start/Stop Server: Use this command to

start and stop the integrated web server. See

also p. 75ff

Take Note: Opens the Sorter to the Take Note

view. If the Sorter is not shown, it opens the

Take Note window.

THE VIEW MENU

The View menu contains all the commands

for modifying the way DEVONthink displays

groups and documents.

SIDEBAR & LAYOUTS

Sidebar: The Sidebar view options allow you

to switch between the four different sidebar

views in a main window. You can toggle the

sidebar's visibility by selecting the same

option again.

Navigate: This is the main sidebar view,

giving you easy access to your databases,
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favorites, and global smart groups. See also

p. 89ff

Reading List: Similar to Safari's Reading

List, this sidebar view allows you

to maintain a list of items for later

consideration. See also p. 99ff

Extras: This view gives you access to recent

updates in tutorials, scripts, and templates.

And if you want to keep up on updates

from us, it includes links to promotions and

release announcements. See also p. 104ff

Import: The Import sidebar view gives you

access to scanning and email archiving. See

also p. 103ff

View: Choose one of the following options

to switch between different layouts for the

item list in a main window. All these views are

similar to options you find in Finder windows.

Icons: Displays items as icons.

List: Displays items in a list view with user-

specified columns shown.

Columns: Displays the item list as a set of

columns.

Cover Flow: Displays large thumbnails in a

side-scrolling view.

Preview: These options allow you to control

the position of the current document's

preview, or dismiss it altogether.

None: This creates a list only view.

Standard: This shows a preview under the

file listing.

Widescreen: This shows the preview to the

left of the file listing.

Quick Look/Slideshow: Opens the Quick Look

panel for the selected items which can be

useful for times when the view/edit pane

isn't displayed. Holding the ⌥ Option key

allows you to display the selected files in a

Quick Look slideshow.

SHOW TAGS & DETAILS

Show/Hide Tags: Shows or hides the tag bar.

Show/Hide Details: Switches between

displaying icons only or displaying icons

together with detailed information such

as kind, label, size, word count, creation

date, and modification date. Available in all

windows using icon or column views.

Show Only Documents: When checked, this

hides groups and smart groups in List and

Icons views. Note this is a per-database

setting, i.e., you can enable or disable it for

each open database.

COLUMNS & SORTING

Columns: This submenu lists all columns

available to be displayed as column headers in

the item list.

Sort: This submenu lists all the attributes

that can be used to sort the current item

list. Choose Unsorted to manually sort the

items. DEVONthink remembers sort settings

for every group separately and uses those

settings when the group is displayed in its

own main window

Customize Metadata: Opens a panel showing

all the available metadata fields that can

be enabled as List view columns or used to

sort on. This includes all enabled custom

metadata.
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FULLSCREEN & ZOOM

Full Screen: Displays either the current

document in a full screen mode optimized for

reading and editing, or the frontmost window

in full screen. There are two options available

here:

Document: Shows the current document in

full screen. Note this is a distraction-free

view, not the standard macOS fullscreen

view.

Window: Shows the current window in a

standard macOS full screen view.

Zoom: Depending on the document type, you

can zoom or out of the document's preview

to your needs:

Actual Size: Displays the document

at actual size, calculated using the

resolution of the screen and the resolution

information of the image or PDF.

All Pixels: Displays the document at a 1:1

ratio so that one pixel of the image equals

one pixel on the screen (PDFs and images

only).

Zoom In/Out: Zooms in or out of the

document.

Zoom to Fit: Displays the document so

that it exactly fits either the height or the

width of the window/preview pane (PDFs

and images only).

Zoom to Width: Displays the document so

that its width fits the width of the window

or view/edit pane (PDFs and images only).

DOCUMENT & PDF OPTIONS

Document Display: This submenu contains

commands for displaying alternate views of

some documents. Note there are alternate

commands shown when used with sheets or

HTML and Markdown files.

Best Alternative/Preview/Table View:

Shows a QuickLook view, or a rendered

view for HTML-based and Markdown files,

the Table view for sheets.

Text Alternative/Source/Form View:

Shows a text-only view of some file types,

e.g.,Word or email. Also shows the page

source of HTML-based and Markdown files

or the Form view for sheets.

Side-by-Side: Shows a side-by-side view

of the rendered view and source for HTML

and Markdown files. Note this does not

apply to Formatted Notes.

PDF Display: This submenu lets you adjust

the way PDF documents are displayed:

Single Page, Two Pages: Shows a multi-

page document as single pages or two

pages facing each other (as in a magazine).

Continuous Scroll: When checked, shows

the pages of the PDF as one long scroll.

When unchecked, only one page is shown

at a time.

Book Mode: When checked, facing pages

start with one single page (the title page),

then facing pages. When unchecked, they

start facing.

Page Breaks: When checked, pages are

shown with a small break between the
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pages. When unchecked, the pages appear

as a continuous document.

Crop Box, Media Box: Crops the page to

the crop or media box. By default, PDF

pages are cropped to the crop box.

TOOLBAR

Hide/Show Toolbar: Hides or shows the

toolbar of the frontmost window.

Customize Toolbar: Lets you configure the

toolbar of the frontmost window.

THE GO MENU

For people who prefer to use the keyboard

for navigation, the Go menu contains all

commands for navigating the hierarchy

of your DEVONthink database, all with

keyboard shortcuts. Use these commands

to go backwards and forwards through your

documents, or to move back to the top level

of the group hierarchy.

DATABASES

Previous Database: Selects the previous

database in the Navigate sidebar.

Next Database: Selects the next database in

the Navigate sidebar.

GROUPS

Top Group: Returns you to the top level of the

database (also known as the "root").

Enclosing Group: Changes the view to

the parent folder of the current group or

document.

Selected Group: Changes the view to the

currently selected group.

To Group…: After classifying or moving

documents to a new location, use this

command to quickly jump to the last used

destination.

DOCUMENTS

First/Previous/Next/Last Document:

Navigates to the first, previous, next, or last

document of all documents in the current

group. This is useful when you have opened

a document in a separate window and want

to move to another document in the same

group.

To Group: Opens a popover where you can

search for a group by name. Results are

shown as you type. The chosen group from

the results will display as the current group.

To Document: Opens a popover to quickly

navigate to a specific document.

To Page/Time: Allows you to jump to a

specified page (PDF documents) or time

(supported video and audio files).

To Link: Opens any detected links in selected

text in plain text, rich text, and Markdown

documents.

Back/Forward: Moves backwards and

forwards through all documents/web pages

you have visited by following cross-links or

Wiki-style links.

Previous/Next Instance: Navigates

backwards and forwards through all instances

of a replicated document. Use these

commands to find out where the other

instances of a replicated item are.
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Previous/Next Highlight: Navigates

backwards and forward through all

highlighted passages within a document,

regardless of whether these passages have

been highlighted by a search or manually

using Format > Highlight.

Next Unread Item: Navigates to the next

item with an unread status in the current

database.

Complete News:

MOVE FOCUS

Choose a command, or use its shortcut, to

quickly switch focus to different panes of a

DEVONthink window. The options available

are dependent on the visible UI elements,

e.g., if the inspectors aren't visible, the Move

Focus to Inspector command will be disabled.

to Sidebar: The current sidebar, e.g., the

Navigate sidebar will have focus. Note

this command requires Settings > General

> Interface > Keyboard Navigation to be

enabled.

to View: The item list will have focus.

to Preview: The view/edit pane will have

focus.

to Inspector: The current inspector will

have focus.

Favorites: Displays a submenu of items in the

Favorites section of the Navigate sidebar.

WORKSPACES

Workspaces allow you to save the state of

your open databases, as well as the contents

and positions of all open windows, so that

you can restore them later. This is ideal if you

are working with the same set of windows

over and over again. Save these windows as

a workspace and recall them whenever you

need them again.

From the Workspaces submenu you can:

Add: Saves the currently open windows

and open databases as a workspace.

Edit: Opens a window that allows you

to edit saved workspaces. Click on a

workspace name to change it, reorder by

dragging, and delete with the - button.

Update: Updates an existing workspace

to the current state of databases and

windows.

Choose: Choose a workspace from the list

of saved workspaces to load it.

THE WINDOW MENU

Just like most every macOS application, the

Window menu lists all open windows of the

active application and gives you access to

commands for managing them.

WINDOWS & TABS

Close, Zoom, Minimize: These three

commands resemble the red, yellow, and

green buttons of any window title bar, and

consequently close the window, minimize

the window to the Dock, or maximize the

window. No magic here. Hold the ⌥ Option

key to change allow the command to affect

all windows.

New, Close, Select Next/Previous Tab: Opens

a new tab, closes the active tab, or moves the

focus to the next or previous tab.

Note: Tabbed browsing needs to be

enabled for these commands to work.
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Bring All to Front: Brings all windows of

DEVONthink to the front. Hold the ⌥ Option

key to change Bring All to Front to Arrange in

Front.

ACTIVITY, DOWNLOADS, LOG

Activity: Opens the Activity panel. This panel

shows all running processes, e.g.,OCR or sync

activity, and allows you to manually stop

them.

Download Manager: This command opens

the Download Manager panel of DEVONthink.

Using the Download Manager, you can

download files or complete web sites from

the internet and store them directly in your

database.

Log: Opens the Log panel. The log lists error

messages and warnings that occurred while

importing new documents. It also opens

automatically when an error occurs. You can

save the log to a text file or clear it.

OPEN WINDOWS

Window List: Select any open window from

the menu to bring it to the front.

THE SCRIPTS MENU

The Scripts menu is located left of the Help

menu and shows a stylized AppleScript 

symbol instead of a normal menu title. It

contains a collection of useful, predefined

AppleScripts you can use directly from within

DEVONthink.

Some of the scripts work without having

selected a document, while others require

you to select the document you want the

script to interact with. In general, the script

will tell you what you have to do when you

select it from the  menu.

Use More Scripts to install additional

scripts and read more about scripts and

DEVONthink's  menu here.

THE HELP MENU

The Help menu contains commands

for opening the integrated help pages,

the support assistant, or visiting the

DEVONtechnologies website.
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DEVONTHINK

Use these commands to open the integrated

help pages, get directions on installing the

browser extension and bookmarklets, or

access the list of changes to DEVONthink.

DEVONthink Help: Opens the internal

documentation.

Extensions & Bookmarklets: Opens the

section in the help with information about

our browser extension and bookmarklets.

Release Notes: Opens the What's New

section of the documentation so you

can see what's new, improved, fixed, or

removed in each release.

SUPPORT

Support Assistant: Opens the support

screen of the Welcome to DEVONthink

assistant with more direct links to the

DEVONtechnologies website, tips, and

tutorials. Note this function requires an

Internet connection.

Tutorials: Opens the Tips and Tutorials

screen of the Welcome to DEVONthink

assistant. The tutorials help get you started

by explaining everyday DEVONthink tasks

in step-by-step detail. Note this function

requires an Internet connection.

CONTACT

These commands take you directly to the

corresponding pages on our website or send

feedback directly us.

DEVONtechnologies: Quickly access our

home page.

Your Account: Opens the login page for your

DEVONtechnologies account where you can

get information on your licenses and the

devices they're registered to.

User Forum: Jump into our user forum.

Frequently Asked Questions: Choose this

option to access many often asked questions

in the Questions & Answers section of our

website, pre-filtered for questions about

DEVONthink.

Contact Us/Report Bug: Use this to draft a

general email to us. When you need to report

an issue, hold the ⌥ Option key to show the

Report Bug. This creates a new message

in your default email client or Apple Mail

containing the console log and all related

crash logs in a ZIP archive, ready to be sent to

our customer support.

THE DOCK MENU

The Dock menu appears when you click

DEVONthink's icon in the Dock with the

⌃ Control key pressed, when you right-click it,

or when you left-click it and hold the mouse

button for one second or longer. When items

are added to a database, a badge appears
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on this icon. Longer tasks, e.g., importing,

indexing, or running scripts, may show a

progress indicator on the dock icon.

It also contains the generic macOS

commands and an Options menu common to

all macOS applications. DEVONthink-specific

items are listed below:

Recent Databases: Quickly reopen a closed

database from this list.

Open Windows: Switch to any open window

from this list. The active window is displayed

with a checkmark next to it.

Take Note: Opens the Take Note panel.

Start/Stop Server: Starts or stops the web

server.
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The Settings window, which you open by

selecting Settings in the application menu, is

the place to go to change global settings for

DEVONthink. You will find a wide variety of

options so you can fine-tune many aspects of

the operations and your experience.

There is also a number of hidden preferences,

intended for customer support, but maybe

useful for you, too. See also p. 257ff

GENERAL

GENERAL

Use the General tab to set the general

behavior for the application, e.g., whether

to check for updates automatically or keep

groups on top when sorting.

General: Set the options for duplicate

detection or to enable alarms for reminders.

Stricter recognition of duplicates: Check to

have DEVONthink use document contents,

file type, file size, and the content hash of

the document, when detecting duplicate

files.

More compatible naming of files: Replaces

the characters |<>%?&*" when naming files

to improve the compatibility with other

filesystems and platforms, e.g., Dropbox or

OneDrive. Forward slashes and colons are

always replaced as these are reserved by

macOS.

Automatically mark items as read:

Enabled by default, this option marks any
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previewed item as read, just as applications

like Apple Mail do. Disable this option to

manually mark items as read.

Enable reminder alarms: Enables or

disables using DEVONthink Reminders. This

can be set on a per-machine basis.

Annotations: Controls where to save

annotation files and whether they should

be moved when the referred file is moved,

e.g., when moving the source file to another

database.

Location: Choose to save newly created

annotation files In shared group or In same

group. The shared group is an Annotations

group in the root of the current database.

Move annotations automatically: Enable

this to cause annotation files to "follow"

their referred files. For example, if you

move the source file to another database,

the annotation file will be moved to the

new database as well

Search scope: Controls where new searches

begin searching and the behavior of the

Search inspector.

Scope Location: Set where toolbar

searches should look when a new search

is initiated. The options are: Last scope,

Current Database, All Databases, and

Current Selection.

Automatically select search inspector:

Enable this to switch to the Search

inspector if the view/edit pane and

inspectors are already visible when doing a

search. This option is enabled by default.

Alerts: Click Reset to make DEVONthink

show alerts again that you previously

dismissed with "Don't show again" checked.

Send anonymized analytics data: Sends

anonymous information about certain

activities in DEVONthink, e.g, a key denoting

an optional script you installed. See our

company's Privacy page for more information

on the data that may be sent.

Check for Updates: Change the settings

in this tab to define when you want

DEVONthink to check for new versions:

never, on startup, daily, weekly, or monthly.

DEVONthink only performs checks for

updates when the computer is connected to

the Internet.

Click Check Now to immediately check for a

new version.

INTERFACE

The options control interface behaviors

including some of the Navigate sidebar.

Interface: These options control the behavior

of the interface, e.g., when double-clicking

documents.

Double-click opens groups in a new

window: This option allows you to open a

new window when you double-click a group.

If unchecked, the group will be selected
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and its contents will be replace the file list

being currently viewed.

Double-click opens documents externally:

Check this if you'd like documents to open

in an external application when double-

clicked. DEVONthink uses the application

set as the default application for the

file type in the operating system, e.g.,

TextEdit for RTF documents. If unchecked,

any document that can be edited in

DEVONthink will be opened in its own

window.

Click on links opens them externally:

Enable opening links in document text

in the system default application. Use

⇧-click to open and activate the default

application. Note ⌘ or ⌥-clicks can be

still used to open links in new tabs or

to add them to the Download Manager,

respectively.

Keep groups on top when sorting: Always

display groups at the top of the item list,

independent of the sort method, e.g., by

Name, by Date Added, etc.

Retain view: When enabled, the view

settings in the current main window, e.g.,

Icons in Widescreen, override the view

settings of other groups or databases.

If a change is made to the current view,

that change will persist when switching.

If no changes are made, the previous view

settings will be restored after disabling this

option.

Document windows prefer fullscreen:

When enabled, while viewing a fullscreen

main window, document windows opened

from it will be opened in fullscreen as well.

Automatically reveal items: Enable this

to reveal the currently displayed item in

the item list, for example when switching

between document tabs in a main window.

Enable tabbed browsing: When checked,

click with ⌘ Command pressed a link in

web, PDF or text views to open it in a new

tab. When unchecked or the ⌘ modifier key

isn't pressed, documents are opened in the

same view, in the default application or in

new windows. Check Always show tab bar

if you'd like to view the document title in a

tab bar when only one document is open.

Sidebar: These options toggle the unification

of items in the Navigate sidebar as well as the

ability to navigate it via keyboard.

Automatically expand & collapse groups:

Check this to automatically select and

expand a group in the sidebar when

revealing or opening it.

Keyboard Navigation: Enables keyboard

navigation with typing selection, and arrow

key hoisting of groups in the Navigate

sidebar.

Unify Databases: When enabled,

navigate the groups of the root of all

open databases in the Open Databases

section of the Navigate sidebar. When

disabled, the groups of the root of the

active database are displayed in an active

database section in the sidebar. This allows

isolating the groups of a database. The

active database will have an asterisk to the

left of the name.

Unify inboxes: Display the inboxes of open

databases only in the Globals section of

the Navigate sidebar. When disabled, the

inbox will be displayed in the item list for

the current database.

Unify tags: Display the Tags group of open

databases only in the Globals section of
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the Navigate sidebar. When disabled, the

Tags group will be displayed in the item list

for the current database

Dock: Specify what items to count and

display on the badge on DEVONthink's dock

icon: Number of new items, Number of

unread items, or Number of unread news.

APPEARANCE

These options control the look of some parts

of the interface.

Alternating row colors in views: Check

to color every second row in item lists

differently.

Display number of items inside groups:

Check to show the number of documents

in groups. In the sidebar, the total number

of items in the group is shown. News feeds

will show the number of unread items. In

the item list, this shows the number of

unread and total documents contained in

a group. For example, "2/10" shows there

are two unread documents out of ten total

documents.

Highlight bookmarks in views: Check to

show bookmarks in the item list and links in

documents marked in blue and underlined.

Mark duplicates and replicants in color:

Check to highlight duplicates marked in

blue and replicants marked in red in most

views. When unchecked, duplicates and

replicants display a property icon to the

right of a document's name.

Show filename extensions: Check this if

you prefer to see the file type's extension

at the end of filenames.

Use dark background for documents: When

enabled, compatible documents, e.g., rich

text, will display white text on a black field

when using macOS' dark mode. When

disabled, documents will display normally.

Labels: Choose how you would like labels to

be shown in lists.

Classic: Tints the group/document icon

(like on Mac OS 9).

Modern: Puts the group/document name in

a colored bubble (like on older versions of

OS X).

Dots: Shows a colored dot in the list (like

on macOS).

As flags: Displays a colored dot in the Flag

column of the item list in List or Columns

view or to the left of an item's name in Icon

view.

View Text Size: set the font size used in the

item list, the contents of sheets in table view,

and the Annotations and Attachments tabs

of the Document inspector.

Sidebar Text Size: Set the font size

DEVONthink uses in the sidebars.
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EDITING

The Editing tab defines all options that fine

tune DEVONthink's text editing behavior,

from the ruler units to default font settings

to summarization options.

GENERAL

Display PDF attachments of rich texts:

When checked, a PDF inserted into an

RTFD documents will display its first page.

Unchecked, you will see a link and the PDF's

filename.

Scale image attachments: Images added

to rich text files and formatted notes are

scaled to the current width of the view/

edit pane.

Check spelling while typing: Spellcheck

while you write.

Check grammar with spelling: Check

grammar as well as spelling while you write.

Correct spelling automatically: Correct

misspelled words automatically.

Smart quotes: Convert straight quotes

("inch marks") to typographer's quotes

("curly quotes") while you type.

Smart copy/paste: Insert or remove spaces

before and after cut or pasted text.

Smart links: Detect web addresses and

turn them into clickable links.

Smart dashes: Convert characters, e.g.,

two hyphens into a proper dash.

Data detectors: Detect dates, times or

addresses in text, and show possible

actions when the mouse cursor moves over

them.

Text replacement: Use the system-wide

text replacements when editing text.

AUTHOR, RULER UNITS AND FONTS

Author: Enter your name. It will be used as

default for metadata, e.g., for new rich text

documents or PDF annotations.

Ruler Units: Select your personal

preference for ruler units: centimeters,

inches, points, or picas.

Plain Text: Select your preferred font.

This is the font automatically used when

you create new documents. Additionally,

specify the background and text colors to

suit your taste.

Rich Text & Note: Select your preferred

fonts for new rich text formats. This is the

font automatically used when you create

new rich text documents or formatted

notes. It is also the default used for

rendered Markdown documents, if no

default stylesheet is specified.

Note: Hold the ⌥ Option key to restore the

default fonts.

FULL SCREEN

Full Screen: Select your preferred font for

reading and editing plain text files in full
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screen mode. Rich text documents will

display their user-specified fonts.

Background: Choose a background color for

the full screen mode.

Text: Choose a text color for the full screen

mode.

Width: Choose a width for displaying

documents in full screen mode. This setting

will apply wider or narrower left and right

margins, based on a percentage of the

screen width.

SUMMARIZATION

Select whether you wish DEVONthink to

summarize based on sentences or whole

paragraphs.

WIKILINKS

WikiLinks are a way to create interconnected

documents in your databases. When enabled,

DEVONthink attempts to detect other

documents matching the terms you've

typed in plain text, rich text, or Markdown

documents. This creates an active hyperlink

to the detected document, allowing you

to quickly jump to it by clicking the link.

WikiLinked text displays as underlined text.

For more information on creating WikiLinks

and other linking methods, see the Document

Linking section.

WIKILINKS

To enable WikiLinking, check the Automatic

checkbox and choose from the options shown

here:

MashedWords: Commonly used to avoid

creating links from individual words,

mashed words are document titles of

joined words. If you type a mashed word,

it will automatically create a link. If a

matching document is detected, it will

open when clicking the link. If a matching

document isn't detected, DEVONthink

will create a new rich text document,

prepopulated with information defined in

the Template section below.

Square Brackets: WikiLinked text can

be defined using square brackets. Type

two opening square brackets and the

beginning of a document name. Then

press ⌥⎋ Option-Escape to show a list of

potential item matches in the database.

Choose a document and press ↩ Return to

complete the link.

Names and Aliases: Matches documents

based on their name or any aliases defined

in the Info Inspector.

All Items/Only Documents/Only Groups:

Choose whether to match only documents,

groups, or both.

Case-insensitive Linking: Enable this to

ignore capitalization when matching Names

and Aliases, e.g., GlobalEconomy and

globaleconomy both would match.

Open new documents in separate

windows: When clicking a WikiLink, the
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linked document will open in its own

document window.

Update name of item links automatically:

When the name of item-linked documents

is changed, this will update the link text in

documents containing item links to those

files.

TEMPLATE

Text and items entered here will be used to

create a new WikiLinked document. You can

type any text you want as well as Control-

click and use Insert Placeholder to insert a

token that will be automatically replaced

when the template is created. The default

title contains several of these tokens already.

Check out the placeholders section of the

appendix for information on the available

choices.

SORTER

The Sorter preference allows you to choose

the window's appearance and location, and

assign a hotkeys for capturing data or taking

a new note. See also p. 58ff

APPEARANCE, LOCATION,…

Appearance: Choose to display the Sorter

as a menu extra, a docked tab on the side

of your screen, or not at all.

Position: Choose the onscreen position

of the docked tab. These options will be

disabled if Show as Dock Tab isn't selected.

Menu Extra Title: Choose whether to

show the menu extra as text, or a space-

conserving icon.

Screen Capture: Check this to play the

system default screen capture sound.

HOTKEYS

Set system-wide hotkeys for: Take Note, Copy

Selection, Clip to DEVONthink, and Search.

To change the hotkeys, click the Click to

record shortcut button, then press the

hotkey that you want to use. Press the

⎋ Escape key to cancel recording a new

shortcut.

Note: On macOS Mojave, you will be asked

to grant Accessibility permissions for Copy

Selection, and Automation permissions for

Clip to DEVONthink.

FILES

The Files preferences contains controls

for a variety of things from imports to

media playblack, thumbnailing to Markdown

extensions, and more.

DEVONthink 3.9.17 Documentation, page 169



IMPORT

Here you can choose options for the location,

encoding, and tagging of files coming from

external sources, including bookmarklets,

DEVONagent Pro, items dropped on the dock

icon, (external) scripts, or services.

New Notes: Check Select (and display)

automatically to automatically select and

display the last note you have taken.

Destination: Choose the default destination

where incoming data is stored.

Select group: A group selector is shown

that lets you choose the destination. The

group selector appears as a black panel

floating on top of all other windows. Use it

to select the group where you want to file

the items.

Global inbox: The data is stored in the

global inbox.

Text Encoding: Choose the default encoding

used for plain text documents. Select

Automatic to let DEVONthink choose the

best encoding.

Tags: Imported files can have metadata

that may be useful as tags. Choose the

desired options to convert specific types

of information to DEVONthink tags. These

options are honored by email archiving,

scanning and OCR, importing from Bookends,

Evernote, Apple Notes, and Yojimbo, as well

as documents created via the Sorter and the

web interface (Server edition only).

Convert keywords to tags: Check this to

convert embedded keywords from PDFs

and RTF(D) files to tags.

Convert properties to tags: Check this to

convert embedded properties from PDF

and RTF(D) files to tags.

Convert geolocation to tags: Check this to

convert proper names of geolocation data

to tags, e.g., "Orlando", "FL", and "United

States".

Convert Hashtags to tags: Check this to

convert found hashtags to tags.

Add Vision suggestions to images: Check

this to automatically apply suggested tags

to imported images.

Recognition: This section has one option:

Scan Barcodes. Enable this to detect

barcodes in images and PDF documents.

If a barcode is detected, the value will be

added to the Barcode attribute in the Info

> Custom inspector. Supported barcodes:

EAN13, ISBN, and QR codes. And note, the

quality of the original will determine the

accuracy of barcode detection.
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THUMBNAILS

These options control whether DEVONthink

displays a custom thumbnail for each file or

the default file type icon.

Generate from actual image: For images,

an embedded thumbnail will be displayed,

if available. Enable this option to create a

thumbnail for the image if no thumbnail is

already available.

File types: Choose the file types for which

DEVONthink should automatically generate

thumbnail icons.

EMAILS

Use these options to define how email is

imported and displayed inside DEVONthink.

Import complete conversations:

DEVONthink can import not only selected

email messages, but also other messages

related to a conversation. Check this box to

let DEVONthink scan your Sent Messages

folder and import sent messages that

belong to the same conversation.

Group conversation threads: Check this

option to combine all messages belonging

to a conversation thread into a group. This

makes identifying conversations easier

and automatically adds structure to the

imported messages.

Note: These features only work if the email

program maintains references to previous

messages sent.

Previously imported will become

replicants: Check this option to import

previously imported messages again as

replicants. When this option is unchecked,

DEVONthink skips previously imported

messages.

Use alternative view: Check this option to

view email messages as text alternative by

default.

Fallback text encoding: When decoding

an email message, DEVONthink uses

the message's encoding information.

When there is no encoding information,

DEVONthink uses the encoding that you

set in this pop-up menu.

Download remote images in HTML

messages: Spammers and other unfriendly

agencies may use images in an email to

track if you have read it. Therefore this

is unchecked by default. This setting

only applies to emails viewed in the Text
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Alternative view, not the Best Altenative

view, of the View > Document Display.

Decrypt secure messages: Check this to

decrypt and file secure email messages.

This allows DEVONthink to search or apply

AI-based functions such as Classify or See

Also to them.

Note: The email message will be stored

decrypted in the database package.

Its contents are available from within

DEVONthink and to other applications or

Spotlight.

Use fixed-width font for plain text

messages: Check to show plain text

messages using a fixed-width font such

as Courier. This is useful if the messages

contain tables or footers formatted with

spaces.

Color quoted text: Check to mark text

quoted from previous recipients in

messages. Click the color buttons to

change the color for first, second, and third

level quotes.

Labels: Select which labels you want to

assign to messages that were flagged

or marked as "high priority". Since items

can only have one label at a time, flagged

messages are treated as more important

than messages marked as "high priority".

Note: The first two options above only

modify the display of email messages in

the text view. By default, messages are

displayed using QuickLook.

MARKDOWN

Choose options for the default mode when

selecting Markdown files, styling, or any

extensions to be used when rendering the

Markdown.

Markdown Display: Choose whether you want

to open Markdown documents by default in

editing, preview mode, or side-by-side mode.

Editing is the default mode.

WYSIWYG editing: Toggle the display of

formatting and detected elements in the

source code of a Markdown document.

Force line breaks: Enable this to treat a

return as the end of a paragraph without

having to add two spaces at the end of the

line.

Import images to group: Creates a local

repository of linked images. The group will

have the name specified in the preference.

Images dragged and dropped or copied and

pasted from outside DEVONthink will be

copied into a group in the current location.

Also, images from web content clipped as

Markdown documents will be downloaded

into the group. (See the Documents >

Markdown > Linking Images section for more

information.)

DEVONthink 3.9.17 Documentation, page 172



Image Reference: Specify the type of link

to use with images pasted, dropped, or

downloaded to Markdown documents. Item

Link will always use an item link. Automatic

will use either item links or relative links,

depending on the location of the image in the

database. Automatic is the default behavior.

Style Sheet: If you want to choose a default

stylesheet to display your Markdown

documents, click the Select button to access

stylesheets stored on your machine, e.g.,

in ~/Library/Application Support/

DEVONthink3/StyleSheets or paste the URL

of an online stylesheet.

JavaScript: If you want to choose a default

JavaScript file to be loaded with all your

Markdown documents, click the Select

button. The JavaScript can be located

anywhere, including an online script, if

needed.

Extensions: Check the desired options for

Markdown extensions:

MathJax support: Supports rendering

mathematical equations via the MathJax

extension.

Mermaid support: Supports rendering

diagrams via the Mermaid extension.

Prism support: Supports syntax coloring

of rendered inline code and code blocks via

the Prism extension.

Summaries: Enable this if you want Summary

documents in Markdown format (See also p.

154ff ) to use blockquotes instead of highlight

formatting.

MULTIMEDIA

Choose options for media playback or the

default display mode of PDFs or images. You

can also choose a background color for these

media types.

Play Media: Check Play automatically to

play audio and video files automatically

when you display them. Check Loop if

you want to play the clips in a loop. Set a

desired background color for the selected

media file.

Image Display: Choose a default zoom

factor and a background color for viewing

images

PDF Display: Choose the default display

size background color for viewing PDFs in

windowed and fullscreen modes. Check

Automatically resize to automatically

resize PDFs in the view/edit pane. Set the

background color.

PDF Clipping Width: Specify a width in

pixels for captured or clipped PDFs. The

default value is Automatic. Note: The

styling on specific sites could override this

setting.
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SHEETS

Choose the options for displaying and

converting sheets to paginated PDFs.

Sheet Display: Choose the default view

when viewing a sheet: Table or Form. Form

view is only available in the Pro or Server

editions.

Background Color: Set the background

color of a sheet in Form view.

Paginated PDF Conversion: Choose

whether to use the Table View or Form

View when converting a sheet to a

paginated PDF via the Data > Convert > to

PDF (Paginated) command.

COLORS

Label: Set the name of color for color labels

applied to files and groups in your database.

Highlight: Set the name and color to be

used for highlighting text in compatible file

formats, like PDFs.

Note: These are global settings, i.e., you

can't have per database label or highlight

colors. Also, following Apple's example,

we only allow setting seven colors in each

category.

WEB

The web preferences resembles the settings

of most web browsers. Use these preferences

to define how DEVONthink's displays web

documents and "live" web pages.

WEB CONTENT

These settings define how DEVONthink

treats special web contents:

Enable ...: Check these options to use

installed third-party plugins, (such as Flash

or RealPlayer plugins), and to run Java

applets or JavaScript scripts contained in,

or linked to, a web page.

Block ...: Check Block pop-up windows to

block pop-up windows, which are often

advertisements; check Only automatic

DEVONthink 3.9.17 Documentation, page 174



JavaScript windows to block only pop-up

windows opened by JavaScript. Uncheck

this option if the web page you're visiting

uses pop-up windows for actual content.

(Some web content management systems

do this.) Check Block zooming to keep web

sites from automatically zooming windows

to full size. Check Block advertisement

to block common inline advertisements

provided by some search engines.

Zoom text only: Check to zoom only the

text and uncheck to use Safari-4-style

zooming.

IMAGES

These settings define how DEVONthink

displays graphics in web pages:

Display images when the page opens:

Check this option to display web pages

with images. Just remember, if unchecked,

you may miss some information.

Animate images, Loop animation: Check

these options to run web graphics

animations and to run animated graphics in

a loop.

Scale images to fit: Check this option to

scale (large) images to fit.

ACCEPT COOKIES

Cookies are little text files with information

that web pages store on your computer use

to recognize you as a returning customer,

among other things. While most cookies are

harmless, you may want to control what is

being stored on your hard disk.

Always: Accept all cookies.

Never: Don't accept any cookies.

Only from sites you navigate to: Accept

cookies, but only from web sites you

navigate to (not from other sites, such as

ad trackers).

Delete cookies on quit: Delete all stored

cookies when you quit DEVONthink.

FONTS

Set the fonts you want to use for displaying

web pages; set separately for variable-width

and fixed-width text.

Note: Hold the ⌥ Option key to restore the

default fonts.

STYLE SHEET

You can further control the way DEVONthink

displays web pages by applying a CSS style

sheet that changes the rendering on the fly.

Click Select and choose your style sheet to

apply it to DEVONthink's integrated web

browser. Note: This is for experts since it

modifies how all web pages are displayed and

can lead to undesired effects.

TEXT ENCODING

Select your desired text encoding for

displaying web pages. Automatic tries

to choose the best available encoding. If

this does not work for you, choose a more

appropriate text encoding for your language

group.
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RSS

DEVONthink comes with built-in RSS

capabilities that enable you to add RSS feeds

to your database and have DEVONthink

update them automatically. Use these

preferences to define how often DEVONthink

checks for new articles, whether to skip

duplicates when updating feeds, when to

remove older articles, and which CSS style

sheet to use for displaying the articles.

Check for updates: Set how often you want

DEVONthink to refresh your feeds. This can

be from 5 minutes to once a day. It can also

be when opening or before synchronizing

a specific database. And of, there's always

the option to check for updates manually.

Convert categories and hashtags to tags:

Some RSS articles have tag metadata

to help people more easily navigate the

publisher's site. Check this option to

convert these to DEVONthink tags. Note

this can add a great number of tags to your

database.

Skip identically named articles: The same

article can be delivered when using multiple

RSS feeds from one site. Enable this option

to avoid downloading duplicate articles.

Remove articles: Set how often older

articles are removed from the feed. Check

Also unread articles to remove them, even

if they're unread.

Remove immediately instead of moving

to the trash: Immediately deletes the RSS

articles.

Also unread articles: Check this to remove

all articles at the specified interval whether

they've been read or not. You can use Data

> Mark > as Locked to lock individual feeds

or articles and prevent automatic deletion.

Feed Format: Choose a file format for

the downloaded articles. (RSS articles are

presented as HTML files, by default.) Check

Use clutter-free layout to try to remove

unwanted ads, etc. from the article.

Feed Style Sheet: For HTML (Feed Format:

Automatic) articles, DEVONthink comes

with multiple styles for displaying them.

You can use your own RSS stylesheets by

placing them into ~/Library/Application

Support/DEVONthink 3/StyleSheets.

Enable Use clutter-free layout with web

archive and single-page PDFs to produce

a file with many extraneous elements

removed.

DATA

Here you can define custom metadata fields

that can be assigned to your documents.
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CUSTOM METADATA

The Custom Metadata column contains a

range of built-in fields, ready to use or modify,

as needed. These cover a variety of common

uses and a list of the pre-defined fields can

be found in the Data section of the appendix.

Enable any field by checking the checkbox

next to it. Use the buttons below the Custom

Metadata column for extra options:

Add: Click the + to create and name a new

custom field.

Remove: Click the - to remove any field.

When deleting a field, a warning will be

displayed. This warning can be suppressed.

Action: Select any field and click  for

more options, including duplicating and

renaming the selected field or restoring the

default metadata fields.

The order of the fields is also the order in

which they appear in the Info inspector.

Note: These options are also available from

the context menu.

PROPERTIES

Use these controls to modify the properties

of the selected field.

Identifier: This is a special name used in

automating with AppleScript. The term is

derived from the field's name, and cannot

be entered or modified manually.

Type: This is the specific type of the

current field. Choose one of twelve data

types, such as Date, Boolean, Decimal

Number, or Languages.

Format: Only displayed with certain data

types, you can choose some pre-defined

formats, like Percent. With the Currency

option, you will have an option to enter a

currency symbol.

Values: Only displayed with the Single-

line Text and Set types, define a list of

items to choose from. These choices will

be displayed in a dropdown menu when in

use. Add and remove the items with the

+ and - buttons. Control-click an item to

change it. If you'd like to resort the items

to alphabetical order click the opposing

arrows button.

Note: Please refer to the Data section for

more detailed information on the data

types.

OCR

DEVONthink contains an optical character

recognition (OCR) module that allows you to

import scanned documents and make them

searchable. These documents are "read" by

the embedded OCR engine and stored as PDF

files that contain an additional (invisible) text

layer with the recognized, computer-readable

text. Use these options to fine tune the OCR

process.

You can import scanned documents, or scan

them directly from within DEVONthink.

DEVONthink 3.9.17 Documentation, page 177



CONVERT INCOMING SCANS

Check Convert to searchable PDF to

apply OCR to file that have been sent

to DEVONthink from a known scanning

software, e.g., ScanSnap Home. Choose

the desired format of the resulting file:

searchable PDF, RTF document, Word

document, or WebArchive.

ORIGINAL DOCUMENT

Check Move to Trash if you want DEVONthink

to move the original documents to the trash

after they have been successfully imported

using OCR. If files are converted by OCR

within the database, the original document

is deleted from the database. If files are

converted at import, the original document is

moved to the Finder's trash. Using this option

is a great way to prevent your incoming

group/folder or database from growing

cluttered after OCR is done.

Note: This option cannot delete files

received from the ScanSnap software.

SEARCHABLE PDF

Check Enter metadata after text recognition

to metadata entry dialog whenever a PDF is

imported using OCR. Use this dialog window

to enter the preferred document name, the

author of the document, and any keywords

describing the document. You can also adjust

the timestamp of the PDF to the actual date

of the paper document. The dialog window

is shown when OCR processing has been

completed.

When checked, the metadata entry dialog

will appear whenever you scan a document

or import an image file with OCR. You may

want to switch this option off when you are

scanning/importing multiple files in a batch.

Note: Information you enter in this dialog

will be available to Spotlight and can

be changed in the Preview application.

The title field will be used to name the

document, the keywords will go into the

Comments field, and the creation date will

become the creation date of the document

in DEVONthink. You can access this

information in the Document Properties

panel.

Check Compress PDF to apply compression

to the resulting PDF, creating a smaller

file. Compression only applies when

adding metadata post-OCR or preserving

annotations from an original PDF after OCR.

PDF RESOLUTION

Set the desired resolution for the image layer

in the PDF from 150 to 600 dpi. On Apple

silicon Macs, you can also choose As source to

retain the original scanned resolution.

AUTO CORRECT

Check Deskew to allow DEVONthink to

attempt to straighten the resulting PDF.

Check Page Orientation to allow DEVONthink

to detect and correct the page orientation.

DICTIONARY AND LANGUAGES

Custom Dictionary: Check Use Dictionary to

use a custom dictionary of acceptable words.

For example, you may have an unusual spelling
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of someone's name in some documents. You

can enter the name as an acceptable choice

for the OCR engine to choose from.

Click the Configure button to add custom

entries for OCR detection. Note you can

only have one dictionary, specified for the

language chosen in the Language dropdown.

Languages: The Languages section of the

OCR preferences lets you identify the

languages of the documents you scan

in. DEVONthink's OCR engines uses this

information to improve the accuracy of

the text recognition. DEVONthink comes

with more than 150 different language

dictionaries.

Select the languages you intend to scan or

import with OCR. Set a primary language

and add one or more secondary languages

using the pop-up menu . Simply select the

languages you want to use from the list

on the right (Available) and move them to

the left side (Selected) using the right-to-

left arrow button. To deactivate a selected

secondary language, select it from the list

on the left and move it to the right using the

arrow button. You can select a maximum of

four secondary languages.

Note: The primary language and the

secondary languages are treated equally.

IMPRINTER

Imprints are custom bits of data that can be

stamped onto images or the pages of PDF

documents. Imprints can be used in a variety

of ways, from stamping when an invoice was

paid to adding specialized numbering. With

the ability to include placeholders, you can

create many kinds of watermarks for your

documents.

CONFIGURATIONS

This column lists any custom imprints

you've already created. Click an existing

configuration to change its appearance or

location on future documents, or click and

release to change the name. Use the buttons

below the Configurations column for extra

options:

Add: Click the + to create and name a new

custom field.

Remove: Click the - button to remove a

custom field.

Action: Select any field and click  for

more options, including duplicating,

renaming, and deleting the selected

configuration. A special item in the menu,
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New Combined Configuration is discussed

below.

Preview: Click this button to see an

example of the imprint, as specified by the

current settings.

New Combined Configuration: Found in

the  action menu, this option allows you

to create new imprints from your existing

ones. This extends the usefulness of existing

imprints.

From the action menu, select the New

Combined Configuration option. Two panes

will be displayed: Combined and a second

Configurations pane. In the righthand pane,

select an existing configuration and click

the < button to add it to the Combined pane

in the center. To remove an item from the

Combined pane, select it and press the >

button. It will reappear in the Configurations

pane on the right. Combined items will be

displayed in the order you add them. To see

what the imprint looks like, press the Preview

button.

Note: DEVONthink remembers the location

and styling of the individual imprints in a

combined configuration.

GENERAL OPTIONS

Check Duplicate item before imprinting to

duplicate the document before imprinting it.

APPEARANCE

Use these controls to define the parts of the

watermark, its font attributes, and the style

of a containing box, if desired.

Title: This is the body of the imprint. Type

any static text you want to appear in the

imprint. Right-click > Insert Placeholder

to define sections of the watermark with

placeholders. Any of these items can be

can be reordered easily by dragging and

dropping.

Font: In the Font options, choose the

font, weight, color, and other styling for

the watermark. If you choose the outline

style, you can choose the Thickness of the

outline.

Border Style: Choose and style a pre-

defined border, if desired. When using a

border, you can also specify the border

Color and Thickness and an optional Fill

color.

Note: There is only one font style for the

watermark. You cannot have mixed styles,

e.g., displaying one word larger or in a

different color.

LOCATION

In the Location tab, choose and fine-tune the

position of the watermark, as well as on what

pages it will appear.

Position: Choose a general position for the

imprint to appear on the document.

Offset X/Y: Fine-tune the position of the

watermark. Negative values are to the left

(X) and down (Y). Positive values are to the

right (X) and up (Y).

Rotate: Set your imprint on an angle, if

desired.

Occurrence: Choose what pages the

imprint should appear on. Use Custom to

have the imprint appear on specific pages.

DEVONthink 3.9.17 Documentation, page 180



SERVER

DEVONthink features a built-in web server

that allows you to share documents on your

local area network, and optionally, over the

internet. As soon as the web server starts,

other users can use a standard web browser

to search your database, view documents,

and download them.

Note: In order to operate properly,

DEVONthink needs to be running and will

only serve open databases.

Enter all necessary details in the General tab

and define users and permissions in the Users

tab. Then click the Start button to start the

web server available to users whom you have

allowed access.

As soon as the server starts, DEVONthink

shows the name and two URLs for your

database at the bottom of the window.

Use either the Bonjour services list of the

Bookmarks view in Safari or enter the listed

URLs into the address field of your web

browser to access your database. Use the

numeric address if the Bonjour does not work

for your network.

To learn more about using web sharing and

how best to make your database available

from the "outside" internet, please read on

here.

GENERAL

Start on Launch: To automatically start

DEVONthink's web server as soon as you

launch DEVONthink, check this checkbox.

Convert images & PDF documents

to searchable PDF: Check this to

automatically convert all images and non-

OCRed PDF documents added from web

sharing users to searchable PDFs.

BONJOUR SETTINGS

Use these settings to define your

DEVONthink server's identity, everything

from the name and port, to creating a

certificate vouching for the "safety" of the

server's activity.

Identity:

Bonjour Name: Enter a distinct name for

your computer here that identifies it on

the local network using Bonjour. This name

will be shown in the list of Bonjour services

on other Macs on your network. Switch

to the Bookmarks view in Safari or your

preferred browser and select Bonjour in the

sidebar.

Bonjour Domain: Set the Bonjour domain

if necessary. Leave this field empty unless

you know what you're doing.

Port: If left empty, DEVONthink will assign

a random, unused port when the server

launches. If the server will be accessed

regularly, or from outside your network,

setting a static port is suggested. As non-

DEVONthink 3.9.17 Documentation, page 181

https://en.wikipedia.org/wiki/Port_forwarding
https://en.wikipedia.org/wiki/Port_forwarding


standard ports can be prohibited on some

networks, consult with your IT department.

Security:

TLS Certificate: If you have a TLS

Certificate, select it from this dropdown.

P12 Certificate: If you have been issued a

P12 file, import it by clicking the Load P12

file button.

Self-signed Certificate: If you have neither,

it's possible to generate a self-signed

certificate for the server. When this option

is chosen, users connecting to the server

will be prompted the certificate may be

insecure. Instruct them to accept your

certificate as valid to allow their browser to

accept your server's identity.

Allow insecure HTTP connection on

port: DEVONthink's server runs on SSL

connections for secure browsing. If you

have a compelling reason to use the older

http protocol, check this box and enter the

port to be used.

Note: When using the server in

administered networks, e.g., public,

corporate, or educational scenarios,

you may need to consult with the IT

department for successful operation.

USERS

User List: The Users tab on the left allows you

to add and remove individual users, as well as

set per database permissions for them.

Add: Click the + button to add a new user.

Remove: Click the - button to remove a

user.

Password: Enter a login password for the

selected user in the Password field under

the Databases list.

Note: If you have DEVONagent Pro

installed, it will be added as a default user.

This allows it to search DEVONthink's

databases in the same way it searches

other websites.

Database Permissions: The Databases list

on the right allows you to set per-database

permissions for the selected user. All open

databases will be listed in this pane, followed

by the permissions that can be set. When a

user is selected in the Users pane, you can

set specific permissions for that user. The

permissions are as follows:
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Read: Allow the user to access the

database. When unchecked the database

will not be visible to the user.

Download: Allow the user to download

documents from the database.

Add: Allow the user to add items to the

database.

Organize: Allow the user to move around

documents and groups in the database.

Delete: Allow the user to delete items in

the database.

Note: Right-click the database's name to

quickly enable or disable all permissions for

that database.

Technical Info: If you need more information

on the activity of the web server, you can find

some deeper details here.

Server Details: The section under the

Databases pane shows some basic

technical data about DEVONthink's server

activity.

Log: In cases where deeper technical

information about the server's activities is

required, click the Log button in the lower

right corner. The log file will open in macOS'

Console application.

SYNC

DEVONthink allows you to keep your

databases in sync with multiple Macs and

iOS devices running DEVONthink To Go. Use

these options to control which databases are

synced, how often they're synced, with which

locations. Learn more about synchronization

and how to set it up in a separate part of this

documentation.

LOCATIONS

The first column lists all sync locations you

have set up. In addition it lists available

direct connections and templates for quickly

setting up new locations. Active locations

are checked. Disabled, inaccessible, or

unactivated locations are shown in grey.

Locations that have an encryption key

specified show a key icon to the right of the

name.

Check any location to activate it. If it is

not yet set up, DEVONthink will show a

sheet requesting all necessary details. Only

a subset of the following fields is shown,

depending on the nature of the sync location:
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URL: The URL of your WebDAV volume

including path to the folder where the sync

store is located or shall be created.

User name: The user name for the service.

Password: The password for the service.

Sync Store Name: The name of the sync

store. If you are setting up an already

active sync location, e.g., you've already

synced from another device, click the

dropdown menu to choose from a list of

existing stores.

Encryption password: The password used

to encrypt the sync store with AES 256 bit

encryption.

Synchronize label names & colors: Check

if you want to bidirectionally synchronize

label names and colors using this location.

Be aware, changes to the colors and names

on any syncing machine will sync to the

others.

Synchronize reading positions: Check if

you want to bidirectionally synchronize

reading and playback positions using this

location. This can help you keep your place

in PDFs you're reading or audio/video you're

playing.

Synchronize custom metadata definitions:

Check if you want to sync any custom

definitions found in the Settings > Data

of the higher editions of DEVONthink and

actively used on items in your databases.

If you are collaboratively syncing, you may

want to disable this option to avoid the

other party from receiving your specific

metadata definitions.

Synchronize content of indexed files:

Check if you want to synchronize the

content of indexed files using this location.

If you uncheck this option only the

metadata about the document will be

synchronized. This is generally only used in

special circumstances.

Verify uploaded items: Check to verify all

uploaded items to make sure that they're

intact. Usually only necessary on very

unstable network connections or in case

you experience troubles with defective

files.

Use the tools below the locations list for

more options:

Add Location: Click the + icon to add

locations not listed by default, e.g., adding

another local sync store.

Remove Location: Select a location and

click - to remove the location.

Show Info: Select a location and click to

show and change the location properties.

Action (Locations): The Locations

Action menu also is used for information,

troubleshooting, and removing chosen sync

locations. In addition to Show Info, and

Remove Location, it contains these special

commands:

Reveal in Finder: Opens a Finder window

with the chosen sync store selected. This

only applies to local sync stores.

Verify Location: Used in troubleshooting

situations, this quickly verifies the integrity

of the sync data of the chosen sync

location. Hold the ⌥ key to select Verify

Location Thoroughly.

Clean Location: Used in troubleshooting

situations, this removes the sync data for

all databases synced to the chosen sync

location.

All the commands listed above are also

available via the context menu.
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Note: You can also add existing local

sync stores (packages with the file name

extension .dtCloud) by dragging them into

the locations list, DEVONthink's Dock icon,

or by simply double-clicking them.

DATABASES

The second column lists all currently open

databases as well as all databases available

remotely in the selected location. The

Local section lists all open database and a

message about their sync status, e.g, the

timestamp of the last sync. The Remote

section lists all databases available for import

or databases that are currently not open on

the machine. When attempting to import the

latter, the local database will be opened by

DEVONthink.

Check any database that you want to have

synchronized using the selected location. If

the database is also already available through

the location, both versions of the database

will be merged and conflicts solved using the

chosen conflict solving strategy (see below).

Uncheck databases you want to discontinue

syncing with the selected location.

Note: Unchecking databases does not

remove the sync data from the location.

See the Clean Database command below or

See also p. 191ff

Use the tools below the locations list for

more options:

Import Database: Select a remote

database and click  to download the data

of the database and save it locally. The

database will be automatically configured

to sync with this location. Alternatively,

you can double-click a remote database to

import it.

Synchronize Database: Select a checked

database and click  to manually sync the

database with this location.

Refresh List: Refreshes the list of remote

databases for the selected location.

Action (Databases): The Databases Action

menu also contains commands for importing,

manually synchronzing, troubleshooting, and

removing sync data. In addition to Import

Database, Synchronize Database, and Refresh

List, it also contains these commands:

Import Encrypted Database: Import a

database as an encrypted database. You

will need to specify the maximum database

size and an encryption key. See also p. 11ff 

This option can be used when importing

any database, but it will not encrypt an

unencrypted database on the source.

Verify Database: Used in troubleshooting

situations, this quickly verifies the integrity

of the sync data of the chosen database.

Hold the ⌥ key to select Verify Database

Thoroughly.

Clean Database: Used in troubleshooting

situations, this removes the sync data for

the chosen database in the current sync

location.

All the commands listed above are also

available via the context menu.

Note: If you have specific databases you'd

like to remove from a sync location, e.g.,

old, no longer used or test databases, the

Clean Database command can be used on

select databases in the Remote section of

the Databases list.
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OPTIONS

Change the general sync settings, noting they

affect all locations and databases.

Synchronize: Choose if you want to

synchronize automatically, manually,

or in fixed intervals. Check On Quit or

Deactivation to automatically synchronize

when you quit DEVONthink or when you

switch to another application.

Max. Connections: Choose the maximum

number of connections DEVONthink

should open. The faster your internet

connection the higher you can usually go.

The recommended value is 16.

Conflicts: Choose how to solve the conflict

if an item was changed both locally and

remotely. Use latest document preserves

the most recently changed document.

Duplicate documents keeps both versions

of the conflicting item and appends "copy"

to the end of one's filename.

Note: The number of maximum

connections used is controlled by the

service you're using.

BONJOUR OPTIONS

Click the button Bonjour Options to control

if and how other instances of DEVONthink or

DEVONthink To Go can connect to your Mac.

Your Mac becomes the sync host or sync

server, the other devices the clients.

Enable incoming connections: Check to

let other devices connect to your copy of

DEVONthink and synchronize.

Open databases automatically: Check

to open databases automatically if the

connecting side (client) requests it.

Port: If needed you can change the IP port

number used for incoming connections.

Leave empty to let DEVONthink choose the

best port number for you (recommended).

Password: Set the password necessary to

connect to your instance of DEVONthink

(mandatory). This password is also used for

AES-256-bit-encrypting the connection at

all times.
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TROUBLESHOOTING
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DEVONthink was created with robustness

in mind. But any computer hardware or

software, regardless of how carefully

developed and built, can write defective data

or destroy files. If you have some general

questions about DEVONthink, sales and

licensing, etc., plase check out our Questions

and Answers section on our site. If you

experience specific technical problems with

DEVONthink or its databases, please check

the following sections.

PROBLEMS IMPORTING FILES

WHY DOES DEVONTHINK NOT RECOGNIZE

MY FILES?

If DEVONthink does not recognize a file, make

sure the file has a proper file name extension.

DEVONthink needs a file name extension to

determine the file type. Add the correct file

name extension to your files (e.g., .txt for

plain text files, .rtf for rich text files, .pdf

for PDFs and .doc for Microsoft Word files)

and try again.

Also, while DEVONthink supports importing

many different file types, there are

thousands of types and we can't guarantee

trouble-free importing or usefulness with

every type.

WHY DOES DEVONTHINK NOT DISPLAY MY

DOCUMENT CORRECTLY?

DEVONthink uses Apple's Quick Look

technology to display previews of many

file formats. If a document is not properly

displayed, especially if it is a proprietary file

format, it may be you don't have a Quick

Look plugin installed for this file type or

the application that created the file is not

installed on your Mac (and supports Quick

Look). Control-click the file and choose Show

In Finder to reveal it. With the file selected

in the Finder, press the spacebar to open a

Quick Look window to determine if the item

is viewable.

WHY CAN'T I SEARCH MY FILE?

Merely importing a file doesn't mean it's

immediately searchable. For example, scan

need to be treated with OCR before they can

be searched.

For proprietary formats, you need to

have a Spotlight importer installed. These

components come from third-parties,
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typically the developer of the format or

an application that can edit it. If there is

a Spotlight importer available for the file

format you're adding to your database,

DEVONthink may be able to use it to gather

some information about the document. The

kind and amount of information is dependent

on how the importer was developed.

WHY ISN'T MY PDF WORKING?

Bad PDFs: PDFs have been around so long,

it would seem they'd be easily supported in

DEVONthink. However, the truth is there are

many bad PDFs out there. If you encounter a

bad PDF, try acquiring a new copy of the file.

No Text: You will receive a "No Text" log

message with PDFs having no text layer, i.e.,,

scans that have not had OCR run on them.

In order for their text to be searchable, you

must run OCR on them.

Protected PDFs: DEVONthink cannot extract

the text part of print- or edit-protected

PDFs. When you import these PDFs, you get a

log entry that tells you that the file contains

"no text". When you select these PDFs in

DEVONthink, the status bar shows Image

instead of PDF+text.

One potential solution for this problem is

Michele Balistreri's PDFKey. It allows you to

print protected PDFs. Use PDFKey to "print" a

PDF file into a new PDF that is both printable

and editable, which allows DEVONthink to

extract the text for searching and classifying.

Note: There are sometimes questions

regarding the PDF functionality available

in other applications. DEVONthink uses

Apple's PDFKit framework, the same as

found in their Preview application. If you

have an issue with a PDF in DEVONthink,

check to see if you have the same issue

in Preview. Other applications, including

those from Adobe where PDFs were

invented, are using their own frameworks.

EMAIL IMPORT DOES NOT
WORK AS EXPECTED

Messages aren't imported or can't be filed:

Email messages are imported with a special

identifier (UUID) that helps DEVONthink

keep track of messages that have already

been imported. Since a UUID must be unique,

you can't have more than one file with that

identifier. If you try to import the same

message into a database, you will receive

a logged message stating "n emails already

imported".

Importing takes a long time or stalls:

Importing email is not a trivial process. Not

only does it copy the message into your

database, but it also reads and analyzes

the entire contents of each one. If you are

importing a large mailbox, the process could

cause a timeout.

To increase the timeout to five minutes,

please enter this in /Applications/

Utilities/Terminal.app (each as a

separate command) while DEVONthink is not

running:

Terminal:

$ defaults write com.devon-

technologies.think3

MailImport.FetchTimeout -float 300

DEVONthink 3.9.17 Documentation, page 188

https://pdfkey.com/


$ defaults write com.devon-

technologies.think3 MailImport.Timeout -

float 300

Another possibility is to split the mailbox

into multiple smaller ones. Lastly, you don't

have to import the entire mailbox at once.

Importing smaller batches often proves to be

less taxing on the machine's resources.

Why can't I import from email application

X?: Inter-application communication,

something at which DEVONthink excels, isn't

universally developed. In order for more true

automation between applications to occur,

the developers need to implement robust

and reliable mechanisms, like AppleScript.

Some apps may provide simple URL schemes

but they are limited in use and capabilities,

often only able to process one file at a time.

Better results can usually be had by merely

dragging and dropping. For email clients with

a good AppleScript dictionary, the potential

for streamlined workflows is increased.

Note: If you are running macOS Mojave or

later, you will need to give permissions for

the Apple Mail plugin to access your email.

Quit DEVONthink.

Quit Apple Mail.

Enable Full disk access in System

Settings > Privacy > Security for

DEVONthink.

Launch DEVONthink and install (or

reinstall) the Mail plugin from the

DEVONthink > Install Add-Ons.

Launch Apple Mail and enable the plugin

via Apple Mail > Preferences > General >

Manage Plug-ins.

UNLOCKING A DATABASE

If you open DEVONthink and see an icon of a

crossed pencil to the right of the database's

name, the database has a file permissions

issue. This makes the database readable,

but not writeable, so you can't modify the

contents in any way.

A permissions issue like this uncommon

but generally caused by three events, in

order from most to least common: restoring

from Apple's Migration Assistant, restoring

from Time Machine, or an operating system

or hardware error. Doing things like using

Migration Assistant will not always cause a

permissions issue, but if you have a crossed

pencil icon and you've recently migrated to a

new machine, this would be the likely cause.

To resolve the issue, do this:

Step 1: Close the database in DEVONthink.

Step 2: Locate your database. If it's the

Global Inbox, it's located in ~/Library/

Application Support/DEVONthink. For

other databases, do a Spotlight search for

kind:database dtBase2.

Step 3: Select the database file and press

⌘I to show the Info pane.

Step 4: At the bottom, you'll see Sharing &

Permissions. Click the lock icon to unlock

it. You will be prompted to enter your

administrative password. (This is the

password you use to log into your account

on your Mac.)

Step 5: Make sure the account marked

(Me) is set to Read & Write.
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Step 6: Click the Action menu and choose

Apply to enclosed items, if it is available,

then close the Info pane.

Step 7: Double-click the database file to

reopen it in DEVONthink.

If this does not resolve the issue, please

contact our support team.

PROBLEMS USING SERVICES

WHY DO THE SERVICES MENU COMMANDS

SHOW NO SHORTCUTS?

They should; however, the keyboard shortcuts

for Services menu commands are only

requested by the supplying application.

macOS assigns these shortcuts and has

ultimate control over which application

or service gets what. If the DEVONthink

Services menu items do not have shortcuts

assigned, it is likely that macOS assigned

these shortcuts to another command, or

that they are used by the current active

application.

WHY DO SPECIFIC SERVICES NOT APPEAR

IN THE MENU?

The operating system relies on information

supplied by the current application to

determine which services should be shown

in the Services menu. For some applications,

often those developed for both Mac and

Windows, this information may not be

what's anticipated. When this occurs, certain

services may not be present. For example,

selecting text on a web page in Firefox will

display the service DEVONthink: Take Plain

Note. The same text on the same page

in Safari will show that option as well as

DEVONthink: Take Rich Note.

Another thing to be aware of, there needs to

be enough space available to do maintenance,

like a database rebuild. To keep an eye on the

space, periodically select it in DEVONthink,

then choose File > Database Properties. At

the bottom of the statistics you will see the

space consumed and the available space to

work with.

SYNC ISSUES

DEVONthink's synchronization was designed

to run in self-maintenance mode. If you are

having issues syncing your DEVONthink

databases, the first place to look is Windows

> Log. Most sync related errors and reports

will be shown here.

Below we cover some things you can check

for the type of sync method you're using as

well as some common questions you may

have.

THINGS TO TRY FIRST

Here are a few general things to try when you

have a sync issue:

Check your network connections, including

trying to log into a remote service.

Reboot the computer

For non-Bonjour and non-iCloud sync

locations, make sure you're entering the

correct store name. When logged into

a remote service, the Sync Store Name

dropdown should list available sync stores

to choose from.
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Make sure you're using the correct

encryption key value for the sync location.

See also p. 193ff

Make sure you have sufficient space for

sync data, especially when using cloud

accounts.

VERIFY & CLEAN

Verifying: If there is an issue reported with

syncing, e.g., broken structures or missing

manifests, you can verify the sync data to

see if it's intact and consistent. Verification

is a good first step in these cases. The results

of a verification will be reported in the log

window.

Cleaning: If the verification fails, you can

clean the sync location or database to

remove the sync data in that location. The

results of the clean will be reported in the

Log window. After a successful clean, you can

upload the database(s) again.

Note: To ease anyones' mind, cleaning a

sync location has no effect on the local

databases on your devices. Sync data is

not your database and is separate from the

local databases on your devices, Mac and

mobile.

To verify or clean sync data, open Settings >

Sync and…

Sync Location: To clean or verify all

the sync data from a specific location,

Control-click it and choose the appropriate

command. For a verification you can

hold the ⌥ Option key and choose Verify

Location Thoroughly to perform a deeper

verification of the sync data. For a remote

sync location, there may be a pause while a

connection is established.

Database: To clean or verify the sync data

for a specific database, select the sync

location to display the databases list.

Control-click the specific database and

choose the appropriate command. For a

verification you can hold the ⌥ Option key

and choose Verify Database Thoroughly to

perform a deeper verification of the sync

data. Repeat this with any databases, as

needed.

Both these actions can be used at any time,

for preventative purposes or just to get a

fresh start with syncing. Also, you may see

unwanted databases in the Remote section

of the databases list for a sync location.

Cleaning the location will remove these

databases too. But if you want to keep the

sync data for your current databases, you can

Control-click and clean specific databases in

the Remote section.

BONJOUR

Bonjour syncs are generally transparent,

but it can only be used on a local network

that allows Bonjour traffic and non-standard

ports. Many public networks disallow this

kind of traffic to protect their customers.

Also, corporate networks will often disallow

this traffic for security reasons.

Note: Bonjour connections cannot be used

over VPN. This is technologically infeasible,

at least at the moment.
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Make sure you have entered the same

password that you have set in the server

Mac's Bonjour options. See also p. 183ff

Make sure DEVONthink is running on the

other Mac or iOS device and both devices

are awake.

Make sure only one device is acting as the

Bonjour server for a given database. You

should not have two devices with incoming

connections enabled trying to serve the

same databases.

Make sure the databases you want to

synchronize are open on the other Mac, or

enable Settings > Sync > Bonjour Options:

Open databases automatically on the

server Mac.

Restart the other Mac, the iOS device, or

both.

Make sure this computer is connected to

the same network as the other syncing

device.

Make sure any firewalls or applications

like Little Snitch are allowing traffic from

DEVONthink.

Check if there are any routers or switches

involved. The more switches and routers

the less reliable the connection due to

port filtering, conflicts, or other unknown

factors.

Restart your router.

If you find yourself on a network that

disallows Bonjour syncing, it is possible to

connect your iOS device to your Mac via your

Lightning cable. This creates a simple ad-

hoc network that will allow Mac-to-mobile

syncing. If you are in a corporate situation,

please discuss this with your IT department

to ensure you're not violating any security

policies. They may also issue an exception

for a specific port you could use for Bonjour

syncing. This port would be entered in the

Port section of the Bonjour options.

ICLOUD

Since your devices are generally signed into

your Apple ID, using iCloud for syncing is

the easiest to set up. However, it should be

understood it can only be used for personal

syncing. Collaborative syncing is not possible

unless all participants are sharing an Apple ID.

Also, syncing to iCloud is done locally first,

the operating system will then upload the

changes to Apple's servers and propagate

the information about it to all other devices.

It generally happens smoothly and in the

background but it means you can't expect the

changes to be ready on other devices as soon

as DEVONthink has finished synchronizing to

iCloud.

Here are a few things to check:

Make sure you have enabled DEVONthink

in System Settings > iCloud > iCloud Drive >

Options on each device.

Make sure all syncing devices are logged

into the same Apple ID.

Note: Be aware iCloud can stall. This is a

sporadic, but documented, issue that can

cause your devices to get out of sync. This

is not under our control, nor can we even

detect it. Please try a thorough verification

of the sync location first. For further help,

contact our support staff for assistance.
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WEBDAV

Our support for WebDAV services allows

you to use cloud services that are WebDAV-

enabled. It also presents some self-hosting

options, even with some NAS devices.

However, they can sometimes be technically

more difficult to implement. Here are some

things to check:

Make sure the service or device you're

trying to connect to is reachable. This is

especially true when self-hosting. If you see

errors in the 500 range in the Log window,

it's a problem with the remote server.

Make sure you are using the proper

protocol in the URL, http:// or https://.

Make sure the URL is complete. This will

be specific to the device or service you're

using. For a Synology NAS, for example,

you have to add the target volume to

the path (a valid URL would look like:

http://diskstation.local:5005/

research). Refer to the service or

manufacturer's instructions for the proper

URL construction.

Make sure you have entered your user

credentials correctly.

Note: WebDAV implementations vary so

it's not possible to guarantee compatibility

in all situations. For self-hosting, Apache

implementations are the most compatible.

DROPBOX

Dropbox is our longest supported sync

method and is generally reliable and a good

performer. However, there are a few things to

consider.

According to Dropbox' rules, you cannot sync

across user accounts. You also can't share

the Apps folder between accounts. Also, they

only allow our sync engine to be logged into

one Dropbox account at a time. If you have

a work and a personal account, you can only

sync to one with DEVONthink.

Log into your Dropbox account to make

sure it's reachable. If you see errors in

the 500 range in the Log window, it is a

problem with the remote server.

Make sure you are connected to the correct

Dropbox account. The active account will

be shown under the sync location's name in

the sync preferences.

Collaborative syncing may be possible using

a common Dropbox account, i.e., using the

same username and password for syncing.

But again, you can only sync to one active

Dropbox account at a time.

COMMON QUESTIONS

I enabled the sync and nothing's happening:

Our sync engine will not sync, upload or

download, without being told to. We believe

in opt-in processes whenever possible.

Merely enabling a sync location just sets up a

location to be ready to receive and transmit

data. You need to enable individual databases

to sync. If you have enabled databases to

sync, check Window > Log for errors.

I'm seeing a message about an invalid

encryption key: When you set up a sync

location, you have the option of entering an

encryption key. This is used to scramble and

descramble the sync data so it's stored in an

encrypted state. Once you've synced the first

time, this value, even if you aren't specifying
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a key, is stored for that sync location. This

value must be entered on other devices

syncing with this sync location.

You can't add, remove, or modify the

encryption key value for a sync location

after the first sync. If you want to make a

change, you must clean the sync location

first. After, the clean, Control-click the sync

location again, choose Show Info, and make

the modification to the key. After the first

sync, this will be the value stored for the

location. Remember, you must change the

value on the other syncing devices. And no,

you do not need to do the clean on the other

devices before changing the value.

I am seeing a message about missing

manifests: Missing manifests are bits of

transactional sync data that cannot be

located by the sync engine. When this occurs,

it can't validate the information about what

has been synced. This is not an issue with the

databases. See the Verify & Clean section

above regarding verifying and cleaning the

sync data.

It's telling me I have a duplicate database

UUID: As noted in the glossary, a UUID is

a unique value given to all DEVONthink

databases. If you copy and rename a

database file in the Finder, this UUID is

preserved and DEVONthink sees two

databases with the same UUID. This will not

sync correctly. Please contact our support

team for assistance on resolving this.

REPAIRING A DEFECTIVE
DATABASE

DEVONthink databases are packages

containing of your files and the supporting

AI-based index. In rare cases this index can

get corrupted or out-of-sync. But as your

files are stored separately, this is not the

end of the world. If your database starts

behaving strangely, or if DEVONthink finds

inconsistencies during start-up, it is time for

some housekeeping.

First we'll deal with the two common terms

you'll see in a repair process: missing and

orphaned files. Then we'll give you steps to

try and restore some order in your databases.

MISSING FILES

All documents in a DEVONthink database

have a path the file system where their

content file is located. This path is stored

for every document, imported or indexed. If

DEVONthink can't find a file at a path stored

in its index, it will be reported as missing.

The most common cause of missing files is

indexed files being moved in the Finder, or

the indexed parent folder being renamed. In

the first case, the file isn't in the location it

was indexed from. Moving the file back into

place will resolve this issue. In the second
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case, the path no longer exists as the names

in the path have changed. Changing the name

back will resolve this.

Regarding indexed items, it's also possible

for out-of-date items to be reported as

missing, especially in cloud-synced locations.

Remember that items indexed in cloud-

synced locations may require a manual

update via File > Update Indexed Items since

a filesystem event may not be triggered by

the cloud software. Also DEVONthink tries to

make sure it doesn't cause any conflicts with

those applications.

The second most common cause of missing

files is people modifying the internal contents

of a database. Some Finder replacement

applications, like PathFinder, allow you to

access package files like normal folders.

The internals can also be accessed by other

methods, like the command line or the

Finder's context menu. If you delete or

reorganize anything, you can easily cause

missing files.

Dealing with missing files: Missing files are

reported in DEVONthink's Window > Log. To

deal with these files, Control-click the item

in the Log window and choose one of two

options:

Reveal: Reveals the item in the expected

location in the database. If the View/Edit

pane is visible, the expected file path is

shown beneath a document thumbnail.

This path is especially useful when dealing

with missing indexed files as it shows the

path in the Finder from which the file was

indexed. If the path shows the file inside

a Files.noindex directory, you may use the

following option if the file is of no concern

or contact our support team.

Move to Trash: If the missing file is of no

value to you, this command moves the

file to the database's Trash. Then choose

the DEVONthink > Empty Trash command

to completely remove the file from the

database.

ORPHANED FILES

Just as with any database application,

controlling the data flow in and out is a

critical process. DEVONthink should be the

gatekeeper of the files in its databases. If an

external agent, whether and application or

a user, adds files outside DEVONthink, they

will cause an internal inconsistency and lead

to orphaned files when following the steps

below.

The most common cause of orphaned files

is a simple and common one: attempting to

create revisions. Say you open a file, a Word

document, in an external application. As

you are reading it, you decide to make some

changes. You type your edits, and select File

> Save As (or File > Duplicate the file first).

The application most commonly will open

the Save dialog in the location of the original

file, in this case, inside the internals of the

database. You have just created an orphaned

file DEVONthink knows nothing about. So the

question becomes, how do I create a revision

without causing this issue?

Duplicate: Duplicate the item in

DEVONthink first.

Rename: Rename the duplicated item.

This can be quickly done by immediately
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pressing ↩ Return, typing the change, then

pressing ↩ again.

Open and Edit: Now you can open the new

file and make your edits.

The other common cause is the same as

with missing files: getting into the database

package and adding files manually.

Note: Modifying the internal contents

of a database outside DEVONthink is

unsupported behavior and can lead to

broken or inconsistent databases. You

should only get into a database's internals

when instructed to by our support team.

FILE INTEGRITY

Another report you may see in the

Log window is regarding file integrity.

DEVONthink scans and stores a SHA1

checksum for each file in a database. This

value is updated as the files change. However,

if you use the utility command File > Check

File Integrity, it may report an integrity error.

This means the stored checksum doesn't

match the newly scanned checksum. This

may indicate a problem with the file itself.

However, this error will also be reported for

indexed items that are not up to date.

STEP 1: VERIFY & REPAIR

As a first step, use >File > Verify & Repair

Database to check your database's

consistency and allow DEVONthink to take

all necessary steps to repair any discovered

problems. This check will include reporting

any missing files, as discussed above, and

importing any orphaned files. If Verify &

Repair Database was able to repair your

database, use File > Optimize to optimize

your database and have DEVONthink create

an internal copy of the index.

Note: Verify & Repair isn't just for

emergencies. Running this command on an

occasional basis is not a bad idea. In fact,

if you're a fairly heavy user of DEVONthink,

running it weekly or bi-weekly does no

harm. It's just a routine checkup.

If Verify & Repair was not successful or your

problems are not resolved, proceed with the

next step.

STEP 2: RESTORE FROM BACKUP

DEVONthink keeps up to two copies of the

index files in case that the index is damaged

beyond repair.

To restore the index file(s) from a previously

saved internal backup, hold the ⌥ Option key

and select File > Restore Backup. DEVONthink

presents you with a list of all available

backups. Choose the latest one and click

Open. This swaps the current set of index

files with the chosen backup metadata

(the current set of index files becomes the

backup, the backup becomes the current set)

so that data is never overwritten. Run File >

Verify & Repair to check the consistency of

this index version and if everything is in the

right order use File > Optimize to optimize

your database and have DEVONthink create a

fresh internal copy of the good index.

If the backed-up index files are also defective,

try the other backups, if available. If all

backups are broken or corrupted, proceed

with the next step.
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STEP 3: REBUILD YOUR DATABASE

Since your files and DEVONthink's index

are stored independently within the

database package, the index can be rebuilt

at any time without you losing metadata.

However, we generally only suggest this when

troubleshooting a database issue.

To rebuild the database from scratch, use

File > Rebuild Database. During the rebuild

process, the index is completely recreated.

Your actual files are not touched. Any

problems that occur during this process are

logged. Also, a new backup metadata set will

be created at the beginning of the rebuild.

STEP 4: RECOVER OR MANUAL REBUILD

If everything above failed, your database is

severely damaged. You have basically two

options:

Time Machine: Restore your database from

your Time Machine backup or whichever

backup medium you use. If you don't use

Time Machine, we strongly advise you to do

so. External hard disks are cheap, and Time

Machine makes backing up your important

files quick and simple.

Manual Rebuild: If you find yourself in the

unfortunate situation where you have no

backups, it may be possible to rebuild your

database manually, following these steps:

Locate the database (.dtBase2 file) in the

Finder.

Rename the file by adding, e.g., an xto the

beginning of the name.

Control-click the database and choose

Show Package Contents in the context

menu.

Copy the most recent backup folder where

your database is located.

Copy the Files.noindex folder into the

copied Backup folder.

Rename the copied Backup folder to the

previously used name and add the file

extension .dtBase2, okaying the extension

when prompted.

Double-click the new database file to open

it in DEVONthink.

Use File > Verify & Repair to ensure that the

database is operating properly.

STEP 5: CONTACT SUPPORT

If none of the above steps helped solving

the problems you have with your database,

please contact us with a precise-as-possible

description of your problem.

Note: In a worst case scenario, if you do not

have a current backup of your documents

and a manual rebuild didn't work, you can

rescue your files manually, but you will lose

any group structure. To manually copy your

files from the defective database, show the

database package in the Finder, Control-

click it, and choose Show package contents

from the context menu. Copy the files in

the Files.noindex subfolder, which are

sorted by kind, to a safe location, e.g., the

desktop. If you want, you can create a new

database, re-import the files, but you will

have to rebuild the database's structures,

tags, etc.

DEVONTHINK CRASHES

If DEVONthink crashes while it's running,

please hold the ⌥ Option key and choose

Help > Report Bug.
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If DEVONthink crashes on startup, there is no

opportunity for you to use our bug reporting

mechanism. However, you can manually

retrieve the crash logs:

In the Finder, hold the ⌥ Option key and

select Go > Library.

Open the Logs/DiagnosticReports folder

and locate the most recent crash report for

DEVONthink. (The date and time is in the

filename.)

Attach the crash log when you start a

support ticket.

In either case, please try to reproduce the

crash before reporting it. Also provide enough

detail about what you were doing at the time

of the crash.

DEVONTHINK BEHAVES
IRRATIONALLY

No software on this planet is bug-free, and

if an application behaves irrationally there

is a good chance that your have just found a

bug. But there could also be another cause:

The application package could have become

damaged during an update or through a bug

in a totally unrelated piece of software on

your computer.

STRANGE APPLICATION BEHAVIOR

If you see odd behavior like

menus disappearing or silently refusing to

do anything,

windows showing graphical artifacts,

or applications not opening at all or

opening with strange error messages,

the first step is to reboot the machine.

If that doesn't resolve the issue, try deleting

DEVONthink's preferences files. Please quit

DEVONthink, launch Terminal app, and enter

this:

Terminal:

$ defaults delete com.devon-

technologies.think3

Note: Rebooting a machine can often

cure a host of issues, closing down rogue

processes, releasing memory, etc. We

suggest rebooting your devices at least

once a week, just to mitigate potential

issues.

STRANGE BEHAVIOR RELATED TO

DOCUMENTS

If the strange behavior only happens with

a particular document, it is possible the

document is damaged, was created in a very

old or extremely new file format that is no

longer or not yet properly supported, or uses

a damaged or malfunctioning Quick Look

plugin.

Please file a support ticket and attach

the document in question, packaged as

a .zip archive, so that we check to see if the

problem lies with DEVONthink or if it the file

itself.

SLOW OPEN AND SAVE
DIALOGS IN THE FINDER

If you find the Open or Save dialog in

applications on your Mac are opening or

performing slowly, it may be that you have

too many tags in your system. Having 5000

tags or more in your filesystem can cause the

Finder to stall as it tries to process them.
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As noted in the Finder Tags and Tagging

Sources subsections, tags can come from

several sources. These tags can also be added

to your Finder tags, perhaps unknowingly.

Tags are added to the Finder tags from

DEVONthink in one of three ways:

Indexed files: If you're indexing files,

any tags you apply in DEVONthink are

automatically applied to the files in the

Finder. This behavior can be prohibited

by enabling the hidden preference

DisableFinderTags, but bear in mind this

will also inhibit importing Finder tags as

well.

Spotlight Index: In the Database Properties

popover for a given database, there is a

Create Spotlight Index option. If this is

enabled, DEVONthink includes tags as part

of the Spotlight metadata, enabling you to

use Spotlight searches like tags:support

in the Finder. However, this also adds to

the tags processed by the Finder. If you

disable the Spotlight index for a database,

the tags for that database will immediately

be removed from the Finder tags,

Exporting files: If you export files to the

Finder, the tags are added to the Finder

tags as they're part of the metadata of

the files. The exports include using the

File > Export > Files and Folders command,

drag and drop from DEVONthink to the

Finder, or doing a File > Rebuild Database.

This behavior can again be prohibited by

the hidden preference mentioned above

regarding indexed files.

Deleting tags in the Finder: While disabling

the Spotlight index for a database will

immediately remove Finder tags from the

system, the other options will not remove

tags from the Finder.

In the Finder, press ⌘-, to open the

preferences. Select the Tags view. Here you

will see a complete list of Tags recognized

by the Finder. Select the tags you want to

remove and press the minus button. You

will be prompted to approve the deletion.

Note: This does not remove any files. It only

removes the tags.

If you have checked the appropriate sections

and didn't find your issue or a resolution,

please do the following: Hold the ⌥ Option

key and choose Help > Report Bug. This

creates a draft email, ready to send to us,

containing troubleshooting information and

logs.

Note: The industry standard turnaround

in software development is 48 business

hours, i.e., weekends excluded. However,

we usually respond earlier. Thanks for your

patience and understanding.
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Automation. No matter how efficient we

are, there is always some process that could

be done more quickly, and sometimes more

accurately. This may be as simple as renaming

a file, or as complex as filing, emailing, and

archiving. While not everything can be

automated, and careful thought should go

into your automation plans, DEVONthink

offers a level of automation capabilities rarely

rivaled in other Mac applications.

AppleScript: Most of DEVONthink is built

on a solid foundation of AppleScript. Not

only used in the scripts you can install from

DEVONthink > Install Add-Ons, they are

also at the core of several pre-installed

templates. Additionally, in conjunction with

other AppleScript-enabled applications,

the potential for automation on your Mac is

extraordinary. This mature but easy to learn

technology is the one we will focus on. See

also p. 201ff

Smart Rules: DEVONthink also offers

a technology for those with little to no

programming experience: smart rules. Smart

rules are conceptually similar to smart groups

but allow you to choose pre-defined actions

to take on matched items. This makes them

accessible to all users, while still providing

AppleScript execution in the smart rules.

They also allow automation based on events.

See also p. 210ff

Item Links: While not an automation

technology in itself, item links are item-

specific identifiers in DEVONthink that can

be used in automation. Providing a way to

refer to files by a unique and unchanging

value, they can help avoid automation

problems when items are moved or renamed

in your databases. See also p. 218ff

JavaScript: In addition to AppleScript,

JavaScript for Automation (JXA) is

supported. However, it is bridged by the

operating system from AppleScript,

not specifically coded for. We advocate

AppleScript for its ease of use by new and

less-experienced programmers.

On a side note, our AppleScript dictionary

has a do JavaScript command you can use

to interact with web content viewed in a

DEVONthink window. With a bit of creativity,

some pretty amazing things can be done!
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AppleScript Objective-C: This is supported,

for those who are inclined that direction.

Terminal: For those who are into other

technologies, like Python, bash, Ruby, etc.,

the question arises: Is there a command line

interface (CLI) for DEVONthink? The answer

is no. However, you can still use a do shell

script command in AppleScript when needed.

Actually, the combination of the shell and

AppleScript creates even more opportunities,

as their individual strengths compensate for

the other's weaknesses.

APPLESCRIPT

AppleScript is an automation technology

introduced by Apple in 1993. Over the years it

has matured and become the friend of many

Mac users wanting to exert more control over

their computing experience. Written in an

easy to learn, almost conversational language,

it offers a tremendous amount of power with

less effort than many languages. DEVONthink

has very robust AppleScript support and

comes with many built-in scripts. These, and

those you write or obtain, make it possible

to automate nearly every aspect of the

application, and to integrate the application

with almost every other macOS application

that supports AppleScript.

INSTALLATION

Add-On Scripts: All add-on scripts that

come with DEVONthink are automatically

installed or updated when you open a new

version of DEVONthink for the first time.

You can, however, manually (re-)install them

by choosing DEVONthink > Install Add-Ons.

The scripts from this panel are installed in a

number of locations:

Script Menu Extra Scripts: These scripts

are accessed from the global Script menu

when you are in specific applications, e.g.,

Safari. They are installed in an application-

specific subfolder of ~/Library/Scripts/

Applications. See also p. 214ff

Folder Action Scripts: These scripts are

used to created hot folders in the Finder.

They are installed in ~/Library/Scripts/

Folder Action Scripts. See also p.

216ff

Apple Mail Rule Scripts: These scripts

for use with Apple Mail Rules. They are

installed in ~/Library/Application

Scripts/com.apple.mail. See also p.

213ff

DEVONthink Scripts: The internal scripts

found in DEVONthink's Scripts menu are

installed in ~/Library/Application

Scripts/com.devon-technologies.think3.

The scripts will be found in one of four

directories:

Menu: These are the scripts found in

DEVONthink's Script menu. See also p.

205ff

Toolbar: These scripts are available to add

as toolbar buttons. See also p. 207ff

Reminders: These scripts will be executed

when a reminder is triggered with an alarm

of Execute External Script. See also p.

206ff

Smart Rules: These scripts are used as

External Scripts in the actions of smart

rules. See also p. 210ff
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Additional scripts, like those you write

yourself, can be put into any of these

folders to be used in these contexts. Other

scripts that may include integration with

DEVONthink can be located wherever it's

convenient.

SCRIPT SHORTCUTS

Many people like mousing around their

applications, while others like to use their

keyboards. If you want to add keyboard

shortcuts to scripts in this menu, you have

two options:

System Preferences: Open System

Settings > Keyboard > Shortcuts > App

Shortcuts. Add a shortcut for DEVONthink,

enter the exact name of the menu item,

and assign a hotkey.

Append Filename: Locate the script in

the Finder and append three underscores

followed by abbreviated command keys and

characters. For example, eMail Current

URL___Cmd-Alt-F2.scpt. The command

key abbreviations are as follows: Cmd

stands for the ⌘ Command, Alt or Opt for

the ⌥ Option, Ctrl for the ⌃ Control, and

Shift for the ⇧ Shift keys.

Note: When using macOS Mojave, you

will often be prompted by the operating

system to allow applications to "control"

on another. These permissions are stored

in System Settings > Security & Privacy >

Security > Automation. Please make sure to

allow any requests of these kind regarding

DEVONthink's control of other applications

or your automation attempts will fail for

obvious reasons.

LEARNING APPLESCRIPT

While this documentation is not an

AppleScript language guide, all the scripts

that come with DEVONthink are editable

and can be explored or modified as you see

fit. The separate sections in this chapter

provide any required terminology and a

simple example script or two. Additionally,

there are some great resources available

online and in print. For the official archived

documentation, refer to Apple's AppleScript

web site. Some additional resources are listed

below:

Online:

DEVONtechnologies Community

MacScripter

AppleScript, the Language of Automation

TECsoft Hands-On Trainings

Books:

AppleScript: The Missing Manual

AppleScript: The Definitive Guide

BASIC APPLESCRIPT
TERMINOLOGY

AppleScript is not a difficult language

to learn. Its plain English approach of

"talking" to applications and elements is

easily understandable. However, like any

language, there are some variations in the

words you can use; dialects, if you will.

AppleScript is implemented by the developer

of an application, so the commands and

parameters may be conceptually the

same as another application's, but using a

different term. This is certainly not meant

to be a complete guide to AppleScripting
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DEVONthink, but what follows are some

common terms or concepts you're likely to

encounter. The examples here and in this

chapter are meant to give you basic ideas

about scripting DEVONthink.

TALKING TO DEVONTHINK

In AppleScript you "talk" to programs like

DEVONthink using a tell statement,

typically referring to an application

either by its name, "DEVONthink 3",

or its bundle identifier, "com.devon-

technologies.think3". While these forms

will work, they might become incompatible

with a future version, e.g., DEVONthink

4, so we strongly recommend to talk to

DEVONthink using the application ID DNtp,

like in the following statement:

Example:

tell application id "DNtp"

close current database

end tell

DEVONTHINK'S DICTIONARY

AppleScript-capable applications have their

commands, elements, and properties listed

in an AppleScript dictionary. DEVONthink

includes a large dictionary as a great

reference for you. To view the dictionary,

open the Script Editor application, select File

> Open Dictionary and choose DEVONthink

in the appearing window. You can also add

DEVONthink to your Script Editor library.

Select Window > Library, click the + button

and choose DEVONthink. This way you keep

DEVONthink's dictionary at hand.

Note: The use of the is almost always

optional, but including it can make the script

seem a bit less robotic. For example, both

lines in this script are functionally the same:

Example:

tell application id "DNtp"

set state of children of current group to

true

set the state of the children of the

current group to true

end tell

As noted above, the dictionary is the best

place to find specific terminology to be used

with DEVONthink. However, here are two

things to understand:

Records: Every item in a DEVONthink

database is a record, a record with

properties. Do a search for "record" in the

dictionary and you'll see it's a fundamental

unit with a wide range of properties

associated with it. This means you won't be

writing code like, get the second rich

text file…. You will be dealing with records

with a particular type, in this case rtf.

There are many commands specifically for

use with records: create record with,

exists record with…, etc. Also note there

are some commands that require the term

record. For example: move, delete, and

convert. You will see a dictionary listing move

record, so you can see the command isn't

merely move, it's move record.

Parents and Children: Another concept to

understand is parents & children. Generally

speaking, these classes deal with the

container or the contents of some object.

The parent of an object is the group

containing it. The children of a group are
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the immediate contents of that group, i.e.,

it does not list the children of sub-groups.

Children can be documents or groups;

parents will only be groups.

Example:

tell application id "DNtp"

set thisGroup to current group

name of (the children of thisGroup whose

(type is XML))

end tell

USING LOCATIONS

One of the common tasks people want to

perform with AppleScript is importing files

to a specific group. In order to direct the files

to a given location, you need to reference it

properly. Below are three general options for

choosing a location:

incoming group: This targets the Global

Inbox, or the inbox of a database when

using incoming group of current

database.

current group: This targets the currently

selected group in the current database.

display group selector: This shows the

group selector so you can choose a location

on demand.

There are many times you want to direct files

into a specific group. That group may not

be the current group you're in and you may

not want to choose a destination each time.

Here are two common ways of specifying

a particular group in your database to be a

destination group in your script:

get record at…: This command allows you

to set a variable by specifying a group's

location in your group structure. The

location is a text string, always beginning

with a forward slash denoting the root of

the database.

get record with UUID…: When using an

item link, you can use the alpha-numeric

string from the reference URL to point to

a specific item. (This command works with

both groups and documents.) This form is

very useful since it doesn't change when an

item's name or location changes.

Example:

tell application id "DNtp"

set myGroup to get record at "/Inbox/New

Files"

import "~/Desktop/001.txt" to myGroup

set groupTwo to get record with uuid

"98BBF96D-7743-46C6-9EB4-51C6EF68373C"

import "~/Desktop/002.txt" to groupTwo

end tell

WORKING WITH A SELECTION

Many times you want to process items

you have selected in DEVONthink. Perhaps

you want to generate a list of names and

dates for use in a document you're working

on. Below is a handler commonly seen in

DEVONthink scripts:

repeat with thisRecord in (selection as

list) … end repeat: This is a very common

handler, used when processing a selection,

single or multiple items.

Example:

tell application id "DNtp"

if selection is not {} then

set nameList to {}

repeat with thisRecord in (selected

records)

copy ((name of thisRecord) & ": " &

(creation date of thisRecord as string) &

return) to end of nameList

end repeat
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create record with {name:"Files",

type:text, content: (nameList as string)}

in incoming group

end if

end tell

INTERNAL SCRIPTS

The Scripts menu of DEVONthink, located to

the left of the Help menu, gives you access

to a large number of pre-made scripts, with

more scripts available. These scripts are not

only useful for every day use, but are also

great for learning how to script DEVONthink.

All the scripts we provide are editable

using the Apple's Script Editor, though

we do suggest making copies to work

on. They are located in ~/Library/

Application Scripts/com.devon-

technologies.think3/Menu. Open this

folder in the Finder with Scripts > Open

Scripts Folder command. Add your own

scripts to the menu by adding them to the

appropriate subfolder in this directory, even

creating subfolders of your own.

A complete listing of the installed scripts can

be found here: See also p. 254ff

SCRIPT LOCALIZATION

If you need to support multiple languages in

your scripts, it is possible to vary the content

of messages based on the language in which

DEVONthink is running. You can add your own

definitions in a Localizable.strings file

in the Contents > Resources directory of

a script package (.scptd). This file must be

contained in a subdirectory of the Resources

folder, named with the country code and

.lproj extension, e.g., fr.lproj would

contain French strings. Define a word or

phrase in your language, followed by the

translated phrase. For example, in a strings

file in a de subdirectory, enter: "This is a

new day!"="Heute ist ein neuer Tag!";.

In your script, you'd enter a command like,

display alert (localized string "This

is a new day!"). If DEVONthink is running

in German, you'd see the German message.

Localization is also available for smart

templates. See the Template Localization

section later in this chapter.

TRIGGERED SCRIPTS

Triggered scripts are AppleScripts that you

attach to an item in DEVONthink (a group

or document) and that are executed each

time you select the item. Items with attached

triggered scripts show an AppleScript icon

behind their name.

Using triggered scripts, you can add your

own custom behaviors when interacting with

items in your database.

ATTACHING A TRIGGERED SCRIPT

While it's possible to write a script that

specifies a triggered script for an item in

DEVONthink, the usual method is manually

attaching one.

Select the item you want to attach a script

to.

Select Tools > Get Info or Tools > Inspectors

> Generic.

Click the down arrow next to Script

and choose Select. Note the script

can be located anywhere, but it must

remain in that location for the script
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to trigger. For convenience, you can

create a folder for them in ~/Library/

Application Scripts/com.devon-

technologies.think3/Menus.

REMOVING A TRIGGERED SCRIPT

Since a triggered script runs when you

interact with the item, it can sometimes

be difficult to detach the script, e.g., if

a script switches to another application

when triggered. For instances like this, to

remove a triggered script from an item do the

following:

Control-click the item you want to remove

the triggered script from and choose Get

Info.

Click the down arrow next to Script and

choose Remove.

TERMINOLOGY

Triggered scripts are defined by a specific

handler: on triggered(var), where var is

the variable representing the item the script

is attached to.

Example:

on triggered(theRecord)

tell application id "DNtp"

display alert "" & (name of theRecord as

string)

end tell

end triggered

REMINDER SCRIPTS

Reminders have several pre-built alarms

available for notifications. However, you

can only specify one alarm per reminder.

Reminder scripts are AppleScripts run by an

alarm set on a specific reminder for an item.

By using or writing your own, you can extend

notification possibilities of your reminders.

ADDING AN EXTERNAL SCRIPT

To add an external script as an alarm

for a reminder, choose Execute External

Script. The next dropdown lists any

available AppleScripts in the ~/Library/

Application Scripts/com.devon-

technologies.think3/Reminders directory.

Add any of your own scripts to this directory

to make them available for any alarm you set.

Currently, there is only one example script

pre-installed:

Open Document: Opens the document in a

new window when the alarm triggers.

ADDING AN EMBEDDED SCRIPT

Sometimes you only need to add a script for

a specific purpose, not general use with all

reminders. DEVONthink allows you to quickly

write an ad-hoc AppleScript specifically for

the current reminder.

To write an embedded script for a reminder,

choose Execute Embedded Script as the

alarm. Click the … button and a popup will

appear with a pre-built handler in place.

Add your code as necessary, then press the

compile button, the one with the stylized eye,

to make sure it compiles correctly. If it does,

you will see the code format itself subtly. If

not, you will hear a system alert. Click outside

the popup to dismiss it. When the alarm goes

off, the script will be executed.
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Note: When a reminder is set to Once, the

reminder is removed and the embedded

script lost after the alarm goes off. If you

have code you'd like to potentially use

again, put it in an external script.

TERMINOLOGY

Triggered scripts are defined by a specific

handler: on performReminder(var), where

var is the variable representing the item the

alarm is set for.

Example:

on performReminder(theRecord)

tell application id "DNtp"

set label of theRecord to 1

say (name of theRecord as string)

end tell

end performReminder

TOOLBAR SCRIPTS

Scripts can also be added to the toolbar

of any DEVONthink window. While there

is a limited amount of space available in

a window's toolbar, this is a handy way to

launch commonly used scripts with one click.

To add a toolbar script place the

script into the folder ~/Library/

Application Scripts/com.devon-

technologies.think3/Toolbar. In order

for the script to be available for use in

the toolbar, you must quit and relaunch

DEVONthink. Then Control-click the toolbar

of a DEVONthink window and choose

Customize Toolbar. Drag your script into the

toolbar and it's ready for use.

TERMINOLOGY

Unlike some other script types, there are no

special handlers required for a toolbar script.

You only need valid AppleScript talking to

DEVONthink.

Example:

tell application id "DNtp"

open tab for record (content record)

end tell

SMART TEMPLATES

Some of the DEVONthink provided templates

are "template packages" (.dtTemplate) and

"smart templates" (.templatescriptd). Both

templates provide a great deal of flexibility

and power, like allowing for inclusion of

language resources. With some creativity

and scripting know-how, you can set up

everything from commonly used group

hierarchies to daily journal entries and much

more.

TEMPLATE PACKAGES

The simpler type of automated templates

DEVONthink supports are: template

packages. These are folders with the file

name extension .dtTemplate that contain

one or multiple .lproj folders, one for

each supported language. Depending on the

system language, you can let DEVONthink

import the files in the correct language.

If you inspect the contents of a template

package, e.g., Classifications > Decimal Filing

System.dtTemplate, you will see the project

folders and their assets as a great example of

this type of template.
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SMART TEMPLATES

The more advanced type of automated

templates are smart templates. These are

not simple files, but actually AppleScript

packages containing script code, and often

including related assets that can be inserted

into your database. This allows for some very

powerful actions like:

The script can add information to the built-

in template, e.g., the current date and time

or data from the web.

The script can act intelligently on data

on the clipboard: If it's a simple text, it

adds the text; if it's a URL, it adds it to a

different area of the document and makes

it clickable.

The script can check if a certain application

is installed, e.g., OpenOffice, before adding

a document.

CREATING TEMPLATES

Template Packages: To create your own

template package, you can duplicate an

existing template, Control-click it, choose

Show Package Contents and edit the

internals as needed. Also note exporting

multiple selected files will yield a template

package.

Smart Templates: To make your own

smart templates, have a look at the

prefabricated smart templates. Duplicate

a .templatescriptd file, like the "Note"

template. Control-click it, and choose

Show Package Contents. You can inspect

and modify the supporting assets and the

main.scpt file to fit your needs.

TEMPLATE PLACEHOLDERS

Placeholders in templates are simple control

codes that are replaced by DEVONthink

when a template file is imported. These

placeholders can be used in your files,

including simple templates, or folder

names of your templates packages. When

used in files, they are typed in the text of

DEVONthink-native files; e.g., plain or rich

text, Markdown, etc. These can be manually

typed or you can Control-click in the text and

choose Insert Placeholder. Below is a list of

valid placeholders:

%time%: The current time

%date%: The current date

%shortDate%: The current date in short

format

%longDate%: The current date in long

format

%monthname%: The month name of the

current date

%weekday%: The week day name of the

current date

%day%: The day number of the current

date

%month%: The month number of the

current date

%year%: The year number of the current

date

%author%: The author entered in Settings

> Editing > Author

%username%: The user's name

%fullUsername%: The user's full name

%organization%: The user's organization

from Contacts

%emailAddress%: The user's email

addresses from Contacts
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%host%: The host name

%databaseName%: The database name

%databasePath%: The database's path

%groupName%: The name of the parent

group

%topGroupName%: The name of the top

group

%clipboard%: The clipboard contents as

plain text

%styledClipboard%: The clipboard

contents as rich text

%clipboardLink%: The clipboard contents

as a clickable rich text link if the clipboard

contains a valid URL

Note: There are more placeholders from

the context menu than can be used in a

template. For example, the placeholder

%record_locality% relates to an existing

record, so this placeholder will not be used

when creating a file from a template.

Custom Placeholders: One more powerful

feature of smart templates is the ability

to define custom placeholders, extending

the possibilities beyond the list shown here.

This allows you to add a custom placeholder

in the text of a template, then define the

replacement value for that placeholder in the

main.scpt. As a great example, check out the

use of the custom %project% placeholder in

the Project smart template. Notice the use of

the placeholder in the enclosed rich text file

and the script.

TERMINOLOGY

With the internal script of a smart template,

there are no special handlers required.

However, the internal script must be located

in the Contents/Resources/Scripts folder

inside the package, and it must remain

named main.scpt. Beyond that, you only

need valid AppleScript.

TEMPLATE LOCALIZATION

If you need to support multiple languages

in your templates, it is possible to have the

name and/or content change based on the

language in which DEVONthink is running.

You can add your own definitions in .strings

files in the Contents > Resources directory

of a template package. Here are the files that

can be used:

LocalizedNames.strings: Contains

definitions of the localized name of the

item created by the template. The syntax

defines one name per line: "en"="My

Project"; or "de"="Mein Projekt";.

Localizable.strings: This file must be

contained in a subdirectory of the

Resources folder, named with the country

code and .lproj extension, e.g., fr.lproj

would contain French strings. Contains

localized definitions of words or phrases,

e.g., the content in a document created

by the template. The syntax defines

one word or phrase per line: "Daily

Journal"="Tageszeitung";.

TOOLBAR TEMPLATES

To add any template to the toolbar, place

the template into the folder ~/Library/

Application Support/DEVONthink 3/

Templates.noindex/Toolbar. In order

for the script to be available for use in

the toolbar, you must quit and relaunch

DEVONthink. Then Control-click the toolbar
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of a DEVONthink window and choose

Customize Toolbar. Drag your template into

the toolbar and it's ready for use.

SMART RULES AND BATCH
PROCESSING

Smart rules are smart groups‚ evolved. Built

in the same style as smart groups, smart

rules don't just show items matching criteria,

they can act on them! From something

as simple as adding (or changing) a color

label, to modifying a filename then filing

a document in another location, smart

rules provide some powerful automation

possibilities. And they're not just for the

technically inclined. No programming

experience is needed for almost every action

available.

Smart rules are conceptually simple and can

be summed up as follows: When this event

occurs > do this action > on items matched >

in this location. Smart rules are made of four

parts:

A location: This is where the smart rule will

look for matching items.

Matching criteria: Like a smart group, you

can specify criteria to be matched. The

smart rule will only act on the matched

items.

An action: This is the action the smart rule

performs when the event occurs.

An event: This is an event that causes an

action to occur, e.g., an "On Quit" event.

If used in a smart rule, a specified action

would run when you quit DEVONthink.

CREATE A SMART RULE

Smart rules can be created in one of two

ways:

Click the + button at the bottom of the

sidebar and choose New Smart Rule. The

Search in dropdown will target the current

location.

Control-click an item in the sidebar and

choose New Smart Rule from the context

menu. This will specifically target that item

in the Search in dropdown.

Note in either case you can change the

Search in parameter to target other

locations, including all open databases.

Note: Smart rules are considered global

objects and can be created only in the

Navigate sidebar of a main window. If you

want to create a smart rule for a group

in the item list, choose Data > Reveal to

display it in the sidebar.

When you create a new smart rule, you will be

shown the predicate editor, just as you see

with smart groups. Just follow these simple

steps to define the parameters of the rule

(with an example):

Name: Give the rule a name, like Label

Edited Screencaptures.

Location: Set the Search in dropdown to

target your desired location, like a group

you add screen captures to. The more

specific the better; a good idea is to use

e.g., a database's inbox.

Matching: Add any criteria to be matched,

e.g., Name begins with screen and Kind is

Image.

Event: Choose an event to trigger the

smart rule, like specifying On Save to run
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the smart rule when matched items are

saved in DEVONthink

Action: Choose an action for the smart

rule, perhaps Change Name to add

"_edited" to the name.

This rule shown above would add "_edited"

as a suffix to the name of any edited images

whose name begins with "screen".

One step further‚ chained actions: If you

hadn't noticed, there's a + button to the

right of the action you specified. And yes,

that means you can chain multiple actions

in a smart rule! For example, we could add

an action to open the edited imaged in the

system default application after it has been

renamed.

Understanding the input: In a smart rule,

there always is only one input. You can't use

conditionals or split the actions into a parallel

process. A matched document is passed

along through the entire process. So if you

have a smart rule processing Markdown files

and one of your actions is Convert to Rich

Text, the resulting rich text file is created

but not passed on to the next actions.

The originally matched Markdown is still

the input. However, there are two actions

that allow switching the input: Duplicate &

Continue and Convert & Continue. The items

created by these actions become the input

for the following actions. In our example,

these actions would pass on the resulting rich

text document as the input for the rest of

the rule.

Order of operations: If you have more than

one smart rule targeting the same location

and/or types of files, they will run in the

order they appear in the Navigate sidebar.

The topmost rule will execute first, then

the second, and so on. Be aware one rule

could make a change that affects whether

an item is matched by subsequent rules. If it

does, those rules logically will not process the

items. Drag related smart rules into the order

they should run or stop and reconsider how

your rules are set up.

Chaining smart rules: Creating smart

rules with more limited functions is often

useful. For example, a rule that just files

documents based on a certain custom

attribute can be used on selected documents

or by drag and drop to the rule. Now say

you have another rule with more complex

functions, e.g., moving a document into a

database, doing OCR, then adding custom

metadata. Provided it's using the same

custom metadata, instead of adding the

same actions as the previous rule, add the

Apply Rule action and choose the filing smart

rule. Now add another smart rule that should

also file things based on the same custom

metadata but in a different location. Use the

Apply Rule action there as well. Now both

rules can use the filing smart rule's actions

without having to redundantly add their own

actions. This is a powerful way to extend the

functions of a smart rule while also using the

simpler functions, when needed.

Importing and Exporting: Smart rules can be

exported to the Finder, sent by email, and

e.g., reimported to DEVONthink on another

Mac. Drag a smart rule to the desktop to

save it to a file or Control-click it and choose

Export. Double-click a saved smart rule to

import it, drag it into the sidebar, or Control-

click into the sidebar and choose Import.
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BATCH PROCESSING

Smart rules are useful for repetitious actions,

usually happening in the background. For

times when you need to make impromptu

changes on specific items, e.g., prefixing

a date to the name of several documents,

batch processing is the best option.

Select a few documents to process, then

choose Tools > Batch Process. A small but

familiar action editor appears where you

can create the chain of actions, just as you

do with smart rules. Then press OK and

the documents are modified. Note not

every smart rule action is available in batch

processing. However, for most actions the

available ones are more than sufficient.

We hope this has given you a good overview

of smart rules and batch processing. Please

see the appendix for a complete list of

available Events and Actions. For those

interested in the Apply Script action,

continue to the next section…

SMART RULE SCRIPTS

Smart Rule scripts are AppleScripts or

JavaScripts run by an Apply Script action

in a smart rule. These scripts allow you to

extend the possibilities beyond the already

powerful pre-defined actions. They also work

with batch processing.

Note: Smart rule scripts will be executed

based on the event handler in the specific

rule. For testing, it can be useful to set the

event to On Demand. This way you can select

the rule to see its matches, then Control-click

it and choose Apply Rule to run it and see the

effects on the matched items.

Also be aware the effects of smart rules

are very broad, i.e., they affect all the items

they match. While you are testing, it's a good

idea to put some limiting criterion in place.

For example, instead of matching all images

in all databases, try matching images in a

specific group or only images that begin with

"Screen".

ADDING AN EXTERNAL SCRIPT

To add an external script to a smart rule, add

an Apply Script action and choose External.

The next dropdown lists any available scripts

in the ~/Library/Application Scripts/

com.devon-technologies.think3/Smart

Rules directory. Add any of your own scripts

to this directory to make them available for

any smart rule you define. Here is a list of the

pre-installed scripts, for everyday use and

your education:

Check Links: Check if bookmarks are valid.

Close All Databases: Closes all databases

but the Global Inbox.

Download Bibliographic Metadata:

Attempts to retrieve the digital object

identifier (DOI) of the document and set

the title and metadata.

Move Into Database: Moves indexed files

into the database.

Move to External Folder: Moves imported

files out to the Finder when they're located

in an indexed group.

Reminders - Next Week: Set a reminder for

a week from the current time and date.

Reminders - Remove: Remove an applied

reminder from the matched item(s).

Reminders - Tomorrow: Set a reminder for

the same time tomorrow.
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Tags - Add Keywords: Automatically adds

Tags from the concordance of the matched

file.

Tags - Assign: Automatically adds tags,

based on Apple's machine learning

technology for images or hashtags and

known tags in titles and content.

Downloads - Add Embedded Images:

Add embedded images to the Download

Manager. Used with HTML-based files, e.g.,

web archives, etc.

Downloads - Add Linked Images: Add linked

images to the Download Manager. Used

with HTML-based files, e.g., web archives,

etc.

Downloads - Add Podcasts: Add detected

podcast links to the Download Manager.

Used with podcast RSS feeds containing

downloadable links.

ADDING AN EMBEDDED SCRIPT

There are times you may need to add some

code for a specific situation. Similar to

some other macOS utility applications,

DEVONthink allows you to write a script

directly in the smart rule's editor.

To write an embedded script for a smart rule,

add or specify an Apply Script action and

choose AppleScript or JavaScript. Click the

Edit Script button and a popup will appear

with a pre-built handler in place. Add your

code as necessary, then press the compile

button, the one with the stylized eye, to make

sure it compiles correctly. If it does, you will

see the code format itself subtly. If not, you

will hear a system alert. When done, click

outside the popup to dismiss it

Note: For those new to scripting, the

repeat loop in the pre-built handler is a

very common (and useful) code snippet for

processing all files returned by a smart rule.

In most cases, work inside that loop.

DEBUGGING

While there isn't a step-by-step logging of all

actions in a smart rule, when you are using a

script action, errors will be reported in the

Log window or toolbar button.

TERMINOLOGY

Smart Rule scripts are defined by a specific

handler: on performSmartRule(var),

where var is the variable representing items

matched by the smart rule.

Example:

on performSmartRule(theRecords)

tell application id "DNtp"

repeat with theRecord in theRecords

if (name of theRecord as string) contains

"Piglet" then

set state of theRecord to true

end if

end repeat

end tell

end performSmartRule

APPLE MAIL RULES

When considering importing emails into your

DEVONthink databases, the question of

"automatic" email importing invariably comes

up. While this isn't fully possible yet, there is

a mechanism in Apple Mail that can provide

some level of "automatic": Mail Rules.
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Found in Apple Mail's Settings > Rules,

these are a rules consisting of criteria to be

matched and an associated action (similar

to smart rules). As incoming emails are

detected, Mail will check for matches in a rule

and execute any actions you've specified in

the rule.

One of the actions available is Run

AppleScript. Selecting this option shows a

dropdown with any installed Mail Rule scripts.

These scripts are installed in ~/Library/

Application Scripts/com.apple.mail

folder. If you write or obtain other scripts for

use with Mail Rules, they can also be placed

in this directory. The scripts provided by

DEVONthink are:

Mail Rule - Add attachments to

DEVONthink: Adds the attachment of the

message it acts on as separate documents

to DEVONthink.

Mail Rule - Add links to DEVONthink: Adds

detected links in the messages as individual

bookmarks in DEVONthink

Mail Rule - Add messages to DEVONthink:

Adds the messages it acts on to

DEVONthink.

Mail Rule - File messages & attachments:

Adds the messages it acts on including all

attachments to DEVONthink.

Mail Rule - File messages & attachments

hierarchically: Adds the messages it

acts on including all attachments to

DEVONthink, recreating the mailbox

structure.

TERMINOLOGY

A full lesson on writing scripts for Mail Rules

is beyond the scope of this help, but you can

open and explore the installed scripts.

Do note there are two required handlers:

using terms from application "Mail"

and on perform mail action with

messages theMessages for rule theRule,

where theMessages is a variable representing

the items matched by the rule. Here's a

simple example:

Example:

using terms from application "Mail"

on perform mail action with messages

theMessages for rule theRule

tell application "Mail"

repeat with thisMessage in theMessages

display alert "" & (subject of

thisMessage)

end repeat

end tell

end perform mail action with messages

end using terms from

Note: Mail Rules are controlled by Apple

Mail, not DEVONthink. While they generally

behave as expected, we can't control

whether the rules will be triggered in Apple

Mail.

APPLICATION SCRIPTS

AppleScript is perfectly suited for integrating

different applications, interchanging

information, and creating workflows.

DEVONthink comes with a number of

scripts that exchange information between

DEVONthink and other AppleScript

supporting applications, like Safari or Mail.
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The Script Menu Extra Scripts provided by

DEVONthink are installed in an application-

specific folder in ~/Library/Scripts/

Applications, e.g., ~/Library/Scripts/

Applications/Safari. These scripts are

accessible from the global scripts menu in

the menu bar at the top of your screen while

you're in the specific application.

MAIL SCRIPTS

Importing email into your DEVONthink

databases is a possible use of AppleScript.

Using AppleScript-enabled email

applications, especially those with a robust

scripting dictionary, increases the potential

for processing emails. This can help you

quickly file those emails directly into

DEVONthink.

DEVONthink comes with scripts for Apple

Mail, Microsoft Entourage, and Microsoft

Outlook. Just select a message or mailbox in

a supported email application and choose the

desired script from the global scripts menu.

DEVONthink provides the following scripts:

Add attachment(s) to DEVONthink: Adds

the attachments of selected emails to

DEVONthink.

Add mailbox(es) to DEVONthink: Adds the

selected mailboxes to DEVONthink.

Add mailbox(es) & attachments to

DEVONthink: Adds the selected mailboxes

to DEVONthink. Attachments are imported

separately.

Add message(s) to DEVONthink: Adds the

selected mailboxes to DEVONthink.

Add message(s) & attachments to

DEVONthink: Adds the selected mailboxes

to DEVONthink. Attachments are imported

separately.

Note: The import of entire mailboxes via

AppleScript can be a resource-intensive

process. Use the Apple Mail plugin for

a more robust experience importing

mailboxes.

WEB BROWSERS

Depending on the capabilities of the web

browser you're using, you may be able to

use application scripts. We have included

a handful of simple scripts that can be run

while browsing in Safari or DEVONagent.

Add abstracts to DEVONthink: Creates a

sheet containing information about items

in a DEVONagent search. This includes

the title, score, summary, and URL of each

result. (DEVONagent only)

Add linked images to DEVONthink: Detects

images on the current page and adds them

to your database.

Add tabs to DEVONthink: Adds bookmarks

for active tabs the browser.

Add linked images to DEVONthink's

downloads: Detects images on the current

page and adds them to DEVONthink's

Download Manager.

Add links to DEVONthink's downloads:

Detects URLs on the current page and adds

them to DEVONthink's Download Manager.

OTHER APPLICATIONS

Obviously we haven't covered all the possible

applications or scenarios on your machine,

and we are sure you have ideas we haven't

thought of. If you have an application you'd
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like to integrate with DEVONthink, check if

it has an AppleScript dictionary. If it does,

the potential exists to communicate between

the applications. But also be aware the

commands, elements, and properties you

can work with are coded by the developer of

those applications.

FOLDER ACTIONS

Folder actions are scripts that you can attach

to folders in the Finder. These act on all items

you add to these "hot folders." When you

add items, the operating system detects

the added files and runs any folder actions

attached to the folder.

The actions supplied by DEVONthink are

installed in ~/Library/Scripts/Folder

Action Scripts, and you can add your

own scripts to this directory, as needed.

For everyday use and exploration, here

are the folder action scripts provided by

DEVONthink:

DEVONthink - Import: Imports files into

your databases.

DEVONthink - Import & Delete: Imports

files into your database, and moves the

files to the trash afterwards.

DEVONthink - Import to selected group:

Imports files to the currently selected

group.

DEVONthink - Index: Index files to your

database, creating links to the original

items in the Finder.

DEVONthink - Index to selected group:

Index files to the currently selected group

in your database.

DEVONthink - Import, OCR & Delete:

Imports files into your database, converts

them to searchable PDFs if necessary, and

moves the files to the trash afterwards.

ATTACHING A FOLDER ACTION

To attach a folder action script to a folder, do

the following:

Control-click a folder in the Finder.

Select Services > Folder Actions Setup

from the context menu.

From the list of available actions, select

the folder action script click Attach.

Manage folder actions: To manage all your

folder actions, Control-click a folder and

choose Services > Folder Actions Setup from

the context menu. Use the Folder Actions

Setup utility to see which folders have scripts

attached, and to remove folder actions from

folders.

Note: If you are running macOS Mojave,

you will be prompted to allow the Folder

Actions Setup application to run. This

notification is controlled by the operating

system, not DEVONthink.

TERMINOLOGY

While we can't provide specific training

on how to create folder actions, check out

Apple's documentation. However, the on

adding folder items to folderVariable
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after receiving filesVariable is the

handler most commonly used in our folder

action scripts. Here is a simple example:

Example:

on adding folder items to theFolder after

receiving theFiles

repeat with thisFile in theFiles

tell application id "DNtp"

set newRecord to import thisFile to

incoming group

if exists newRecord then tell application

"Finder" to delete thisFile

end tell

end repeat

end adding folder items to

Note: Folder actions, like any computer

processes, are treated very literally. When

processing files with a folder action, it's

best to move or delete the files from the

watched folder. This keeps the action from

trying to reprocess files.

SHORTCUTS AND AUTOMATOR

Apple's Shortcuts and Automator

applications were created to help non-

programmers take some control of their

machines. They allow you to visually

string together simple steps to create an

automated process. Though much more

limited due to their linear nature and lack of

debugging tools, they may still be useful for

some situations. Additionally, they let you

create other types of items like workflows,

services, or Quick Actions.

DEVONthink doesn't offer specific

Shortcut or Automator actions. However,

as DEVONthink has a deep and robust

scripting dictionary, the Run AppleScript

action in those applications opens up some

automation opportunities. The key to

integration with DEVONthink is passing or

receiving file paths via scripting.

Note: While Shortcuts is newer, the tips

presented here generally apply to both

applications. And while we may investigate

DEVONthink-specific questions regarding

Shortcuts or Automator, we do not offer

support specifically for them.

GETTING INFORMATION INTO DEVONTHINK

As an example, importing selected files in the

Finder can be accomplished by passing file

paths to DEVONthink. To do this, use a Get

Selected Files in Finder action before this Run

AppleScript action:

Example:

on run {input}

tell application id "DNtp"

repeat with thisFile in input

import (POSIX path of thisFile) to

incoming group

end repeat

end tell

end run
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SENDING INFORMATION OUT OF

DEVONTHINK

For passing items from DEVONthink, this Run

AppleScript action provides a list of file paths

to be processed. This action should be placed

before the third-party application's actions.

Example:

on run {}

tell application id "DNtp"

if (selected records) is not {} then

set fileList to {}

repeat with thisRecord in (selected

records)

if (path of theRecord is not "") then

copy ((path of theRecord) as POSIX file)

to end of fileList

end if

end repeat

end if

if fileList is not {} then return fileList

end tell

end run

Note: In Shortcuts, the records' path likely

needs to be passed as a POSIX file.

Automator prefers POSIX paths, so use

copy (path of thisRecord) to end of

fileList instead. Also, you need to ensure

the selected items are not groups or smart

groups as they don't exist in the filesystem.

WARNING: Be very cautious when using the

paths from DEVONthink. Actions like moving,

deleting, renaming etc. would compromise

your database. Immediately following the

AppleScript action, use a Save action with

the AppleScript Result in Shortcuts or the

Copy Finder Items action in Automator to

keep from modifying the underlying files in

your database.

ITEM LINKS

Every database, group, or document in your

DEVONthink database has a URL (uniform

resource locator) associated with it. While

web URLs typically begin with http:// or

https://, DEVONthink's URLs take the form

of x-devonthink-item:// followed by a

long alphanumeric ID. For PDFs, the link can

contain a reference to a specific page. For

audio and video, a reference to the current

playback time. And for RTFs, you can get

a reference to a specific paragraph in the

document. These links can be used in any

file type or application that supports live

hyperlinks, e.g., the notes fields of OmniFocus

tasks. This allows you to access DEVONthink

documents as easily as clicking a link in a web

browser.

You can get this item link manually by

selecting a document or group and choosing

Edit > Copy Item Link. In addition you can

manually extend the copied URL with the

following parameters:
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app: Used in conjunction with

the openexternally parameter,

specify the name of the app to open

the referenced file with, e.g., x-

devonthink-item://E35A4AFF-

BD90-4131-9D54-62849E0EF4DE?

openexternally=1&app=preview.

length: Specify the number of characters

from the start parameter. Used in

selection links.

openexternally: Opens the referenced

item in the system default application,

e.g., opening a PDF in Preview. Used with a

value of 1, e.g., openexternally=1.

opentab: Opens the referenced item in a

new tab in the current main window if a

document is already being viewed. Used

with a value of 1, e.g., opentab=1

page: Opens a PDF to the specified page.

Usage: page=<integer>.

reveal: Reveals an item in the item list

instead of opening it in a new window.

Usage: reveal=1.

search: Directly jumps to the first

occurrence of the search string in

the specified document. Usage:

search=<string>.

start: Specify the starting character on the

current page. Used in selection links.

time: Directly jumps to the specified time

in seconds in a video or audio document.

Usage: time=<float>.

Example:

x-devonthink-item://<recordID>?reveal=1

x-devonthink-item://<pdfID>?page=5

x-devonthink-item://<textFileID>?

search=iPad%20Pro

x-devonthink-item://<movieID>?time=43.5

Note: The first parameter after the ID is

always added after a question mark (?),

additional ones after an ampersand (&),

and any values must be percent-encoded.

TERMINOLOGY

Manually getting item links can be useful

for some hard-coded cases, but there

are many times you want to get them

programmatically. There are two AppleScript

properties for a record related to item links:

reference URL: This is the item link as

described above.

UUID: This is the unique identifier of the

item, i.e., the long alpha-numeric string in

the reference URL.

Here is an example of getting and using an

item link to create a Markdown compliant link

on the clipboard:

Example:

tell application "DNtp"

set recordName to name of content record

set recordURL to reference URL of content

record

set the clipboard to ("[" & recordName &

"](" & recordURL & ")")

end tell

The terminology for using item links can

depend on the capabilities of the application

you're scripting. Here is an example, using a

hard-coded URL, with an application that can

open URLs:

Example:

tell application "Opera"

tell window 1

make new tab with properties {URL:"x-

devonthink-item://929D101B-35AC-474C-801C-

D8818C48DB80?line=125"}

end tell

DEVONthink 3.9.17 Documentation, page 219



end tell

P.S.: For the shell scripters, the URLs can be

used with an open command.

URL COMMANDS

URL commands are a type of item link

that don't merely point to an existing file,

they issue some special commands to

DEVONthink. Though not as powerful as

AppleScript, these commands can be used in

special circumstances.

TERMINOLOGY

The URLs are constructed from a single

command and optional parameters, with the

following format:

x-devonthink://<command>?
<parameter=value&parameter=value&...>

Note: The first parameter after the ID is

always added after a question mark (?),

additional ones after an ampersand (&),

and any values must be percent-encoded.

Listed below are the commands and

parameters available:

Commands:

createFormattedNote: Creates a

formatted note.

createHTML: Creates a new HTML

document.

createMarkdown: Creates a Markdown

document.

createPDF: Creates a PDF.

createRTF: Creates a rich text document.

createWebArchive: Creates a web archive.

createBookmark: Creates a new bookmark.

Note: Use the location parameter set

to a URL with the commands above to

download the page in the specified format.

createGroup: Creates a group.

createText: Creates a new plain text

document.

clip: Opens the Clip to DEVONthink panel.

note: Opens the Take Note panel.

search: Initiates a search in the open

databases.

Parameters:

title: The title of the item to be created

(string).

comment: A Comment to be added

(string).

location: The URL linking to the content,

e.g., the URL of the website for the

bookmark (URL).

tags: Tags to be added (comma separated

strings).

destination: The UUID of a group where the

item shall be created (string).

source: The HTML content for HTML

documents (string, only used by

createHTML and createFormattedNotes).

text: The text content for text documents

(string, used by createText and

createMarkdown).

width: The page width (integer, only used

by createPDF).

paginated: Paginate the created PDF

(boolean, only used by createPDF).

hide: Hide and deactivate application after

executing the comment (boolean).

noselector: Skip group selector (boolean).

query: The query to search for (string, only

used by search).
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reader: Post-process the page (integer, 0 =

no post-processing, any other value = post-

process).

referrer: The URL that referred to the item

(URL).

selection: The selected text (string, only

used by createRTF).

Example:

x-devonthink://createRTF?title=New

%20bookmark&location=http%3A%2F

%2Fwww.devontechnologies.com&noselector=1

Note: These are not x-callback-urls. An

x-callback-url is a specific type of URL

scheme that returns a value to the calling

application.
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In the appendices you will find additional

information that helps you getting familiar

with DEVONthink, such as a glossary of

commonly used terms, a listing of the

Boolean operators used in searches,

commonly found context menu items, and

much more.

GLOSSARY

Become familiar with these terms to get the

most out of working with DEVONthink.

MOUSE & TRACKPAD

In this documentation, secondary click refers

to clicking an element with either the Control

key held, the right mouse key, or clicking with

two fingers on a trackpad. You can configure

your mouse and trackpad behavior, so a

secondary click could be defined differently

on your system. In this case, clicking with the

Control key held works always.

KEYBOARD SYMBOLS

⌘ The Command key, usually next to the

Space bar.

⌥ The Option key.

⌃ The Control key (usually labeled with

"ctrl").

⇧ The Shift key.

⎋ The Escape key (usually labeled with

"esc").

⇥ The Tab key.

↩ The Return key.

INTERFACE ELEMENTS

Bars: Smaller sections of a window

providing specialized information or

controls, e.g., the Information Bar found

just above the item listing. It shows

information about the selection as well as

buttons to sort or change the view.

Context menu: The menu that appears

when you Control-click something.

The context menu gives you access to

frequently used commands that deal

directly with the clicked object. Specific

context menu items are discussed in their

respective sections, but there is a list of

commonly seen commands in the Context

Menu Items section of this appendix.

Inspectors: Specialized panes at the right

of a main window, providing information
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about the current selection as well as

functions like See Also & Classify.

Item list: The list of items in the current

location, viewable as a list, icons, columns,

or Cover Flow. Items can be documents,

groups, or smart groups.

Sidebar: The panes found at the left side of

a main window, comprised of the Navigate,

Reading List, Import, and Extras panes.

View/Edit pane: A pane of the

DEVONthink main and document windows

that lets you view a document or, when

possible, edit it. The view/edit pane

displays the content of your documents

depending on their type. See also p. 82ff

View: The layout for a DEVONthink main

window. You can change the layout using

the commands found in the View  menu.

Window: DEVONthink uses three different

types of windows: main, document, and

other. Main windows show lists of items

and, in some views, also the contents of

the selected document, whereas document

windows can be opened for individual

documents.

DOCUMENTS & GROUPS

Database: A collection of all documents

stored in DEVONthink. You can create and

open as many databases as you like.

Document: A file in the database; for

example, a plain or RTF text, a PDF, or an

image (.jpg, .tiff, .png, etc.). Technically a

document is an entry in a database with

text, RTF, or image content, sometimes

simply referred to as "content".

Default destination: The default

destination group for incoming data. Set in

Settings > Files > Import.

Duplicate: A copy of a file, either explicitly

created or detected by DEVONthink's AI.

Group: A collection of documents or other

groups inside the database. Similar in

appearance and behavior to a folder in the

Finder. See also p. 146ff

Global Inbox: A special database serving as

a destination for incoming data. The Global

Inbox is always opened when DEVONthink

is started and accessible through the

sidebar. The Global Inbox can be set as the

default destination in Settings > Files >

Import.

Inbox: A special group for data coming in

to a database. Every database has an Inbox

group.

News feed: Also referred to as RSS, a

news feed is like a web page, but split

into multiple articles. A feed reader or

web browser can split the feed "page"

into its parts and show each of them as

a separate news item and/or store it in a

local database. DEVONthink stores feeds in

a database and displays them like a group.

The contents are updated live from the

internet as the connected feed changes.

Older news bits are kept, while fresh news

bits are added and marked as unread.

When you add a bookmark that points

a feed, DEVONthink tries to add it as a

proper feed document if possible.

Replicant: A document or a group that

appears in more than one place in the

database. Unlike an alias in the file system,

a replicant is not a real document pointing

to another file (usually the original);

rather it is a second entry in the table of

contents for the very same document.

Consequently, there is no original; when
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you replicate a document you'll end up with

two replicants.

Sheet: A collection of records or structured

sets of data, presented in a spreadsheet

style, similar to data viewed in Apple

Numbers or Microsoft Excel. Alternatively,

the data can be displayed in form view,

similar to browsing records in, e.g.,

FileMaker.

Smart group: A special type of group with

a set of search criteria saved with it. This

is similar to "Saved Search" folders in the

Finder. Every time you visit this smart

group, DEVONthink runs the attached

search and displays it as the content of the

group. DEVONthink creates a number of

pre-defined smart groups when you create

a new database.

Trash: A temporary location in a database

for deleted files. Similar to the Trash in

the Finder, all trashed items are stored

until you explicitly delete them using

DEVONthink > Empty Trash.

TAGS

Group tag: Groups within a database that

apply their name as tags to their contents.

Items moved out of these groups will not

retain the group tags. Group tags appear

grey in all tag lists.

Ordinary tag: Tags created through the

Tag bar or other means are created in a

special top-level Tags group. They are called

"ordinary tags" and appear blue in all tag

lists.

See the Iconology section for icons specific to

these two items.

ITEM PROPERTIES

Flagged/Unflagged: Items can be checked

or unchecked for your personal use, e.g.,

for creating a to-do list, maintaining a

shopping list, or writing a list of project

tasks.

Locked/Unlocked: Items can be locked

to keep them from being unintentionally

deleted (groups, documents) or modified

(documents).

Read/Unread: Items can be marked read

or unread, which is useful for captured or

automatically downloaded news items or

documents that you want to read later.

Both unread items and groups containing

unread items are shown in bold.

UUID: Each database, group, or document

in DEVONthink receives a unique identifier

(UUID) when it's created. This is a read-

only alphanumeric string that refers only to

the particular item. The UUID allows you to

reference an item regardless if its location

or name changes, and is usually found in

item links.

See the Iconology section for icons specific to

the flagged, locked, or unread states.

SYNCHRONIZATION

Sync location: Sync locations are used to

keep your databases on all your devices in

sync. They summarize all information about

which databases to sync through what kind

of connection (e.g., direct connections to

DEVONthink on a Mac, WebDAV, CloudMe,

Dropbox etc.) and with which sync store.

Bonjour (Direct connection): A sync

method for syncing one device to another

Mac or mobile device running DEVONthink
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or DEVONthink To Go, respectively.

Unlike other sync methods, there is no

intermediary storage location for the sync

data. It is direct - device to device.

Sync store: A sync store is a special folder

containing sync data. These can be direct,

local, e.g., on your Mac or a thumb drive, or

remote, as used with cloud services.

Encryption key: A user-defined word used

to "scramble" or "unscramble" your sync

data when syncing. When used, your sync

data is stored in an encrypted state in the

sync store.

Local database: A database that exists and

is open on this device.

Remote database: A database that is not

open on this device, or exists at the sync

location, e.g., on Dropbox, but has not been

downloaded to this device.

Pending document: A document for which

only the metadata is locally available.

This happens when you choose not to

synchronize indexed files for the sync

location.

WebDAV: A type of web server used

by some cloud services, some network

attached storage devices, or running

locally. It can usually be used by

DEVONthink for syncing.

ICONOLOGY

Additional icons behind item names, e.g., in

main windows, indicate that the item has

been indexed instead of imported, is locked,

has a comment or annotation attached,

is encrypted, e.g., PDFs or encrypted

databases, or has a triggered script attached.

Groups also serving as tags show a tag icon.

Depending on your preferences, replicants,

duplicates, or replicated duplicates are

indicated with a little grey icon instead of

appearing in color.

Item has encryption applied, e.g.,

encrypted PDFs, and encrypted database,

or an encryption key has been specified for

a sync location in Settings > Sync.

Item is unread.

Item has been flagged.

Item is indexed, not imported.

Item is locked.

Item has a comment.

Item has an annotation.

Item has a reminder set.

Item has outgoing item links.

Item has incoming item links.

Item has a script attached.

Group is a tag, too.

Item has an attachment (email messages

only).

Item is synced but its content is not (yet)

downloaded.

Item is a duplicate

Item has one or more replicant(s)

Item is a duplicate, but also has one or

more replicant(s)

TOOLBAR ITEMS

DEVONthink provides a wide variety of

toolbar items, giving you quick "push-button"

access to many everyday tools.

DEFAULT ITEMS

The following toolbar buttons are available in

the default set you see when you first launch

DEVONthink:

DEVONthink 3.9.17 Documentation, page 225



Sidebar: Show and hide the global sidebar.

Preview: None:  Hides the document

preview.

Preview: Standard:  Shows the document

preview below the item listing.

Preview: Widescreen:  Shows the

document preview besides the item listing.

Actions:  Contains the context menu for

items selected in the item listing..

New:  Adds documents in DEVONthink-

native formats. Similar to Data > New.

Open:  Opens the current item in a

DEVONthink window if possible.

Open externally:  Open the current

document in the system default

application.

Share:  Opens the macOS Share menu for

the selected items. This does not apply to

groups.

Mark: Flagged:  Changes the flagged state

of the selected item.

Mark: Read:  Changes the read statue of

the selected item.

Mark: Locked:  Changes the locked state of

the selected item.

Label:  Changes the label color of the

selected item.

Search:  This is the main search bar,

accessing all or specific groups and

databases.

Synchronize:  Initiates a manual sync of the

current database. See also p. 183ff

Get Info:  Opens a popup from the button

displaying a number of commonly used

inspectors.

Show/Hide Inspectors:  Shows or hides the

Inspector panes.

Show/Hide Tags:  Shows or hides the Tags

bar under a document's preview.

Note: The items for showing or hiding the

document preview as well as for marking

items flagged, read, or locked are also

available as a combined toolbar item.

ADDITIONAL ITEMS

In addition to the default set, there are many

other specific buttons available, shown in the

essential order found in View > Customize

Toolbar:

Scripts: Provides access to the contents of

the Scripts menu.

Quick Look: Opens a Quick Look preview

for the selected document.

Zoom In: Zooms into the current item.

Actual Size: Zooms the current item to the

default zoom level.

Zoom Out: Zooms out of the current item.

Zoom to Fit: Sets the magnification of the

current item to fit the bounds of the view/

edit pane.

Zoom to Width: Sets the magnification of

the current item to the width of the view/

edit pane.

Full Screen: Displays the current document

in DEVONthink's full screen mode.

Groups: Group: Creates a new group in the

current location.

Groups: Smart Group: Creates a new smart

group in the current location.

Group: Groups the selected items into a

new group.

Ungroup: Ungroups the selected group and

deletes the now-deserted empty group.

Classify: Attempts to classify the current

item.

Plain Text: Creates a plain text file in the

current location.
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Rich Text: Creates a rich text file in the

current location.

Markdown Text: Creates a Markdown file in

the current location.

Formatted Note: Creates a formatted note

in the current location.

Sheet: Creates a sheet in the current

location.

Bookmark: Create a bookmark in the

current location.

Launch URL: Opens a URL associated with

the current item in the system default

browser.

Save: Explicitly save changes to a

document.

Delete: Moves the current item to the

database's trash.

Print: Prints the selected document. If

a document cannot be printed, the item

listing will be printed.

Import: Imports files into the current

location.

Export: Provides access to the contents of

the File > Export menu.

Update: Manually updates indexed items in

a database.

Show in Finder: Reveals a file in its location

in the Finder.

Reveal: Reveals a file in smart groups or

search results in its current location.

Merge: Merges multiple files into one,

leaving the originals intact.

Merge and Delete: Merge multiple files into

one, putting the originals in the database's

trash.

Optimize: Does an internal optimization

and backup of a database's metadata.

Verify: Checks the integrity of the

database and repairs items it can.

Log: Opens a popover showing available

messages from the Log window.

Send by Email: Creates a new message

in your default email app and attaches

selected items.

Synchronize All: Initiates a manual sync of

all open and actively syncing databases.

Take Note: Opens the Take Note view,

either in the Sorter or a Take Note panel.

Imprinter: Provides access to any imprints

available in the Tools > Imprinter menu.

OCR: Runs OCR on a compatible file, e.g.,

PDFs or images, producing the selected

output type.

Note:

Reveal: Be cautious with this button. When

used on imported files, it will reveal them

in the internals of the database. You do not

want to modify these internal files in the

Finder. This option is best used on indexed

files.

Verify & Repair: Please refer to the

troubleshooting chapter for information on

database maintenance and repairs.

Send by Email: The ability to add the

attachments depends on the inter-

application capabilities of the email

application. If it doesn't provide support

for this, you may be able to drag

documents into draft messages or the

email application's dock icon.

Some items are also available as a

compound toolbar icon.
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CUSTOM ITEMS

If you are creating scripts or templates, they

will be available to add to the toolbar after

quitting and relaunching DEVONthink. See

the appropriate sections for information

on where to save these files for use in the

toolbar.

KEYBOARD SHORTCUTS

Keyboard shortcuts make using DEVONthink

much more efficient for many people. Some

of the following shortcuts are common

to most Mac applications; others are only

available in DEVONthink. In addition, many

menu commands have keyboard shortcuts.

These are shown directly in the menu.

Note: You can change the shortcuts for

menu commands in System Settings >

Keyboard > Shortcuts > App Shortcuts.

WINDOWS

Control-Tilde (~): Cycles through open

application windows. This is a common

macOS shortcut.

Control-Tab: Cycles focus between the

item list, view/edit pane, and the Tags bar

or Inspectors (if visible).

Escape: Cancels processes, closes dialogs

or Quick Look previews, etc., depending on

the context.

Command-}: Cycles to the next tab.

Command-{: Cycles to the previous tab.

Note: Hold ⇧ to cycle in reverse order.

DOCUMENT LISTS

Navigating items:

Up/Down arrow: Navigates up and down in

all views. Use ⇧ to select multiple entries.

Left/Right arrow: Expands or collapses the

selected groups in horizontal split, vertical

split or List views, or navigates to previous/

next item in other views.

Option-click (the triangle in front of a

group): Expands or collapses all groups that

are contained within this group as well.

Option-Left/Right arrow: Expands or

collapses the selected groups and all their

children the item list.

Selecting items:

Shift-click: Selects consecutive items.

Shift-arrow: Extends the next consecutive

item to the current selection.

Command-click: Adds a non-consecutive

item to the selection.

Manipulating items:

Return: Renames documents.

Backspace: Deletes selected items.

Command-Drag: When dragging items from

the Finder, this moves, not copies, the file

into the database.

Option-drag: Duplicates items to the drag

destination instead of moving it.

Command-Option-drag: Creates replicants

for the items at the drag destination.

Dragging items from the Finder to

DEVONthink with ⌥⌘ pressed indexes the

item. Dragging items into documents with

⌥⌘ held inserts a link to the item.
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Item List:

Command-Shift-O: Opens a selected

document in the system default

application.

Tab: Jumps to the first or next editable

column when using View > List.

Space: Opens the standard Quick Look

panel showing a preview of the selected

items.

Option-Space: Opens a full screen Quick

Look slideshow.

Option-bracket: Using [ and ], goes

backwards and forwards through the

visited locations.

VIEW/EDIT PANE

Home/End: Goes to beginning of, or end of,

any view.

Page up/down: Scrolls one page up and

down in any view.

Space/Shift-Space: Scrolls one page down

or up in non-editable views, e.g., web pages,

images, or PDF documents.

Command-click: Opens the target of a link

in a new tab or separate window.

Command-Option-drag: Inserts a cross-

link for groups or documents dropped

into a rich text document. Dragging files

or folders from the Finder to a rich text

document with ⌥⌘ pressed creates links to

them.

Command-Shift-click: Opens a link in a new

tab and activates it. This requires enabling

tabbed browsing in Settings > General.

Option-bracket: Using [ and ], goes

backwards and forwards through the

documents or visited web pages .

Option-drag: Selects text using a

rectangular selection ribbon.

Option-click (a link): For HTML-based files,

adds the clicked URL to the Download

Manager panel.

Option-click (a word): Initiates a search

with the clicked word as the search term.

Shift-arrow: Expands or contracts the

current text selection.

THE SORTER

General Note Creation and Clipping:

Command-S: Saves the entered data.

Equivalent to clicking Add.

Escape: Clears any entered data.

Equivalent to pressing the retreating circle

icon.

Voice and Video Note:

Spacebar: Start and stop recording.

Screen Capture:

Command-1: Capture the entire window.

Command-2: Capture a highlighted window.

Command-3: Capture a marqueed area.

Web Clip:

Command-1: Clips from the default

browser.

Command-2: Clips from a URL you've

copied to the clipboard.

Command-3: Type a URL to clip and any

associated data, e.g., comments, tags, etc..
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Clip to DEVONthink:

Command-F: Toggles the Clutter-free

option.

SHEETS

Return: Moves one cell down for editing.

Shift-Return: Moves one cell up for editing.

Tab: Moves one cell to the right for editing.

Shift-Tab: Moves one cell to the left for

editing.

Arrows: Moves the editing selection.

Escape: Stops editing.

PDFS

+: Zooms in.

-: Zooms out.

Command-drag: Scrolls the visible area

with the mouse.

IMAGES

+: Zooms in.

-: Zooms out.

MULTIMEDIA

Spacebar: Start and stop playback.

Left/Right Arrows: Move forward or

backward one frame or .25 second.

Option-Left/Right Arrows: Jump to the

beginning or end of the file.

Shift-Left/Right Arrows: Move forward

or backward in 15 second intervals. The

Shift-interval is customizable in the hidden

preferences.

Command-Left/Right Arrows: Change

forward or reverse playback speeds.

Option-Forward/Reverse buttons: Hold the

Option key and click the forward or reverse

buttons to change playback speeds in .1

increments, e.g., 2.1, 2.2, etc.

Up/Down Arrows: Adjust the playback

volume. Hold Option to switch between

mute and full volume.

Note: These keys operate when a

multimedia file is the active document.

They are not global controls, i.e., they will

have no effect on an audio file playing in a

minimized window.

CONTEXT MENU ITEMS

DEVONthink also provides many commands

in context menu items, shown when you

Control-click on elements in the application.

Many of the context menu items are also

found in DEVONthink's menus. Below is a

list of common menu items you'll find in the

context menus for documents and windows.

DOCUMENT CONTENTS

When you Control-click in the contents of

documents, you will see a context menu

with commands and options. The items

shown are related to the file type and if you're

interacting with a selection in the document.

Specific items, e.g., commands relating only

to PDFs, are covered in their respective

sections.

In editable documents:

Add to Favorites: Adds the current

document to the Favorites.

Add to Reading List: Adds the current

document to the Reading List.

Services: Displays the macOS Services

menu.
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Text or links in text:

Add Link to Reading List: Adds a link to the

Reading List.

Add Link: Allows you to enter a URL for the

selected text, converting the text to an

active link.

Add tag [word]: Tags the document with

the selected word (only available if the

word is not already a tag of the document).

Convert to Item Link: Converts a selected

WikiLink into an item link. See also p. 34ff 

An alternate command, available when

holding the ⌥ key, Convert All to Item

Links  converts all WikiLinks in the current

document into item links. These commands

only apply to plain text, rich text, and

Markdown documents.

Copy Link: Copies a clicked link to the

clipboard (only available for selected links).

Edit Link: Edits the destination of a

selected link. Selecting this option allows

you to remove the link as well.

Insert Link To: Inserts a link to an item you

select in the submenu (only available when

no text is selected).

Insert Placeholder: Inserts a predefined

placeholder or one specified as custom

metadata in Settings > Data.

Highlight: Highlights the selection with

the current highlight color. Using this

command on a selection again removes the

highlighting.

Link To: Makes the selected piece of text a

cross-link and links it directly to the group

or document you select in the submenu.

Look Up [word]: Looks the selected text up

in macOS's Dictionary.

Make Link: Makes the selected piece of

text a WikiLink. The destination of the

WikiLink is a document with the same

name as the selected text. If no document

with that name exists, clicking the created

link creates it using the template you have

set in the Settings > WikiLinks.

Open Link in Browser: Opens the selected

link in the default browser or application.

Open Link in DEVONagent: Opens the

selected link in a DEVONagent Pro browser

window.

Open Link in New Tab: Opens the selected

link in a new tab in DEVONthink.

Open Link in PhotoStickies: Opens a link in

PhotoStickies.

Open Link: Opens the selected link.

Quick Look Attachments: Opens a

QuickLook window for both item links

and WikiLinks in plain text, rich text, and

Markdown documents. Selecting a text

block with multiple links opens a QuickLook

window for all detected links.

Remove Link: Use this to remove the link

status of selected text.

Search with Google: Searches for the

selected text in Google.

Search [word]/Selected Phrase: Searches

for the selected word or phrase in your

open databases.

See Related Text: Displayed like search

results, this shows a list of documents

related to the selected text passage. This

option is only available when more than

one word is selected.

See [word]: Opens a drawer with

documents related to the selected word.
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Set Name As: Sets the name of the

document to the selected piece of text

(needs to be less than 256 characters).

Share: Shares selected text via the

available sharing extensions.

Add Link to Downloads: Adds a link to the

Download Manager.

Images and PDF documents:

Actual Size: Displays the document at

its actual size. Uses also the resolution

information contained in the file.

All Pixels: Zooms the image so that one

image pixel equals one pixel on the screen.

Zoom In/Out: Zooms in or out of the

document, or displays it in its actual size.

Zoom To Fit: Zooms the image so that

it fits into the view/edit pane or the

document window.

Zoom To Width: Zooms the image to fit

the width of the view/edit pane or the

document window.

ITEM LIST

These context menu items are commonly

shown when you ⌃-click items in a main

window's item lists. In items lists, the

commands are also often available in the

Actions toolbar button. Some of these

commands are also seen in the See Also &

Classify Inspector pane.

Add To: Commands in this submenu add

the currently selected documents to your

Favorites or the Reading List.

Apply Rules: Runs a chosen smart rule on

selected items matching the location and

criteria of the rule.

Convert: This submenu displays options for

converting from one file type to another.

The options shown here are dependent on

the type of file selected.

Copy Item Link: Copies a link to the current

item.

Copy URL: Copies the URL of the selected

document to the clipboard. This only

appears when one document is selected.

Duplicate To: Duplicates the selected item

to the group you select from the submenu.

Get Info: Opens an popup containing more

detailed information about the currently

selected file or group.

Group Items: Groups multiple selected

items in an item list.

Label: Changes the label of the selected

item.

Launch URL: Opens the URL in the selected

item's URL field. Hold the ⌥ Option key to

choose Launch URL in Background. This

keeps DEVONthink in the foreground.

Mark: Changes the flagged, locked, or read

status of the selected item.

Move Into Database: Moves an indexed

item into the database. Use this command

with caution as it moves the file from its

current location into the internals of your

database. It does not copy the file.

Move To External Folder: Moves a non-

indexed item, e.g., imported or created in

DEVONthink, out to an indexed folder in

the Finder.

Move To: Moves the selected item to the

group you select from the submenu.

Move to Trash: Moves the clicked item to

the Trash. Hold the ⌥ Option key to shows

Move All Instances to Trash when used in

items lists.
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New: This submenu allows you to quickly

create several built-in file types. See the

Data menu for more information on these

file types.

New from Template: This submenu allows

you to create new documents from any of

the installed templates.

Open: Opens the selected item in a

separate main window or document

window.

Open in Tabs: Hold the ⌥ Option key and

Open changes to Open in Tabs. If the View/

Edit pane is visible, this opens the selected

items in new tabs. If the View/Edit pane

isn't visible, a new document window will

open with each selected document in its

own tab in the window.

Open With: Opens the selected item in an

external application.

Rating: Allows you to set a rating, from no

stars to five stars.

Replicate To: Replicates the selected item

to the group you select from the submenu.

Reveal: Shows and selects the selected

item in its location in DEVONthink.

Send by Email: Sends the selected item by

email.

Share: Opens the Share menu.

Show in Finder: Shows the selected item in

the Finder.

Tags: This submenu offers special

commands for automatically adding some

kinds of tags. See the Tagging > Tagging

Sources section of the manual for more

information.

Thumbnails: This submenu allows you to

Create, Update, or Remove the thumbnail

for a file.

Ungroup Items: Ungroups a group, leaving

its contents behind. The group is not

preserved.

Imprinter: Choose an imprint you've

defined in Settings > Imprinter to apply it

to the current image or PDF.

OCR: Choose the output file type and

convert a compatible file via OCR.

Note:

Send by Email: The ability to add the

attachments depends on the inter-

application capabilities of the email

application. If it doesn't provide support

for this, you may be able to drag files into

draft message or the email application's

dock icon.

SEARCH OPERATORS

Searching in DEVONthink already is a powerful function. The addition of Boolean operators,

parentheses, and wildcards extend the power to fine-tune your search even further.

Note: The syntax of the operators is compatible to DEVONagent and EasyFind, the Finder,

Spotlight, common search engines as well as common programming languages such as C, C++,

Objective-C, Java, and JavaScript. The complexity of the query is unlimited.
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CASE

All terms are case-insensitive. You may, if you wish, use capitalization for proper names in a query,

but DEVONthink will ignore case in interpreting the query.

PRECEDENCE OF TERMS

Search terms and associated operators will be interpreted from left to right, except as modified

by including portions of the query within parentheses.

WILDCARDS

To make searching more flexible, you can replace parts of words with wildcards. For example, you

can search for plural forms of words without having to type, e.g., "dog" and "dogs". The available

wildcards are:

?: Matches exactly one character.

*: Matches none, one, or multiple characters.

[a-z]: Matches one character of the range a through z.

[abc...] or [a|b|c|...]: Matches one character out of the given list of characters.

[^...]: Matches one character that is not contained in the given list or range.

Note: The wildcards presented here are not full regular expressions.

Example:  Searching a document containing this text: DEVONtechnologies makes great

software:

text:~tech matches as the tech is contained in one of the words.

text:tech does not match as there is no word tech.

text:tech* does not match as there is no word beginning with tech.

text:*tech does not match as there is no word ending with tech.

text:*tech* matches as tech is found in a word with text before and after it. However, unless

you have a specific purpose, using the contains (~) operator is more succinct.

Searching a document with the text: He made a cake. She is making cookies. They live in

Madeira:

text: ma[dk]* matches "made", "making", and "Madeira".

text: ma[dk]? matches only "made".

Given a document named 2024-2-14_Big Light Electric:

name:[0-9] would only match "2".

name:[0-9][0-9] would only match "14"

name:[0-9]* would match all the numbers, regardless of length.

name:[0-9][0-9]* would match two or more numbers, e.g, "14" and "2024".

name:19[0-9][0-9] If you were looking for documents only in the 1900s, this would match,

e.g. "1914".

DEVONthink 3.9.17 Documentation, page 234



name:202[0-9] big would match this document or others from the 2020s, e.g., "2021-3-9_Big

Light Electric".

BOOLEAN OPERATORS

The operators (often called Boolean operators) are words or symbols that establish logical rules

for the terms in the search query. If no operator is given, DEVONthink infers AND. The available

Boolean operators are:

term1 AND term2: Contains term1 AND term2

term1 BUT term2: Contains term1 AND term2

term1 OR term2: Contains term1 OR term2

term1 XOR term2: Contains term1 or term2, but not both

term1 EOR term2: Contains term1 or term2, but not both

NOT term: Does not contain term

"term1": Contains the string of words term1, in exactly this form

Besides the classic Boolean operators, DEVONthink uses a number of operators that usually are

found in high-end databases. Use these operators as a replacement for AND and "quotes" to fine

tune your query.

term1 OPT term2: term1 is required, term2 is optional. If term2 is also found, the found

document ranks higher in the search results.

term1 NEAR term2: term1 occurs 10 words or less before or after term2

term1 NEAR/n term2: term1 occurs n or less words before or after term2

term1 BEFORE term2: term1 occurs before term2

term1 BEFORE/n term2: term1 occurs n or less words before term2

term1 NEXT term2: term1 occurs right before term2 (shortcut for BEFORE/1)

term1 NEXT/n term2: term1 occurs n or less words before term2 (synonym for BEFORE/n)

term1 AFTER term2: term1 occurs after term2

term1 AFTER/n term2: term1 occurs n or less words after term2

~term1: Contains term1, also as part of a word

For convenience, some of these operators can also be abbreviated using commonly used symbols:

AND: &, &&, +

OR: |, ||

XOR: ^, ^^

NOT: !, -

Operators are evaluated in the following priority: parenthesis > phrase/hyphens > (NOT)

BEFORE/AFTER/NEAR/NEXT > NOT > AND/OR/XOR/EOR. Terms with same priority but without

parenthesis are evaluated from left to right.
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WHITE SPACE HANDLING

Words linked by non-white separators (e.g., page-index or page_id) are treated like phrases put

into "quotes". Words separated by hyphens are handled like word1word2 OR "word1 word2".

Characters separated by dots are considered to be abbreviations and therefore handled like

words separated by hyphens, e.g., the term t.a.t.u is equal to "t a t u" OR tatu.

EXAMPLES

By using any or all of the operators and rules laid out above you can create complex queries that

find the exact information you're looking for. Here are some example queries that show how the

operators are used.

Example: Devonian Dinosaurs

This query looks for all documents that contain the words "devonian" and "dinosaurs".

Example: (Steve NEAR Jobs) AND iMac BUT NOT MacBook OPT Pro

This query looks for documents that contain the words "Steve" and "Jobs" no farther ten words

away from each other, as well as the word "iMac" (no specific position relative to Steve and Jobs),

but not the word "MacBook". The word "Pro" does not need to occur, but if it does, the document

is ranked higher in the list of search results.

Example: Paracetamol NEAR (~effect OR impact) AND ((side OR second*) NEAR/2

~effect)

This query looks for documents containing the word "Paracetamol" near (within 10 words) to

words either starting with "effect" (and so also "effects") or "impact". In addition, the document

needs to contain the word "side" or any word starting with "second" located within two words

range of any word starting with "effect".

SEARCH PREFIXES

DEVONthink supports a wide variety of

searchable attributes. These include common

attributes, like names or tags, but also

include document or DEVONthink-specific

items, like word counts or custom metadata

you've defined.

Similar to searching with Spotlight or some

other applications, the use of search prefixes

is supported. These take the form of a

prefix and a prefix operator, e.g., name:,

followed by the search term. These prefixes

are automatically applied when you choose

criteria in an advanced search but they can

also be manually entered in the search field.

SEARCH PREFIXES

Below is a list of the available search field

prefixes as you would manually type into the

search field or a script:
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text: Text contents in a file.

metadata: The metadata for a file.

name: The name of an item. For

documents, this is distinct from the

filename and does not include the file

extension.

url: The associated URL.

comment: Spotlight Comments.

docAuthors: The name of the sender of an

email.

docAuthorEmailAddresses: The email

address of the sender of an email.

docRecipients: The name of a recipient of

an email.

docRecipientEmailAddresses: The email

address of a recipient of an email.

docTitle: The title of a file. The title may be

distinct from its name, e.g., a song title for

an MP3 file.

docComment: The RTF-specific comments

for a file.

docHeadline: A headline applied to some

files. Rare.

docSubject: The subject line from an email.

docDescription: The description found on

some files, typically images.

docKeywords: The PDF or RTF specific

keywords for a file.

docOrganization: The company specified in

imported links or vCards from the Contacts

application.

docCopyright: Copyright information in the

metadata of a file.

docAlbum: The album information from

media metadata, e.g., MP3 files.

docComposer: The composer information

from media metadata, e.g., MP3 files.

docCreator: The process or application

used to create a file.

docProducer: The producer of a file, usually

applied to media files.

aliases: Aliases applied to an item.

tags: Tags applied to an item.

label: The color label of an item, from 0 (no

label) though 7 or by name, e.g., Important.

rating: The star rating of an item, from 0

(unrated) through 5.

width: The width of a document in points,

i.e., the width multiplied by 72.

height: The height of a document in points,

i.e., the height multiplied by 72.

length: The number of pages in a file or

length of a media file in seconds.

size: The size of an item in bytes, KB, MB, or

GB, e.g., size >= 50 MB.

wordcount: The number of words in the

contents of a file.

charactercount: The number of characters

in the contents of a file.

hits: The number of times a file has been

viewed or opened.

filename: The name of the file in the file

system, including the file extension.

extension: The extension of a file, e.g., txt.

This also supports an Any Extension option

to filter filenames having or lacking an

extension.

kind: Supports any, group, smartgroup,

tag, ordinarytag, grouptag, text,

rtf, formattednote, markdown, html,

webarchive, xmlfile, propertylist,

image, pdf, quicktime, video, audio,

bookmark, feed, news, script, sheet,

email, and other.
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Item prefixes: These special prefixes are

for state-based queries, like if items are

replicants or contains aliases. They all follow

the form of item:<specified state>, e.g.,

item:locked.

You can specify the state of items, i.e., is or is

not. The available options are as follows:

Replicated: Matches items that are

replicants.

Duplicated: Matches items that are

duplicates.

Indexed: Matches items that are indexed,

not imported.

Pending: Matches items whose contents

aren't downloaded and available.

Tagged: Matches items with tags applied.

The other option is specifying whether items

do or don't contain a certain property. For

example, you can search for items containing

aliases and the item:<specified state>

syntax is also used. This includes the negated

form. Here are the searchable properties:

Aliases: Matches items with aliases.

Annotation: Matches items with an

associated annotation file.

Comment: Matches items with a Finder

comment.

Data: Matches items with child items,

e.g., a group with items contains data. An

empty group can be found via item!:data,

meaning the item does not contain data.

Metadata: Matches items with metadata.

Reminder: Matches items with a reminder

set. (See Annotations & Reminders)

Script: Matches items with a script applied

in the Info inspector.

Thumbnail: Matches items with a

thumbnail applied.

URL: Matches items with a URL set in the

Info inspector.

Marked: Item states shown in the Flag

column in the item list, e.g., locked, can

be searched for. When choosing criteria

in the Advanced options of the toolbar

search, choose the Marked criterion. If

using a raw query string, the search prefix is

item:<specified state> and it's negated

form, item!:<specified state>. Here are

the marking options available:

Flag: The flag state of an item. Supports

flagged or unflagged.

Unread: The unread state of an item.

Supports read or unread.

Locking: The locking state of an item.

Supports locked or unlocked.

Dates: Dates are a very commonly used

property in searches, for example, if you're

looking for a document you created two days

ago. Here are the date-based properties you

can search for. See the Date Operators in the

next section for the syntax you can use with

these.

added: The date the item was added to the

database. The long form additionDate is

also supported.

created: The date the item was created.

The long form creationDate is also

supported.

modified: The date the item was

last modified. The long form

modificationDate is also supported.
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opened: The date the item was last

opened. The long form openingDate is also

supported.

due: The due date set in a Reminder for

an item. The long form dueDate is also

supported.

Miscellaneous Properties: There are also

some a bit more esoteric attributes you can

search for, like the number of attachments

in emails, or the detected language of a

document.

md_attachments: The number of

attachments in an email or the number of

resources added to an RTFD file.

md_annotationcount: The number of

annotations set in a PDF file.

md_encrypted: The encrypted state of

a PDF. This is a Boolean value denoted

numerically, e.g., md_encrypted==1 when a

file is encrypted.

md_incomingItemLinkCount: The number

of item links to a document from other

documents in DEVONthink.

md_outgoingItemLinkCount: The number

of item links to other documents present in

a document.

md_language: An abbreviation of the

detected language in the contents of a file.

For a list of values, select a language in the

criteria and note the abbreviation to use.

md_country: An abbreviation of the

country in the geolocation data for a file.

For a list of values, select a country in the

criteria and note the abbreviation to use.

md_zipcode: The postal code detected in

the geolocation data for a file.

md_area: The state, province, or region

detected in the geolocation data for a file.

md_locality: The city detected in the

geolocation data for a file.

Custom Metadata: Any custom metadata

attributes defined in the Data settings are

also available as search prefixes. The search

prefix you will type is a concatenated form

of the attribute's name, prefixed with md. For

example, an attribute of Total Cost would

have a search prefix of mdtotalcost.

There are also two special prefixes you can

use:

scope: This limits where you are searching.

It supports selection (the current group

or database), referring to a database by

name (in quotes), and inboxes. If no scope

is specified, the search applies to all open

databases. When used, scope: should be

the last parameter in the query.

any: When used, this allows you to specify

whether to return results matching any of

the criteria. This can only be used when

specifying more than one search prefix,

e.g., tags and filename.

Example:

additionDate>=2019-03-10

scope:selection

tags:sync; methods scope:"Tech

Stuff"

any: name:test OR imprint {any:

tags:blue; red}

Sub-criteria searches: Yes, you may have

noticed in the last example a tags search in

curly braces. This creates sub-criteria for the
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search. This obviously extends the search

options to allow creating even more complex

forms.

PREFIX OPERATORS

Many times prefixes end with a colon, e.g.,

tags: but some use other forms, depending

on the available options in the criterion.

For example, words can "begin with" some

characters, but a size is greater or less than a

value. If you select a criterion you would see

what options apply. Use the keys below to

map the option to its operator.

Matches, Is, Is Not:

: is equal to the term matches. With strings-

based queries, it allows for wildcards to

be used. It is also used for state-based

queries, like Kind. The negated form, :! is also

supported.

== is equal to the term is. This must be an

exact match of the search term. These can

be used in strings and number-based queries.

The negated form, != is also supported.

Example:

Kind is Group → kind:group

Item is indexed → item:indexed

Item is not Replicated → item:!

replicated

Extension is XML Document →

extension==XML

Language is not English → language!=en

String Matching: These are operators that are

used with string-based queries, like names or

text content. These queries also support:

:< is equal to begins with.

:> is equal to ends with.

:~ is equal to contains. (The tilde is the

second key down on the top left of an English

keyboard.)

Example:

Subject begins with party →

docSubject:<party

Locality ends with field →

md_locality:>field

Name contains tech → name:~tech

Number Matching: In addition to the == and

!= operators, numbers can also use these

operators:

< is equal to is less than and <= is is less than

or equal to.

> is equal to is greater than and >= is is

greater than or equal to.

Example:

Word Count is less than 1000 →

wordcount<1000

Size is greater than 10MB → size>10 MB

Hits is greater than or equal to 1 → hits>=1

Range Matches: For certain numerical

attributes, you can use a range matching

syntax, attibute:lowerLimit-upperLimit.

For example, wordcount:500-1000 matches

files with between 500 and 1000 words.

This is identical to the longer form syntax

of wordcount>=500 wordcount<=1000.

Range matches can be used with: width,

height, duration, length, hits, wordcount,

charactercount, and size prefixes.

Date Operators: These are operators used

with date-based queries, like the creation

date of files.

< is equal to before and <= is before or on.
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> is equal to later and >= is later or on.

:# is equal to within last and :!# is not within

last. These searches default to days, but

you can also use weeks, months, or years.

For example, modified:!#1weeks, noting

you always use the plural form of the time

component.

For dates-based queries, : is equal to is and

:! equals is not.

For greater compatibility, some other

combinations of operators are allowed.

due:<=2020-01-03 is equivalent to

due<=2020-01-03.

Named Relative Dates: You can use these

terms for relative dates: Today, Yesterday,

This Week, Last Week, This Month, Last

Month, This Quarter, Last Quarter, This Year,

and Last Year. Use these with is, before (or

on), and after (or on) operators.

Example:

Date Created is after January 31, 2019 →

created:>=2019-01-31

Date opened is not within last 5 days →

openingDate:!#5days

Date Due is not Today → due:!Today

Date searching allows for some flexibility in

formats. Time is not a required parameter,

but can be specified. These searches are all

equivalent:

Example:

additionDate>10 march, 2019

additionDate>March 10, 19

additionDate>2019-03-10 08:30:00

-0500

TEMPLATES

DEVONthink comes with a number of built-in templates for general use. Use these templates to

add a task list, a quote, or whole group structure for project management to your database.

Templates are stored in the ~/Library/Application Support/DEVONthink 3/

Templates.noindex folder. In order to manage your templates, rename them, organize them

in subfolders, or delete them, you can quickly access this folder by selecting Data > New from

Template > Open Templates Folders. More templates are available by selecting Data > New from

Template > More Templates, or as extras in the Support Assistant or in the Extras sidebar.

A very useful thing you can do is add your own files to this folder, even if the files aren't directly

editable in DEVONthink. For example, you may have a specific Pages template you often use.

Open the template in Pages and save it into DEVONthink's Templates folder. Now you can add

documents to your database even more efficiently.

BUILT-IN TEMPLATES

DEVONthink comes with the following built-in templates, which serve as great examples of the

template feature.
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Accounts & Passwords:

Email Accounts: Adds a sheet to record technical details of an email account details.

Online Account: Adds a sheet for storing website account details.

Serial Number: Adds a sheet for storing product serial numbers.

Classifications:

Decimal Filing System: Adds ten groups for the decimal filing system used by many European

companies for filing (scanned) paper documents.

Dewey Decimal Classification: Inserts a group with sub-groups that builds the first levels of the

Dewey Decimal Classification. Use this feature for databases that contain knowledge spanning

many subjects.

Library of Congress Classification: Inserts a group with sub-groups that builds the first

levels of the Library of Congress Classification. Use this feature for databases that contain

knowledge spanning many subjects.

Education:

Cornell Notes: Adds a document that allows you to write notes in Cornell style on a topic of

interest. Available as Markdown or rich text documents.

Cornell Notes (Education): Adds a document that allows you to write notes in Cornell style for

a particular course and topic. Available as Markdown or rich text documents.

Lab Notes: Adds a document that allows you to create lab reports. Available as Markdown or

rich text documents.

References: Adds a sheet for recording citation information such a DOI, authors, journal,

publication year, etc.

Reference (from Bookends): Adds the reference selected in Bookends to your database.

Reference (from Endnote): Adds the reference selected in Endnote to your database.

Quotes: Adds a sheet for recording quotes along with the author, source, comments, etc.

Quote (from clipboard): Adds a rich text document for a quotation or citation. The clipboard

content is automatically inserted and, if it's an Internet address (URL), it is automatically made

clickable.

Articles: Adds a sheet for keeping track of articles.

Booklets: Adds a sheet for keeping track of booklets.

Books: Adds a sheet for keeping track of books.

Manuals: Adds a sheet for keeping track of manuals.

Proceedings: Adds a sheet for keeping track of proceedings.

Technical Reports: Adds a sheet for keeping track of technical reports.

Theses: Adds a sheet for keeping track of theses.

PubMed: Runs a query in PubMed and adds the resulting documents formatted as rich text

documents to your database.
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Productivity:

Daily Journal: Adds Journal group with month and day subgroups, containing a file with a

daily quote, some news headlines, and space to write your thoughts. This template is a good

example of smart templates. The journal is available in two separate templates: Text (rich text)

and Markdown.

Note: Adds a new note. If the clipboard contains text, it is automatically inserted.

Phone Note: Adds a new phone note, automatically inserting the current date and time.

Project: Adds a simple project group structure including an "About this project" document. The

smart template asks for a project name; retrieves your name, department, email address, and

phone number from your contact card; and adds this information to the "About this project"

document.

Task List: Adds a simple task list.

Weekly Review: Adds a formatted note displaying checklist items and space to review the

week.

Registers:

1--31: Adds 31 groups, numbered 1 through 31.

A--Z: Adds 26 groups, named A through Z.

Days of the Week: Adds groups for the days of the week.

Months: Adds groups for the twelve Christian months.

Smart Groups:

Email ... Videos: Adds smart groups displaying documents of a given kind.

Due or Flagged: Adds a smart group displaying flagged items or items with a due date this

week.

Last ...: Adds smart groups displaying documents modified within a given period.

Documents with Annotations: Adds a smart group displaying files with annotations, e.g.,

highlights.

Large Documents: Add a smart group displaying documents larger than 5 MB.

PDF (not searchable): Add a smart group displaying all PDF documents that don't contain

machine-readable text.

Star Ratings (1-5): Add a smart group displaying items with a rating of one or five stars.

Toolbar: By default this contains no templates. Add your own templates to ~/Library/

Application Support/DEVONthink 3/Templates.noindex/Toolbar. These can be added to

the DEVONthink windows using View > Customize Toolbar.
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Note: Some of the included templates are just simple files. Others are smart templates,

packages that contain assets and scripts that provide powerful template generation. See the

Automation chapter for more information on them.

METADATA

DEVONthink stores a large number of

metadata fields internally when importing

documents from the file system, e.g., from

PDF, RTF, MP3, EXIF/IPTC, HTML, and email

messages as well as from all files that deliver

metadata through the Spotlight metadata

importer. Here's a partial list of theoretically

supported fields:

FILE METADATA

General Metadata:

Title

Headline

Subject

Creator

Producer

PDF Metadata:

Author

Title

Subject

URL

Keywords

RTF Metadata:

Author

Title

Comment

Subject

URL

Keywords

Organization

Copyright

Email Metadata:

Authors

Author email addresses

Recipients

Recipient email addresses

Email addresses

Media and Publication Metadata:

Album

Composer

Contributors

Publishers

Editors

Organizations

MultiMarkdown Metadata:

title

description

author

comment

subject

organization

keywords

publisher

email

copyright

generator

dc.title

dc.creator

dc.subject

dc.description

dc.rights

dc.contributor

dc.keywords

dc.publisher
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og:title

og:description

geo.position

ibcm

CUSTOM METADATA

Another powerful feature of DEVONthink

is custom metadata fields. Specified in the

Settings > Data, you can define fields that

are meaningful to you, your company, your

research group, or even your family!

When you create a custom metadata

field, you give it a name. DEVONthink uses

this name to create an identifier for use

in automated processes. This identifier

is created automatically and cannot be

changed.

Data Types: When you define a custom field,

you choose a data type for it. So what's a

"data type"? It's simply a kind of a value; like

"a" is a character and "42" is a (the!) number.

The following data types are supported,

including any interface items associated with

them, e.g., checkboxes or dropdown menus:

Boolean: This is a true or false value.

Displayed as a checkbox.

Countries: A dropdown menu providing a

list of country names.

Languages: A dropdown menu providing a

list of languages.

Integer: A whole number, e.g., with no

fractional part, like 17.

Decimal Number: A fractional number,

represented with a decimal point.

Date: Can be specified as Date & Time or

Date.

Identifier: Any alphanumeric value,

specified as needed, e.g., a customer or

patient number.

Single-line Text: A dropdown providing a

list of terms you defined for the field in the

Data preferences. You can also type in a

new value.

Multi-line Text: Enter a small paragraph of

text. Line breaks can be typed by pressing

Option-Return.

Rich Text: Same as Multi-line text but

supports basic formatting, e.g., bold or

italic text.

Set: Similar to the Single-line text, this

shows a dropdown with values pre-defined

for the field in the Data preferences.

However, new values can't be entered

outside the preferences.

URL: Accepts any valid URL, including

filesystem URLs.

Link: A special dropdown that allows you to

choose an item in your databases. a link for

the chosen item is used.

Note: The Countries and Languages lists

are lengthy, but not necessarily exhaustive.

For Multi-line Text and Rich Text, only one

line will be displayed in its column in the

item list.

Predefined Custom Metadata: In Settings

> Data, we have provided some custom

metadata fields to get you started. These are

ready to use and explore and serve as great

examples of the data types discussed above:

Date

Company

Author

Abstract

Status
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Serial Number

ISSN/ISBN

Digital Object Identifier (DOI)

PubMed ID

PMC ID

Barcode

Format

Category

Subcategory

Genre

Country

Language

Price

Tax

Tip

Decimal

PLACEHOLDERS

One of the most powerful features of

DEVONthink is the ability to insert data

dynamically. A placeholder is a bit of code

DEVONthink interprets when used in these

scenarios, replacing it with a specific value.

You may have an imprint with a Name

placeholder defined in the title. When the

imprint is used on a PDF, the placeholder is

converted to the name of the file!

To extend the possibilities even further,

you can combine static text and multiple

placeholders to achieve truly custom results.

You can use these in smart rules and the

command Tools > Batch Process, in alarms

on Reminders, custom imprints on images

and PDFs, and in templates for creating

WikiLinks documents. However, please be

aware not all placeholders can be used in all

those situations. For example, you can't use

the Location placeholder in a template as the

document doesn't have a location until after

it's created. Testing is strongly encouraged.

Below is a list of placeholders currently

available. Following each description is the

raw placeholder that can be used when

creating templates in external application

or using the import template AppleScript

command:

Name: The name or title of the document.

%recordName%

Proposed Name: A suggested name derived

from a document's title or from the first

line of the document if no title is present.

%recordProposedName%

Name Without Date: Returns the filename

after parsing out any detected dates.

%recordNameWithoutDate%

Aliases: Any aliases applied to the

document. %recordAliases%

Finder Comment: Any Finder comments

applied to the document. %recordComment

%

File Name: The filename in the file system.

%recordFilename%

File Extension: The extension

of the document's filename.

%recordPathExtension%

Kind: The kind of the file, e.g., group or rich

text document. %recordKind%

URL: The URL in the Info pane. %recordURL

%

Item Link: The unique URL of the

document. %recordLink%

Location: The location in the database; e.g.,

/Inbox/Research. %recordLocation%
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Tags: Tags applied to the document.

%recordTags%

#Tags: Tags applied to the document but

returned as hashtags. %recordHashTags%

Index: This is a number that increments

based on the number of items being

processed by a smart rule. %recordIndex%

Counter: Similar to the Index, this is

a zero-padded incrementing number.

%recordCounter%

Document Amount: This is an amount

detected in the name or content of

documents, like receipts or invoices. Often

used with smart rules. %documentAmount%

Document String: This is a string

detected in the name or content of

documents. Typically used with smart rules.

%documentString%

Digital Object Identifier: The unique digital

object identifier of the active document, if

available. %digitalObjectIdentifier%

Bates Number: Inserts a Bates number.

%recordBatesNumber%

Page Count: The total number of pages in

the document. %recordPageCount%

Group Name: The name of the group

containing the document, e.g., /001/a/b/

myfile.txt would report b as the group

name. %groupName%

Top Group Name: The name of the top level

group in the root of the database, e.g.,

/001/a/b/myfile.txt would report 001 as

the top group name. %topGroupName%

Database Name: The name of the database

containing the document. %databaseName%

Database Path: The filesystem path of the

database. %databasePath%

Attachments: The number of attachments

in a document, e.g., a rich text document or

email. %record_attachments%

PDF Annotations: The number of

annotations in the active document.

%record_annotationcount%

Incoming Item Links: The number

of documents containing item

links to the active document.

%record_incomingItemLinkCount%

Outgoing Item Links: The

number of documents linked

to in the active document.

%record_outgoingItemLinkCount%

Language: An abbreviation of language

detected in the document's indexed

contents. %record_language%

Country: The country in the geolocation

data for a document. %record_country%

Postal Code: The postal code derived from

the geolocation data for a document.

%record_zipcode%

Administrative Area: This is state, province,

or region in the geolocation data for a

document. %record_area%

Locality: The city in the geolocation data

for a document. %record_locality%

Tab: A tab character. %tab%

Line Break: A line break (return) character

for multi-line text. %newline%

Date Placeholders: There are several types of

date-specific placeholders to choose from.

You can choose from several built-in formats,

e.g., the short date, or create your own with

individual date component placeholders.

Due to the repetition of date placeholders,

the raw value of every individual placeholder

isn't listed here. However, below are the date

component raw values. Note some formats
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will resolved relative to your geographic

location, e.g., Jan 1, 2001 for the medium

date would be common in the US.

01/01/2001: The short date format.

%shortDate%

Jan 1, 2001: The medium date format.

%date%.

2001/01/01: The ISO date format.

%sortableDate%

Saturday, Jan 1, 2001: The long date

format. %longDate%

11:59:59 AM: The current time shown in

12 or 24 hour format, depending on your

system settings. %time%

12 hours, 43 minutes, and 12 seconds:

A custom time format made with text

and the following placeholders. %hour%,

%minute%, and %second%

01: The zero-padded number of the date.

%day%

Saturday: The name of the day. %weekday%

01: The zero-padded number of the month.

%month%

January: The name of the month.

%monthname%

2001: The full year. %year%

01: The short year. %shortYear%

Listed below are the supported date types

with their raw value provided. Prefix the raw

value with a date component as shown in the

example below.

Example:

%newestDocumentDateLongDate%

Current Date: Today's date. There is no

prefix to the raw placeholders for current

date.

Addition Date: The date the item added to

the database. recordAddition…

Creation Date: The date the item was

created. recordCreation…

Modification Date: The date the items was

last modified. recordModification…

Document Date: This is a date detected in

the document's contents, e.g., in a receipt.

For PDFs only the first four pages are used.

documentDate…

Newest/Oldest Document Date: The

newest or oldest date detected in the

document. For PDFs, only the first four

pages are used. newestDocumentDate… and

oldestDocumentDate…

Note: When using the raw values for

the date types, e.g., modification date,

note the date component's raw value will

start with a capital letter. For example,

use %recordCreationShortDate% not

"%recordCreationshortdate%".

Clipboard: Inserts plain text content from

the clipboard. %clipboard%

Clipboard Styled: Inserts rich text content

from the clipboard. %styledClipboard%

Clipboard Link: Inserts a link from rich text

content on the clipboard. %clipboardLink

%

Predefined Author: This is the Author

specified in DEVONthink's Settings >

Editing. %author%

Username: The shortname of the current

macOS account. %username%

Full Username: The longname of the

current macOS account. %fullUsername%

Organization: This is the company name, if

defined by the (Me) contact card in macOS

Contacts. %organization%
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Email Address: The primary email address,

as defined by the (Me) contact card in

macOS Contacts. %emailAddress%

Host: The hostname of the machine. %host

%

Properties: Some files have specific

properties, e.g., the author of an email.

These are displayed in the Info > Properties

inspector. Here are properties with supported

placeholders with their raw value.

Author: The name of the sender of an

email. %kMDItemAuthors%

From: The email address of the sender of

an email. %kMDItemAuthorEmailAddresses

%

Recipient: The name of a recipient of an

email. %kMDItemRecipients%

To: The email address of

a recipient of an email.

%kMDItemRecipientEmailAddresses%

E-mail: Email addresses detected in a

document. %kMDItemEmailAddresses%

Title: The title of a file. The title may be

distinct from its name, e.g., a song title for

an MP3 file. %kMDItemTitle%

Comment: The RTF-specific comments for

a file. %kMDItemComment%

Headline: A headline applied to some files.

Rare. %kMDItemHeadline%

Subject: The subject line from an email.

%kMDItemSubject%

Description: The description found

on some files, typically images.

%kMDItemDescription%

Keywords: Keywords typically

applied to PDF, rich text, or images.

%kMDItemKeywords%

Organization: The company specified in

imported links or vCards from the Contacts

application. %kMDItemOrganizations%

Copyright: Copyright information in the

metadata of a file. %kMDItemCopyright%

Album: The album information from media

metadata, e.g., MP3 files. %kMDItemAlbum%

Composer: The composer information

from media metadata, e.g., MP3 files.

%kMDItemComposer%

Creator: The process or application used to

create a file. %kMDItemCreator%

Producer: The producer of a file, usually

applied to media files. %kMDItemProducer%

A more extensive listing other types of

metadata can be found in the Metadata

section of this appendix.

Custom Metadata: This menu lists any

custom metadata attributes you've defined

in the Data settings. In order to use raw

placeholders, add the md prefix to the

identifier of the custom attribute shown

in the settings. For example, mddoi for the

Digital Object Identifier attribute.

SMART RULE EVENTS AND
ACTIONS

Smart rules in DEVONthink provide many

powerful actions and events that can trigger

these actions. Below is a list of the available

options for both.

EVENTS

When an action is triggered is almost as

important as the action itself. Actions can be

triggered when any of these events occur:
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On Demand: Run only when Apply Rule is

selected in a context menu or Tools > Apply

Rules.

On Startup: Runs when DEVONthink

launches.

Before Synchronization: Runs all actions

before DEVONthink begins synchronizing

to any sync location.

After Synchronization: Runs all actions

after DEVONthink completes synchronizing

to any sync location, i.e. all uploads,

downloads, and changes are committed.

On Quit: Runs when DEVONthink quits.

Every Minute: Runs the specified actions

every minute.

Hourly/Daily/Weekly: Runs the specified

actions on an hourly, daily, or weekly

schedule.

On Workdays: Runs on Monday through

Fridays.

On Weekends: Runs on Saturday or Sunday.

On Creation: Runs when a new document

is created in the specified location. To

trigger actions when taking notes or screen

captures with the Sorter, choose Via

Sorter.

Before Saving: Runs before saving a

matched document.

After Saving: Runs after saving a matched

document.

On Imprinting: Runs when any matched

document has been imprinted.

On Import: Runs when documents are

added to the specified location.

On Clipping: Runs when documents

are added via clipping, e.g., via menu

commands, the Sorter, DEVONagent,

bookmarklets, or AppleScript.

On Download: Runs when items are

downloaded via DEVONthink's Download

Manager.

On Scan: Runs after a scanning operation

has completed.

On OCR: Runs after an OCR operation has

completed.

On News: Runs when an RSS feed refreshes

and receives new articles.

On Upload: Runs when an item is uploaded

through DEVONthink's web server.

On Open: Runs when a matching item is

opened in a new document window or

viewed in a main window.

On Open Externally: Runs when a matching

file is opened in an external application.

On Launch URL: Runs when the URL

associated with the item is launched.

On Reminder: Runs when an alarm set on a

matching item's Reminder comes due.

On Renaming: Runs after matched items

are manually renamed.

On Labelling: Runs when a label is added to

or changed on an item.

On Flagging: Runs when an item is flagged.

On Moving: Runs when matched items are

moved to the specified location.

On Classifying: Runs when matching items

are classified by DEVONthink.

On Tagging: Runs when matched items are

tagged

On Replicating: Runs when matched items

are replicated.

On Duplicating: Runs when matched items

are duplicated.

On Convert: Runs when an item is

converted to a new format.
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On Moving into Database: Runs when

indexed items are moved into the

database, becoming imported items.

On Moving to External Folder: Runs when

imported or created items in a database

are moved to external locations, becoming

indexed items.

You can and and remove multiple event

triggers by pressing the + or - buttons. Fox

example, you could use an On Import and

an On Moving event trigger to act on files

imported or moved into it.

ACTIONS

The power in smart rules and batch

processing is in the actions. DEVONthink

provides actions that cover simple tasks,

e.g., prefixing a filename, all the way to ultra-

powerful AppleScript injection via external

or embedded scripts. Since you can chain

multiple actions together, the possibilities are

nearly endless.

Note batch processing supports a smaller

number of actions than smart rules. Here's a

list of available actions with those also usable

in batch processing marked with (BP):

Bounce Dock Icon: Causes DEVONthink's

dock icon to bounce. This will only trigger

when DEVONthink isn't the active

application.

Display Notification: Shows a message

via the Mac's Notification Center.

Notifications need to be enabled in

System Settings > Notifications for Display

Notification to operate correctly.

Display Alert: Shows a message in an alert

window.

Speak Text: Using your computer's voice

synthesis, it will speak the message you

specify.

Play Sound: Plays a selected system alert

sound.

Send Mail: Enter email addresses to send

the matching items. This can be a comma-

delimited list of addresses, names, or enter

the name of a group you've defined in your

contacts.

Add to Reading List: Add the matched

items to the Reading List.

Open: Opens in a document window, a file

that triggered or was produced by a smart

rule.

Open Externally: Open the matched file in

the system default application.

Launch URL: Open the URL associated

shown in the Info Inspector & URL.

Check Bookmarks: Checks the URL of the

matched items. Any issues with the URL

are reported in the Log window or the Log

popover.

Apply Rule: Perform the actions of another

smart rule on items passed by the current

smart rule. The items passed by the initial

smart rule must match the criteria of the

second smart rule to trigger it. This can be

useful after performing smart rule actions

like OCR or executing scripts, helping to

avoid redundant or scheduled smart rules.

Apply Script: Run a script on the

matched items. Choose a script from

installed External scripts. Or choose

AppleScript/JavaScript and write your

code in the embedded script editor popup.

Embedded scripts are only available to the

smart rule they are created in. See also p.

212ff   (BP)
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Item scanning: Supported both in smart

rules and batch processing, the next two

actions allow you to scan the name or text of

a document and use the results when found.

Each of the actions also has a parameter you

specify for the type of data you're scanning

for. These actions and parameters can be

used with subsequent actions that support

placeholders, e.g., Scan Text: Date →

Document Date with Change Modification

Date. If the action returns no results, actions

using the results will not be executed.

However, unrelated actions in the smart rule

chain will be executed normally.

Scan Name: Scans the name of the file.

(BP)

Scan Text: Scans the contents of the file.

(BP)

The following four parameters are used with

the Scan Name and Scan Text actions. With

String, Date, and Amount, a prefix and/or

suffix before/after the wildcard has to be

specified.

String: An asterisk (*) wildcard specifies

data to be captured. Other terms added

will be used to help located the desired

string. In subsequent actions, use the

Document String placeholder to represent

the captured string.

Date: Similar to String parameter, use the

desired format of the Document Date

placeholder to represent the captured

string in subsequent actions.

Amount: Similar to String parameter,

use the desired format of the Document

Amount placeholder to represent the

captured string in subsequent actions.

Regular Expression: Items in parentheses

are captured; items outside parentheses

are ignored. You can specify multiple

captures in an expression. Using the

captured text in subsequent actions is

specified by using backslash, \, and the

number of the capture, starting at 1. Note

we use Apple's NSRegularExpression which

supports the ICU regular expression syntax.

Example:

Using the String parameter, Invoice *

would capture 0012345 in a file named

Invoice 0012345..

Using the Date parameter, *  would

capture the date in a file named

2020-01-01.

Using the Amount parameter, $* would

capture the dollar amount detected.

Using the Regular Expression parameter,

Bill To: ([A-Za-z0-9 ,]+) would

capture the name of the person or

company billed. \1 would be used in the

subsequent action.

Change Name/Aliases/Comment/Label/

Rating: Change the specific attribute of

the matched file. For items with an existing

attribute, e.g., a comment, a placeholder

will preserve the existing value. (BP)

Mark: Toggle the state of read/unread,

flagged/unflagged, and locked/unlocked.

Note you change more than one of these

attributes with one action, but you can

chain more than one Mark action in the

smart rule. (BP)

Change Creation/Modification Date:

Change the creation or modification date

of matched files to: current, addition,
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creation, modification, or the document

date. (BP)

Add Tags: Add tags to the matched files.

As you type, tags from all open databases

will be suggested. Press the comma key to

commit the tag. (BP)

Add Tags from Document: Adds existing

tags if they are detected in the matched

document's contents. (BP)

Remove Tags: Removes specific tags you

enter. (BP)

Remove All Tags: Removes all tags from the

items. (BP)

Tags: Adds or converts tags to matched

documents from these commands:

Convert HashTags, Convert Keywords,

Convert Properties, Convert Geolocation,

Add Vision Suggestions to Images, and

Scan Barcodes. (See the View menu for

more information on these options.)

Move/Replicate/Duplicate: Move, replicate,

or duplicate a matched file to a chosen

location.

Duplicate & Continue: Duplicates matched

files and applies subsequent actions to the

copies.

File: Allows you to file items into a group.

Specify subgroups using a forward slash,

e.g., 2019/DEVONtech would create or file

into the DEVONtech subgroup of a 2019

group in the current group. You can use

placeholders to define the location. (BP)

Classify: Using our AI, this will attempt

to move any matched files to an apropos

location. Failures to classify files are noted

in the Log window.

Move Into Database: Moves indexed items

into the database, essentially importing

them. Note this removes the file from the

original location in the filesystem.

Move To External Folder: For an item

located in an indexed group, this moves the

file to the indexed folder in the Finder.

Convert: Attempts to convert files

into plain/rich text, formatted notes,

Markdown, HTML, web archive, or PDF.

Convert & Continue: Converts files and

applies subsequent actions to the copies.

Thumbnails: Adds, updates, or removes a

matched file's thumbnail.

OCR: This will perform OCR on a file, if

possible. Choose a format to generate a

new file in the selected file type. Note the

file type selected will override the option

set in Settings > OCR > Convert incoming

scans to. Choose Apply to convert a

matched file directly to a PDF with OCR.

This action does not generate new files.

Imprint: Apply the selected imprint to any

matching files, if possible.

Custom Metadata: If you have specified

custom metadata fields, you will have

options to change values with an action.

For example, if you had a Boolean field

named "Done", you could have the action

set this field to true when the action is

triggered. (BP)

Move to Trash: Move the item to the

database's trash. The items are not

removed from the database until the trash

is emptied.

Delete: Be very cautious with this option.

Delete truly deletes a file. It is not sent to

the database's trash. It is not sent to the

Finder's trash. It is completely deleted.
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SCRIPTS

Below is a list of the DEVONthink supplied

scripts, segregated by the menu items in the

Script menu:

Comments:

Append Selected Text: Adds the selected

text to the comments of the current

document.

Assemble: Collects the comments of the

selected documents and creates a new

document listing them.

Convert to Tags: Converts the tag

contained in the comments field to real

tags if the comments field of the selected

document contains tags separated by

commas.

Speak: Speaks the comments of the

selected documents.

Data:

Move Duplicates to Trash: Moves all

duplicates of the selected document to the

trash.

Find & Remove Similar Contents: Finds and

removes similar documents.

Group With Duplicates: Creates a group

with duplicates of the selected documents.

Group With Replicants: Creates a group

with replicants of the selected documents.

Verify & Optimize Databases: Runs a

verification on all open databases and

optimizes them if they verify successfully.

Errors are alerted and logged to Window >

Log.

Check file integrity of databases: Runs a

checksum comparison on all items in open

databases to check for any discrepancies

in the current and stored values. Errors are

alerted and logged to Window > Log.

Download:

Linked Images of Page: Adds linked images

of a displayed web page to the database.

Images of Page: Adds the images of a

displayed web page to the database.

Links of Page: Adds links contained on a

displayed web page to the database.

Download as…: Converts bookmarks to

one of these formats: Formatted Notes,

HTML Pages, PDF Documents (One Page or

Paginated), and Web Archives

Edit:

Count Characters: Counts the characters

in the current selection.

Count Words: Counts the words in the

current selection.

Replace text in documents: Enter text

to find and replace in plain and rich text

documents.

Execute:

AppleScript: Executes an AppleScript

script.

Perl: Executes a Perl script.

Shell: Executes a shell script.

Export:

Listing: Saves a UTF-8 text file containing

a text listing of the names of all contents/

groups of the current database.

Daily Backup Archive: Creates a

compressed backup (.Zip) of the current

database in ~/Backup. All backups are

include a datestamp in the filename for

easy tracking and identification. These

can be useful for copying to external
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media or uploading to a cloud service

as a secondary backup strategy. Note:

When using this script with an encrypted

database, the database will be compressed

in an unencrypted state.

Feeds:

Nature -- Hubble News: Downloads the

latest Hubble news.

iTMS -- Added Albums: Downloads covers

of albums recently added to the iTunes

Music Store.

Format:

Body Normal: Formats selected text as

"Body Normal".

Body Small: Formats selected text as

"Body Small".

Header Capitalized: Formats selected text

as "Header Capitalized".

Header Main: Formats selected text as

"Header Main".

Header Secondary: Formats selected text

as "Header Secondary".

Source: Formats selected text as "Source".

Reset Spacing: Resets the line and

paragraph spacing of selected rich text.

Images:

Copy Info to Comment: Copies basic image

info to the comment field.

Flip Horizontal / Vertical: Flips the image

horizontally/vertically.

Rotate Left / Right: Rotates the image

left/right.

Landscape to Portrait: Rotates only

landscape images to portrait.

Portrait to Landscape: Rotates only

portrait images to landscape.

Scale to 1024 pixels: Scales the image to

1,024 pixels.

Scale to 200%: Scales the image to 200

percent.

Scale to 50%: Scales the image to 50

percent.

Import:

Del.icio.us: Imports your del.icio.us

bookmarks. The descriptions are used to

name the imported bookmarks; the notes

and the tags are added to the comments.

If the keychain does not contain a key for

del.icio.us, dialogs pop up allowing you to

enter the user name and password.

Man Page: Imports a UNIX manual page as

a PDF document.

Perldoc: Imports the documentation of Perl

pages, modules, functions, or programs.

Reminders:

Add as Event to Calendar: Adds a new

event to Calendar linking back to the

selected item in DEVONthink.

Add as To Do to OmniFocus: Adds

the selected item as a to-do item to

OmniFocus.

Add as To Do to Reminders: Adds

the selected item as a to-do item to

Reminders.

Add as To Do to The Hit List: Adds the

selected item as a to-do item to The Hit

List.

Add as To Do to Things: Adds the selected

item as a to-do item to Things.

Note: These are scripts for integrating with

external applications. For scripting internal

reminder scripts, see the Reminder Scripts

section of the chapter about automation.
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Rename:

Append Selected Text: Appends the

selected text to the title of the currently

selected item.

Replace Text: Replaces a text passage in

the titles of selected documents.

To Webpage Title: Sets the titles of the

selected documents to the names of the

web pages pointed to by their URL fields.

To Subject: Sets the titles of the selected

documents to the subject lines of the email

messages if the selected documents are

email messages.

Sheets:

Add Multiple Records: Adds up to 999

empty records to a sheet.

Column Sum&Mean Value: Calculates the

sum and average of a table column.

Row Sum&Mean Value: Calculates the sum

and average of a table row.

Check sums in last column: Checks the

sums in the last column on validity.

Tabs:

Open Bing: Open a new tab for the Bing

search engine.

Open Google: Open a new tab for the

Google search engine.

Open Location: Open a new tab for a

location you specify.

Note: The last script does no URL

validation, though DEVONthink's dictionary

makes it possible to script this too.

Thumbnails:

Flip Horizontal / Vertical: Flips the

thumbnails of selected documents

horizontally/vertically.

Rotate Left / Right: Rotates the

thumbnails of selected documents left/

right.

Landscape to Portrait: Rotates only

landscape thumbnails to portrait.

Portrait to Landscape: Rotates only

portrait thumbnails to landscape.

Note: While these scripts work with all

image formats including PDF, they should

not be used for PDF documents. They will

only work on the first page of the PDF and

destroy all embedded metadata.

Caching: All scripts in the Scripts menu

are cached, meaning their properties are

persistent until you quit and relaunch the

application or DEVONthink automatically

updates the menu, e.g., after adding or

removing scripts.

WEB SITE EXPORT TEMPLATES

For exporting selected groups or files as

a web site, DEVONthink uses templates

available in ~/Library/Application

Support/DEVONthink 3/Websites/ to

create HTML files from documents. You

can choose the template in the save dialog

that appears when you use File > Export > as

Website.

In the markup of HTML templates, the

following placeholders can be used:

%charset%

%comment%

DEVONthink 3.9.17 Documentation, page 256



%content%

%databasePlusLocation%

%modification%

%stylesheet%

%title%

%url%

%tags%

These placeholders will be replaced with

actual information during the export.

The placeholders will only be replaced in

documents that are converted to HTML

during export, namely plain text, rich text,

Microsoft Office/OpenOffice documents,

scripts, chat logs, and sheets.

HIDDEN PREFERENCES

There are a few settings in DEVONthink

not available through the application

Settings. Most of them are intended to

facilitate customer support but they might

be interesting for you as well.

HOW TO ACCESS THE HIDDEN

PREFERENCES

All hidden preferences are simple on/off

switches. You set and unset them using the

"defaults" command in the Terminal. To set

preferences via the Terminal DEVONthink

must not be running or it will overwrite your

changes when you close it.

To set a preference using the Terminal, noting

the commands are case-senstive, they are

written like this:

Terminal:

$ defaults write com.devon-

technologies.think3

ShouldScaleAttachedImages -bool TRUE

The above command activates the preference

with the key "ShouldScaleAttachedImages".

Change TRUE to FALSE to deactivate it. Use

any of the preferences keys below to activate

or deactivate them.

Some hidden preferences allow specifying

a numeric value, e.g., CounterDigits. These

types of preferences also need to be set via

a Terminal command. Use the -int argument

before specifying the number, like so:

Terminal:

$ defaults write com.devon-

technologies.think3 CounterDigits -int 3

There is a special preference to

allow DEVONthink to detect other

plain text formats as plain text:

"AdditionalPlainTextExtensions". As it

replaces the list of additional plain text

extensions we recommend that you read the

current list first (empty by default) before

adding your own to the end of the list.

Terminal:

$ defaults read com.devon-

technologies.think3

AdditionalPlainTextExtensions

2014-07-31 08:25:27.101

defaults[21950:3312262] The domain/

default pair of (/Users/eb/Library/

Preferences/com.devon-technologies.think3

AdditionalPlainTextExtensions) does not

exist

# This "error" shows there are no

additional formats specified.

$ defaults write com.devon-

technologies.think3

AdditionalPlainTextExtensions -

string .otl.todotxt

DEVONthink 3.9.17 Documentation, page 257



$ defaults read com.devon-

technologies.think3

AdditionalPlainTextExtensions

.otl.todotxt

AVAILABLE HIDDEN PREFERENCES KEYS

AdditionalPlainTextExtensions: Adds

additional plain text extensions, separated

by dots.

AVSkippingInterval: Specify the numbers

of seconds to skip forward or backward

when using the right and left arrow

keys with Shift held in audio/video files.

Seconds are specified as an -int, e.g., -int

5. The default is 15 seconds.

AdditionalXMLExtensions: Adds additional

XML file name extensions, separated by

dots.

BatesNumberDigits: Specifies the number

of digits used for the placeholder.

CounterDigits: Specifies the number of

digits used for the placeholder.

DatePlaceholdersWithoutLeadingZeros:

Disables date and time placeholders from

using prefixing zeros.

DisableActivityWindow: Disables

automatically showing/hiding of the

Activity window.

DisableAutomaticDeconsolidation:

Inhibits items added to indexed groups in

DEVONthink from automatically moving

out to the indexed Finder folder.

DisableAutomaticUpdatingOfIndexedItems:

Disables automatic updating of indexed

items.

DisableBadgeLabel: Disable the badge label

on DEVONthink's Dock icon.

DisableFileSystemEvents: DEVONthink no

longer listens to file system events.

DisableFileCoordination: DEVONthink no

longer uses file coordination, registering

its interest in certain files and waiting for

replies. This can cause very long delays if

the coordinating process isn't responding

quickly.

DisableFinderTags: DEVONthink no longer

imports or exports Finder tags.

DisplayGroupsInPreviewPane: DEVONthink

will display the contents of selected

groups, smart groups, and feeds in the

view/edit pane of main windows. The

preview only displays files, not groups.

DisableHighlightColorMapping: Uses the

same colors when highlighting documents

in dark and light mode.

DisablePDFValidation: Disables validating

PDFs created by merging, converting, or

clipping.

DisablePreprocessedClipping: Disable

additional processing of a web page's

content before sending the clipped file to

DEVONthink.

DisableRelativeDates: Disable displaying

relative dates, e.g., "Today" in the item

list. This will instead always show absolute

dates, e.g., "2023.02.14".

DisableTagAutocompletion: Disable

displaying the popup of tag suggestions

when entering tags, e.g., in the Tags bar.

DontAutomaticallyEnableOperatorsOptions:

After a toolbar search, disables

automatically enabling the Operators &

Wildcards option in the Search inspector.

DontSetFindPboard: Disable using macOS'

shared pasteboard, avoiding search terms

from being automatically used in other

applications.

EnableApplicationFiles: Applications can

be imported/indexed.
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EnableAutomaticConsolidation: Indexed

items moved to a non-indexed location

in the database will be moved from their

Finder location as an imported item.

EnableFSEventLogging: Enables logging of

filesystem events when requested by our

support team. It should not be needed for

general use.

EnableEvernoteRTFDImport: Enable this to

import notes from Evernote notebooks as

rich text files.

EnableSearchFieldAutocompletion: Enable

this to have DEVONthink attempt to

complete search strings as you type them

in the toolbar search field. Note this option

only works when the search options Live

while typing and Partial matches while

typing are disabled. (See also p. 87ff )

ForceEditablePDFs: Some PDFs contain

objects that are problematic for Apple's

PDFKit. DEVONthink opens these files in

a read-only state. Enable this option to

disable this behavior and open all PDFs as

editable. Note: This does not eliminate the

potential for problems with certain PDFs.

IndexRawMarkdownSource: Index the

source code of Markdown files instead of

the rendered content only.

MaximumNumberOfRecentDestinations:

Specify the number of recent destinations

shown in the Recent Destinations section

of the context and popup menus, e.g., in

the Move To popover. The default value is

10.

MaximumNumberOfRecentSearches:

Specify the number of recent searches

available in the toolbar search field or the

Search inspector. The default value is 10.

MonospacedSidebarFont: Use a

monospaced system font in the sidebars of

main windows.

MonospacedViewFont: Use a monospaced

system font in the item list of main

windows.

OpenLinksInForeground: Clicked links

always open in the foreground, including

when opening documents externally. In

Terminal: -bool FALSE

PersistentSortingOfSearchResults: Retains

the last sort method used in database

search results.

PlainTextIsMarkdown: Treat all plain text

files as markdown.

RawMarkdownPasting: When pasting

rich content into a Markdown file, the

formatting is converted to Markdown.

Enable this to ignore formatting and paste

as raw plain text.

RawOPMLImport: Imports .opml files as

native files instead of parsing and creating

groups, feeds, etc. from them.

RichNotesWithoutAttachments: Services

create RTF instead of RTFD.

ShowAdditionalInfoInPathBar: Shows

some details about the selected item in the

Information Bar.

SyncDebugLog: Enable additional sync

logging for debugging.

UsePDFDocumentDates: Use the PDF's

internal metadata dates instead of the

filesystem dates when importing and

setting creation and modification dates.

WindowToolbarStyleExpanded: Enable the

expanded toolbar style on macOS Big Sur.

This shows the title bar above the toolbar

instead of the new unified default style.

WindowToolbarTitleHidden: Permanently

removes the title of a main window,
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making space for more toolbar

buttons. Note this cannot be used if 

WindowToolbarStyleExpanded  is enabled.

ServerDebugLog: Enable additional logging

for debugging DEVONthink's webserver.

WebServerSession: Specify the duration

of idle time before logout in DEVONthink's

websharing interface. The duration is

specified in seconds as an -int, e.g., -

int 600. The default duration is 1800 (30

minutes).

Note: These hidden preferences could be

changed or removed with any update.
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This chapter contains the version history of

DEVONthink, our end user license agreement

(EULA), and credits.

VERSION HISTORY

 New   Improved   Fixed   Removed

VERSION 3.9.17

After a crash, DEVONthink no longer shows a warning but only shows an alert when you open a

database that's already in use on the same computer. Creating a new sheet lets you name the

sheet right away. We also improved the appearance when using or toggling to dark mode and

back. Bonjour syncing ignores dynamically changing host names for more reliable connections.

And, as always, we fixed various issues, too, from Markdown rendering to converting document

formats.

The Data > New > Sheet panel lets you name the new sheet.

A new warning shows when a database may be open in another user account.

A hidden preference, WindowToolbarTitleHidden, lets you hide a main window's

title and gives you more space for toolbar items. Note that you cannot use it with the

WindowToolbarStyleExpanded hidden preference.

The Format Bar is available in fullscreen window mode on macOS 15 and later. Show or hide it

with Format > Show/Hide Format Bar.

The Table of Contents inspector is more compatible with poorly constructed HTML content.

You can make the group selector larger.

DEVONthink positions Popovers more consistently relative to the current window.

DEVONthink no longer shows a warning dialog after it crashed or was quit forcefully.

DEVONthink better supports the System Settings' Accessibility > Display > Increase contrast

option, especially in dark mode.

File and folder names can have leading or trailing underscores in their names.

Automation prompts to allow DEVONthink to control the Finder no longer self-dismiss.

The compare AppleScript command only returns a maximum of 40 results, consistent with the

See Also & Classify inspector.
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You can control how long the download URL and download markup/JSON from AppleScript

commands run by using a with timeout of x seconds… end timeout block.

Improved overall database performance.

Sync — Bonjour passwords stored in Keychain Access use the host's ID as the host name of a

device can sometimes change when switching networks.

Ordered lists in Markdown didn't render properly if there was no space after the dot. Fixed.

Inline MathJax equations didn't always render properly in Asian language documents. Fixed.

Edits to formatted notes could break the base URL causing resources like images to fail to

load. Fixed.

Web pages using the Consent framework crashed WebKit. Fixed.

Converting emails (Pro and Server editions) and rich text documents to PDF documents could

stall the app. Fixed.

Searching for tags in a toolbar search or via smart groups and rules didn't work correctly with

groups excluded from tagging and grouped RSS feeds. Fixed.

Inactive tagging fields could freeze the app on rare occasion. Fixed.

For favorited groups, the item count wasn't shown and their unread count didn't match what

was reported in the item list. Fixed.

The internal versions group wasn't properly filtered when determining statistics in Database

Properties nor was it ignored in toolbar searches. Fixed.

Switching between light and dark modes could cause visual artifacts in labels, ratings, and the

Activity pane. Fixed.

The background color of selected or hovered tabs in the tabs bar didn't display correctly in

light mode. Fixed.

Destination popups, e.g., in the Sorter, didn't display correctly in dark mode if the destination

was the root of the Global Inbox or database. Fixed.

The alignment of labels in the License dialog was off. Fixed.

The Sorter didn't always appear in the menubar on macOS Tahoe. Fixed.

Pressing ⌃↩ on modern versions of macOS didn't work properly in Icon view and could also

change text selections. Fixed.

Pressing the ⎋ Escape key with the database authentication panel open caused an issue. Fixed.

The Apply Rule smart action didn't work properly if the applied rule ran asynchronous

actions. Fixed.

Pro — In rare cases, while in List view with a specific custom metadata field shown, disabling

that field on another device and synchronizing could crash the app. Fixed.

Pro — Tags were not applied to a document when scanning to a binder. Fixed.

Pro — Using Data > Move to Trash could have caused glitches if the icon view of the scanner

interface was active. Fixed.
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Pro — Changing the type of custom metadata fields, e.g., from Boolean or a number to a

string, then editing a smart rule which uses these fields, crashed the app. Fixed.

Sync — On rare occasions, adding a Bonjour sync location or synchronizing via Bonjour could

cause memory issues. Fixed.

VERSION 3.9.16

DEVONthink now detects empty pages when clipping PDF documents, ensuring more consistent

and useful results. We have made the Safari and Sharing extensions more reliable in macOS

Tahoe and improved the sync performance. The app now also automatically adjusts resource

usage based on your machine's temperature and workload. And, of course, we've included

additional fixes to improve stability and reliability.

We improved the consistency of syntax colorizing for quotes in Markdown documents.

When clipping web content or using the download PDF document from AppleScript

command to create PDF documents, DEVONthink now detects empty black and white pages

and either filters them out or aborts the clipping.

We reduced resources used with versioning by 90% for compatibility with version 4, especially

during toolbar searches and while updating smart groups and rules.

DEVONthink now explicitly registers its extensions to ensure they're available in Safari and

macOS' Share menu.

We improved the handling of menu scripts execution.

Sync — We improved the reliability of syncing the Reading List and custom metadata via

Bonjour.

Sync — DEVONthink now detects the battery and thermal state of the machine and throttles

the CPU and I/O load when syncing, as needed.

Thumbnailing many small documents could sometimes cause a crash. Fixed.

Converting rich text documents or emails to paginated PDF documents intermittently froze on

macOS Tahoe. Fixed.

Invalid relative image and transclusion links in Markdown could break previewing or converting

the document or crash the application. Fixed.

Links entered in lists in Markdown documents didn't work properly in WYSIWYG mode. Fixed.

Markdown headings containing code weren't colored correctly. Fixed.

Searches with proximity operators didn't always highlight the search hits in PDF documents.

Fixed.

In macOS' dark mode, text entered in new HTML documents was not inverted to white. Fixed.

The Tools > Summarize Annotations and summarize highlights of records commands

could sometimes return highlights in the wrong order, e.g., those made by PSPDFKit. Fixed.
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Web clipping via the Sorter when opened with the hotkey would include Safari's profile name.

Fixed.

Images dropped or pasted into Markdown documents with the Files > Markdown > Import

images to group setting enabled didn't honor the Files > Import > Recognition or Files > Import

> Tags settings. Fixed.

Documents moved or duplicated between databases could incorrectly have the extension

added to the internal name if General > Appearance > Show filename extensions was enabled.

Fixed.

Documents could be renamed with an empty name if General > Appearance > Show filename

extensions was enabled. Fixed.

Duplicate notifications from the Extras sidebar could occur when multiple main windows were

open. Fixed.

The internal name of files created via AppleScript incorrectly retained the extension. Fixed.

Pro — The popup menu Reveal command of item link dropdowns in the Data inspector or form

view of sheets always opened a new window. Fixed.

Pro — In the German localization, the OCR > PDF Resolution setting couldn't be changed. Fixed.

Sync — Bonjour synchronization could sometimes cause memory issues. Fixed.

VERSION 3.9.15

In Markdown documents, DEVONthink 3.9.15 detects links much faster and renders lists more

reliably. Links to Apple Notes in a document now work, indexed Google Drive documents launch

like the Finder does, and the Sorter's Add and Preview buttons now show their keyboard

shortcuts. For automators, folder actions trigger smart rules using the On Import or On OCR

events. And of course, we have, again, made DEVONthink faster and more reliable.

Editing very long Markdown documents is much more performant. DEVONthink detects links

in Markdown documents at least 25 times faster when syntax coloring and WYSIWYG is

enabled.

Prism.js renders Objective-C code marked with the alternate objc or language-objc as well

as the default language-objectivec.

DEVONthink indexes web-based documents and converts them to plain text better.

In the Sorter's Video Note tab, the camera and microphone menu is disabled if DEVONthink is

disabled in macOS' Privacy & Security > Camera settings.

The Add and Preview buttons of the Sorter now display their keyboard shortcuts when the

Command key is pressed.

DEVONthink's built-in folder action scripts now run smart rules using the perform smart

rule AppleScript command with the On Import and On OCR event triggers, as appropriate.
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Pro — If you choose Database in the To dropdown of the scanner interface, a dedicated Group

dropdown lets you choose the group to scan to. The settings are saved and also restored when

connecting to a scanner.

Thumbnailing Markdown documents could cause a rare crash. Fixed.

Markdown lists didn't render properly when indented with one space. Fixed.

The Scan Text smart action didn't ignore Markdown metadata if there was no other content

in the document. Fixed.

For RSS and Atom feeds with multiple authors, only the first was used. Fixed.

In the item list in List view, the Tags column didn't display autocompletion results. Fixed.

The tooltip shown when hovering over items with truncated names didn't fully display the

name if the item also had property icons. Fixed.

An open Quick Look panel didn't update when changing the selection of the view/edit pane

when the hidden preference DisplayGroupsInPreviewPane was enabled. Fixed.

The First, Previous, Next, and Last commands in the Go menu couldn't be used in toolbar

search results. Fixed.

In a multi-monitor setup with vertically positioned screens, the Sorter was only partially visible

as a docked tab. Fixed.

Links using Apple Notes' URL scheme couldn't be clicked in documents. Fixed.

Indexed Google Drive documents couldn't be opened via the Data > Open With command.

Fixed.

.strings files weren't indexed correctly. Fixed.

If the DEVONthink helper background task crashed, other background tasks, e.g., running

scripts, could be blocked for a period of time. Fixed.

Pro — In the popup menu of URL fields in the Info > Custom inspector and the form view of

sheets, the Paste and Remove commands neither saved changes nor updated the layout.

Fixed.

Pro — Search queries using date-based custom metadata weren't always parsed correctly.

Fixed.

Server — The icons in the Server > Users settings didn't display correctly in macOS' dark mode.

Fixed.

VERSION 3.9.14

This release includes several improvements and fixes. We've enhanced support for relative links

in Markdown documents, allowing for spaces within the links. We also addressed an issue with

list indentation. Previously, the Favorites section, e.g., within the Move To context menu, onlly

displayed the first favorited item. We've resolved this, ensuring all favorited items are shown.
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Furthermore, we've improved document language detection. Finally, it wasn't possible to navigate

EPUB documents in the web interface via the table of contents, and DEVONthink unintentionally

renamed images and PDF documents dragged via Universal Control.

Image links in Markdown documents support relative URLs containing spaces instead of

requiring percent-escaping.

DEVONthink better detects the language of documents, whether you import, index, or create

them within the application.

Line items in Markdown lists indented with 4 or more spaces didn't render correctly. Fixed.

Images and PDF documents dragged from the Finder into DEVONthink between two Macs

connected via Universal Control would be renamed on import. Fixed.

After inserting or deleting pages in a PDF document, the title of main and document windows

and the subtitle of document windows didn't reflect the changed page count. Fixed.

Copying section links in EPUB documents via the Table of Contents inspector didn't include

anchors. Fixed.

The Favorites section in the Move To, Duplicate To, and Replicate To context menus and

Destination popups, e.g., in the Sorter, only displayed the first favorited group. Fixed.

Sync — Databases with names containing, e.g., "GoogleDrive", "Google Drive", or "OneDrive"

couldn't be created or imported from sync locations. Fixed.

Server — In the web interface, EPUB documents couldn't be navigated via the table of

contents. Fixed.

VERSION 3.9.13

This maintenance release fixes two regressions of the previous version and also improves a few

things. Underlines and strikethrough PDF annotations retain the last color used, and importing

encrypted databases via sync suggests the anticipated size. In addition, version 3.9.12 displays

some package-based documents better in DEVONthink Server's web interface and handles

filesystem events more reliably.

Setting the color of underline and strike-through PDF annotations in the Annotations panel

makes it the default color for those annotation types.

Using the Undo command after classifying items works better in cases where annotation files

have also been automatically moved.

Better support for package-based documents with embedded HTML or PDF based previews.

Revised appearance of tab preview popovers, shown when hovering on document tabs, for

macOS 15 Sequoia and later.

Dates specified in the Advanced search editor are converted to the toolbar search string using

always the format YYYY-MM-DD HH:MM:SS to avoid time zone issues.
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Thumbnailing of videos uses now artwork if available.

The Recent Databases section in the Navigate sidebar is more efficiently handled when you

have multiple main windows open.

Better handling of filesystem events.

Server — The web interface better displays package-based documents with an embedded

HTML or PDF preview.

Sync — The approximate size of an encrypted database is now included in the sync data and

used as the default size when importing the database on another Mac.

When using macOS' dark mode, converting a Markdown or web-based document to a one page

PDF displayed white text on a dark background in the converted document. Fixed.

The Move, Duplicate to, and Replicate to context submenus didn't include Favorites or Recent

Destinations section headers. Fixed.

Revealing nested tags could fail when the General > Interface > Unified Tags setting was

enabled. Fixed.

When the Sorter was opened via a hotkey as a docked tab, it didn't respond to key commands.

Fixed.

Creating an annotation in the Info > Annotations & Reminders > Annotations inspector could

crash the application on rare occasion. Fixed.

Token fields in smart rules and batch processing could appear truncated. Fixed.

The color of the Multimedia filter menu icon was incorrect. Fixed.

The See Also & Classify inspector didn't show groups anymore. Regression. Fixed.

The registration panel did not show the success or failure alert immediately after the trial

period expired. Fixed.

Indexed groups were not automatically updated in newly created databases unless you closed

and opened the database or quit and relaunched the application. Fixed.

Migrating and opening a database on a different Mac could stall the application for a while

while checking filesystem events. Fixed.

Pro — The OCR > Apply action in smart rules stopped working due to a regression in 3.9.11.

Fixed.

Pro — Emails and mailboxes could no longer be imported or archived in the View > Import >

Emails sidebar due to a regression in version 3.9.11. Fixed.

Pro — When printing or converting the form view of sheets to paginated PDF, rich text fields

had a black background when using macOS' dark mode. Fixed.
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VERSION 3.9.11

With this release, Markdown editing gets a little more polish with improved indentation on lists

and controlling list view columns and sort options is easier with the Customize Metadata panel

in the root of the View menu. In addition, DEVONthink sends us some anonymized data that can

help us determine, e.g., if some features or actions are more popular than others. Of course, you

can switch this off in the app's settings. We fixed several issues, too, as we continue to improve

performance and reliability.

Added Usage: Send anonymized analytics data to the General > General settings. See our

company's Privacy page for more information on the data that may be sent.

Characters are more reliably escaped when converting plain or rich text or pasting rich text to

Markdown.

In Markdown lists, items spanning multiple lines are consistently indented when Files >

Markdown > WYSIWYG editing is enabled.

Markdown rendering is more compatible with responses from version 4's chat assistant.

In the item list, the Word Count and Character Count columns display more consistently.

You can now find the Customize Metadata command on the top level of the View menu.

Additionally, we've slightly improved the appearance of this panel.

The File > Export > Metadata (JSON) command includes the location of items.

The Add linked images to DEVONthink scripts for DEVONagent, Google Chrome, and Safari

load images more efficiently and much faster.

Improved overall reliability.

When using DEVONthink's View > Full Screen > Document mode, selecting text with a mix of

underline and strike-through styles could cause a crash. Fixed.

Unlocked groups and feeds with a mixture of flagged and unflagged items didn't show an icon

showing the mixed state. Fixed.

When DEVONthink was offline, URLs in HTML, web archives, and Markdown previews didn't

load linked items, e.g., stylesheets, that were already saved to the database. Fixed.

After zooming in or out while editing text, lines didn't always wrap even though Format > Wrap

Lines was enabled. Fixed.

The Copy command for the color well in the Info > Generic inspector didn't work. Fixed.

Once enabled, Exclude from Wiki Linking in the Info > Generic inspector and popover couldn't

be disabled. Fixed.

Tags on groups exported via File > Export > Files & Folders weren't retained when reimporting

the groups. Fixed.

When using aliases in WikiLinks, an incorrect number of WikiLinks or mentions could be

reported for the incoming Wiki references AppleScript property or in the Document >

Links or Document > Mentions inspectors. Fixed.
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Pro — Duplicated Imprinter configurations incorrectly retained shared font information. Fixed.

Server — After starting the web server, not all the permissions columns were shown as

uneditable and not all requests were logged. Fixed.
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LICENSE AGREEMENT

PLEASE READ THIS LICENSE CAREFULLY

BEFORE USING OUR SOFTWARE. BY USING

THE SOFTWARE, YOU ARE AGREEING TO

BE BOUND BY THE TERMS OF THIS END

USER LICENSE AGREEMENT. IF YOU DO NOT

AGREE TO THE TERMS OF THIS LICENSE

YOU MUST DELETE THE SOFTWARE FROM

YOUR DEVICES.

1. LICENSE

The application and other components

(e.g. graphics, sounds) governed by

this License (the “Software”) and the

related documentation are licensed to

you by DEVONtechnologies. You own

the devices on which the Software is

stored but DEVONtechnologies and/or

DEVONtechnologies' licensor(s) retain title to

the Software and related documentation.

1.1: This License allows you to use the

Software on the number of devices owned

or controlled by you, defined by the number

of Seats purchased for the License or, for

the App Store, by Apple. A Seat is a physical

device capable of running the Software. This

License does not limit the number of people

using the Software on the device.

1.2: Licenses purchased directly from

DEVONtechnologies can be resold in

compliance with European Union law.

Licenses purchased in the Apple App Store

are non-transferrable.

2. RESTRICTIONS

2.1: The Software contains copyrighted

material, trade secrets and other proprietary

material and in order to protect them

you may not decompile, reverse engineer,

disassemble or otherwise reduce the

Software to a human-perceivable form.

2.2: You may not sublicense, modify, rent,

lease, or create derivative works based upon

the Software in whole or in part. You may not

distribute the Software in any form.

3. MAINTENANCE AND SUPPORT

DEVONtechnologies provides support for

the Software with respect to this license

agreement or as required under applicable

law. Apple has no obligation whatsoever

to furnish any maintenance and support

services with respect to Software.

4. DISCLAIMER OF WARRANTY ON

SOFTWARE

4.1: You expressly acknowledge and agree

that use of the Software is at your sole risk.

The Software and related documentation

is provided “AS IS” and without warranty

of any kind. You acknowledge that

DEVONtechnologies, if technically and legally

possible, provides free trial versions of the

Software for evaluation.

4.2: DEVONtechnologies expressly disclaims

all warranties of any kind, whether express

or implied, including, but not limited to

the implied warranties of merchantability,

fitness for a particular purpose, and non-
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infringement. DEVONtechnologies is

responsible for warranties required by

applicable law.

If Software was purchased in the Apple

App Store and you notify Apple in case that

Software fails to conform to applicable

warranty, Apple will refund the purchase

price. To the maximum extent permitted

by applicable law, Apple will have no other

warranty obligation whatsoever with respect

to Software, and any other claims, losses,

liabilities, damages, costs or expenses

attributable to any failure to conform to any

warranty will be DEVONtechnologies' sole

responsibility.

4.3: Unless otherwise provided in Sect. 6,

DEVONtechnologies does not represent or

warrant to you that (a) the Software will

meet your requirements, (b) your use of

the Software will be uninterrupted, timely,

secure, or free from error, (c) any information

obtained by you as a result of your use of

the Software will be accurate or reliable,

and (d) that defects in the operation or

functionality of the Software provided to you

will be corrected.

4.4: No advice or information, whether

oral or written, obtained by you from

DEVONtechnologies shall create any warranty

not expressly stated in this License.

5. LIMITATION OF LIABILITY

5.1: UNDER NO CIRCUMSTANCES

INCLUDING NEGLIGENCE, SHALL

DEVONTECHNOLOGIES BE LIABLE FOR ANY

INCIDENTAL, SPECIAL OR CONSEQUENTIAL

DAMAGES THAT RESULT FROM THE USE

OR INABILITY TO USE THE SOFTWARE OR

RELATED DOCUMENTATION.

5.2: In no event shall DEVONtechnologies'

total liability to you for all damages, losses

and causes of action (whether in contract,

tort (including negligence) or otherwise)

exceed the amount paid by you for the

Software.

5.3: The aforementioned limitation of liability

also applies for the personal liability of

DEVONtechnologies' staff, contributors,

representatives, licensors, organs and their

members.

5.4: If you are domiciled in the Federal

Republic of Germany, the aforementioned

limitations of liability (Sect. 5.1 to 5.3) do

not apply for personal injury of life, body

and health, and for strict product liability

law. They do not apply in case the damage

is a consequence of the breach of a cardinal

obligation, an essential obligation, or a

warranty in the meaning of Section 444 of

the German Civil Code.

5.5: Liability for the breach of a cardinal

obligation or essential obligation is limited

to the amount paid by you for the Software.

Aforementioned limitation of liability with

respect to the amount you paid for the

Software does not apply in case of gross

negligence, wilful misconduct, personal injury

of life, body and health, the breach of a

warranty in the meaning of Section 444 of

the German Civil Code, other strict product

liability law. DEVONtechnologies remains

responsible for product liability according to

Sect. 44 a TKG (Telekommunikationsgesetz).
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5.6: The aforementioned limitations of

liability (Sect. 5.1 to 5.5) only apply as far as

permitted by law.

5.7: DEVONtechnologies is responsible for

addressing any claims of this License.

6. DEFECTS

6.1: DEVONtechnologies grants you a license

to the Software in its current version only.

DEVONtechnologies encourages you to use

the free trial version of the Software for

evaluation.

6.2: You cannot claim that a given state of

the Software will be achieved through an

update or a new version.

6.3: In the event that the Software does not

comply with express terms of this License

Agreement or there is a breach of these

warranties, if the usability of the Software

is affected severely and sustainably, or if

any bug or any severe anomaly could not

be detected during the use of the free trial

version, DEVONtechnologies may at its

option either replace the Software free of

charge to you or refund the purchase price.

7. INTELLECTUAL PROPERTY RIGHTS

DEVONtechnologies owns or licenses the

intellectual properties that Software is

based on. In case of third-party claims that

Software infringes third-party's intellectual

property rights, DEVONtechnologies is

responsible for the investigation, defense,

settlement and discharge of any such

intellectual property infringement claim.

8. GENERAL

8.1: Any changes, amendments, or the

abrogation of the agreement between

you and DEVONtechnologies, including

this License, require written form. The

requirement of written form can only be

waived in written.

8.2: This License constitutes the whole

legal agreement between you and

DEVONtechnologies with regard to the

Software, and completely replaces any

prior agreements between you and

DEVONtechnologies in relation to the

Software. Separate agreements may

apply for other software or services which

DEVONtechnologies may provide to you. If

the End User License Agreement available

on the DEVONtechnologies website differs

from this License, the online version has

precedence.

Apple, and Apple's subsidiaries, are third

party beneficiaries of the License, and, upon

your acceptance of the terms and conditions

of the License, Apple will have the right (and

will be deemed to have accepted the right)

to enforce the License against you as a third-

party beneficiary thereof.

8.3: You agree that you comply with

applicable third-party terms of agreement

when using Software.

8.4: You agree that if DEVONtechnologies

does not exercise or enforce any legal right or

remedy which is contained in this License, or

which DEVONtechnologies has the benefits

under any applicable law, this will not be
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taken as a waiver of DEVONtechnologies'

rights and those rights will still be available to

DEVONtechnologies.

8.5: If any court of law, having jurisdiction

to decide on this matter, finds that any

provision of this License is invalid, then this

provision will be removed from this License

without affecting the remaining parts of

this License. The remaining provisions of

this License will continue to be valid and

enforceable.

8.6: This License, and your relationship with

DEVONtechnologies with regard to the

Software, shall be governed by the laws of

Germany without regard to its conflicts

of laws provisions. The application of the

UN Convention on the International Sale of

Goods (CISG) shall be excluded.

8.7: The court of Besigheim, Germany,

shall have sole jurisdiction if you are a

businessman. In case you are a consumer,

the place of jurisdiction shall be Besigheim,

Germany, if you transfer your legal domicile

or regular residence to a place outside the

Federal republic of Germany, or your legal

domicile or regular residence are unknown

upon filing a legal action.

8.8: You agree and warrant that you are

not located in a country that is subject to

a U.S. Government embargo, or that has

been designated by the U.S. Government

as a “terrorist supporting” country; and you

are not listed on any U.S. Government list of

prohibited or restricted parties.

CREDITS

ABBYY FINEREADER ENGINE

ABBYY FineReader 11.x Engine Copyright

© ABBYY Software Ltd. OCR by ABBYY

Software House.

MULTIMARKDOWN

Copyright © 2016-2018 Fletcher T. Penney.

MultiMarkdown is released under both the

GPL and MIT licenses. You may pick the

license that best fits your needs.

Modifications to remove reliance on Glib2:

Copyright © 2011 Daniel Jalkut, licensed

explicitly MIT.

LyX export code © 2013-2014 Charles R.

Cowan, licensed under both GPL and MIT

licenses.

Portions based on: peg-markdown.

Copyright © 2008-2011 John MacFarlane.

ODF output code © 2011-2013 Fletcher T.

Penney. peg-markdown is released under

both the GPL and MIT licenses. You may

pick the license that best fits your needs.

Original Markdown specification by John

Gruber.

The GPL: This program is free software;

you can redistribute it and/or modify it

under the terms of the GNU General Public

License as published by the Free Software

Foundation; either version 2 of the License,

or (at your option) any later version. This

program is distributed in the hope that it will

be useful, but WITHOUT ANY WARRANTY;

without even the implied warranty of

MERCHANTABILITY or FITNESS FOR A

PARTICULAR PURPOSE. See the GNU General
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Public License for more details. You should

have received a copy of the GNU General

Public License along with this program; if

not, write to the Free Software Foundation,

Inc., 51 Franklin St, Fifth Floor, Boston, MA

02110-1301 USA

The MIT License: Permission is hereby

granted, free of charge, to any person

obtaining a copy of this software and

associated documentation files (the

"Software"), to deal in the Software without

restriction, including without limitation the

rights to use, copy, modify, merge, publish,

distribute, sublicense, and/or sell copies

of the Software, and to permit persons to

whom the Software is furnished to do so,

subject to the following conditions: The

above copyright notice and this permission

notice shall be included in all copies or

substantial portions of the Software. THE

SOFTWARE IS PROVIDED "AS IS", WITHOUT

WARRANTY OF ANY KIND, EXPRESS OR

IMPLIED, INCLUDING BUT NOT LIMITED TO

THE WARRANTIES OF MERCHANTABILITY,

FITNESS FOR A PARTICULAR PURPOSE AND

NONINFRINGEMENT. IN NO EVENT SHALL

THE AUTHORS OR COPYRIGHT HOLDERS

BE LIABLE FOR ANY CLAIM, DAMAGES OR

OTHER LIABILITY, WHETHER IN AN ACTION

OF CONTRACT, TORT OR OTHERWISE,

ARISING FROM, OUT OF OR IN CONNECTION

WITH THE SOFTWARE OR THE USE OR

OTHER DEALINGS IN THE SOFTWARE.

PANTOMIME

Copyright © 2001-2009 Ludovic Marcotte.

SHORTCUTRECORDER

Copyright © 2006, contributors to

ShortcutRecorder. (See the contributors

listed in detail later in the file.)

All rights reserved. Redistribution and use

in source and binary forms, with or without

modification, are permitted provided that

the following conditions are met:

Redistributions of source code must retain

the above copyright notice, this list of

conditions and the following disclaimer.

Redistributions in binary form must

reproduce the above copyright notice,

this list of conditions and the following

disclaimer in the documentation and/

or other materials provided with the

distribution.

The name of the contributors may not

be used to endorse or promote products

derived from this software without specific

prior written permission.

THIS SOFTWARE IS PROVIDED BY THE

CONTRIBUTORS "AS IS" AND ANY EXPRESS

OR IMPLIED WARRANTIES, INCLUDING, BUT

NOT LIMITED TO, THE IMPLIED WARRANTIES

OF MERCHANTABILITY AND FITNESS FOR

A PARTICULAR PURPOSE ARE DISCLAIMED.

IN NO EVENT SHALL THE CONTRIBUTORS

BE LIABLE FOR ANY DIRECT, INDIRECT,

INCIDENTAL, SPECIAL, EXEMPLARY, OR

CONSEQUENTIAL DAMAGES (INCLUDING,

BUT NOT LIMITED TO, PROCUREMENT OF

SUBSTITUTE GOODS OR SERVICES; LOSS

OF USE, DATA, OR PROFITS; OR BUSINESS

INTERRUPTION) HOWEVER CAUSED AND

ON ANY THEORY OF LIABILITY, WHETHER

IN CONTRACT, STRICT LIABILITY, OR TORT

(INCLUDING NEGLIGENCE OR OTHERWISE)
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ARISING IN ANY WAY OUT OF THE USE OF

THIS SOFTWARE, EVEN IF ADVISED OF THE

POSSIBILITY OF SUCH DAMAGE.

Contributors to Shortcut Recorder, in no

order in particular:

Jesper, waffle software. Initial idea and

concept, first shot at implementation

using NSView.

David Dauer. Refinement, cleaner

reimplementation, documentation, IB

Palette.

Jamie Kirkpatrick, Kirk Consulting Ltd.

Further modularisation and re-factoring,

and general bug fixes.

Ilya Kulakov. ShortcutRecorder 2.0 and

further support.

Alexander Ljungberg. Graphics for

ShortcutRecorder 2.0

SPARKLE

Copyright © 2006-2013 Andy Matuschak

Permission is hereby granted, free of charge,

to any person obtaining a copy of this

software and associated documentation

files (the "Software"), to deal in the Software

without restriction, including without

limitation the rights to use, copy, modify,

merge, publish, distribute, sublicense, and/

or sell copies of the Software, and to permit

persons to whom the Software is furnished

to do so, subject to the following conditions:

The above copyright notice and this

permission notice shall be included in

all copies or substantial portions of the

Software.

THE SOFTWARE IS PROVIDED "AS IS",

WITHOUT WARRANTY OF ANY KIND,

EXPRESS OR IMPLIED, INCLUDING BUT

NOT LIMITED TO THE WARRANTIES

OF MERCHANTABILITY, FITNESS

FOR A PARTICULAR PURPOSE AND

NONINFRINGEMENT. IN NO EVENT SHALL

THE AUTHORS OR COPYRIGHT HOLDERS

BE LIABLE FOR ANY CLAIM, DAMAGES OR

OTHER LIABILITY, WHETHER IN AN ACTION

OF CONTRACT, TORT OR OTHERWISE,

ARISING FROM, OUT OF OR IN CONNECTION

WITH THE SOFTWARE OR THE USE OR

OTHER DEALINGS IN THE SOFTWARE.

SKIM

Copyright © 2008-2018, Christiaan Hofman

and contributors All rights reserved.

Redistribution and use in source and binary

forms, with or without modification, are

permitted provided that the following

conditions are met:

Redistributions of source code must retain

the above copyright notice, this list of

conditions and the following disclaimer.

Redistributions in binary form must

reproduce the above copyright notice, this

list of conditions and the following disclaimer

in the documentation and/or other materials

provided with the distribution. Neither the

name of Christiaan Hofman nor the names

of any other contributors may be used to

endorse or promote products derived from

this software without specific prior written

permission.

THIS SOFTWARE IS PROVIDED BY THE

COPYRIGHT HOLDERS AND CONTRIBUTORS

"AS IS" AND ANY EXPRESS OR IMPLIED
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WARRANTIES, INCLUDING, BUT NOT

LIMITED TO, THE IMPLIED WARRANTIES OF

MERCHANTABILITY AND FITNESS FOR A

PARTICULAR PURPOSE ARE DISCLAIMED.

IN NO EVENT SHALL THE COPYRIGHT

OWNER OR CONTRIBUTORS BE LIABLE

FOR ANY DIRECT, INDIRECT, INCIDENTAL,

SPECIAL, EXEMPLARY, OR CONSEQUENTIAL

DAMAGES (INCLUDING, BUT NOT LIMITED

TO, PROCUREMENT OF SUBSTITUTE GOODS

OR SERVICES; LOSS OF USE, DATA, OR

PROFITS; OR BUSINESS INTERRUPTION)

HOWEVER CAUSED AND ON ANY THEORY

OF LIABILITY, WHETHER IN CONTRACT,

STRICT LIABILITY, OR TORT (INCLUDING

NEGLIGENCE OR OTHERWISE) ARISING

IN ANY WAY OUT OF THE USE OF THIS

SOFTWARE, EVEN IF ADVISED OF THE

POSSIBILITY OF SUCH DAMAGE.

LETSMOVE

Public domain. More information can be

found atLetsMove.

ZIPZAP

Copyright © 2012, Pixelglow Software. All

rights reserved.

Redistribution and use in source and binary

forms, with or without modification, are

permitted provided that the following

conditions are met:

Redistributions of source code must retain

the above copyright notice, this list of

conditions and the following disclaimer.

Redistributions in binary form must

reproduce the above copyright notice,

this list of conditions and the following

disclaimer in the documentation and/

or other materials provided with the

distribution.

THIS SOFTWARE IS PROVIDED BY THE

COPYRIGHT HOLDERS AND CONTRIBUTORS

"AS IS" AND ANY EXPRESS OR IMPLIED

WARRANTIES, INCLUDING, BUT NOT

LIMITED TO, THE IMPLIED WARRANTIES OF

MERCHANTABILITY AND FITNESS FOR A

PARTICULAR PURPOSE ARE DISCLAIMED.

IN NO EVENT SHALL THE COPYRIGHT

HOLDER OR CONTRIBUTORS BE LIABLE

FOR ANY DIRECT, INDIRECT, INCIDENTAL,

SPECIAL, EXEMPLARY, OR CONSEQUENTIAL

DAMAGES (INCLUDING, BUT NOT LIMITED

TO, PROCUREMENT OF SUBSTITUTE GOODS

OR SERVICES; LOSS OF USE, DATA, OR

PROFITS; OR BUSINESS INTERRUPTION)

HOWEVER CAUSED AND ON ANY THEORY

OF LIABILITY, WHETHER IN CONTRACT,

STRICT LIABILITY, OR TORT (INCLUDING

NEGLIGENCE OR OTHERWISE) ARISING

IN ANY WAY OUT OF THE USE OF THIS

SOFTWARE, EVEN IF ADVISED OF THE

POSSIBILITY OF SUCH DAMAGE.
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TECHNOLOGY
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All commercial DEVONtechnologies

applications are based on a proprietary

AI technology, with rock-solid database

foundation that allow them to manage large

numbers of documents or knowledge bits

while analyzing them almost instantly at the

same time.

GENERAL CONCEPT

DEVONtechnology, on which all

DEVONtechnologies' applications are built, is

a new technology at the very beginning of its

development. DEVONtechnologies constantly

improves the technology and enhances it for

more functionality, efficiency, robustness and

flexibility.

Development of the DEVONtechnology is a

battle on two main forefronts of information

processing technology. DEVONtechnologies is

working hard on unifying both the top-down

and the bottom-up AI concepts by imitating

high-level functions and simulating the basic

functionality of natural systems. This leads

to highly functional, fast and efficient AI

systems that can be used in a great variety

of information processing contexts, such as

pattern recognition, signal processing and

information storage and retrieval.

FEATURES

The DEVONtechnology is a rock-solid

foundation suitable for a variety of

completely independent applications.

Therefore it is ideal for the rapid

development of a huge range of new

database-, signal-processing- and language-

analysis-driven applications. The ability to

deal with any kind of digital data makes it

extremely flexible.

The size of DEVONtechnology-based

databases can, depending on the type of

data stored, grow logarithmically and make

indexing is completely unnecessary. Also,

applications based on the DEVONtechnology

improve themselves continuously (the more

data they handle, the better the results),

are language-independent and iron out any

irregularities by applying fuzzy logic.

STRUCTURE

The DEVONtechnology consists of a kernel

and several layers. Together they perform all

the underlying computing, from 'simple' data

handling to complex signal processing.

Kernel: The kernel is the foundation for all

layers and applications and is responsible

for data handling, semantic and associative

data processing, signal processing, fast

statistic analyses and all fuzzy algorithms.

It has to be as fast, flexible, and extensible

as possible; it is 64-bit aware and uses a

generic, proprietary file format (see above)
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allowing it to verify and repair low level data

consistency, featuring logarithmic growth

of the database and logarithmic speed

decrease with increasing database size. The

DEVONtechnology kernel is Unicode-aware,

completely language-independent and self-

optimizing and self-organizing.

Layers: The layers form a shell around the

kernel and provide high-level functions

for the applications built on top of them.

The database layer, for example, is used to

store and organize data and supports all

kinds of relations (1:n, n:1, n:n), hierarchies

and freeform databases. No indexing or

primary keys are required, strings can be

unlimited in size and it's possible at any time

to extend the range of pre-defined data

types (Boolean, character, float, double,

signed, unsigned, string, date, time, blob,

color, size, and point). Another layer, the

XML layer, makes it easy to handle XML code

within the DEVONtechnology; it has a very

small overhead, compared to DOM parsers or

available XML databases, requires no indexing

and supports the tight integration of other

databases (and vice versa).

APPLICATIONS

Some of the most likely applications for

the DEVONtechnology are databases

(knowledge bases, expert systems, search

engines, table-of-content-generators,

instant data-mining), intelligent agents,

encryption, compression and archiving.

Other uses for DEVONtechnology may be

chat-bots, context-sensitive help, optical

character recognition (OCR), speech analysis,

recognition and synthesis, staticstics,

thesauri and automatic translations.

In particular, applications dependant on

processing human language, either written or

spoken, benefit from the flexible technology

foundation. So, DEVONtechnologies' main

focus in the development of new applications

is in these areas: databases, 'intelligent'

agents, text and speech analysis, statistics.

Look forward to see a great range of different

applications based on the DEVONtechnology.

A few have already been announced

on the DEVONtechnologies web site:

www.devontechnologies.com.
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Besides DEVONthink, DEVONtechnologies

publishes a number of other commercial,

shareware, and freeware applications and

services that might be helpful for you.

OVERVIEW

DEVONtechnologies is focused on developing

innovative applications for finding, storing,

and organizing information. Our main

objective is to make complex yet flexible

technology that is both easy to use and

lightning fast. All applications are based on

the DEVONtechnology, a powerful and solid

core unique to DEVONtechnologies.

DEVONthink

DEVONthink To Go

DEVONagent

DEVONsphere

We also publish some freeware apps and

services for your everyday work with your

Mac.

NEWSLETTER & COMMUNITY

Would you like us to keep you informed about

updates and new product releases? Visit our

blog and subscribe to our free newsletter.

If you have a moment feel free to visit our

lively user community. Here users of all skill

levels meet to discuss our applications, talk

about our technology, and exchange tips and

tricks for DEVONthink & Co.

DEVONTHINK

Organize and work with all your documents,

bookmarks, email messages, text files,

images, PDFs, in one place, regardless where

they originated. Quickly capture data without

interrupting your workflow. DEVONthink's

unique AI assists you in getting the most out

of your data collection.

Learn more about DEVONthink

Check your upgrade options if you want to

upgrade to a higher edition

DEVONTHINK TO GO

If you're serious about working on iOS,

DEVONthink To Go is your document

repository when you're not at your Mac.

Collect, organize, edit, and annotate.

Automate with Shortcuts. Keep your

document collection always in sync between

your Mac, iPad, and iPhone. Privately and

securely.

Learn more about DEVONthink To Go.
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DEVONAGENT

DEVONagent Pro helps you search more

efficiently on the web. It searches multiple

sources, frees you from hunting for the really

relevant results, and gives you power tools

for your research. DEVONagent Express and

DEVONagent Lite (free) make searching

the web as easy as using Spotlight. Search

Google, Bing, YouTube, Facebook, Twitter,

even the Mac App Store, right from the menu

bar.

Learn more about DEVONagent Pro.

DEVONSPHERE

Make your Mac smarter: Let DEVONsphere

Express keep track of related emails, articles

on the same subject, and similar web pages.

Discover the hidden connection between

seemingly unrelated files.

Learn more about DEVONsphere Express.

NEEDFUL THINGS

Search files on your hard disk, watch web

cams, create thumbnails, or access all your

files and apps from the menu bar. Reformat

paragraphs in your favorite word processor or

do little calculations anywhere you can type

in text. All for free.

Learn more about our freeware apps and

services.
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